Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/04/2017, à 15:11

parislanuit

Ethernet non géré depuis upgrade vers 16.10 et 17.04

Bonjour,

Mon ethernet ne fonctionne plus avec le message Network manager "peripherique non géré"

Tout marchait bien sous 16.04, au passage vers 16.10 plus d'ethernet, j'ai upgradé vers 17.04 toujours rien..

lspci donne :

00:19.0 Ethernet controller: Intel Corporation 82567LF-2 Gigabit Network Connexion

ça me semble étrange vu qu'il s'agit d'une carte réseau intégrée à un chipset intel (ICH10 Family) très répandu (core2duo).

J'ai éssayé de rajouter les lignes à interfaces:

auto eth0
iface eth0 inet dhcp

Aucun résultat.



Quelqu'un aurait une solution?

Dernière modification par parislanuit (Le 24/04/2017, à 15:13)

Hors ligne

#2 Le 24/04/2017, à 18:04

ruski_stil

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Bonjour,

pareil!
mais en live cd ça marche!!!
je suis sur le pc en question!

j'ai deja testé:

 cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
moi@moi:~$ ifconfig -a
enp2s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:23:54:05:fc:46  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 34464  bytes 2067840 (2.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 34464  bytes 2067840 (2.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

moi@moi:~$ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 49892  bytes 2993520 (2.9 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 49892  bytes 2993520 (2.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


moi@moi:~$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIB (ICH10) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4850]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV770 HDMI Audio [Radeon HD 4850/4870]
02:00.0 Ethernet controller: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6101/6102 single-port PATA133 interface (rev b2)
05:02.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
moi@moi:~$ sudo lshw # j’ai juste copié pour eth0
 *-network DÉSACTIVÉ
                description: Ethernet interface
                produit: AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
                fabriquant: Qualcomm Atheros
                identifiant matériel: 0
                information bus: pci@0000:02:00.0
                nom logique: enp2s0
                version: b0
                numéro de série: 00:23:54:05:fc:46
                capacité: 1Gbit/s
                bits: 64 bits
                horloge: 33MHz
                fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=ATL1E driverversion=1.0.0.7-NAPI firmware=L1e latency=0 link=no multicast=yes port=twisted pair
                ressources: irq:17 mémoire:fe9c0000-fe9fffff portE/S:dc00(taille=128)

Merci!

Hors ligne

#3 Le 24/04/2017, à 18:11

xubu1957

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Bonjour,

Regardes cette solution :

jipsan a écrit :

Pour tous ceux qui auraient le même pb, je pense avoir trouvé la solution:
éditer (en sudo)
/etc/resolvconf/resolv.conf.d/head
ajouter
nameserver 80.10.246.2
ou/et 80.10.246.129 (orange) ou 109.0.66.10 ou 109.0.66.20 (sfr)
enregistrer et redémarrer.
chez moi, cela a réglé le problème.

dans : perte internet après mise à niveau vers 17.04

Dernière modification par xubu1957 (Le 24/04/2017, à 18:13)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#4 Le 27/04/2017, à 00:35

Olivier33300

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Hors ligne

#5 Le 27/04/2017, à 18:08

ruski_stil

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

xubu1957 a écrit :

Bonjour,

Regardes cette solution :

jipsan a écrit :

Pour tous ceux qui auraient le même pb, je pense avoir trouvé la solution:
éditer (en sudo)
/etc/resolvconf/resolv.conf.d/head
ajouter
nameserver 80.10.246.2
ou/et 80.10.246.129 (orange) ou 109.0.66.10 ou 109.0.66.20 (sfr)
enregistrer et redémarrer.
chez moi, cela a réglé le problème.

dans : perte internet après mise à niveau vers 17.04

N a pas marché!
Ensuite :
Sudo ifconfig eth0 up
La reponse est eth0 ERREUR en recuperant les sognaux de l interface: aucun peripherique de ce type.
Sudo dhclient eth0
Cannot find device eth0

Je capte pas pourquoi en live la carte fonctionne et installé elle n est pas reconnue.
Avec ma 16.04 aucun souci...
Vu que j ai upgradé sur mon portable sans soucis, jai ete bin couillon de le faire sur le pc du bureau  tiens!

Hors ligne

#6 Le 27/04/2017, à 18:12

xubu1957

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Bonjour,

Cette solution :

Le 27/04/2017, Olivier33300 a écrit :

Bonjour,

Here is how to fix this problem.

Edit file /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf and change it's content from :

[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan
To :

[keyfile]
unmanaged-devices=*,except:type:ethernet,except:type:wifi,except:type:wwan
And then run :

sudo service network-manager restart
That's all.

Solution trouvé là :


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#7 Le 27/04/2017, à 18:41

ruski_stil

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Vu que ma carte n est pas reconnue je vais reinstaller en propre depuis un cd.

Hors ligne

#8 Le 28/04/2017, à 11:39

Olivier33300

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

Bonjour ruski_stil,
ta carte ethernet est bien reconnue, elle apparaît sous le nom : enp2s0 (cette nomination remplace eth0 dans les nouvelles distribution ubuntu)

Ouvre un terminal (Ctrl+Alt+T) et saisie cette commande :

gedit /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

Le fichier "10-globally-managed-devices.conf" s'ouvre, donne nous son contenue STP.

Hors ligne

#9 Le 10/05/2017, à 17:14

ruski_stil

Re : Ethernet non géré depuis upgrade vers 16.10 et 17.04

@Olivier33300
Merci des conseils, mais j'ai réinstallé après mon message et ça a du être un bug à la mise à niveau.
Ça fonctionne maintenant.
Mais les conseils serviront à qqn d'autre qui lira le sujet.
Vu que ce n'est pas moi qui a ouvert, je ne peux pas mettre résolu.

Hors ligne