Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/06/2017, à 22:00

FranckyNow

Problème version nodejs ubuntu 16.04

Bonjour,
J'aimerais m’entraîner à la programmation d'application avec React Native et pour cela j'ai besoin de nodejs mais malheureusement je n'arrive pas à mettre à jour sa version malgré des dizaines de tentatives je reste bloqué à la 4.2.6 !
J'ai essayé de suivre ce cours : https://www.youtube.com/watch?v=Y7rbJRj … e=youtu.be
Mais dés la 3:45 minutes à cette ligne :

create-react-native-app MaMeteo

L'erreur suivante s'affiche :

*******************************************************************************
ERROR: npm 5 is not supported yet
*******************************************************************************

It looks like you're using npm 5 which was recently released.

Create React Native App doesn't work with npm 5 yet, unfortunately. We
recommend using npm 4 or yarn until some bugs are resolved.

You can follow the known issues with npm 5 at:
https://github.com/npm/npm/issues/16991

*******************************************************************************

Donc les erreurs viennent de npm et nodejs qui n'est pas dans la version 6, en plus c'est précisé sur ce site qu'il faut la version 6 : https://github.com/react-community/crea … native-app

Je vous remercie d'avance pour votre aide smile

Hors ligne

#2 Le 22/06/2017, à 23:57

J5012

Re : Problème version nodejs ubuntu 16.04

github react native a écrit :

You'll need to have Node v6 or later on your machine. We strongly recommend using npm v3, v4, or a recent version of Yarn. Create React Native App does not currently work with npm v5 due to bugs in npm

npm des depots ubuntu xenial est en 3.5.2 → v3

nodejs v6 est à installer manuellement ... https://nodejs.org/en/download/

il est conseillé de desinstaller nodejs et npm provenant des depots, nodejs 6.11.0 fournit npm 3.10.10 ...

Hors ligne

#3 Le 23/06/2017, à 01:20

FranckyNow

Re : Problème version nodejs ubuntu 16.04

Merci de ta réponse, mais j'ai déjà essayé cette méthode.
Premièrement on dirait que la suppression de nodejs et npm ne se fait pas totalement.
Deuxièmement sur ce site j'étais passé par "pack manager" (lien en bas de page) et cela n'avait pas fonctionné hmm

Hors ligne

#4 Le 24/06/2017, à 07:34

J5012

Re : Problème version nodejs ubuntu 16.04

tu ne peux pas avoir la meme erreur ... il n'y a pas de npm v5 dans le paquet ...

avais-tu au moins reinstallé l'app react-nativ avec le nouveau npm ?

Hors ligne