Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 17/08/2017, à 19:05

erresse

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Phroso a écrit :

Dans "ouvrir avec", l'application n'est pas listée, je ne peux donc pas l'associer. C'est le nœud du problème.

Normal, je t'ai expliqué pourquoi...
Dans un premier temps, la fenêtre des propriétés doit afficher la liste des applications déjà associées à ce type de fichier.
En bas de la fenêtre, tu dois avoir un bouton "Ajouter".
Si tu cliques dessus, il va faire afficher une liste de toutes les applications dans la quelle tu choisis celle que tu veux pour ouvrir ton fichier.
Dans cette liste, il n'y a pas "timidity", c'est ce qui te gêne...
Tu devrais avoir une fenêtre ressemblant peu ou prou à ceci :
170817082407978592.png
Et il doit y avoir en bas un champ de saisie (il faut cliquer sur la petite flèche noire pour le révéler) dans lequel tu peux taper le chemin de l'application que tu veux utiliser (par exemple timidity), ou aller chercher cette application en naviguant dans les répertoires système jusqu'à trouver l'exécutable (normalement dans /usr/bin/timidity).
Dès lors, ce programme sera associé à tous les fichiers avec .mid comme suffixe ET le nom "timidity" apparaîtra dans la liste des applications de "Ouvrir avec...".
Note: je n'ai pas l'interface Unity, ni Nautilus comme gestionnaire, moi c'est Ubuntu-Mate et Caja, mais on doit bien trouver l'équivalent de ce que je t'ai décrit dans ton environnement...


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#27 Le 17/08/2017, à 21:40

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Merci Erresse de ta réponse.
Je comprends ce que tu dis et je ne manifeste aucune mauvaise volonté. Ce n'est pas mon intérêt. Je voudrais résoudre ce problème au plus vite, crois-moi.
Ce que tu expliques, existait sous la version que j'utilisais avant : la 12.04.
Avec la 16.04 voici ce qu'il y a :
mini_124954choisir.png
Pas de bouton ajouter ou de commande personnalisée.
Le post #23 le confirme.
La même réponse propose de passer par un autre gestionnaire de fichier : pcmanfm. Ou comme toi peut-être par Ubuntu-Mate ou Caja.
Conclusion : avec Nautilus, ça n'existe plus !

J'ai réussi l'association avec pcmanfm donc. Merci à agn01.
Mais l'application plante au démarrage (clic droit - ouvrir avec). Elle s'affiche brièvement puis disparaît.
Pourquoi ?
Y-a-t-il une nouvelle association à créer ? Un fichier à purger ? Un conflit ?
Merci pour vos conseils.

Dernière modification par Phroso (Le 17/08/2017, à 22:17)


Ubuntu 16.04 LTS

Hors ligne

#28 Le 17/08/2017, à 22:46

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Non je n'ai rien fait de particulier. Je suppose que Pcmanfm modifie des fichiers (j'aimerais bien savoir lesquels) que Nautilus utilise.

Phroso a écrit :

Pcmanfm trouve bien TiMidity++ jusqu'à /usr/bin

Dans la procédure n°5 je passais, dans Pcmanfm par Ouvrir avec>Ouvrir avec>Applications installées>Son et vidéo>Timidity++ MIDI sequenceur
Je viens d'essayer en passant par Ouvrir avec>Ouvrir avec>Ligne de commande personnalisée avec Ligne de commande= usr/bin/timidity + Exécuter dans un émulateur de terminal + garder la fenêtre de terminal ouverte + Nom de l'application : TiMIDIty + Définir l'application sélectionnée comme application par défaut (ouf !). Ça fonctionne mais sans fenêtre graphique.
Ah j'ai oublié : il faut fermer Nautilus puis le réouvrir pour que ce soit pris en compte.
Toujours avec la même procédure j'ai finalement remis Timidity++ MIDI sequenceur par défaut.
Et là miracle dans Nautilus>Ouvrir avec je peux choisir TiMIDIty et ça marche !

Mais tu me diras "la belle affaire, chez moi ça ne fonctionne pas !"
Peut être supprimer Timidity et le réinstaller. Mais je parierais que tu l'as déjà fait.

PS : demain je m'attaquerai à Frescobaldi et j'aurais peut-être besoin de ton aide.


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#29 Le 18/08/2017, à 00:02

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

J'ai recherché quels était les fichiers qui contenait le texte "timidity-interfaces-extra", pas dans tous les répertoires mais dans les plus plausibles.
Je l'ai trouvé dans :
1- dans /etc/gnome/defaults.list
    audio/midi=timidity-interfaces-extra.desktop
   
2- /usr/share/applications/mimeinfo.cache
    audio/midi=org.gnome.Totem.desktop;audacious.desktop;timidity-interfaces-extra.desktop;
    audio/x-mod=rhythmbox.desktop;org.gnome.Totem.desktop;audacious.desktop;timidity-interfaces-extra.desktop;gnome-mplayer.desktop;
   
3- /usr/share/applications/bamf-2.index
    timidity-interfaces-extra.desktop    /usr/bin/timidity -ia            false

4- var/lib et var/log (je ne suis pas allée voir car ça faisait geler gedit)

5-  ~/.config/mimeapps.list
    [Default Applications]
        audio/midi=timidity-interfaces-extra.desktop
    [Added Associations]
        audio/midi=timidity-interfaces-extra.desktop;userapp-timidity-VNN74Y.desktop;audacious.desktop;nautilus-autorun-software.desktop;vlc.desktop;

Je pense que le 5ème est intéressant et qu'on est autorisé à le modifier sans risque.
Dans les versions précédentes d'Ubuntu il me semble que  mimeapps.list était dans ~/.local/share/applications/
userapp-timidity-VNN74Y.desktop je ne sais pas ce que c'est. Peut-être celui que j'ai crée avec pcmanfm comme indiqué dans le post précédent.


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#30 Le 18/08/2017, à 10:21

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour et merci beaucoup agn01 pour tes recherches et tes explications.
L'application par défaut dans Nautilus est bien désormais "TiMidity++MIDIsequencer".
Sans utiliser toute la démarche que tu décris. Je laisse comme ça.
Un autre progrès (si on veut !) est que j'entends la première note du fichier avant que l'application plante.

J'ai trouvé comme toi la présence de Timidity dans les répertoires que tu énumères.
Pas forcément avec la même rédaction ou dans le même ordre que sur ton PC.
Mais quel est le répertoire qui bloque ?
Pourquoi les soundfonts ne sont pas identiques dans Timidity++ et dans interfaces-extra ? On ne sait pas.

Plus simplement, il faudrait juste que le lancement de l'application ne plante pas.
Effectivement, j'ai désinstallé complètement et réinstallé Timidity plusieurs fois. Des fichiers de configuration
restent peut-être actifs quelque part...

Quelle est la manœuvre qui permettrait de bien faire fonctionner Timidity au lancement ?
Merci pour vos suggestions.


Ubuntu 16.04 LTS

Hors ligne

#31 Le 18/08/2017, à 15:21

erresse

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

agn01 a écrit :

Je viens d'essayer en passant par Ouvrir avec>Ouvrir avec>Ligne de commande personnalisée avec Ligne de commande= usr/bin/timidity + Exécuter dans un émulateur de terminal + garder la fenêtre de terminal ouverte + Nom de l'application : TiMIDIty + Définir l'application sélectionnée comme application par défaut (ouf !). Ça fonctionne mais sans fenêtre graphique.

Bonjour agn01,
Ceci est normal, "timidity" est une application en ligne de commande, elle n'affiche rien. Si tu tapes "timidity fichier.mid", la musique se joue et tu ne peux que l'écouter jusqu'au bout, vu qu'il n'y a rien pour commander le programme.
C'est le paquet supplémentaire "...-interfaces-extra" qui contient les interfaces graphiques qu'on peut mettre "par-dessus" timidity.
Donc, si tu ouvres (dans "Ouvrir avec" ou autrement) tes fichiers avec "timidity", tu n'auras pas d'interface, si tu les ouvres avec l'autre commande (...MIDISequencer), il ouvre une interface graphique et exécute timidity simultanément.

@Phroso:
Sur ta capture d'écran, je vois en bas de la fenêtre un bouton : "Chercher de nouvelles applications". Qu'est-ce que ça fait lorsque tu cliques dessus ? Est-ce que ce n'est pas justement le moyen d'ajouter une application qui ne figure pas dans la liste de choix ?


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#32 Le 18/08/2017, à 15:55

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour Erresse,
"Chercher de nouvelles applications" appelle le dépôt des "logiciels Ubuntu" pour installer de nouvelles applications ou supprimer
celles qui existent.
Malheureusement, ça ne crée pas de lien avec celles qui sont absentes de la liste et présentes sur le PC.

Mais ça y est, le clic droit m'indique TiMidity++MIDIsequencer par défaut. Même avec Nautilus.
Mais l'application plante au démarrage.
Si tu as une idée pour réparer ce mauvais départ, je prends.
Merci.


Ubuntu 16.04 LTS

Hors ligne

#33 Le 18/08/2017, à 16:07

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Une partie du problème est donc résolue : avoir Timidity accessible par clic droit sur un fichier *.mid dans Nautilus.

Phroso a écrit :

Pourquoi les soundfonts ne sont pas identiques dans Timidity++ et dans interfaces-extra ? On ne sait pas.

Personnellement je n'entends pas de différence : j'ai essayé avec une pièce de Couperin une fois en utilisant FluidR3_GM.sf2 et une autre fois en utilisant freepats.cfg. Mise à part le fait que FluidR3_GM esqt bien meilleur que freepats, je n'ai pas entendu de différences entre Timidity et Timidity Interfaces Extra. J'imagine que Timidity Interfaces Extra utilise timidity.cfg.

Phroso a écrit :

Plus simplement, il faudrait juste que le lancement de l'application ne plante pas.

Effectivement !
Quelques questions pour débroussailler l'affaire :
1- Est-ce que tu as parfaitement désinstallé timidity avant de le réinstaller ?

sudo apt-get remove --purge timidity timidity-daemon

2- Est-ce que tu as vérifié avec Moniteur système que ça ne bouffait pas toute ta CPU ?
3- Est-ce que Timidity fonctionne en ligne de commande ?
4- Quel est le contenu de ton /etc/timidity/timidity.cfg ?
5- Quel est le contenu de ton /usr/share/applications/timidity-interfaces-extra.desktop
6- Est-ce que au cours de tes multiples tentatives tu n'aurais pas modifier les audio groups ?

A tout hasard tu peux tenter de mettre ton ordi en veille puis sortir de veille et rééssayer .Ça parait loufoque mais c'est une situation que j'ai connue et que je connais encore mais en sens inverse (Timidity ne marche plus en sortie de veille)


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#34 Le 19/08/2017, à 18:29

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour  agn01
j'ai repris les manips que tu m'as indiquées.
1- j'ai supprimé avec la commande. Sans doute restait-il des morceaux de timidity-daemon par rapport à mes désinstallations.
A la réinstallation, 5 secondes de musique et crash, dont voici la réponse de l'ordi :
mini_265008crash1.png
mini_840841crash2.png
Mais j'ai retrouvé Timidity en application par défaut dans le menu contextuel, sans repasser par pcmanfm.

2- pas de consommation excessive de CPU
3- Timidity fonctionne en ligne de commande
4- le contenu de /etc/timidity/timidity.cfg

# Instrument configuration file for timidity
# $Id: timidity.cfg,v 1.7 2005/09/03 19:26:03 hmh Exp $

# You can change just about every option in TiMidity++ using
# This config file.  Please refer to the timidity.cfg(5) manpage
# for more details

## If you have a slow CPU, uncomment these:
#opt EFresamp=d		#disable resampling
#opt EFvlpf=d		#disable VLPF
#opt EFreverb=d		#disable reverb
#opt EFchorus=d		#disable chorus
#opt EFdelay=d		#disable delay
#opt anti-alias=d	#disable sample anti-aliasing
#opt EWPVSETOZ		#disable all Midi Controls
#opt p32a		#default to 32 voices with auto reduction
#opt s32kHz		#default sample frequency to 32kHz
#opt fast-decay		#fast decay notes

## If you have a moderate CPU, try these:
#opt EFresamp=l
#opt EFreverb=g,42
#opt EFchorus=s
#opt s32kHz
#opt p64a

# Disabling some of the Midi Controls can help with the CPU usage a lot.
# The same goes to the VLPF, sample anti-aliasing and effects such as
# reverb and chorus

# By default, try to use the instrument patches from freepats:
#source /etc/timidity/freepats.cfg

# alternatively, you can use the fluid-soundfont:
#source /etc/timidity/fluidr3_gm.cfg
#source /etc/timidity/fluidr3_gs.cfg
soundfont /home/phroso/soundfont_pour_timidity/PC51f.sf2

5- le contenu de  /usr/share/applications/timidity-interfaces-extra.desktop

[Desktop Entry]
Comment=Software sound renderer (MIDI sequencer, MOD player)
Comment[ja]=ソフトウェア・シンセサイザ(MIDI/MODプレイヤー)
Name=TiMidity++ MIDI sequencer
Name[ja]=TiMidity++ MIDIシーケンサ
Terminal=false
Type=Application
Exec=/usr/bin/timidity -ia
Categories=AudioVideo;Audio;Sequencer;
X-AppInstall-Package=timidity-interfaces-extra
X-AppInstall-Section=universe
Icon=/usr/share/pixmaps/timidity.xpm
MimeType=audio/midi;audio/x-mod;

6- J'ignore ce que sont les audio groups. Si j'y ai modifié quelque chose, c'est involontaire !

Le système veille/sortie de veille ne change rien à mon problème.
Pourquoi le système plante au démarrage de Timidity ?
Des idées ?
Merci pour votre partage.


Ubuntu 16.04 LTS

Hors ligne

#35 Le 19/08/2017, à 22:38

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonsoir,

3- Le fait que timidity fonctionne en ligne de commande est une bonne chose et donne l'espoir de résoudre le problème.
6- le contenu de  /usr/share/applications/timidity-interfaces-extra.desktop est identique au mien
5-  le contenu de /etc/timidity/timidity.cfg diffère du mien par le choix des soundfonts. la syntaxe est correcte mais peut-être que le problème vient de PC51f.sf2
Ça vaudrait le coup de rééssayer en modifiant comme suit :
#soundfont /home/phroso/soundfont_pour_timidity/PC51f.sf2
source /etc/timidity/freepats.cfg

Phroso a écrit :

j'ai retrouvé Timidity en application par défaut dans le menu contextuel, sans repasser par pcmanfm.

Je suppose que c'est Timidity++ MIDI sequenceur.
Est-ce que tu pourrais créer, avec pcmanfm une entrée de "Ouvrir avec" qui ne soit que timidity (voir procédure dans le post #28) ? Ça permettrait de savoir si le crash vient de l'interface graphique.


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#36 Le 20/08/2017, à 11:05

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour  agn01,
merci pour tes réponses et ta patience à m'aider smile
5- j'ai fait des essais multiples en changeant les soundfonts.
Le problème est le même, quelle que soit la source sonore choisie. On peut éliminer cette raison.

Pcmanfm crée un lien avec /usr/bin/timidity. Or, dans ce répertoire, il n'y a que "Timidity++ MIDI sequenceur", dont l'exécutable est timidity seul (sans les autres qualités).
Je ne vois pas comment changer cette association, avec autre chose.
La solution n'est pas loin ...
Merci toujours pour vos idées.

PS : @  agn01 : le lecteur Midi de Frescolbaldi fonctionne-t-il maintenant ?

Dernière modification par Phroso (Le 20/08/2017, à 11:07)


Ubuntu 16.04 LTS

Hors ligne

#37 Le 21/08/2017, à 10:22

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Phroso a écrit :

Pcmanfm crée un lien avec /usr/bin/timidity.

Je suppose que tu as fait comme ça :
mini_961939pcmanfmassociationunity.png

Phroso a écrit :

Or, dans ce répertoire, il n'y a que "Timidity++ MIDI sequenceur", dont l'exécutable est timidity seul (sans les autres qualités).

Dans quel répertoire ?

Pour ma part, j'ai récupéré  timidity dans Nautilus :
mini_889034nautilusmidouvriravec.png

Il apparait dans ~/.config/mimeapps.list

audio/midi=timidity-interfaces-extra.desktop;audacious.desktop;vlc.desktop;userapp-timidity-VNN74Y.desktop;

et le fichier userapp-timidity-VNN74Y.desktop est dans /home/agnes/.local/share/applications :

[Desktop Entry]
Type=Application
Name=Timidity
Exec=/usr/bin/timidity %f
Categories=Other;
NoDisplay=true
MimeType=audio/midi
Terminal=true
X-KeepTerminal=true

PS : finalement j'ai désinstallé Frescobaldi. En fait ce que je voulais faire c'est ouvrir des fichiers abc et les écouter. J'avais cru comprendre que Lilypond le pouvait. Mais finalement je peux le faire avec AbcNavigator (Wine) . Pour l'édition des partitions j'utilise Melody Assistant sous Wine (j'ai une license à vie acquise en 2001 et qui à ma grande surprise est effectivement encore valide). Par contre le problème est de faire les associations de fichiers avec des noms de fichiers et répertoires contenant des espaces...

Dernière modification par agn01 (Le 21/08/2017, à 10:25)


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#38 Le 31/08/2017, à 18:23

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour Agnès,
merci pour ces précisions.
J'ai refait l'association comme tu me l'indiques sur la première capture d'écran.
Un progrès : timidity fonctionne sans planter à partir de Pcmanfm ou de Nautilus.
Je suis gêné malgré tout, par le fait que l'application démarre à partir du terminal et non de l'interface.
Comme dans ton exemple j'ai coché : "Exécuter dans un émulateur de terminal".
Et je n'arrive pas à supprimer cette configuration. J'ai supprimé timidity, pcmanfm : rien à faire la configuration revient à la réinstallation.
Ca marche donc, mais je voudrais accéder à l'application par l'interface et non par la commande du terminal.
Faut-il supprimer les fichiers :
- ~/.config/mimeapps.list
- .local/share/applications ?

La résolution approche, merci pour ton aide.


Ubuntu 16.04 LTS

Hors ligne

#39 Le 31/08/2017, à 19:59

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour,
Si timidity ne plante plus, c'est un gros progrès. Tu sais pourquoi ?

Dans dans mon ~/.config/mimeapps.list

audio/midi=timidity-interfaces-extra.desktop;audacious.desktop;vlc.desktop;userapp-timidity-VNN74Y.desktop;

timidity-interfaces-extra.desktop; correspond au lancement avec l'interface. Le fichier se trouve dans /usr/share/applications et apparait sous le nom TiMidity++ MIDI sequencer dans Nautilus.
Son contenu :

[Desktop Entry]
Comment=Software sound renderer (MIDI sequencer, MOD player)
Comment[ja]=ソフトウェア・シンセサイザ(MIDI/MODプレイヤー)
Name=TiMidity++ MIDI sequencer
Name[ja]=TiMidity++ MIDIシーケンサ
Terminal=false
Type=Application
Exec=/usr/bin/timidity -ia
Categories=AudioVideo;Audio;Sequencer;
X-AppInstall-Package=timidity-interfaces-extra
X-AppInstall-Section=universe
Icon=/usr/share/pixmaps/timidity.xpm
MimeType=audio/midi;audio/x-mod;

userapp-timidity-VNN74Y.desktop; correspond au lancement à partir du terminal. Le fichier se trouve dans~/.local/share/applications.
Son contenu :

[Desktop Entry]
Type=Application
Name=Timidity
Exec=/usr/bin/timidity %f
Categories=Other;
NoDisplay=true
MimeType=audio/midi
Terminal=true
X-KeepTerminal=true

Tu peux modifier ce fichier en l'ouvrant   :

sudo gedit ~/.local/share/applications/userapp-timidity-VNN74Y.desktop

(en remplaçant userapp-timidity-VNN74Y.desktop par son nom chez toi)
et modifier NoDisplay et/ou Terminal (false à la place de true)

Mais si tu veux une interface, il vaut mieux utiliser timidity-interfaces-extra.desktop.
En tout cas je ne supprimerais pas mimeapps.list, car il y a d'autres applications concernées.
Pour détailler, j'ai :
* dans la section [Default Applications]

audio/midi=timidity-interfaces-extra.desktop

* dans la section [Added Associations]

audio/midi=timidity-interfaces-extra.desktop;audacious.desktop;vlc.desktop;userapp-timidity-VNN74Y.desktop;

Par défaut j'ouvre donc timidity avec interface mais je peux aussi par "ouvrir avec" choisir d'ouvrir sans interface. (l'ouverture avec vlc ne fonctionne pas -histoire de codec. Je vais la supprimer)

Dernière modification par agn01 (Le 31/08/2017, à 19:59)


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#40 Le 01/09/2017, à 21:31

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour Agnès,
arrh ! j'suis pas doué !
Je n'y arrive pas, malgré la précision de tes conseils.

Tu peux modifier ce fichier en l'ouvrant   :

sudo gedit ~/.local/share/applications/userapp-timidity-0W0R5Y.desktop

et modifier NoDisplay et/ou Terminal (false à la place de true)

En faisant cette commande, le terminal s'ouvre en tâche de fond et je ne peux plus intervenir pour arrêter la musique. Aucune interface.
Je souhaite que les fichiers Midi s'ouvent avec Timidity++ MIDI sequencer. En repassant par Pcmanfm, "ouvrir avec..." je peux le faire, mais ça plante au bout de 2 notes. Idem dans Nautilus.
Soit le fichier s'ouvre dans le terminal et ça fonctionne "tout ou rien" (pas de pause, de retour en arrière, etc), soit l'ouverture plante avec l'interface.
(Ouvrir avec timidity équivaut à ouvrir avec le terminal en fond.)
A force de désintallations/réinstallations, les fichiers de configuration s'accumulent.
Exemple : dans

~/.config/mimeapps.list

Dans la section [Added Associations], j'ai :

audio/midi=timidity-interfaces-extra.desktop;userapp-timidity-0W0R5Y.desktop;vlc.desktop;audacious.desktop;userapp-timidity-FJIG5Y.desktop;

J'ai la même chose que toi pour la section [Default Applications] :

audio/midi=timidity-interfaces-extra.desktop

Par contre, chez moi VLC ouvre les fichiers Midi, mais avec sa propre soundfont, pas terrible.
Repartir de zéro, effacer tous les fichiers de configuration : cela semble impossible.
J'ignore ce que je fais mal et où ça bloque.
Merci pour ta patience et tes conseils.


Ubuntu 16.04 LTS

Hors ligne

#41 Le 01/09/2017, à 22:48

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Il ne faut pas se battre la coulpe ! J'ai eu pas mal de déboires avant d'y arriver, malheureusement sans doute plus par chance que de manière raisonnée.
Donc tu peux ouvrir un fichier midi avec timidity sans interface mais ça ne te convient pas, ce que je comprends.
Et avec une interface ça plante.
A ce stade on est en droit de penser que c'est le paramètre -ia qui pose problème.
Pour s'en assurer ça vaudrait le coup de voir ce que ça fait avec un lancement en ligne de commande :

timidity -ia unfichier.mid

et tant qu'à faire essayer aussi :

timidity -ig unfichier.mid

ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#42 Le 02/09/2017, à 20:20

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Bonjour Agnès,
aucune de ces commandes par le terminal ne fonctionne.
Par contre, chacune énumère des erreurs, qui corrigées, apporteront peut-être une solution.
L'interface dans les 2 cas, paraît, mais c'est tout, aucun son.

timidity -ia

renvoie :

Requested buffer size 32768, fragment size 8192
Warning: Cannot convert string "-adobe-helvetica-bold-r-*-*-14-*-75-75-*-*-*-*" to type FontStruct
ALSA pcm 'default' set buffer size 32768, period size 8192 bytes
Warning: Cannot convert string "-adobe-helvetica-bold-r-*-*-12-*-75-75-*-*-*-*" to type FontStruct
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-adobe-helvetica-bold-r-normal--14-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-adobe-helvetica-bold-r-normal--12-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-adobe-helvetica-bold-o-normal--14-*-*-*-*-*-*-*" to type FontSet
Warning: Cannot convert string "-adobe-helvetica-medium-r-normal--12-*-*-*-*-*-*-*" to type FontStruct
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-adobe-helvetica-medium-r-normal--12-*-*-*-*-*-*-*" to type FontSet
XIO:  fatal IO error 11 (Ressource temporairement non disponible) on X server ":0"
      after 1736 requests (1736 known processed) with 0 events remaining.
CONNECTION PROBLEM WITH XAW PROCESS: No such file or directory
timidity -ig

répond

(timidity:2083): Gtk-CRITICAL **: IA__gtk_text_buffer_get_bounds: assertion 'GTK_IS_TEXT_BUFFER (buffer)' failed
(timidity:2083): Gtk-CRITICAL **: IA__gtk_text_buffer_insert: assertion 'GTK_IS_TEXT_BUFFER (buffer)' failed
(timidity:2083): Gtk-CRITICAL **: IA__gtk_text_buffer_delete_mark: assertion 'GTK_IS_TEXT_MARK (mark)' failed
PANIC !!! OTHER COMMAND ERROR ?!?! 0

On voit bien que quelque chose ne va pas.
Mais comment y remédier ?
Merci pour ton aide.


Ubuntu 16.04 LTS

Hors ligne

#43 Le 03/09/2017, à 19:04

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Aie ! Là, je donne ma langue au chat.
La seule fois où j'ai eu un "fatal IO error 11" c'était à l'époque de Ubuntu 9.04 ou 10.04 et c'était dû à un problème de pilote de carte graphique.
Ce qui ne veut pas du tout dire que ton problème vient de là. Dans ce domaine je n'y connais rien.

Reste Audacious, qui permet de choisir les soundfonts, pour écouter les midi.
et timidity (sans interface) pour convertir les midi en un autre format (on doit pouvoir écrire un script, accessible par clic droit dans Nautilus, pour choisir le format et convertir les fichiers sélectionnés)

Désolée de ne pas pouvoir aider plus.


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#44 Le 03/09/2017, à 20:34

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Je ne vois pas le rapport de lecture des polices et de carte graphique avec Timidity.
L'ordi est le même qu'avant le changement de version ... et ça marchait bien.

Effectivement, je pourrai employer Audacious, qui utilise "spontanément" les soundfonts chargées pour Timidity.
Timidity peut fonctionner en le lançant d'abord, puis en cherchant le fichier à écouter. Mais l'interface n'est pas très commode.

En tout cas, merci beaucoup Agnès pour ton aide et ta patience.
Je laisse la question ouverte en espérant que quelqu'un apportera une solution.
Merci d'avance pour vos contributions.


Ubuntu 16.04 LTS

Hors ligne

#45 Le 03/09/2017, à 22:02

agn01

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

Juste un mot
Toutes les lignes du type

Warning: Cannot convert string "-adobe-helvetica-bold-r-*-*-14-*-75-75-*-*-*-*" to type FontStruct

je les ai aussi. Mais ça n'empèche pas Timidity de fonctionner chez moi. Ce ne sont que des avertissements.
Le

fatal IO error

est plus ennuyeux...


ubuntu 16.04 LTS 32 bits sur ordi fixe
xubuntu 16.04 LTS 32 bits sur portable eaynote MX45-202

Hors ligne

#46 Le 15/09/2017, à 17:43

Phroso

Re : [Non résolu] Lecture de fichiers MIDI avec Timidity/Menu contextuel

up avant abandon


Ubuntu 16.04 LTS

Hors ligne