Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/01/2018, à 07:32

Scolitantides

Problème avec compiz

Bonjour,

Je galère sur un ordi portable HP Compaq 6910p sur lequel j'ai installé Ubuntu 16.04 LTS. Tout allait à peu près bien jusqu'à ce que j'essaie de résoudre un problème mineur lié à l'installation d'une imprimante (HP également). J'avais réussi à l'installer, mais elle se désactivait à chaque fois que l'on éteignait l'ordinateur et qu'on le rallumait. J'ai pensé que le problème venait d'une mauvaise installation, j'ai donc essayé autrement... mal m'en a pris ! Je ne sais plus exactement ce que j'ai fait, mais après avoir supprimé l'imprimante, j'ai essayé de la remettre non pas via "port USB" mais via un autre choix dont je ne me rappelle plus l'intitulé.

Et là il y a eu un plantage, lié selon le message d'erreur à usr/bin/compiz. A partir de là, la barre de lancement latérale et la barre de menu global se sont mises à déconner. Notamment, quand je survolais la barre de lancement, elle disparaissait, puis je n'avais plus que le fond d'écran, puis tout réapparaissait. J'ai alors essayé de comprendre à quoi servait compiz et j'ai cru comprendre que c'était lié à des objets en 3D, je ne voyais pas l'utilité et du coup j'ai voulu l'enlever. J'ai si bien réussi que maintenant je n'ai plus du tout la barre de lancement ni la barre de menu global au lancement de la machine. C'est là que je me suis dit que j'allais arrêter les frais !

Voila les questions que je me pose : je pense utiliser Unity, avec Ubuntu 16.04 LTS, mais est-ce bien le cas (sinon je me suis trompé de forum !) ? Si oui, quel est le lien avec compiz ? J'ai cru comprendre que les 2 étaient incompatibles, mais alors faut-il enlever compiz ou pas ? Sinon faut-il que j'essaie de le remettre ? Je précise enfin que depuis, j'ai remis l'imprimante via le "port USB" que de ce côté là c'est revenu à la situation initiale (fonctionne mais problème de l'activation).

Merci d'avance pour vos conseils.

Hors ligne

#2 Le 12/01/2018, à 07:14

Scolitantides

Re : Problème avec compiz

Bonjour,
J'ai réussi à revenir à la situation antérieure, en réinstallant Unity. Donc actuellement quand j'allume l'ordinateur tout s'affiche normalement, mais dès que la souris reste pointée sur la barre de lancement, elle disparaît avec la barre de menu, puis tout disparaît (sauf fond d'écran) puis tout revient. Idem quand je veut éteindre l'ordinateur par la roue dentée qui permet de gérer la session. Je continue à chercher dans la documentation et le forum, je vais essayer d'être moins "bourrin", mais si quelqu'un a une idée, je suis toujours preneur.
J'ajoute les résultat de compiz --debug

marion@marion-HP-Compaq-6910p:~$ compiz --debug
compiz (core) - Info: Loading plugin: core
compiz (core) - Debug: Trying to load core from: /home/marion/.compiz-1/plugins/libcore.so
compiz (core) - Debug: dlopen failed: /home/marion/.compiz-1/plugins/libcore.so: cannot open shared object file: No such file or directory
compiz (core) - Debug: Trying to load core from: /usr/lib/i386-linux-gnu/compiz/libcore.so
compiz (core) - Debug: dlopen failed: /usr/lib/i386-linux-gnu/compiz/libcore.so: cannot open shared object file: No such file or directory
compiz (core) - Debug: Trying to load core from: /usr/lib/compiz/libcore.so
compiz (core) - Debug: dlopen failed: /usr/lib/compiz/libcore.so: cannot open shared object file: No such file or directory
compiz (core) - Info: Starting plugin: core
compiz (core) - Debug: Started plugin: core
compiz (core) - Error: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Info: Stopping plugin: core
compiz (core) - Debug: Stopped plugin: core
compiz (core) - Info: Unloading plugin: core

et unity --debug

marion@marion-HP-Compaq-6910p:~$ unity --debug
unity-panel-service stop/waiting
unity7 stop/waiting
unity-panel-service start/running, process 5708
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
/usr/bin/compiz (core) - Info: Loading plugin: core
/usr/bin/compiz (core) - Info: Starting plugin: core
[New Thread 0xb768ab40 (LWP 5714)]
/usr/bin/compiz (core) - Info: Loading plugin: ccp
/usr/bin/compiz (core) - Info: Starting plugin: ccp
[New Thread 0xb4d17b40 (LWP 5768)]
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
/usr/bin/compiz (core) - Info: Loading plugin: composite
/usr/bin/compiz (core) - Info: Starting plugin: composite
[New Thread 0xb43dab40 (LWP 5779)]
/usr/bin/compiz (core) - Info: Loading plugin: opengl
/usr/bin/compiz (core) - Info: Starting plugin: opengl
/usr/bin/Compiz (opengl) - Info: GLX_EXT_buffer_age is supported
/usr/bin/compiz (core) - Info: Loading plugin: copytex
/usr/bin/compiz (core) - Info: Starting plugin: copytex
/usr/bin/compiz (core) - Info: Loading plugin: regex
/usr/bin/compiz (core) - Info: Starting plugin: regex
/usr/bin/compiz (core) - Info: Loading plugin: move
/usr/bin/compiz (core) - Info: Starting plugin: move
/usr/bin/compiz (core) - Info: Loading plugin: compiztoolbox
/usr/bin/compiz (core) - Info: Starting plugin: compiztoolbox
/usr/bin/compiz (core) - Info: Loading plugin: commands
/usr/bin/compiz (core) - Info: Starting plugin: commands
/usr/bin/compiz (core) - Info: Loading plugin: vpswitch
/usr/bin/compiz (core) - Info: Starting plugin: vpswitch
/usr/bin/compiz (core) - Info: Loading plugin: animation
/usr/bin/compiz (core) - Info: Starting plugin: animation
/usr/bin/compiz (core) - Info: Loading plugin: resize
/usr/bin/compiz (core) - Info: Starting plugin: resize
/usr/bin/compiz (core) - Info: Loading plugin: wall
/usr/bin/compiz (core) - Info: Starting plugin: wall
/usr/bin/compiz (core) - Info: Loading plugin: grid
/usr/bin/compiz (core) - Info: Starting plugin: grid
/usr/bin/compiz (core) - Info: Loading plugin: mousepoll
/usr/bin/compiz (core) - Info: Starting plugin: mousepoll
/usr/bin/compiz (core) - Info: Loading plugin: snap
/usr/bin/compiz (core) - Info: Starting plugin: snap
/usr/bin/compiz (core) - Info: Loading plugin: workarounds
/usr/bin/compiz (core) - Info: Starting plugin: workarounds
/usr/bin/compiz (core) - Info: Loading plugin: place
/usr/bin/compiz (core) - Info: Starting plugin: place
/usr/bin/compiz (core) - Info: Loading plugin: imgpng
/usr/bin/compiz (core) - Info: Starting plugin: imgpng
/usr/bin/compiz (core) - Info: Loading plugin: fade
/usr/bin/compiz (core) - Info: Starting plugin: fade
/usr/bin/compiz (core) - Info: Loading plugin: unitymtgrabhandles
/usr/bin/compiz (core) - Info: Starting plugin: unitymtgrabhandles
/usr/bin/compiz (core) - Info: Loading plugin: expo
/usr/bin/compiz (core) - Info: Starting plugin: expo
/usr/bin/compiz (core) - Info: Loading plugin: session
/usr/bin/compiz (core) - Info: Starting plugin: session
/usr/bin/compiz (core) - Info: Loading plugin: scale
/usr/bin/compiz (core) - Info: Starting plugin: scale
/usr/bin/compiz (core) - Info: Loading plugin: ezoom
/usr/bin/compiz (core) - Info: Starting plugin: ezoom
/usr/bin/compiz (core) - Info: Loading plugin: unityshell
/usr/bin/compiz (core) - Info: Starting plugin: unityshell
[New Thread 0xadcf7b40 (LWP 5858)
WARN  2018-01-12 14:41:14 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'org.gnome.Shell' yet as we don't have a connection, waiting for it...
[New Thread 0xad41ab40 (LWP 5859)]
WARN  2018-01-12 14:41:14 unity.debug.interface DebugDBusInterface.cpp:217 Unable to load entry point in libxpathselect: libxpathselect.so.1.4: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type -- full D-Bus introspection will not be available
WARN  2018-01-12 14:41:14 xim.controller XIMController.cpp:103 IBus natively supported.
WARN  2018-01-12 14:41:14 unity.dash.gsettingsscopereader GSettingsScopes.cpp:108 Error fetching protocol metadata for scope: social.scope : Impossible de trouver un fichier de clés valide dans les répertoires de recherche
WARN  2018-01-12 14:41:15 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'com.canonical.Unity.Launcher' yet as we don't have a connection, waiting for it...
WARN  2018-01-12 14:41:15 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'com.canonical.Unity.Dash' yet as we don't have a connection, waiting for it...
WARN  2018-01-12 14:41:15 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'org.gnome.SessionManager.EndSessionDialog' yet as we don't have a connection, waiting for it...
WARN  2018-01-12 14:41:15 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'com.canonical.Unity.Session' yet as we don't have a connection, waiting for it...
WARN  2018-01-12 14:41:15 unity.glib.dbus.server GLibDBusServer.cpp:593 Can't register object 'org.gnome.ScreenSaver' yet as we don't have a connection, waiting for it...
[Thread 0xad41ab40 (LWP 5859) exited]
ERROR 2018-01-12 14:41:16 unity.glib.dbus.server GLibDBusServer.cpp:538 DBus name lost 'org.gnome.Shell'
ERROR 2018-01-12 14:41:16 unity.glib.dbus.server GLibDBusServer.cpp:538 DBus name lost 'com.canonical.Unity'
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
WARN  2018-01-12 14:41:16 unity.key.gnome.grabber GnomeKeyGrabber.cpp:108 Trying to grab a disabled action, we skip it
[Thread 0xadcf7b40 (LWP 5858) exited]
[New Thread 0xadcf7b40 (LWP 5872)]
[New Thread 0xad41ab40 (LWP 5873)]
[New Thread 0xab58ab40 (LWP 5874)]
[New Thread 0xaad89b40 (LWP 5875)]
[New Thread 0xaa588b40 (LWP 5876)]
[New Thread 0xa9d87b40 (LWP 5877)]
[New Thread 0xa9586b40 (LWP 5878)]
[New Thread 0xa8d85b40 (LWP 5879)]
[New Thread 0xa8584b40 (LWP 5880)]
[New Thread 0xa7d83b40 (LWP 5881)]
[Thread 0xadcf7b40 (LWP 5872) exited]
[Thread 0xa7d83b40 (LWP 5881) exited]
[Thread 0xa9586b40 (LWP 5878) exited]
[Thread 0xab58ab40 (LWP 5874) exited]
[Thread 0xad41ab40 (LWP 5873) exited]
[Thread 0xaad89b40 (LWP 5875) exited]
[Thread 0xaa588b40 (LWP 5876) exited]
[Thread 0xa8584b40 (LWP 5880) exited]
[Thread 0xa8d85b40 (LWP 5879) exited]
[Thread 0xa9d87b40 (LWP 5877) exited]


[New Thread 0xa9d87b40 (LWP 6274)]
[New Thread 0xa8d85b40 (LWP 6275)]
[Thread 0xa9d87b40 (LWP 6274) exited]
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

(soffice:6293): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:6293): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
[Thread 0xa8d85b40 (LWP 6275) exited]

Et après avoir attendu quelques minutes (heures), j'ai fermé le terminal alors qu'à priori il y avait encore un processus actif...

Si ça inspire quelqu'un smile

Dernière modification par Scolitantides (Le 12/01/2018, à 16:21)

Hors ligne

#3 Le 13/01/2018, à 09:06

Scolitantides

Re : Problème avec compiz

C'est encore moi. Finalement j'ai réinstallé Ubuntu. Je ne mets pas "résolu", on ne peut pas vraiment dire que ce soit le cas.

Hors ligne

#4 Le 13/01/2018, à 12:23

BigTigger

Re : Problème avec compiz

Je ne vais pas vraiment t'aider mais plutôt partager mon expérience. J'ai exactement le même problème avec un Compaq 6710b, de mon côté le problème est apparu après une mise à jour système.
J'ai parcouru plusieurs posts en essayant les solutions proposées sans résultat. J'ai par contre constaté, après une réinstallation la disparition du problème, seulement en faisant la mise à jour système demandée je suis retourné à la case départ !!

Pour info j'ai exécute les commandes de Scolitantides avec le même résultat.

Hors ligne

#5 Le 14/01/2018, à 09:45

Scolitantides

Re : Problème avec compiz

Ah oui, effectivement ! Il y avait 4 mises à jour proposées, dont une du système, et ça n'est pas allé au bout. Et je me retrouve avec le même problème... que j'aurais pu éviter si j'avais bien lu ton message roll

Quoiqu'il en soit ça me fait dire que le problème ne vient pas forcément de l'imprimante. Je me demande si tout simplement Ubuntu 16.04 n'est pas trop lourd pour cet ordi, qui doit dater de 2008 je pense. Il est vrai que j'ai hésité au début à mettre plutôt Xubuntu. Il fonctionne avec un processeur Intel core 2 Duo T7300 de 2 Ghz et une RAM de 2 Go. Il a un disque dur de 80 Go.

Quelqu'un peut-il me (nous) conseiller, notamment s'il faut réinstaller Ubuntu 16.04 sans faire les mises à jour par la suite ou changer de système d'exploitation ?

Merci.

Hors ligne

#6 Le 14/01/2018, à 19:47

BigTigger

Re : Problème avec compiz

Bon je viens de finir une ré installation difficile. J'ai bloqué toutes le mises à jour système. Pour le moment c'est stable, plus de problème.
Pour information j'ai la même configuration avec mon PC j'ai simplement acheté 2Go de RAM en plus et ça avance mieux. Ceci dit avec cette configuration, et jusqu'à présent je n'avais pas de problème.
Pour le moment je regarde pour passer sous Ubuntu GNOME ou Xubuntu.
Vu que nous ne sommes que 2 sur ce post je te tiens informé sur mes investigations

Hors ligne

#7 Le 17/01/2018, à 18:44

Scolitantides

Re : Problème avec compiz

Merci pour tes retours. De mon côté je suis finalement passé sur Xubuntu, pour l'instant tout va bien. smile

Hors ligne

#8 Le 18/01/2018, à 07:48

BigTigger

Re : Problème avec compiz

Je viens de finir une installation de Lubuntu, même conclusion cela fonction bien. Je vais le comparer, en agrément et en performance avec UBUNTU GNOME puis je m'adapterais.
Je pense que l'on va pouvoir clore ce post sans savoir ce qu'il c'est passé!!

Hors ligne