Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/10/2017, à 18:28

ludo-boa

[RESOLU] configuration Apache2

Salut la communauté.

Voilà, je viens posté sur la communauté ubuntu afin de peut être trouver une solution à mon problème.

Je suis le cour openclassrooms
Et je suis sur le chapitre : Interrogez un serveur web

Voici ce qui est demandé :

Afin de pouvoir interroger notre serveur sans restriction, nous allons modifier la configuration du serveur Apache en autorisant toutes les requêtes cross-domain.
Pour cela, il faut modifier le fichier de configuration principal d'Apache, qui se nommehttpd.conf. Son emplacement dépend de l'installation d'Apache. Il se trouve souvent parmi d'autres fichiers de configuration dans un répertoire nomméconf, lui-même situé dans le répertoire où est installé Apache.

Ouvrez le fichier httpd.conf avec un éditeur de texte (par exemple Brackets) puis recherchez la ligne ci-dessous.

LoadModule headers_module modules/mod_headers.so

Cette ligne permet d'activer le module Apache de personnalisation des en-têtes de requêtes HTTP. Elle ne doit pas commencer par un caractère#(qui place la suite de la ligne en commentaire). Si c'est le cas, supprimez le caractère#.Ensuite, ajoutez les lignes suivantes à la fin du fichier.

<IfModule mod_headers.c>
    # Accept cross-domain requests
	Header always set Access-Control-Allow-Origin "*"
</IfModule>

Sauf que je n'ai pas de fichier httpd.conf sous Apache2 version 2.4.18
je n'ai trouvé nul part cette ligne LoadModule headers_module modules/mod_headers.so.
Et j'ai insérer les lignes demandées à la fin de mon fichier apache2.conf
J'ai redémarré mon serveur et lorsque je lance ma page html j'ai des erreurs dans la console.

Je ne comprends pas comment configurer mon Apache pour effectuer un requête XMLHttpRequest.

Je ne sais pas si je suis bien clair.

Et ce que quelqu'un pourrait m'aider ?

Dernière modification par ludo-boa (Le 08/10/2017, à 09:38)


"La chute n'est pas un échec, l'échec est de rester là où nous sommes tombés."

Hors ligne

#2 Le 08/10/2017, à 01:33

Vobul

Re : [RESOLU] configuration Apache2

Dans apache2.conf t'as pas d'autres lignes LoadModule ? Mets ta ligne juste dessous. Sinon il y a peut-être aussi des fichiers dans conf.d/.

Dernière modification par Vobul (Le 08/10/2017, à 01:33)


Vobul

Hors ligne

#3 Le 08/10/2017, à 07:56

bruno

Re : [RESOLU] configuration Apache2

Bonjour,

Le cours que tu cites est totalement inadapté à un système Linux. Le fichier httpd.conf n'est plus utilisé depuis des années et apache2.conf ne devrait pas être modifié. Je t'invite donc a annuler tes modifications

Pour activer le module Apache il faut faire :

sudo a2enmod headers

puis relancer Apache.

sudo service apache2 restart

Ensuite pour autoriser les requêtes inter domaines (CORS, attention danger !), il suffit de placer ces lignes dans la configuration de ton hôte virtuel (voir /etc/apache2/sites-enabled) ou dans un fichier .htaccess à la racine de ton site :

<IfModule mod_headers.c>
    # Accept cross-domain requests
	Header always set Access-Control-Allow-Origin "*"
</IfModule>

et recharger la configuration d'Apache:

sudo service apache2 reload

En ligne

#4 Le 08/10/2017, à 09:37

ludo-boa

Re : [RESOLU] configuration Apache2

Salut.

Merci Vobul et Bruno de vos réponses rapides.

Je passe en résolu. La réponse de Bruno m'a débloqué. Merci bien !


"La chute n'est pas un échec, l'échec est de rester là où nous sommes tombés."

Hors ligne

#5 Le 12/03/2018, à 14:09

bikach

Re : [RESOLU] configuration Apache2

salut, désoler de ressortir ce topic,

mais j'ai le même problème que @ludo-boa,

j'ai essayé la méthode de @bruno mais en vain

j'ai rajouté dans mon virtual host

<IfModule mod_headers.c>
    # Accept cross-domain requests
	Header always set Access-Control-Allow-Origin "*"
</IfModule>

une fois dans <directory> et essayé egalement avant la fermeture de </virtualhost..> en vain

j'ai crée le fichier .htaccess a la racine de mon site avec <ifModule...> a l'interrieur en vain

rien ne va

biensur jai reload apache a chaque fois j'ai active l'option headers malgre tout rien ne fonctionne

y a til une autre façon de procédé ?

Hors ligne

#7 Le 12/03/2018, à 14:22

bikach

Re : [RESOLU] configuration Apache2

merci bruno pour le partage masi l'anglais et moi on est en rupture lol

peut etre je configure mal mon virtualhost

le bout de code je doit le mettre entre les balise <directory> ou apres ?

Hors ligne

#8 Le 12/03/2018, à 14:34

bruno

Re : [RESOLU] configuration Apache2

Aucune importance, tu peux même le mettre dans un .htaccess
Attention le code que j'ai donné était un exemple, tel quel il autorise tous le domaines ! Il vaut mieux n'autoriser que les domaines utiles…

En ligne

#9 Le 12/03/2018, à 15:23

bikach

Re : [RESOLU] configuration Apache2

merci pour le temps que tu prend a m'aider
mais je n'arrive pas a saisir le fichier .htaccess il faut le mettre a la racine de mon site,
c'est le dossier où ce trouve les fichier du site cest ça?
parceque si c'est bien ça j'ai toujours la meme erreur

comment tu precise un nom de domaine particulier dans

Header always set Access-Control-Allow-Origin "*"

?

désoler je suis new sur ubuntu, également sur l'utilisation de apache etc..

Hors ligne

#10 Le 12/03/2018, à 15:30

bikach

Re : [RESOLU] configuration Apache2

cest bon mon amie

c'était un problème de chemin vraiment désole je tes fait perdre ton temps

encor mille merci j’espère un jour te rendre l'appareil

tchous

Hors ligne

#11 Le 14/03/2018, à 18:04

roland2018

Re : [RESOLU] configuration Apache2

bsr à tous moi j ai presque le meme probleme sur mon server apache2 et ssl lorsque je veux demarrer apache je recoi le message
ERROR: le module ssl does not exist!

Hors ligne

#12 Le 14/03/2018, à 19:09

krodelabestiole

Re : [RESOLU] configuration Apache2

Hors ligne