Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/04/2018, à 19:19

Labelle19

No Operating system. Bios Legacy. Sector 1.

Après plusieurs manipulations malheureuses (j'ai modifié mon HD, avec Gparted, alors que je croyais modifier un disque-dur externe!!!), j'ai maintenant le message: No operating system.

J'ai ensuite tenté d'installer Lubuntu 17.10 à côté de la version 16.04, espérant que l'amorçage se ferait à partir de la nouvelle installation.  Mais, non.  Toujours le même message.  Je suis sur le Live-CD 17.10 Lubuntu présentement.

Voici le rapport boot-info.

http://paste.ubuntu.com/p/RZrYdRVGm8/

Également, voici d'autres infos:

lubuntu@lubuntu:~$ sudo parted -l
Model: ATA Hitachi HTS54505 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  205GB  205GB   primary   ntfs
 2      205GB   500GB  295GB   extended
 7      205GB   405GB  200GB   logical   ext4
 5      405GB   416GB  10,4GB  logical   linux-swap(v1)
 6      416GB   500GB  84,4GB  logical   ext4            boot

Merci.


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 18/04/2018, à 16:51)

Hors ligne

#2 Le 18/04/2018, à 10:23

Naziel

Re : No Operating system. Bios Legacy. Sector 1.

Bonjour,

Quelles modifications as tu fait? Tu peux tenter la réparation recommandée de boot repair.

Hors ligne

#3 Le 20/04/2018, à 17:01

ikewdu

Re : No Operating system. Bios Legacy. Sector 1.

Salut,

Le drapeau boot est placé sur une partition logique. Avec gparted, remets-le déjà, par clic droit,  sur la partition NTFS de 205 GB. Et fais le point.

Dernière modification par ikewdu (Le 20/04/2018, à 17:02)

Hors ligne

#4 Le 20/04/2018, à 18:55

Nasman

Re : No Operating system. Bios Legacy. Sector 1.

Si le démarrage était géré par grub en legacy, je pense que le flag boot n'y changera rien.

Avec grub dans le mbr on a:
- chargement du mbr avec indication de l'emplacement de diskboot.img à l'offset 5c (en général LBA=1 si table msdos)
- chargement de la LBA=1 (ou emplacement de bios_boot si gpt)
- chargement des 63 secteurs suivants (core.img) qui doit contenir les infos sur l'emplacement de /boot/grub
- chargement de grub.cfg et menu de boot des différents OS

Le no operating système suggère que les premières étapes ne se font pas ou que ce n'est pas grub qui est dans le mbr.

Que donne

sudo dd if=/dev/sda bs=512 count=2 | hexdump -C

PC fixe sous Bionic 64 bits et portable avec Xenial 64 bits

En ligne

#5 Le 20/04/2018, à 21:23

ikewdu

Re : No Operating system. Bios Legacy. Sector 1.

Re,

Le rapport boot-info semble dire que GRUB est bien dans le mbr. Et perso, un flag boot sur une partition logique, ça me semble peu propice au démarrage. Je le remettrais de toute manière sur la seule partition principale, et après, on pourrait toujours aviser selon le message d'erreur.

Hors ligne

#6 Le 21/04/2018, à 02:48

Labelle19

Re : No Operating system. Bios Legacy. Sector 1.

Naziel a écrit :

Bonjour,

Quelles modifications as tu fait? Tu peux tenter la réparation recommandée de boot repair.

Merci Naziel

J'ai pu effectivement réparer le démarrage avec Boot-Repair.  J'ai donc récupéré mon installation avec Lubuntu 16.04, après avoir effacé la première partition et créée une de 200 mo, tel que suggéré par Boot-Repair (avec une séparation /boot partition dans les options avancées).

Cependant, une fois le login entré dans mon installation initiale, je constate que je ne peux accéder à Internet.  Firefox me répond que je n'ai pas accès, de vérifier ma connexion.  Bon, alors, voici ma démarche.  J'ai vérifié mon adresse IP à l'aide de Ifconfig.  J'ai tenté de la renouveller, mais j'ai un message d'erreur indiquant que le périphérique (dhcp je crois...) n'est pas présent.  Je suis allée voir la config du routeur, et j'ai supprimé les baux des adresses IP; j'ai supprimé ma connexion sur mon Wifi dans Connexion réseau.  Toujours rien.  J'ai même eu un conflit avec l'adresse de mon téléphone cellulaire mais là, c'est réglé, j'ai 2 adresses distinctes.  J'écris ce message sur mon laptop avec le LiveCD.

Je ne sais plus quoi faire maintenant.

Hors ligne

#7 Le 21/04/2018, à 06:18

xubu1957

Re : No Operating system. Bios Legacy. Sector 1.

Bonjour,

Pour cette partie du message :

Cependant, une fois le login entré dans mon installation initiale, je constate que je ne peux accéder à Internet.  Firefox me répond que je n'ai pas accès, de vérifier ma connexion.  Bon, alors, voici ma démarche.  J'ai vérifié mon adresse IP à l'aide de Ifconfig.  J'ai tenté de la renouveller, mais j'ai un message d'erreur indiquant que le périphérique (dhcp je crois...) n'est pas présent.  Je suis allée voir la config du routeur, et j'ai supprimé les baux des adresses IP; j'ai supprimé ma connexion sur mon Wifi dans Connexion réseau.  Toujours rien.  J'ai même eu un conflit avec l'adresse de mon téléphone cellulaire mais là, c'est réglé, j'ai 2 adresses distinctes.  J'écris ce message sur mon laptop avec le LiveCD.

Pour une version 17.10 ou une version 16.04 avec un noyau 4.13, tu peux regarder > Anomalies réseaux en Ethernet sur la version 17.10 .

Dernière modification par xubu1957 (Le 21/04/2018, à 10:35)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#8 Le 21/04/2018, à 10:29

Naziel

Re : No Operating system. Bios Legacy. Sector 1.

Arf, tu vas être embêté, il fallait pas suivre le conseil de la partition boot séparée, juste faire le boot repair sad Le noyau linux pèse assez lourd, résultat, cette partition de 200 Mo va se remplir extrêmement rapidement et tu auras des problèmes d'installation de noyaux (c'est le conseil du boot info qui n'est presque jamais valable). Désolé, je me suis mal exprimé sur mon premier message.

Dernière modification par Naziel (Le 21/04/2018, à 10:32)

Hors ligne

#9 Le 26/04/2018, à 23:10

Labelle19

Re : No Operating system. Bios Legacy. Sector 1.

Naziel a écrit :

Arf, tu vas être embêté, il fallait pas suivre le conseil de la partition boot séparée, juste faire le boot repair sad Le noyau linux pèse assez lourd, résultat, cette partition de 200 Mo va se remplir extrêmement rapidement et tu auras des problèmes d'installation de noyaux (c'est le conseil du boot info qui n'est presque jamais valable). Désolé, je me suis mal exprimé sur mon premier message.

Effectivement, j'ai été très embêtée.  J'ai finalement pu démarrer sur partition configurée avec Lubuntu 17-10 et retrouver les fichiers de mon autre partition.  Suite à ta réponse, j'ai agrandi la partition du boot passant de 200 Mo à 5 Go, espérant que ça sera suffisant.  Merci pour ton aide.  J'ai énormément à apprendre. alors j'apprécie grandement l'aide suggérée.  Merci!

Hors ligne

#10 Le 27/04/2018, à 08:02

Nasman

Re : No Operating system. Bios Legacy. Sector 1.

Ce qu'il faut surtout faire c'est un ménage régulier dans les noyaux.


PC fixe sous Bionic 64 bits et portable avec Xenial 64 bits

En ligne

#11 Le 29/04/2018, à 05:28

moko138

Re : No Operating system. Bios Legacy. Sector 1.

Signalé.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne