Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/07/2018, à 17:38

BlackHole643

[Résolu] Installation wordpress

Bonjour

Je suis perdu, j'ai suivi à la lettre le wiki pour l'installation de wordpress : lien.
Tous les feux semblent être au vert mais je n'arrive pas à voir la moindre page sur mon navigateur internet (Chrome). J'ai constamment une page :

Ce site est inaccessible
Impossible de trouver l'adresse IP du serveur de nomdemonsite.extension.
Effectuez une recherche Google sur nom de mon site extension.
ERR_NAME_NOT_RESOLVED

Qu'est ce que j'ai loupé ?

D'avance merci pour l'aide.

Dernière modification par BlackHole643 (Le 07/07/2018, à 22:15)

Hors ligne

#2 Le 07/07/2018, à 18:02

krodelabestiole

Re : [Résolu] Installation wordpress

salut.

nom_de_mon_site c'est le nom que tu as donné à ton hôte virtuel ?
tu ne peux pas utiliser de _ (underscore) dans un nom de domaine.

tu peux éventuellement remplacer ces infos dans ton fichier wordpress.conf, ton fichier hosts, redémarrer apache et accéder à ton wordpress par ex. avec http://nomdemonsite/

sinon il faudrait que tu donnes plus de détails (est-ce que tu as enregistré un nom de domaine, etc.)

Dernière modification par krodelabestiole (Le 07/07/2018, à 18:03)

Hors ligne

#3 Le 07/07/2018, à 18:20

BlackHole643

Re : [Résolu] Installation wordpress

pardon j'ai voulu anonymisé un peu le truc et j'ai pas fait gaffe qu'en fait c'était marqué en dessous...
donc je corrige le message qui apparait c'est :

Ce site est inaccessible
Impossible de trouver l'adresse IP du serveur de nomdemonsite.extension.
Effectuez une recherche Google sur nom de mon site extension.
ERR_NAME_NOT_RESOLVED

Mon fichier wordpress.conf

<VirtualHost *:80>
        ServerName wordpress
        DocumentRoot /var/www/wordpress
        <Directory /var/www/wordpress>
                AllowOverride all
                Require all granted
        </Directory>
        ErrorLog /var/log/apache2/error.wordpress.log
        CustomLog /var/log/apache2/access.wordpress.log combined
</VirtualHost>

mon fichier hosts

127.0.0.1   localhost
127.0.1.1   prodigy
127.0.0.1   wordpress

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

je comprends pas bien un truc : sous dans les options de wordpress j'ai
- Adresse web de WordPress (URL) j'ai laissé http://wordpress
- Adresse web du site (URL) : là j'ai modifié en mettant un truc à ma sauce : http://nomdemonsite.extension

et sur un autre site j'ai vu qu'il fallait ajouter dans /etc/apache2/apache2.conf

<Directory /var/www/html/>
    AllowOverride All
</Directory>

Edit : pour info j'utilise l'extension WP Super Cache
Quand je vais dans les réglages de cette extension je peux tester le cache. Quand je teste le cache j'obtiens ce genre de message

Récupération de http://wordpress/ pour la première mise en cache.FAILED

Errors: : cURL error 7: Failed to connect to wordpress port 443: Connection refused
Récupération de la première copie de http://wordpress/ :FAILED

Errors: : cURL error 7: Failed to connect to wordpress port 443: Connection refused
Récupération de la deuxième copie de http://wordpress/ :FAILED

Errors: : cURL error 7: Failed to connect to wordpress port 443: Connection refused

Dernière modification par BlackHole643 (Le 07/07/2018, à 20:15)

Hors ligne

#4 Le 07/07/2018, à 21:22

BlackHole643

Re : [Résolu] Installation wordpress

Bon finalement j'ai supprimé les plugin SSL (vu que j'ai pas de certificat) et le truc du cache (je débute donc on verra plus tard). Ca a l'air de fonctionner excepté un truc : la page d'accueil. J'ai remodifié dans les réglages l'Adresse web du site (URL) et j'ai remis http://wordpress. Quand je vais spécifiquement sur l'adresse d'une page l'aperçu s'ouvre bien. Par contre l'aperçu de l'accueil ne s'affiche jamais. Je tape http://wordpress et il me renvoie vers le site http://nomdemonsite.extension.
Quand je change l'URL et que je mets http://test et que je fais la même chose il ne m'ouvre pas l'accueil mais il ne remplace pas cette URL par http://nomdemonsite.extension.
Je rechange encore en remettant http://wordpress et ça revient encore sur http://nomdemonsite.extension.

J'y comprends vraiment rien...

Dernière modification par BlackHole643 (Le 07/07/2018, à 21:23)

Hors ligne

#5 Le 07/07/2018, à 22:14

BlackHole643

Re : [Résolu] Installation wordpress

Résolu c'était vraisemblablement un problème de cookie !!!!

Du coup je vais travailler sur le contenu du site avant de bidouiller les options...

Hors ligne