Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/08/2018, à 22:31

RolandG

plantage en recovery mode pour absence de swapfile

Bonjour à tous,

Quand je suis passé à Bionic Beaver, j'ai lu (pas de trace...) qu'à partir d'un certain niveau de RAM (>12Go, si ma mémoire est bonne), il n'était plus besoin d'un espace swap et que ne pas définir de partition swap était suffisant pour que le système ne mette pas de swap en œuvre.

Comme quoi, qd on trouve une bonne nouvelle, il vaudrait mieux tjrs creuser un peu plus loin ...

Bref,  mon mini PC a parfaitement tourné sans pendant plus d'un mois, puis, au détour d'une modification un peu plus osée, plouf, système planté (en fait sudo détruit), donc reboot, recovery mode, il y a des paquets cassées que je ne peux reconstruire faute de réseau, donc mise en service réseau (ce qui remet le système en RW par montage des éléments du fstab) et ... replouf, pour cause de swapfile absent !

Ci-dessous les cinq dernière lignes avant l'arrêt complet et prolongé (en fait, cinq heures, donc vraiment planté profond), ressaisies con la mano, faute de copié collé :

[  OK  ] Found device HGST_HTS541010B7e610 archives.
         Activating swap /swapfile...
[FAILED] Failed to activate  swap /swapfile.
See 'systemctl status swapfile.swap' for details
[DEPEND] dependency failed for Swap.

Zut (c'est la version polie).
et là tout s'arrête.

C'est visiblement la fin du fichier fstab et, en fait, il m'a affiché les 4 dernières lignes après chaque montage de toutes les partitions déclarées au fstab.

Pour info, le fstab ci-dessous (j'ai eu exactement le même résultat la ligne "swapfile" commentée ou active), récupéré depuis une liveusbkey :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=66ea518b-c52a-472a-8013-108d2671bba9 /               btrfs   defaults,subvol=@ 0       1
# /boot was on /dev/sda1 during installation
UUID=08748804-821e-417d-b853-e596d4d4be80 /boot           ext4    defaults        0       2
# /home was on /dev/sdb3 during installation
UUID=8e6b7c2a-1774-482c-a020-b824aa40024c /home           btrfs   defaults,subvol=@home 0       2
/swapfile                                 none            swap    sw              0       0
UUID=70649675-de0d-4755-8dc2-5124aa328a51 /media/roland/archives auto defaults 0 0

et la commande systemctl répond ceci :

root@roland-miniPC:~#systemctl status swapfile.swap
[]swapfile.swap - /swapfile
   Loaded: loaded (etx/fstab; generated)
   Active: inactive (dead)
     What: Swapfile
     Docs: man: fstab(5)
           man: systemd-fstab-generator(8)
root@roland-miniPC:~#

J'ai aussi eu le même plantage en tentant de monter le réseau après avoir fait, en mode recovery dans la session root :

root@roland-miniPC:~#mount -o rw,remount /
root@roland-miniPC:~#swapoff -a
root@roland-miniPC:~#

je relis la doc, cette fois-ci l'officielle, au chapitre swapfile, et on m'y dit qu'il faut tjrs au moins un swapfile ...

Ma question est :
Que dois-je faire pour pouvoir passer ce blocage :
- L'installation, en session root de recovery mode, d'un swapfile selon la doc (à partir de 3.5) ou
- Convaincre le recovery mode de l'inexistance de swapfile (comment ???)

Merci par avance de vos avis, suggestions, pistes, ...

Dernière modification par RolandG (Le 10/08/2018, à 22:34)


loup maigre (et vieux ...)

Hors ligne

#2 Le 10/08/2018, à 22:47

Naziel

Re : plantage en recovery mode pour absence de swapfile

Bonjour,

au détour d'une modification un peu plus osée

C'est à dire?

Hors ligne

#3 Le 10/08/2018, à 22:59

RolandG

Re : plantage en recovery mode pour absence de swapfile

modification des sudoers par ajout d'un fichier me permettant de ne pas taper le PW pour certaines commandes, invoquées en mode sudo dans des automates ne sachant pas répondre à ce genre de question (fcron, par exemple).
Ca a fonctionné avec les deux premières, l'ajout de la 3me devait comporter une erreur de syntaxe


loup maigre (et vieux ...)

Hors ligne

#4 Le 10/08/2018, à 23:17

Naziel

Re : plantage en recovery mode pour absence de swapfile

Tu as bien utilisé visudo? visudo prévient pour les erreurs de syntaxe non?
Tu peux donner le retour de

ls -l /swapfile

Et je remarque que defaults de la doc n'est pas présent sur la ligne /swapfile du fstab, c'est sw qui remplace (je sais pas si cela a quelque chose à voir)

Dernière modification par Naziel (Le 10/08/2018, à 23:20)

Hors ligne

#5 Le 11/08/2018, à 01:56

??

Re : plantage en recovery mode pour absence de swapfile

Bonsoir

Pour info, sur une machine 18.04.1 qui fonctionne

$ systemctl status swapfile.swap
Unit swapfile.swap could not be found.
a@a:~$ 
a@a:~$ cat /etc/fstab| grep swap
# swap was on /dev/sda8 during installation
#UUID=ff32a7ea-7be8-49a9-9571-0c2da78b9285 none            swap    sw              0       0
a@a:~$ 

J'avais oublié que les partitions swaps ont du être invalidées pour installer une version cryptée.   J'ai manifestement oublié d'ajouter un fichier de swap en remplacement......

il y a simplement à craindre que le fichier /swap soit inaccessible. Peux-tu donner l'état du disque dur paragraphe 1 et 3.1 de https://doc.ubuntu-fr.org/smartmontools et te servant du support d'installation


As-tu une installation chiffrée? cryptée ? ( https://bugs.launchpad.net/ecryptfs/+bug/1670336 )
https://bugs.launchpad.net/ubuntu/+sour … ug/1713980


essayes nano /etc/fstab
et commente la ligne décrivant ton fichier swap

Dernière modification par ?? (Le 11/08/2018, à 02:12)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#6 Le 11/08/2018, à 08:24

RolandG

Re : plantage en recovery mode pour absence de swapfile

@Naziel,
Non, je n'ai pas utilisé visudo puisque je n'ai pas modifié le fichier sudoers mais ajouté un fichier dans /ets/sudoers.d (cf cette doc)
Ce fichier contenait

roland ALL=(ALL) NOPASSWD: /bin/kbdrate, /bin/fcron

mais bien vu pour le swapfile :

ls -l /swapfile
-rw------- 1 root root 2147483648 juill. 24 11:48 /swapfile

Donc, ce fichier swapfile de 2Go a été automatiquement installé, mais je ne sais pas sur lequel de mes disques, j'espère pas sur le SDD où se trouve la racine / (/home est sur un autre HD).

Pourquoi la session recovery ne trouve-telle pas ce fichier swap ?
_____________________________________________________________________________

@ ?? (!! aussi  wink

Mon PC étant tout neuf, comportant
un HDD 1To
- deux partitions pour W10
- une partition 200Go pour /home
- une partition 600Go pour /archive
et un SDD 256Go pour /
Je ne pense pas à une panne.

Je tente une install de smartmontools sur une session livekey et reviens avec les résultats (ou l'échec)


loup maigre (et vieux ...)

Hors ligne

#7 Le 11/08/2018, à 09:27

RolandG

Re : plantage en recovery mode pour absence de swapfile

Je n'arrive pas a installer smartmontools sur ma livekey.
Mais mes disques sont neufs ...


loup maigre (et vieux ...)

Hors ligne

#8 Le 11/08/2018, à 09:49

RolandG

Re : plantage en recovery mode pour absence de swapfile

ni

swapon -s

ni

swapon --show

ne fonctionnent en session recovery :
le système me rend le prompt sans rien répondre.

Existe-t-il une autre solution pour savoir où est installé le swapfile ?

merci par avance


loup maigre (et vieux ...)

Hors ligne

#9 Le 11/08/2018, à 10:40

??

Re : plantage en recovery mode pour absence de swapfile

as-tu commenté la ligne decrivant le fichier swapfile dans /etc/fstab

normalement le fichier est directement à la racine / comme son nom l'indique

 ls  -ls 

Dernière modification par ?? (Le 11/08/2018, à 10:43)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#10 Le 11/08/2018, à 11:53

Naziel

Re : plantage en recovery mode pour absence de swapfile

Ok, le swap est bien présent, je pensais à un problème de droits dessus mais j'ai pas l'impression que ce soit ça.

Par contre je vois une partition /boot, peux tu donner le retour de

df -h | grep boot

afin de voir si elle serait pas pleine

Hors ligne

#11 Le 11/08/2018, à 15:48

RolandG

Re : plantage en recovery mode pour absence de swapfile

@?? : effectivement, le swapfile est bien dans la racine, soit sur le SSD, ce qui ne m'arrange pas, mais je modifierais cela plus tard

et une fois commenté la ligne swapfile dans fstab, le montage réseau de la session recovery ne crée plus d'erreur, mais se bloque après la dernière ligne du fstab, sans erreur (mais il ne revient pas au menu de recovery)
_______________________________________
@Naziel :

df -h | grep boot
/dev/sda1        1.5G      146M      1,3G     11% /boot

________________________________________
@tous :
J'ai retenté un démarrage normal.
J'arrive sans encombre à l'écran d'identification (fonds bordeau, demande du mot de passe après sélection de mon compte sur carré orange).
Il accepte mon mot de passe puis ... plus rien, et je reste ainsi sur le fond bordeaux, vierge ...

MAIS j'ai accès aux consoles (tty3, tty4, tty ...) fonctionnelles.
Mon ~ est bien le home/roland attendu, tout semble fonctionner sauf gnome.

en tous cas, Ubuntu est bien vivant derrière l'écran bordeau.

Vers quoi orienter mes recherches pour réparer cela ?


loup maigre (et vieux ...)

Hors ligne

#12 Le 11/08/2018, à 16:43

??

Re : plantage en recovery mode pour absence de swapfile

Bonjour
   Je suis tenté de te proposer cette documentation https://doc.ubuntu-fr.org/ubuntu_minimale
  que je traduis par

sudo apt-get install --reinstall  lightdm gnome-core xfonts-base xserver-xorg

si tu es en mode recovery, regardes le guide de ma signature pour faire fonctionner le réseau si les commandes ci-dessus exigent une connexion internet.


Cependant tu devrais pouvoir essayer une connexion WAYLAND.   puisque tu as l'écran d'accueil qui te propose la saisie du nom. Il faut alors que tu bascules en wayland avant de valider le mot de passe.

évidemment, la documentation expliquant comment le faire semble manquer.  En tout cas, je ne trouve pas.
- Donc mise a jour de ce document https://doc.ubuntu-fr.org/fenetre_de_connexion
===> Donc lorsque tu as la grille d'écran de saisie du mot de passe
      Sous la zone de  saisie du mot de passe, il y a un rectangle avec les deux mots  SE CONNECTER
     A gauche de ce rectangle, il y a une roue crantée.

   Il faut cliquer sur la roue crantée,    une fenêtre s'ouvre alors. Elle contient deux lignes.
      La première  ne contient que le mot UBUNTU.  on voit que c'est la valeur implicite.
     Il faut cliquer sur la seconde ligne qui contient l'expression   UBUNTU SUR WAYLAND
     Lorsque c'est fait, on peut remplir le mot de passe et choisir Se connecter
    On est alors dans une session wayland au lieu de X11

On peut le vérifier en frappant la commande

echo $XDG_SESSION_TYPE

Il y a alors quelques outils graphiques qui ne fonctionnent pas encore très bien
     

Mais si le problème a un rapport avec tes modifications, il serait certainement plus rapide de refaire une installation.

Dernière modification par ?? (Le 11/08/2018, à 17:32)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#13 Le 13/08/2018, à 16:36

RolandG

Re : plantage en recovery mode pour absence de swapfile

Bonjour,
Installation intégrale refaite.
Home était sur une partition séparée ... bon plan.
J'avais bien noté les détails des ajouts post installation, donc pas de gros pépin. (j'ai presque tout mis dans un script)
Tout fonctionne (ou semble fonctionner wink ).
Merci de votre attention


loup maigre (et vieux ...)

Hors ligne