Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/10/2018, à 18:37

Matugenos

[RESOLU]Grammalecte inopérant dans LO.

Bonjour ! A la suite de la mise à niveau vers ubuntu 18.04.1, je me suis aperçu que Grammalecte 6.3 ne fonctionnait plus dans LibreOffice 6.1.2.1. J'ai désinstallé et réinstallé Grammalecte et obtenu les messages suivants au cours du processus :

"The service.com.sun.star.loader.Python cannot be instanded."

Grammalecte s'affiche cependant dans la liste des extension avec la précision suivante :

"Erreur: le statut de cette extension est inconnu."

Je saurais gré à qui me sortira de cette situation, qui semble être dû à un problème avec Python, ce qui me dépasse largement.

Dernière modification par Matugenos (Le 09/10/2018, à 15:58)


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#2 Le 04/10/2018, à 19:19

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Ça fonctionne chez moi, mais j'ai grammalecte 0.6.5


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#3 Le 05/10/2018, à 17:13

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Merci ! Je vais me mettre à la recherche de la version 6.5.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#4 Le 05/10/2018, à 17:22

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Désolé. Même résultat avec la version 6.5.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#5 Le 05/10/2018, à 17:31

JLK

Re : [RESOLU]Grammalecte inopérant dans LO.

Matugenos a écrit :

Bonjour ! A la suite de la mise à niveau vers ubuntu 18.04.1, je me suis aperçu que Grammalecte 6.3 ne fonctionnait plus dans LibreOffice 6.1.2.1. J'ai désinstallé et réinstallé Grammalecte et obtenu les messages suivants au cours du processus :

"The service.com.sun.star.loader.Python cannot be instanded."

Grammalecte s'affiche cependant dans la liste des extension avec la précision suivante :

"Erreur: le statut de cette extension est inconnu."

Je saurais gré à qui me sortira de cette situation, qui semble être dû à un problème avec Python, ce qui me dépasse largement.

Peut-être faut-il réinstaller LibreOffice et éventuellement purger le profil, ou même réinstaller l'extension ?
Ou alors attendre que l'auteur mette à jour son extension ? neutral

Hors ligne

#6 Le 05/10/2018, à 17:36

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Bizarre ! Je viens de recharger une autre fois Grammalecte 6.5 sur le site Dicollecte du créateur avec le même résultat. J'ai donc essayé de l'installer sur Firefox, et là j'ai comme réponse "fichier corrompu". L'impasse, quoi.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#7 Le 05/10/2018, à 17:47

JLK

Re : [RESOLU]Grammalecte inopérant dans LO.

Matugenos a écrit :

Bizarre ! Je viens de recharger une autre fois Grammalecte 6.5 sur le site Dicollecte du créateur avec le même résultat. J'ai donc essayé de l'installer sur Firefox, et là j'ai comme réponse "fichier corrompu". L'impasse, quoi.

C'est curieux.
Mais il y a peut-être une explication rationnelle : la dernière version de Grammalecte a été crée avant Libreoffice 6.1 et Ubuntu 18.04.1.
Néanmoins, je suis sur Libreoffice 6.1 (via les PPA) sous Ubuntu 16.0.5 et je ne rencontre pas ce type problème, ni dans Firefox, ni Libreoffice.

Hors ligne

#8 Le 05/10/2018, à 18:01

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Donne nous :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#9 Le 05/10/2018, à 19:27

corrigo

Re : [RESOLU]Grammalecte inopérant dans LO.

Est-ce qu'avec la mise à niveau, la passerelle python (qui est requis pour l’utilisation de Grammalecte) pour LibreOffice n'a pas sauté ?

Tente la commande suivante :

 sudo apt install python3-uno

Dernière modification par corrigo (Le 05/10/2018, à 19:27)

Hors ligne

#10 Le 05/10/2018, à 19:27

JBF

Re : [RESOLU]Grammalecte inopérant dans LO.

J'ai la version 0.6.5 de Grammalecte sur LibreOffice 6.1.2 du PPA et Ubuntu 18.04. Cette version de Grammalecte fonctionne normalement.
Quelle est ta version de Python ? Grammalecte (À propos de Grammalecte) me dit que j'ai une machine virtuelle Python 3.6.6.


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://fr.libreoffice.org/get-help/poser-une-question

Hors ligne

#11 Le 06/10/2018, à 16:55

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Voici déjà ma réponse à nam1962 que je remercie de sa sollicitude :

 bernard@bernard-W54-55SU1-SUW:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Alpha amd64 (20140205)]/ trusty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic universe
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse

## Uncomment the following two lines to add software from Canonical's
##'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

deb http://www.bchemnet.com/suldr/ debian extra # désactivé pour la mise à niveau vers xenial désactivé pour la mise à niveau vers bionic
deb http://archive.ubuntu.com/ubuntu/ bionic-proposed universe main multiverse restricted
# deb-src http://archive.ubuntu.com/ubuntu/ xenial-proposed restricted main multiverse universe
bernard@bernard-W54-55SU1-SUW:~$ ls /etc/apt/sources.list.d -1
atareao-atareao-trusty.list
atareao-atareao-trusty.list.distUpgrade
atareao-atareao-trusty.list.save
atareao-ubuntu-atareao-xenial.list
atareao-ubuntu-atareao-xenial.list.distUpgrade
atareao-ubuntu-atareao-xenial.list.save
danielrichter2007-ubuntu-grub-customizer-bionic.list
danielrichter2007-ubuntu-grub-customizer-bionic.list.save
embrosyn-ubuntu-cinnamon-bionic.list
embrosyn-ubuntu-cinnamon-bionic.list.save
embrosyn-ubuntu-cinnamon-xenial.list
embrosyn-ubuntu-cinnamon-xenial.list.save
geany-dev-ppa-trusty.list
geany-dev-ppa-trusty.list.distUpgrade
geany-dev-ppa-trusty.list.save
getdeb.list
getdeb.list.distUpgrade
getdeb.list.save
google-earth-ec.list
google-earth-ec.list.distUpgrade
google-earth-ec.list.save
google-earth-pro.list
google-earth-pro.list.distUpgrade
google-earth-pro.list.save
google.list.distUpgrade
google.list.save
graphics-drivers-ubuntu-ppa-bionic.list
graphics-drivers-ubuntu-ppa-bionic.list.save
gwendal-lebihan-dev-ubuntu-cinnamon-nightly-bionic.list
gwendal-lebihan-dev-ubuntu-cinnamon-nightly-bionic.list.save
i-nex-development-team-ubuntu-daily-bionic.list
i-nex-development-team-ubuntu-daily-bionic.list.save
kranich-cubuntu-trusty.list
kranich-cubuntu-trusty.list.distUpgrade
kranich-cubuntu-trusty.list.save
kranich-ubuntu-extras-bionic.list
kranich-ubuntu-extras-bionic.list.save
libreoffice-ppa-trusty.list
libreoffice-ppa-trusty.list.distUpgrade
libreoffice-ppa-trusty.list.save
otto-kesselgulasch-gimp-trusty.list
otto-kesselgulasch-gimp-trusty.list.distUpgrade
otto-kesselgulasch-gimp-trusty.list.save
rvm-ubuntu-smplayer-bionic.list
rvm-ubuntu-smplayer-bionic.list.save
scribus-ubuntu-ppa-xenial.list
scribus-ubuntu-ppa-xenial.list.distUpgrade
scribus-ubuntu-ppa-xenial.list.save
spotify.list.distUpgrade
spotify.list.save
teamviewer.list
teamviewer.list.distUpgrade
teamviewer.list.save
tsbarnes-ubuntu-indicator-keylock-daily-bionic.list
tsbarnes-ubuntu-indicator-keylock-daily-bionic.list.save
ubuntu-wine-ppa-trusty.list
ubuntu-wine-ppa-trusty.list.distUpgrade
ubuntu-wine-ppa-trusty.list.save
videolan-ubuntu-master-daily-bionic.list
videolan-ubuntu-master-daily-bionic.list.save
videolan-ubuntu-stable-daily-xenial.list
videolan-ubuntu-stable-daily-xenial.list.distUpgrade
videolan-ubuntu-stable-daily-xenial.list.save
yannubuntu-ubuntu-boot-repair-bionic.list
yannubuntu-ubuntu-boot-repair-bionic.list.save
bernard@bernard-W54-55SU1-SUW:~$ 

Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#12 Le 06/10/2018, à 18:06

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Bon, ben voilà...
Tes dépôts sont un total désastre avec du proposed et des PPA qui pourrissent toute ton install, dont du trusty (pour LO, entre autres) et du getdeb (PPA toxique qui vient d'être abandonné).

On peut tenter de nettoyer, mais je pense qu'une clean install qui dure 45 minutes finalisation comprise sera plus rapide...


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#13 Le 07/10/2018, à 12:37

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

J'opte pour le nettoyage des dépôts, si vous me tenez la main, car je ne voudrais pas perdre un certain nombre d'éléments que je ne suis pas sûr retrouver. Je ne suis pas très doué. Si je savais les dépôts à supprimer et ceux à conserver ou à établir.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#14 Le 07/10/2018, à 14:14

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Entre temps, je suis passé au conseil de corrigo en chargeant python3-uno, et houps ! Grammalecte s'installe comme une fleur et fonctionne à merveille. Grand merci donc à vous, corrigo.

Il me reste à faire le ménage dans mes PPA. J'ai déjà supprimé getdeb considéré comme nocif. Je veux bien aller plus loin si quelqu'un veut bien me donner un coup de main.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#15 Le 07/10/2018, à 15:00

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Je regarde à nouveau.
Le nettoyage est impossible.
Trop de doublons, versions différentes, PPA bricolés...

Tout boulot sur l'install actuelle conduira à des problèmes sans fin dans quelques semaines.

Je peux apporter de l'aide pour une réinstall c'est tout.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#16 Le 07/10/2018, à 15:31

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Si vous voulez parler d'une ré-installation de zéro d'ubuntu 18.04, cela me fiche la trouille. Les PPA qui figurent actuellement dans Logiciels & mises à jour y sont pratiquement depuis l'installation initiale de la version 14.04 d'ubuntu sans que cela ne me pose de problème. Vous comprendrez qu'étant un utilisateur de base, peu familiarisé avec les subtilités de l'informatique, je me tâte. Ne serait-il pas possible de supprimer ou d'inactiver les quelques PPA qui posent problème ?


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#17 Le 07/10/2018, à 15:41

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Alors..
On a tous débuté ! Et on a tous eu les chocottes le temps de nous rendre compte que les chocottes devant un ordi, c'est rigolo.
Voilà de quoi on parle : https://doc.ubuntu-fr.org/reinstallation_ubuntu
Tes premiers dix mètres en vélo sans petites roues ont du être autrement plus difficiles wink


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#18 Le 08/10/2018, à 09:48

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

La nuit portant conseil, et bien que tout semble fonctionner au poil, je vais tenter une réinstallation en suivant vos instructions nam1963, si cela peut m'éviter d'autres problèmes.
Et merci encore de votre investissement.


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#19 Le 09/10/2018, à 15:48

Matugenos

Re : [RESOLU]Grammalecte inopérant dans LO.

Bon, je m'étais fait un monde avec ce clear install ou fresh install, ne sachant pas de quoi il retournait. Je me suis donc plongé dans la documentation et j'ai trouvé. Disposant d'un CD avec la version 18.04 LTS d'ubuntu, il ne me reste plus qu'à prendre mon courage en main, de respirer un bon coup et de me lancer, après avoir fait une sauvegarde de mes fichiers personnels par précaution.

Mes remerciements à tous !

Dernière modification par Matugenos (Le 09/10/2018, à 15:56)


Clevo Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz x86_64
Ubuntu 18.04.1 LTS bionic beaver GNOME Shell

Hors ligne

#20 Le 09/10/2018, à 20:40

nam1962

Re : [RESOLU]Grammalecte inopérant dans LO.

Une fois la réinstallation faite, pour finaliser, regarde là wink http://forum.ubuntu-fr.org/viewtopic.php?id=2026344


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne