Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 04/10/2018, à 17:41

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

ne jamais faire sudo gedit, non

voir là avec les droits d'administration :
https://doc.ubuntu-fr.org/tutoriel/comm … ity_budgie

Hors ligne

#27 Le 04/10/2018, à 17:58

DRbuntu91

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

krodelabestiole a écrit :

ne jamais faire sudo gedit, non

C'est la doc. qui m'a induit en erreur .... j'ai bêtement remplace sudo nano par sudo gedit par ce que je n'aime pas trop nano....
Mais donc la bonne commande est:

gksudo gedit /etc/hosts

PS: c'est un peu hors sujet ici, mais la règle est bien:
- sudo pour les commandes et les programmes fonctionnant dans une console?
- gksudo pour les programmes qui ont une interface graphique?


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#28 Le 04/10/2018, à 19:02

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Je n'ai vu les 2 derniers commentaires qu'après donc j'ai fait la procédure avec gedit
Du coup j'ai fait ça (écran de droite) mais quand j'ai voulu sauvegarder ça ma donné ce qu'il y a dans l'écran de gauche
1538672474.png

Par contre quand j'utilise la formule du lien sur host, wordpress apparait

GNU nano 2.9.3                      /etc/hosts                                

127.0.0.1       localhost
127.0.1.1       damhestia-HP-xw4600-Workstation
127.0.0.1       worpress

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters









                            [ Lecture de 10 lignes ]
^G Aide      ^O Écrire    ^W Chercher  ^K Couper    ^J Justifier ^C Pos. cur.
^X Quitter   ^R Lire fich.^\ Remplacer ^U Coller    ^T Orthograp.^_ Aller lig.

et j'ai essayé l'adresse direct dans FF, ça me dit "not found"

Dernière modification par Damhestia (Le 04/10/2018, à 19:11)

Hors ligne

#29 Le 04/10/2018, à 19:17

DRbuntu91

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Tu as fait une erreur dans la ligne 127.0.0.1 wordpress  (tu as oublié le d)
Pour voir si ta modification a bien été sauvegardé refait un

cat /etc/hosts

PS1: je ne sais pas expliquer les warning mais a mon avis ça n’empêche pas bon fonctionnement
PS2: au lieu de sudo utilises plutôt gksudo comme suggéré par krodelabestiole


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#30 Le 04/10/2018, à 20:38

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Oui j'avais vu tout à l'heure et l'ai modifié tongue

damhestia@damhestia-HP-xw4600-Workstation:~$ cat /etc/hosts
127.0.0.1	localhost
127.0.1.1	damhestia-HP-xw4600-Workstation
127.0.0.1	wordpress

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
damhestia@damhestia-HP-xw4600-Workstation:~$ gksudo gedit /etc/hosts

La commande « gksudo » n'a pas été trouvée, voulez-vous dire :

  commande « gfsudo » du deb gfarm-client

Essayez : sudo apt install <nom du deb>

J'avoue être complètement larguée....

Hors ligne

#31 Le 04/10/2018, à 23:33

DRbuntu91

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Ton fichiers hosts me semble OK
Et donc... WP donne quoi?
PS: pour gksudo je ne me souviens plus comment je l'ai installé - peut-être qu'un autre intervenant saura expliquer (a vrai dire je ne modifie que très très rarement des fichiers système)


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#32 Le 05/10/2018, à 11:28

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

DRbuntu91 a écrit :

PS: c'est un peu hors sujet ici, mais la règle est bien:
- sudo pour les commandes et les programmes fonctionnant dans une console?
- gksudo pour les programmes qui ont une interface graphique?

plus maintenant.

la doc que j'ai indiquée détaille tout ça :
https://doc.ubuntu-fr.org/tutoriel/comm … ity_budgie

gedit admin:///etc/hosts

ou

sudo nano /etc/hosts

gksudo ne fonctionne plus avec wayland.
sudo pour lancer une application graphique peut engendrer des problèmes de permissions qui peuvent compromettre des fonctionnalités pour l'utilisateur courant.

mais pour des technos serveur (lamp / wordpress) on n'utilise généralement pas d'interface graphique (en prod c'est quasi systématiquement ssh). c'est pour ça que dans ce contexte on documente plutôt nano sur le wiki (qui reste très simple à prendre en main), et pas d'applications graphiques qui dépendent de l'environnement de bureau (gnome / kde / etc.)

Dernière modification par krodelabestiole (Le 05/10/2018, à 11:39)

Hors ligne

#33 Le 06/10/2018, à 16:11

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

DRbuntu91 a écrit :

Ton fichiers hosts me semble OK
Et donc... WP donne quoi?
PS: pour gksudo je ne me souviens plus comment je l'ai installé - peut-être qu'un autre intervenant saura expliquer (a vrai dire je ne modifie que très très rarement des fichiers système)

Et bien je n'arrive toujours pas à me connecter que ce soit en passant par le lien de la page ou http://localhost/wordpress

Hors ligne

#34 Le 06/10/2018, à 16:28

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

que donne http://wordpress exactement ?

est-ce qu'il y a quelque chose dans /var/log/apache2/error.worpress.log maintenant ?

sudo tail /var/log/apache2/error.worpress.log

que contient /etc/apache2/sites-available/wordpress.conf ?

sudo cat /etc/apache2/sites-available/wordpress.conf

le virtualhost est-il activé ?

sudo a2ensite wordpress

si tu n'as pas suivi l'intégralité de la procédure d'installation de la doc il faudrait nous indiquer sur quelles parties tu as bloqué (/etc/hosts par ex.)
https://doc.ubuntu-fr.org/wordpress#prerequis

Hors ligne

#35 Le 07/10/2018, à 16:23

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Alors c'est bon, j'arrive à accéder à la page worpress pour finir la configuration par contre impossible de me connecter avec les éléments en ma possession
Voici les commandes que tu m'as demandé:

damhestia@damhestia-HP-xw4600-Workstation:~$ sudo tail /var/log/apache2/error.worpress.log
[sudo] Mot de passe de damhestia : 
tail: impossible d'ouvrir '/var/log/apache2/error.worpress.log' en lecture: Aucun fichier ou dossier de ce type
damhestia@damhestia-HP-xw4600-Workstation:~$ sudo cat /etc/apache2/sites-available/wordpress.conf
<VirtualHost *:80>
        ServerName wordpress
        DocumentRoot /var/www/wordpress
        <Directory /var/www/wordpress>
                AllowOverride all
                Require all granted
        </Directory>
        ErrorLog /var/log/apache2/error.wordpress.log
        CustomLog /var/log/apache2/access.wordpress.log combined
</VirtualHost>
damhestia@damhestia-HP-xw4600-Workstation:~$ sudo a2ensite wordpress
Site wordpress already enabled

Sinon j'ai suivi l'intégralité de la procédure. J'avais bloqué sur l'adresse IP mais ça a été corrigé et lorsque j'ai créé la base de données wordpress, je n'ai pas modifié le mot de passe qui est donc "mot_de_passe". J'ai voulu le modifié en suivant la procédure mais il m'a mis

mysql> USE wordpress;
Database changed
mysql> UPDATE wp_users SET user_pass=MD5('Mmdpe') WHERE user_login = 'Wordpress';
ERROR 1146 (42S02): Table 'wordpress.wp_users' doesn't exist
mysql> EXIT

La dernière chose que je n'ai pas pus faire correctement (mais je ne sais pas si ça joue) c'est de me loguer sur phpmyadmin en tant que root et ai dû créer un compte utilisateur

Hors ligne

#36 Le 07/10/2018, à 19:23

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Damhestia a écrit :

Sinon j'ai suivi l'intégralité de la procédure. J'avais bloqué sur l'adresse IP mais ça a été corrigé et lorsque j'ai créé la base de données wordpress, je n'ai pas modifié le mot de passe qui est donc "mot_de_passe". J'ai voulu le modifié en suivant la procédure mais il m'a mis

mysql> USE wordpress;
Database changed
mysql> UPDATE wp_users SET user_pass=MD5('Mmdpe') WHERE user_login = 'Wordpress';
ERROR 1146 (42S02): Table 'wordpress.wp_users' doesn't exist
mysql> EXIT

attention, tu confonds 2 système d'authentification différents. quand tu crées la base de données, tu créés un compte MySQL (celui avec lequel WordPress se connectera à la base de données). Hors là tu suis visiblement une procédure pour modifier un compte utilisateur (ou administrateur) WordPress (celui que tu devras entrer pour te connecter à l'admin de WordPress)

pour modifier le mot de passe d'un compte MySQL la doc est là : https://doc.ubuntu-fr.org/mysql#utilisateurs
donc :

sudo mysql
ALTER USER 'WordPress'@'localhost' IDENTIFIED BY 'nouveau_mot_de_passe';
FLUSH PRIVILEGES;
EXIT
Damhestia a écrit :

La dernière chose que je n'ai pas pus faire correctement (mais je ne sais pas si ça joue) c'est de me loguer sur phpmyadmin en tant que root et ai dû créer un compte utilisateur

pour le dire simplement on ne peut plus se connecter à phpMyAdmin avec le compte root
il faut créé un autre compte avec tous les droits :
https://doc.ubuntu-fr.org/phpmyadmin#acces_root

Hors ligne

#37 Le 08/10/2018, à 03:23

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Ok merci pour tous ces renseignements.. c'est un peu la découverte pour moi tout ça...

J'ai modifié mon mot de passe avec ta procédure du coup

Par contre je n'arrive toujours pas à me connecter à Wordpress et là je ne comprend vraiment pas pourquoi ça ne fonctionne pas...

Je me tate à supprimer la base donnée wordpress pour en recréer une au cas j'ai beugé dans la première... mais j'ai peur d'empirer les choses

Hors ligne

#38 Le 08/10/2018, à 04:43

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Damhestia a écrit :

Par contre je n'arrive toujours pas à me connecter à Wordpress et là je ne comprend vraiment pas pourquoi ça ne fonctionne pas...

il faudrait mieux décrire ton problème stp

Hors ligne

#39 Le 09/10/2018, à 19:06

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

1539104738.png
Voilà mon problème... sauf que je ne vois pas pourquoi car j'utilise bien les identifiants que j'ai....

Hors ligne

#40 Le 09/10/2018, à 19:31

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

les infos concernant la connexion à la base de données ne sont pas bonnes à l'étape 1.
https://doc.ubuntu-fr.org/wordpress#ins … erface_web

Nom de la base de données : wordpress
Identifiant : WordPress
Mot de passe : le mot de passe qu'on a noté à l'étape précédente (lors de la création de la base de donnée et de l'utilisateur WordPress)
Adresse de la base de données : localhost
Préfixe des tables : wp_

attention aux majuscules / minuscules, etc.

Dernière modification par krodelabestiole (Le 09/10/2018, à 19:32)

Hors ligne

#41 Le 09/10/2018, à 22:43

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Les infos dont tu parles ce sont les miennes ou celles du documents?

J'ai bien essayer toute les variantes possibles et inimaginable...

C'est pour ça que je me disais qu'il vaudrait peut être mieux que je supprime la base de données wordpress existante et que je recréé une ... parce que j'ai surement dû faire une mauvaise manip quelque part et pour la retrouver tintin!
Qu'en pense tu?

Hors ligne

#42 Le 09/10/2018, à 23:43

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

après

sudo mysql

tu peux donner les retour de ces commandes :

SHOW DATABASES;
SELECT user, host, plugin, authentication_string FROM mysql.user;
quit

Hors ligne

#43 Le 10/10/2018, à 11:10

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

mysql> SHOW DATABASES;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| mysql              |
| performance_schema |
| phpmyadmin         |
| sys                |
| wordpress          |
+--------------------+
6 rows in set (0.06 sec)

mysql> SELECT user, host, plugin, authentication_string FROM mysql.user;
+------------------+-----------+-----------------------+-------------------------------------------+
| user             | host      | plugin                | authentication_string                     |
+------------------+-----------+-----------------------+-------------------------------------------+
| root             | localhost | auth_socket           |                                           |
| mysql.session    | localhost | mysql_native_password | *THISISNOTAVALIDPASSWORDTHATCANBEUSEDHERE |
| mysql.sys        | localhost | mysql_native_password | *THISISNOTAVALIDPASSWORDTHATCANBEUSEDHERE |
| debian-sys-maint | localhost | mysql_native_password | *E6395891BDCF46ECAEC81F424E4A44F299AE4FE9 |
| WordPress        | localhost | mysql_native_password | *72BD77C2F6B91614701AE8DE6A10EC26AF091A25 |
| phpmyadmin       | localhost | mysql_native_password | *17EB1DBAD268037044B05CF29232767B91FF94BB |
| damhestia        | localhost | mysql_native_password | *17EB1DBAD268037044B05CF29232767B91FF94BB |
+------------------+-----------+-----------------------+-------------------------------------------+
7 rows in set (0.00 sec)

Hors ligne

#44 Le 10/10/2018, à 19:09

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

la base de donnée wordpress existe bien, l'utilisateur WordPress aussi.

pour le tester :

mysql -u WordPress -p

tu tapes le mot de passe.
si ça ne passe pas c'est que le mot de passe n'est pas bon.

puis

USE wordpress;

si ça ne fonctionne pas c'est que l'utilisateur WordPress n'a pas accès à la base de données wordpress.

puis

quit

si tout fonctionne c'est que tu entres de mauvaises infos à l'étape 1 de l'installeur worpress.

Hors ligne

#45 Le 10/10/2018, à 22:53

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Bon, shame on me, comme c'était prévisible, l'erreur venait de moi.
Je n'avais absolument pas vu qu'il y avait un P majuscule dans wordpress... je m'en suis aperçu en voyant la première ligne de commande sur mon terminal!!!

Je vais me permettre une dernière question si ça ne t'embête pas...
J'ai l'intention d'avoir plusieurs site en travail en même temps... du coup comment je fais? Je suis cette procédure et après je fais pareil? https://doc.ubuntu-fr.org/apache2#creat … s_virtuels
Si j'ai bien compris, j'affecte un bout de mon serveur local pour chaque site? Comme un appartement dans un immeuble, c'est bien ça?

En tout cas merci beaucoup pour ton aide et surtout ta patience! Au delà de la résolution de mon problème, j'ai appris énormément de chose sur LINUX!
et merci aussi à DRbuntu91!

Hors ligne

#46 Le 10/10/2018, à 23:04

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Damhestia a écrit :

Je vais me permettre une dernière question si ça ne t'embête pas...
J'ai l'intention d'avoir plusieurs site en travail en même temps... du coup comment je fais? Je suis cette procédure et après je fais pareil? https://doc.ubuntu-fr.org/apache2#creat … s_virtuels
Si j'ai bien compris, j'affecte un bout de mon serveur local pour chaque site? Comme un appartement dans un immeuble, c'est bien ça?

oui.

Hors ligne

#47 Le 11/10/2018, à 10:22

DRbuntu91

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Bonjour
C'est un peu ce que j'ai fait. J'ai 2 sites en local ce qui me permet de tester mes modifications avant de les implémenter sur le vrai site internet.
Mais je ne me souviens plus exactement comment j'ai fait....
PS: Note bien tous tes identifiants et mots de passe par ce que quand il faut modifier son site internet 6 mois plus tard on a parfois un peu de mal!

mysql> SHOW DATABASES;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| MonSite-1          |
| MonSite-2          |
| mysql              |
| performance_schema |
| phpmyadmin         |
| sys                |
+--------------------+
7 rows in set (0,00 sec)

mysql> SELECT user, host, plugin, authentication_string FROM mysql.user;
+------------------+-----------+-----------------------+-------------------------------------------+
| user             | host      | plugin                | authentication_string                     |
+------------------+-----------+-----------------------+-------------------------------------------+
| root             | localhost | mysql_native_password | *61FEE5EE62BA1155987C167DFBC68BB3A0FE28E9 |
| mysql.session    | localhost | mysql_native_password | *THISISNOTAVALIDPASSWORDTHATCANBEUSEDHERE |
| mysql.sys        | localhost | mysql_native_password | *THISISNOTAVALIDPASSWORDTHATCANBEUSEDHERE |
| debian-sys-maint | localhost | mysql_native_password | *3C07DC16B30F01B356182283F32A0EB1D3BD6236 |
| phpmyadmin       | localhost | mysql_native_password | *98704D5F8F37EEE6CD8B49CB01F085FC90323DBC |
| MonSiteAdmin     | localhost | mysql_native_password | *12D70D0AFF870C6565ACC85BBD819BF9C29E0004 |
+------------------+-----------+-----------------------+-------------------------------------------+
6 rows in set (0,00 sec)

mysql> quit
Bye

Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#48 Le 11/10/2018, à 10:37

krodelabestiole

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

keepass est pratique pour ça.

si tu n'as plus de question tu peux ajouter [résolu] au sujet de ton 1er message.

Hors ligne

#49 Le 11/10/2018, à 11:19

Damhestia

Re : [Résolu] Perdue dans l'installation de Lamp/Wordpress

Merci pour ces derniers conseils!

Et sûrement à bientôt pour une nouvelle problématique!

Hors ligne