Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/04/2008, à 14:02

Jul Music

xsane ne fonctionne qu'en root

Bonjour,

Bon j'ai un scanner epson perfection 2480 photo (usb) et il ne fonctionne qu'en root.

Voilà où j'en suis après quelques recherches (j'ai essayé plein de trucs sans vraiment de réussites.... mais j'avance je crois) :

- j'ai téléchargé le firmware, et configurer snapscan.conf
-j'ai autorisé "user" à utiliser des scanners et je l'ai coché dans le groupe scanner (via Utilisateurs et groupes dans administration)
- en root le scanimage -L donne : device `snapscan:libusb:002:004' is a EPSON EPSON Scanner1 flatbed scanner

- Pour le faire fonctionner en "user" :

sudo chmod 777 /dev/bus/usb/002/004
sudo chmod 777 ~/.sane/xsane/*

La tout marche nickel sauf qu'il faut que je retape ces deux lignes à chaque démarrage.

Ma question : existe-il un moyen de changer définitivement ces permissions ?


merci.
smile

Dernière modification par Jul Music (Le 27/04/2008, à 14:04)

Hors ligne

#2 Le 27/04/2008, à 20:08

Jul Music

Re : xsane ne fonctionne qu'en root

bon j'ai résussi mais j'aimerai qu'un spécialiste confirme que ma méthode est à peu près correct.

En tout cas ça marche nickel.

j'ai modifié le fichier "40-basic-permissions.rules" qui se trouve dans /etc/udev/rules.d/  comme suit :

A la place de :

# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0664"
SUBSYSTEM=="usb_device",		MODE="0664"

j'ai mis :

# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0777"
SUBSYSTEM=="usb_device",		MODE="0777"

Voilà je pense que ça change les permissions pour tous mes périphériques usb.

Cela pose-t-il un problème ?

Hors ligne

#3 Le 28/04/2008, à 18:20

Jul Music

Re : xsane ne fonctionne qu'en root

up...

merci, a moins que je ne poste pas au bon endroit ?

Hors ligne

#4 Le 21/05/2008, à 11:51

mastano

Re : xsane ne fonctionne qu'en root

Jul Music a écrit :

bon j'ai résussi mais j'aimerai qu'un spécialiste confirme que ma méthode est à peu près correct.

En tout cas ça marche nickel.

j'ai modifié le fichier "40-basic-permissions.rules" qui se trouve dans /etc/udev/rules.d/  comme suit :

A la place de :

# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0664"
SUBSYSTEM=="usb_device",        MODE="0664"

j'ai mis :
# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0777"
SUBSYSTEM=="usb_device",        MODE="0777"

Voilà je pense que ça change les permissions pour tous mes périphériques usb.

Cela pose-t-il un problème ?

Merci pour ce conseil très utile.
J'ai fait exactement la même chose et c'est nickel

#5 Le 22/05/2008, à 00:00

Grunt

Re : xsane ne fonctionne qu'en root

<Mode Debian ON>
Ajoute les utilisateurs autorisés à accéder au scanner, au groupe "scanner"
Comme ça:
"adduser ton_login scanner", précédé d'un sudo bien sûr.
<Mode Debian OFF>

#6 Le 22/05/2008, à 13:04

Thierry L

Re : xsane ne fonctionne qu'en root

Ou en mode graphique :

Administration -> utilisateurs et groupes

Sélectionner l'utilisateur, dévérouiller, afficher ses propriétés, onglet privilèges utilisateur, et cocher utiliser des scanners

mais c'est plus long lol


Mon photoblog : La suite en images - Linux Mint 9 sur PC et Mac OS X sur iMac.

Hors ligne

#7 Le 22/05/2008, à 15:17

Grunt

Re : xsane ne fonctionne qu'en root

big_smile Wosh, y'a ça sur Ubuntu? Ah ouais ils ont bossé le user-friendly, quand même..

C'est plus long, mais ça a exactement le même effet que "adduser", donc ça revient au même.
Et c'est de toute façon plus propre que le chmod.

#8 Le 22/05/2008, à 16:07

Thierry L

Re : xsane ne fonctionne qu'en root

roll Bah je pense que ce n'est pas spécifique à Ubuntu (j'ai déjà procédé comme ça sous Debian - Lenny ou Etch, ou les deux je ne sais plus).


Mon photoblog : La suite en images - Linux Mint 9 sur PC et Mac OS X sur iMac.

Hors ligne

#9 Le 07/06/2008, à 15:04

nico de berlin

Re : xsane ne fonctionne qu'en root

Jul Music a écrit :

j'ai modifié le fichier "40-basic-permissions.rules" qui se trouve dans /etc/udev/rules.d/  comme suit :

j'ai mis :
# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0777"
SUBSYSTEM=="usb_device",        MODE="0777"

Voilà je pense que ça change les permissions pour tous mes périphériques usb.

Un grand merci pour l'astuce, qui m'a resolu ce probleme bien penible...
smile
Nicolas

#10 Le 07/06/2008, à 21:55

tomcat007

Re : xsane ne fonctionne qu'en root

On fait comment pour editer le fichier :
"40-basic-permissions.rules" qui se trouve dans /etc/udev/rules.d/" et pouvoir enregistrer ensuite les modifs ???
Moi, il me refuse de les enregistrer !!! Je n'est pas les droit il me dit !
Je doit me loger en ROOt je suppose, mais comment faire...
Je suis débutant dans linux et je suis un peu perdu...

Merci pour l'aide

Hors ligne

#11 Le 09/06/2008, à 22:51

manchois

Re : xsane ne fonctionne qu'en root

Bonsoir toomcat007,


tu fais dans ton terminal

 $ gksudo gedit

tu fais ta manip tu enregistres et tu fermes

Dernière modification par manchois (Le 09/06/2008, à 22:51)


Config: carte mère GIGABYTE 970A-DS3P avec AMD 8320FX, memoire 4GO, carte graphique AMD EAH5450,2 dd WD160go sata, 1DD WD 500go sata3 1 DD  WD 500go sata2, 2 lecteurs graveur sata,  moniteur LG 1930sq. Ubuntu 18.04
Laptop HP pavillion G6 carte graphique  radeon hd 7670m  DD 750 go ubuntu 18.04

Hors ligne

#12 Le 10/06/2008, à 10:24

jeromeg

Re : xsane ne fonctionne qu'en root

Un petit [Résolu] au début du titre ?

À +

Hors ligne

#13 Le 28/10/2008, à 13:28

s_Frantz

Re : xsane ne fonctionne qu'en root

Merci, mon scanner USB avait disparu depuis la migration vers la RC d'Intrepid Ibex (8.04->8.10), mon utilisateur était bien membre du groupe scanner... et la modification du fichier "40-basic-permissions.rules" a tout remis en ordre.

--
Frantz

Hors ligne

#14 Le 29/10/2008, à 17:07

Athol

Re : xsane ne fonctionne qu'en root

MERCI  à vous tous, ce sujet m'a permit de retrouver mon scanner....

Hors ligne

#15 Le 11/11/2008, à 19:43

godchat

Re : xsane ne fonctionne qu'en root

Merci a vous je peux utiliser mon scan maintenant...cool... On devrait mettre cette astuce dans un tuto Ubuntu. (Moi ché pas faire:/)
En tous cas je vais imprimer cette astuce si un jour mon ordi plante au moins j'ai tout sous la main.

Merciiiiiiiii, Merciiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii.:D

Heu comment on fait pour resolu ??????:rolleyes:

Dernière modification par godchat (Le 11/11/2008, à 19:49)

Hors ligne

#16 Le 11/11/2008, à 22:44

J5012

Re : xsane ne fonctionne qu'en root

bonne solution mais inexplicable...
j'ai mon permission a 664 et j'ai pas de problemes pour scanner (c'est pas un epson bien sur, et j'ai installe hplip avec sudo).

peut-etre que epson demande des permissions root pour son pilote ??

Hors ligne

#17 Le 23/11/2008, à 22:33

as2277

Re : xsane ne fonctionne qu'en root

Grand_Grunt a écrit :

<Mode Debian ON>
Ajoute les utilisateurs autorisés à accéder au scanner, au groupe "scanner"
Comme ça:
"adduser ton_login scanner", précédé d'un sudo bien sûr.
<Mode Debian OFF>

Pour moi, cela ne suffit pas, j'ai du modifier le fichier /etc/udev/rule.d/40-basic-permissions.rules et ensuite redémarrer udev : sudo /etc/init.d/udev restart

Merci pour votre aide à tous.:cool:


Dell G3 15
Ubuntu depuis juin 2007 ; version 19.04 depuis juillet 2019
Homme libre, avant tout tu chériras la mer.

Hors ligne

#18 Le 24/11/2008, à 11:57

Grunt

Re : xsane ne fonctionne qu'en root

Pour moi, cela ne suffit pas, j'ai du modifier le fichier /etc/udev/rule.d/40-basic-permissions.rules et ensuite redémarrer udev : sudo /etc/init.d/udev restart

Merci pour votre aide à tous.

Je ne connaissais pas cette méthode, pour moi il était nécessaire de déconnecter et reconnecter l'utilisateur ajouté à un groupe. Merci. smile

#19 Le 16/12/2008, à 19:01

Old timer

Re : xsane ne fonctionne qu'en root

Je viens d'installer un scanner Epson V10, sous Intrepid, avec le même pb : XSane ne se lançait qu'en root.
Après avoir testé avec succès la manip indiquée ci-dessus par Jul Music, je n'étais pas très satisfait de devoir ainsi modifier les permissions de base de tous les périphs usb.
J'ai donc adapté à partir du processus d'install de ma Brother, et ça marche finement :
- créer (ou modifier s'il existe déjà) un fichier 45-libsane.rules dans /etc/udev/rules.d/, avec le contenu suivant :
       # Epson V10/V100 (GT-S600/F650)
       SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="012d", MODE="0777", GROUP="scanner"
       LABEL="libsane_rules_end"
  (Modifier, évidemment, les id en fonction du produit... )
- un petit coup de  /etc/init.d/udev restart et ça marche!

#20 Le 19/01/2009, à 23:19

Gaston22fr

Re : xsane ne fonctionne qu'en root

j'ai un scanner epson perfection V10 et toute les manipulations expliquées dans le post fonctionnent mais j'ai toujours un léger problème.
En fait lorsque je quitte xsane il me met deux fois le message "erreur de création de fichier permission non accordée" puis il se ferme normalement mais ne conserve pas les paramètres - ce qui fait que je ne peux en aucun cas déclarer définitivement mon imprimante pour une action copie......
Je viens de réaliser un passage ubuntu 8.04 LTS à 8.10.....avec formatage du disque
J'ai l'impression qu'il demande toujours à travailler en ROOT

Hors ligne

#21 Le 25/01/2009, à 20:17

pec

Re : xsane ne fonctionne qu'en root

Bonjour bonsoir
Même problème pour moi après réinstallation de Intrepid
J'ai réalisé les manips préconisées mais mon scanner epson n'est pas reconnu par "user"
J'ai réinstallé les drivers comme sur la page suivante : http://doc.ubuntu-fr.org/scanner_epson puis suivi cette discussion mais rien.......
Alors, le pire c'est que je veux bien faire un petit lanceur pour faire:

sudo chmod 777 /dev/bus/usb/002/004

Sauf que le chemin de l'usb change à chaque redémarrage et donc, je suis obligé de faire un lsusb pour récupérer les valeurs finales (sudo chmod 777 /dev/bus/usb/00X/00X)  ......pfffff galère!!
mad
merci pour vos idées wink

Dernière modification par pec (Le 25/01/2009, à 20:32)


LINUX est à une jolie fille ce que Windows est à une prostituée. La jolie fille, il faut la séduire et la comprendre pour obtenir ce que l'on désire, la prostituée , il suffit de la payer, et surtout bien se protéger.

Hors ligne

#22 Le 09/02/2010, à 19:01

maxlefou

Re : xsane ne fonctionne qu'en root

moi je n'ai aucun fichier nommé 40-basic-permissions.rules dans l'endroit indiqué...

par contre j'ai un 45-libsane.rules avec dedans ;

# File created by a script to add epson scanners. See http://doc.ubuntu-fr.org/imprimante_epson_multifonctions
# Epson Stylus SX400
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="084a", MODE="655", GROUP="scanner"

j'ai changé en

# File created by a script to add epson scanners. See http://doc.ubuntu-fr.org/imprimante_epson_multifonctions
# Epson Stylus SX400
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="084a", MODE="777", GROUP="scanner"

et un 45-iscan.rules qui contenait

SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="084a", MODE="655", GROUP="scanner"

que j'ai changé en

SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="084a", MODE="777", GROUP="scanner"

puis j'ai rebooté pour tester... aucun changement... sad

Mais ces fichiers me montrent qu'ils recherchent éventuellement un group nommé scanner... Comme le groupe existe pas je le crée et je me mets dedans (sudo addgroup scanner, puis sudo adduser user scanner)... aucun changement...

un peu d'aide pour qqn sur karmic ?

Dernière modification par maxlefou (Le 09/02/2010, à 19:15)


-- Max le Fou / ButtBadger
http://img.photobucket.com/albums/v606/buttbadger/maxbuntu.png

Hors ligne

#23 Le 27/06/2010, à 19:41

Bristow

Re : xsane ne fonctionne qu'en root

maxlefou, j'ai le même soucis sur Lucid... as-tu résolu ton problème.

En fait, Xsane ne trouve mon scanner Perfection V10 que lorsque je lance Xsane en root.

Avez-vous une idée, sachant qu'il n'y plus de groupe scanner et que le fichier 40-basic-permissions.rules n'existe pas...

Merci !


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org
Ubuntu 16.04 LTS avec Mate sur desktop | Ubuntu 18.04 LTS sur laptops
Également sur Mastodon.

Hors ligne

#24 Le 06/07/2010, à 05:37

J5012

Re : xsane ne fonctionne qu'en root

j'ai verifie les permissions de groupe, et le groupe scanner est toujours present (jaunty), et l'option scanner dans les permissions usagers est present mais mon user n'est pas coche !

et pourtant j'arrive a scanner... j'utilise en fait gscan2pdf qui doit avoir un acces root a xsane...

Hors ligne

#25 Le 02/02/2016, à 13:49

bertrand1963

Re : xsane ne fonctionne qu'en root

Bonjour,
J'ai le même problème avec une Epson XP305
Donc j'ai rajouté une ligne dans /lib/udev/rules.d/40-libsane.rules avec ce qui est conseillé plus haut.
J'ai relancé udev : /etc/init.d/udev restart
Mais ça n'a pas suffit, alors j'ai débranché et rebranché la connexion physique USB.
Et là ça marche sans les droits root !

Hors ligne