Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/02/2019, à 22:08

Geronimo12

activer Verr Num au démarrage[resolu]

Bonsoir,
j'ai beau chercher, je n'y suis pas arriver... je lis que numlock n'est plus nécessaire pour la 18.04 donc je me cherche mais ne trouve pas...

comment puis je bloquer le verrouillage numérique au démarrage svp ?

merci d'avance

Dernière modification par Geronimo12 (Le 13/02/2019, à 23:09)


MSI GP60 leopard, Ubuntu 18.04.2 LTS processeur Intel Core i5-4210H CPU @2.90Ghz x 2, mémoire vive 7,7 Go, carte graphique intel corporation 4th Gen Core processor integrated graphics controller, Nvidia GTX950M,  avec ssd msata 120 Go

En ligne

#2 Le 11/02/2019, à 22:54

nollitu

Re : activer Verr Num au démarrage[resolu]

Bonsoir

Va voir la Doc , je crois que tu y trouveras ton bonheur:

https://doc.ubuntu-fr.org/numlockx

Hors ligne

#3 Le 11/02/2019, à 23:37

Geronimo12

Re : activer Verr Num au démarrage[resolu]

merci j'ai essayé mais ça ne marche pas : sudo -H -u gdm -s /bin/bash
dbus-launch gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'
exit


MSI GP60 leopard, Ubuntu 18.04.2 LTS processeur Intel Core i5-4210H CPU @2.90Ghz x 2, mémoire vive 7,7 Go, carte graphique intel corporation 4th Gen Core processor integrated graphics controller, Nvidia GTX950M,  avec ssd msata 120 Go

En ligne

#4 Le 13/02/2019, à 00:16

Geronimo12

Re : activer Verr Num au démarrage[resolu]

quelqu'un pour m'aider svp ?


MSI GP60 leopard, Ubuntu 18.04.2 LTS processeur Intel Core i5-4210H CPU @2.90Ghz x 2, mémoire vive 7,7 Go, carte graphique intel corporation 4th Gen Core processor integrated graphics controller, Nvidia GTX950M,  avec ssd msata 120 Go

En ligne

#5 Le 13/02/2019, à 10:00

nollitu

Re : activer Verr Num au démarrage[resolu]

Essaie ceci:

sudo -i

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

Clavier verrouillé après redemarrage

Dernière modification par nollitu (Le 13/02/2019, à 10:01)

Hors ligne

#6 Le 13/02/2019, à 15:52

Geronimo12

Re : activer Verr Num au démarrage[resolu]

merci mais ça ne fonctionne pas par contre ça m'a supprimer tout mon dock


MSI GP60 leopard, Ubuntu 18.04.2 LTS processeur Intel Core i5-4210H CPU @2.90Ghz x 2, mémoire vive 7,7 Go, carte graphique intel corporation 4th Gen Core processor integrated graphics controller, Nvidia GTX950M,  avec ssd msata 120 Go

En ligne

#7 Le 13/02/2019, à 17:19

lynn

Re : activer Verr Num au démarrage[resolu]

Bonjour,

Geronimo12 a écrit :

merci mais ça ne fonctionne pas par contre ça m'a supprimer tout mon dock

La commande citée par nollitu n'a pas pu supprimer ton dock. Il y a forcement une autre explication.
Pour connaître les dernières commandes que tu as exécutées et trouver celle(s) en cause, postes le retour de

history 30

Dernière modification par lynn (Le 13/02/2019, à 17:19)


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

En ligne

#8 Le 13/02/2019, à 17:20

ylag

Re : activer Verr Num au démarrage[resolu]

Salut,

Geronimo12, au #3 a écrit :

merci j'ai essayé mais ça ne marche pas : ...

Tu avais bien passé le tout en trois commandes distinctes ?

sudo -H -u gdm -s /bin/bash

...suivi de:

dbus-launch gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

...et pour fermer le shell "root":

exit

Edit: Grillé par @lynn ! smile

A+

Dernière modification par ylag (Le 13/02/2019, à 17:22)

Hors ligne

#9 Le 13/02/2019, à 17:38

ylag

Re : activer Verr Num au démarrage[resolu]

Salut,

Tu pourrais aussi tenter cette manip prise dans le wiki de ArchLinux, au paragraphe Extending_getty@.service
Je l'ai fait sur ma 18.04, et ça me semble fonctionner.

Il s'agit donc de créer le sous-dossier /etc/systemd/system/getty@.service.d et d'y ajouter un fichier nommé activate-numlock.conf qui doit contenir:

[Service]
ExecStartPre=/bin/sh -c 'setleds -D +num < /dev/%I'

Si ça ne fonctionne pas, simplement faire:

sudo rm -r /etc/systemd/system/getty@.service.d

...pour effacer le tout et revenir à l'état initial.

A+

Dernière modification par ylag (Le 13/02/2019, à 17:47)

Hors ligne

#10 Le 13/02/2019, à 23:09

Geronimo12

Re : activer Verr Num au démarrage[resolu]

merci beaucoup tout le monde,

ça fonctionne ! il suffisait que je tape bien les 3 commandes distinctes comme suggéré par ylag wink


MSI GP60 leopard, Ubuntu 18.04.2 LTS processeur Intel Core i5-4210H CPU @2.90Ghz x 2, mémoire vive 7,7 Go, carte graphique intel corporation 4th Gen Core processor integrated graphics controller, Nvidia GTX950M,  avec ssd msata 120 Go

En ligne