Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/05/2019, à 08:57

tuxrouge

besoin d'aide pour réparer mon serveur

j'ai un serveur  tout propre que j'ai un peu cassé

dessus j'ai flectra installé qui tourne sur le port 7073 et nginx le renvoi depuis le port 80
j'ai voulu tester tracim et j'ai bêtement suivi la doc https://hub.docker.com/r/algoo/tracim

docker run -e DATABASE_TYPE=sqlite -p 8080:80 -v $TRACIM_STORAGE/etc/:/etc/tracim -v $TRACIM_STORAGE/var:/var/tracim algoo/tracim

Suivant la doc je l'avais déclarée:

TRACIM_STORAGE=~/tracim
mkdir -p $TRACIM_STORAGE/etc
mkdir -p $TRACIM_STORAGE/var

je me suis évidemment aperçu une fois que je l'avais envoyé que j'avais un problème sur le port et je me suis aussi rendu compte juste après que flectra n'était plus accessible (502 Bad Gateway nginx/1.10.3)
j'ai stoppé puis désinstallé le docker tracim sans que ça ne règle quoique ce soit

Je ne comprends pas quels fichiers ont été modifiés par la commande docker et je ne sais pas comment y remédier

je suis allé faire un tour du côté des erreurs de nginx et j'ai ça mais ça ne me parle pas plus.

2019/05/24 08:42:44 [warn] 11574#11574: server name "/var/www/html" has suspicious symbols in /etc/nginx/sites-enabled/flectra:5
2019/05/24 08:42:44 [emerg] 11574#11574: unexpected "}" in /etc/nginx/nginx.conf:71
2019/05/24 08:43:54 [warn] 11602#11602: server name "/var/www/html" has suspicious symbols in /etc/nginx/sites-enabled/flectra:5
2019/05/24 08:44:03 [warn] 11610#11610: server name "/var/www/html" has suspicious symbols in /etc/nginx/sites-enabled/flectra:5
2019/05/24 08:44:03 [warn] 11613#11613: server name "/var/www/html" has suspicious symbols in /etc/nginx/sites-enabled/flectra:5
2019/05/24 08:44:08 [error] 11616#11616: *1 upstream prematurely closed connection while reading response header from upstream, client: 5.51.41.225, server: mon-site.fr, request: "GET / HTTP/1.1$
2019/05/24 08:44:08 [error] 11616#11616: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 5.51.41.225, server: mon-site.fr, request: "GET / HTTP/1.1", upstream$
2019/05/24 08:44:10 [error] 11616#11616: *1 no live upstreams while connecting to upstream, client: 5.51.41.225, server: mon-site.fr, request: "GET / HTTP/1.1", upstream: "http://localhost/", ho$
2019/05/24 08:46:33 [error] 11616#11616: *4 connect() failed (111: Connection refused) while connecting to upstream, client: 141.101.88.118, server: mon-site.fr, request: "GET / HTTP/1.1", upstr$
2019/05/24 08:46:33 [error] 11616#11616: *4 upstream prematurely closed connection while reading response header from upstream, client: 141.101.88.118, server: mon-site.fr, request: "GET / HTTP/$

mon etc/nginx/nginx.conf

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

}

#mail {
#    # See sample authentication script at:
#    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#    # auth_http localhost/auth.php;
#    # pop3_capabilities "TOP" "USER";
#    # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#    server {
#        listen     localhost:110;
#        protocol   pop3;
#        proxy      on;
#    }
#
#    server {
#        listen     localhost:143;
#        protocol   imap;
#        proxy      on;
#    }
#}

mon /etc/nginx/sites-enabled/flectra

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    server_name mon-serveur.fr;
    root /var/www/html;
    location / {
        proxy_pass http://localhost:7073;
            # force timeouts if the backend dies
            proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
            proxy_redirect off;

            # set headers
            proxy_set_header    Host            $host;
            proxy_set_header    X-Real-IP       $remote_addr;
            proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header    X-Forwarded-Proto https;
    }
}

par ailleurs quand j'essaye d'accéder directement à flectra en utilisant le don port adresseip:7073 j'ai le message "La connexion a été réinitialisée"

pourtant flectra tourne bien

# service flectra status
● flectra.service - Flectra Open Source ERP and CRM
   Loaded: loaded (/lib/systemd/system/flectra.service; enabled; vendor preset:
   Active: active (running) since Fri 2019-05-24 16:07:25 CEST; 1h 34min ago
 Main PID: 353 (flectra)
 Tasks: 4 (limit: 4915)
 Memory: 131.3M
 CPU: 7.202s
   CGroup: /system.slice/flectra.service
           └─353 /usr/bin/python3 /usr/bin/flectra --config /etc/flectra/flectra

Du coup je viens questionner les spécialistes wink

Hors ligne

#2 Le 12/06/2019, à 09:59

bruno

Re : besoin d'aide pour réparer mon serveur

Bonjour,

Je suppose que tu n'as pas arrêté et supprimé correctement ton conteneur docker car ta configuration semble corrcte et les  erreurs dans les logs ne correspondent pas à celle-ci.
Redémarre ton serveur.

Hors ligne