Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 09/08/2019, à 17:26

youyou25

Re : [Résolu] Pas de reseau

je dois une cle mais avec une version de 2016 !!!

Hors ligne

#27 Le 09/08/2019, à 17:27

xubu1957

Re : [Résolu] Pas de reseau


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#28 Le 09/08/2019, à 17:31

youyou25

Re : [Résolu] Pas de reseau

un smartphone, OUI.

Hors ligne

#29 Le 09/08/2019, à 17:43

xubu1957

Re : [Résolu] Pas de reseau

Il faudrait pouvoir installer le pilote de la carte filaire Ethernet.

sudo apt install r8168-dkms

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#30 Le 09/08/2019, à 17:54

youyou25

Re : [Résolu] Pas de reseau

j'ai telecharger le fichier r8168-8.036.00.tar-1
est ce que je peux l'installer sur mon PC, si oui comment ?

Hors ligne

#31 Le 09/08/2019, à 18:18

youyou25

Re : [Résolu] Pas de reseau

la connexion par telephone ne fonctionne pas, je ne sais pas pourquoi !

Hors ligne

#32 Le 09/08/2019, à 18:35

xubu1957

Re : [Résolu] Pas de reseau

Il va falloir d'autres aidants, ne me servant pas d'un smartphone.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#33 Le 09/08/2019, à 21:16

ylag

Re : [Résolu] Pas de reseau

Bonsoir,

Ton noyau n'est pas installé correctement, il manque certains paquets dont linux-modules-extra-4.15.0-55-generic qui installe le pilote r8169 de ton contrôleur ethernet. L'absence de ce paquet est probablement la raison pour laquelle ta connexion filaire ne fonctionne pas.

Pour info, voici les paquets relatifs au noyau sur ma 18.04:

linux-generic					install
linux-headers-4.15.0-54				install
linux-headers-4.15.0-54-generic			install
linux-headers-4.15.0-55				install
linux-headers-4.15.0-55-generic			install
linux-headers-generic				install
linux-image-4.15.0-54-generic			install
linux-image-4.15.0-55-generic			install
linux-image-generic				install
linux-modules-4.15.0-54-generic			install
linux-modules-4.15.0-55-generic			install
linux-modules-extra-4.15.0-54-generic		install
linux-modules-extra-4.15.0-55-generic           install

Il te faudrait tenter d'installer au moins les méta-paquets linux-generic et linux-image-generic, qui devraient tirer comme dépendances les autres paquets requis pour compléter l'installation du noyau?

Ça peut se faire par la création d'un environnement «chroot» via un liveUSB.

En premier lieu, il faudrait que tu enlèves de tes sources le dépôt:

https://apt.dockerproject.org/repo ubuntu-trusty

...qui ne fournit pas de paquets pour Ubuntu Bionic 18.04 et sera toujours source d'erreur lors de tentatives de mises à jour.

Puis il faut déterminer quel est le chemin de ta partition racine qui devra être montéé dans l'environnement chroot, la commande:

lsblk

...doit permettre de le faire.

À ce stade, il faut démarrer sur le liveUSB. (une version antérieure à la 18.04 devrait faire l'affaire, si la 18.04 n'est pas disponible).
Ensuite revérifier le chemin de ta partition racine Ubuntu 18.04 sur ton disque dur avec lsblk passé à partir de la session live.

Passer ensuite à la création de l'environnement chroot (je prends ici pour exemple que la racine de ton système serait sur sda1):
Monter la racine dans la session live:

sudo mount /dev/sda1 /mnt

Monter les systèmes de fichiers suivants pour rendre utilisable le chroot:

for i in /dev /dev/pts /proc /sys /etc/resolv.conf ; do sudo mount --bind $i /mnt$i ; done

Entrer ensuite dans le chroot:

sudo chroot /mnt

À partir de ce point, tu devrais être en utilisateur «root» dans ta 18.04 installée.
Tente maintenant la mise à jour de la liste des paquets:

apt update

...si tout se passe sans erreur, on tente l'installation des méta-paquets linux-generic et linux-image-generic:

apt install linux-generic linux-image-generic

Ça devrait aussi installer les paquets manquants de ton noyau.

Lorsque terminé, faire la commande:

exit

...pour sortir du chroot.
Arrêter ensuite la machine et retirer la clé liveUSB, puis tenter un démarrage normal et voir si le réseau filaire est activé?

Faudrait que @xubu1957 et/ou @cqfd93 revoient ma procédure pour valider...

A+

Dernière modification par ylag (Le 10/08/2019, à 12:01)

Hors ligne

#34 Le 10/08/2019, à 17:31

youyou25

Re : [Résolu] Pas de reseau

Bonjour à tous,

problème résolu, j'ai pu installer les paquets manquants.
Je remercie tous ceux qui m'ont apporté leur AIDE !!! smile:):)

Hors ligne

#35 Le 10/08/2019, à 17:34

xubu1957

Re : [Résolu] Pas de reseau

Bonjour,

C'est bien !

Pour éditer ta discussion et rajouter [Résolu] au début du titre, il faut utiliser le bouton Modifier au bas de ton premier message.

Merci wink


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#36 Le 10/08/2019, à 17:48

cqfd93

Re : [Résolu] Pas de reseau

Bonjour,

ylag a écrit :

apt install linux-generic linux-image-generic

Ça devrait aussi installer les paquets manquants de ton noyau.…
Faudrait que @xubu1957 et/ou @cqfd93 revoient ma procédure pour valider...

Pas de problème, je pense même que l'installation de linux-generic seul aurait suffit à ajouter toutes les dépendances.


cqfd93

Hors ligne

#37 Le 11/08/2019, à 12:35

ylag

Re : [Résolu] Pas de reseau

Bonjour,

@youyou25:

Content que ça marche pour toi ! smile

cqfd93 a écrit :

...je pense même que l'installation de linux-generic seul aurait suffit à ajouter toutes les dépendances.

Merci pour la précision; aurais-tu une explication sur le pourquoi de l'existence de ces deux paquets?
Quand faut-il en choisir un plutôt que l'autre, et est-ce que linux-image-generic seul aurait suffit?
Chez-moi, les deux sont installés autant sur ma 16.04 que sur ma 18.04.

A+

Dernière modification par ylag (Le 11/08/2019, à 12:38)

Hors ligne

#38 Le 11/08/2019, à 16:46

cqfd93

Re : [Résolu] Pas de reseau

Bonjour,

ylag a écrit :

Merci pour la précision; aurais-tu une explication sur le pourquoi de l'existence de ces deux paquets?

Je ne saurais pas te dire, tout ce que je sais c'est que ce sont des méta-paquets nécessaires pour mettre à jour les noyaux.

Quand faut-il en choisir un plutôt que l'autre, et est-ce que linux-image-generic seul aurait suffit?

Ils ne sont pas interchangeables, l'un dépend de l'autre mais l'inverse n'est pas vrai, comme on peut le voir là (compare les dépendances) :

moi@aurore:~$ dpkg --status linux-generic
Package: linux-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 15
Maintainer: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Architecture: amd64
Source: linux-meta
Version: 4.4.0.157.165
Depends: linux-image-generic (= 4.4.0.157.165), linux-headers-generic (= 4.4.0.157.165)
Description: Complete Generic Linux kernel and headers
 This package will always depend on the latest complete generic Linux kernel
 and headers.
moi@aurore:~$
moi@aurore:~$ dpkg --status linux-image-generic
Package: linux-image-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 15
Maintainer: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Architecture: amd64
Source: linux-meta
Version: 4.4.0.157.165
Depends: linux-image-4.4.0-157-generic | linux-image-unsigned-4.4.0-157-generic, linux-modules-extra-4.4.0-157-generic, linux-firmware, intel-microcode, amd64-microcode
Recommends: thermald
Breaks: nvidia-304 (<< 304.135-0ubuntu0.16.04.3~), nvidia-340 (<< 340.104-0ubuntu0.16.04.2~), nvidia-384 (<< 384.130-0ubuntu0.16.04.2~), virtualbox-dkms (<< 5.1.38-dfsg-0ubuntu1.16.04.3~), virtualbox-guest-dkms (<< 5.1.38-dfsg-0ubuntu1.16.04.3~), virtualbox-guest-dkms-hwe (<< 5.1.38-dfsg-0ubuntu1.16.04.2~)
Description: Generic Linux kernel image
 This package will always depend on the latest generic kernel image
 available.
moi@aurore:~$

Chez-moi, les deux sont installés autant sur ma 16.04 que sur ma 18.04.

Il y en a même un troisième : linux-headers-generic.


cqfd93

Hors ligne

#39 Le 11/08/2019, à 17:16

ylag

Re : [Résolu] Pas de reseau

Salut,

cqfd93 a écrit :

Ils ne sont pas interchangeables, l'un dépend de l'autre mais l'inverse n'est pas vrai, comme on peut le voir là (compare les dépendances) :

Donc il faut mettre linux-generic qui installera les paquets nécessaires à la construction du noyau...
Merci! smile

A+

Dernière modification par ylag (Le 11/08/2019, à 17:25)

Hors ligne

#40 Le 11/08/2019, à 17:37

cqfd93

Re : [Résolu] Pas de reseau

Absolument wink


cqfd93

Hors ligne