Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 17/11/2008, à 14:10

raphaelharboun

Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Bonjour tout le monde, tout nouveau dans la communauté linuxienne, j'essaye depuis plus d'une semaine de faire finalement marcher mes drivers ATI...
J'espere que certains d'entre vous pourront m'aider...

J'ai un PC portable Asus M6ne dont j'ai retiré l'ecran (il etait completement cassé) et depuis il est branché a un lcd asus 20".
j'ai installé une premiere fois ubuntu 8.04 mais impossible d'installer correctement les drivers
je suis finalement passé sur intrepid mais toujours le meme probleme.
je m'explique:

Quand je finis l'installation de ubuntu, j'arrive sans probleme (sans message low-graphic mode) sur mon bureau mais la resolution n'est pas adaptée, donc je lance le gestionnaire de résolution d'ecran, et la il m'affiche bien mes deux ecrans ( laptop, asus) mais seulement en mode mirroir, ce qui fait que lorsque je choisi le asus avec la resolution que je veux j'obtient un ecran avec le fond d'ecran ubuntu et un dossier au milieu qui contient mes disque, mais pas de barre de tache.

je me décide donc a installer les driver fglrx avec apt-get install xorg-driver-fglrx (je crois que c'etait ca la commande), une fois que c'est fait gros probleme, quand je redemarre, ubuntu m'affiche le message d'erreur low graphic mode et malheuresement rien ne marche a part l'option continuer en low graphic mode !!!

a ce stade et j'ai essayé d'inverser ces deux étape, j'installe les drivers offciel ATI, les derniers catalyst téléchargés sur le site officiel, avec la commande sudo sh ati........run, ca m'installe tout tranquillement, ca me relance le systeme, toujours le meme message d'erreur low graphic mode, et la j'ai donc le ati control center d'installer, mais quand j'essaye de le lancer message d'erreur "probleme d'initialisation dans l'edition catalyst control center linux, il peut provenir du suivant, aucun pilote graphique ATI n'est installé, ou bien le pilote ATI ne fonctionnne pas correctement, veuillez installer le pilote ATI approprié a votre matériel ATI, ou configurez avec aticonfig"
Bien sur quand je lance aticonfig --initial -f ca ne change rien ni ne fait rien au fait.

apres avoir trainé sur le forum j'ai bien essayé de faire un tour dans le fichier xorg.con mais il ressemble pas a ce que j'ai vu sur le net, il est "vide"

 # xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

De plus, lorsqsue je rentre dans le gestionnaire des Drivers, c'est vide de chez vide il n'y a rien de marque donc impossible de choisir parmis une liste de driver video..a moins que je sois pas au bon endroit!

Je vous remerci d'avance pour l'aide que vous pourrez m'apporter.

Raphael

EDIT

j'ai tenté de reinstaller un nieme fois les drivers ATI catalyst en prenant la version 64bit comme conseillée,
et petite chose que j'avais mal signalé, lorsque je fais sudo aticonfig --initial -f il me dit qu'il trouve le fichier mais il met "erreur de segmentation"

personne ne voit ce que c'est..?

Dernière modification par raphaelharboun (Le 17/11/2008, à 19:43)

Hors ligne

#2 Le 17/11/2008, à 19:44

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

petit up, desolé je sais pas si ca se fait ici ...

Hors ligne

#3 Le 19/11/2008, à 14:12

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

N'y a t-il donc personne dans cette communauté d'érudit pour venir en aide a un pauvre néophyte comme moi ??
un peu de flatterie ca plait toujours...

Hors ligne

#4 Le 22/11/2008, à 20:12

Nadia & redjus

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

bonjour, j'ai le meme probleme que toi sur une ati radeon mobility 9700.
meme en compilant un xorg.conf manuellement rien ne change, je suis en 800x600 et intrepid ne veut rien savoir sur aucun driver...

si on pouvait juste avoir une résolution a peut pres acceptable, on s'occupera de la 3D apres...

merci bien.

#5 Le 24/11/2008, à 13:26

Olibrigus

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Salut à tous,

Même problème, je suis passé de Hardy à Intrepid et au démarrage, il me force à démarrer en mode graphique pourri. J'ai aussi un Radeon 9600. J'ai essayé aussi plein de solutions et rien.

Quand je lance à partir du CD, tout se passe bien et tout est bien reconnu. J'ai donc copier le /etc/X11/xorg.conf et je l'ai recopier ensuite sur ma vrai partition et toujours rien.

J'ai essayé de désinstaller des drivers, marche pas non plus. Et rien ne s'affiche dans le gestionnaire des pilotes.

J'ai vraiment pas envie de tout réinstaller.

Est-ce que ça pourrait être un conflit entre Compiz (installé sous Hardy) et les nouveaux settings d'Intrepid??

Bon, le premier qui trouve fait signe aux autres !

Merci

Hors ligne

#6 Le 24/11/2008, à 14:05

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Salut raphaelharboun,

Comme indiqué dans la documentation "radeon", ta carte utilises la pilote libre "radeon". Il n'y a rien à faire de plus que de l'utiliser.

Le pilote ATI propriétaire pour Linux, ne gère pas ton modèle de carte.

Tu peux vérifier, après un installation propre, que l'accélération graphique est OK.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#7 Le 24/11/2008, à 19:20

Olibrigus

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Cool, j'ai réussi à récupérer ma résolution normale.

J'ai juste lancé ces 3 commandes dans un terminal et j'ai rebooté.

sudo apt-get remove fglrx-control
sudo apt-get remove xorg-driver-fglrx
sudo apt-get autoremove

Excellent !

Hors ligne

#8 Le 25/11/2008, à 15:12

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Merci inbox pour ta répons..
j'ai donc reinstallé ubuntu 8.10
je peux a present profiter des effets graphiques, mais comme je le disais, quand je vais dans resolution de l'ecran, je suis en mode clone avec une resolution max de 1024x768, je presume que c'etait la resolution max de l'ecran 15"4 du pc portable, mais la je suis avec un ecran asus 20" en VGA. je devrais pouvoir monter jusqu'a 1680x1050 mais c'est disponible que lorsque je desactive le mirror, et donc ca fait une sorte de double ecran sauf qu'il en manque 1 roll:rolleyes:

Hors ligne

#9 Le 25/11/2008, à 15:51

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Et donc, si c'est OK pour toi, passe ton sujet en résolu.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#10 Le 25/11/2008, à 16:30

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Ben lol , en fait c'est pas resolu, dsl...
j'ai le meme probleme que sous ubuntu 8.04
je peux profiter des effets graphiques mais la resolution est toujours merdique...
J'arrive pas a quel ecran je veux prendre par defaut: laptop(paix a son ame) et VGA(celui que je veux)
pour une avoir le choix d'une bonne resolution je suis oblige de decocher "mirror" et si je choisi alors 1680x1050, j'obtiens un ecran tout degueu,avec un quart exploitable et le reste des 3/4 freeze...

Donc en fait j'aimerais forcer la carte a choisir mon ecran VGA comme ecran par defaut, et pouvoir profiter de 1680x1050...

Hors ligne

#11 Le 25/11/2008, à 18:23

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

probleme resolu je sais pas comment...
a force de tester les resolution et retester....
au bout d'un moment la machine a ceder et m'a tout afficher proprement...
Je redemarre plus jamais....

Hors ligne

#12 Le 25/11/2008, à 20:42

pierluc

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

inbox a écrit :

Salut raphaelharboun,

Comme indiqué dans la documentation "radeon", ta carte utilises la pilote libre "radeon". Il n'y a rien à faire de plus que de l'utiliser.

Le pilote ATI propriétaire pour Linux, ne gère pas ton modèle de carte.

Tu peux vérifier, après un installation propre, que l'accélération graphique est OK.

A+

Catalyst 8.11 supporte la Radeon 9600. Le support débute avec la série des 9500.


Porte-Folio: http://pearluc.wordpress.com
Linux, là où la main de l'homme n'a jamait mit pied.
Capitaine Patnaud, Émission Dans une galaxie près de chez vous
Pour rire: www.tetesaclaques.tv

Hors ligne

#13 Le 25/11/2008, à 21:18

raphaelharboun

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

pierluc a écrit :
inbox a écrit :

Salut raphaelharboun,

Comme indiqué dans la documentation "radeon", ta carte utilises la pilote libre "radeon". Il n'y a rien à faire de plus que de l'utiliser.

Le pilote ATI propriétaire pour Linux, ne gère pas ton modèle de carte.

Tu peux vérifier, après un installation propre, que l'accélération graphique est OK.

A+

Catalyst 8.11 supporte la Radeon 9600. Le support débute avec la série des 9500.

ben c'est genial mais je t'assure qu'apres 2semaines a avoir tout teste...ca marche pas!!

Hors ligne

#14 Le 25/11/2008, à 23:08

pierluc

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Possible, les pilotes ATI c'est toujours du trouble. Dans mon cas j'ai une Radeon 9550, cette carte là c'est sensé d'être une coche en dessous de la 9600. J'ai essayé d'installer le pilote avec les .deb et ça marchait pas alors j'ai pris la procédure automatique qui n'utilise pas les .deb et ça a marché. Mais avec d'autres versions j'avais eu des problèmes avec cette techniques.


Porte-Folio: http://pearluc.wordpress.com
Linux, là où la main de l'homme n'a jamait mit pied.
Capitaine Patnaud, Émission Dans une galaxie près de chez vous
Pour rire: www.tetesaclaques.tv

Hors ligne

#15 Le 25/11/2008, à 23:31

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Pourrait-on dire que le pilote ATI est censé fonctionner pour ce type de carte ?


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#16 Le 17/12/2008, à 22:27

Beo

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Essayé avec Intrepid et les nouveaux Catalyst 8.12 : même problème.
Pourtant quand on lit toute la doc .pdf de chez ATi (release notes + install) on remarque que les ATI 9600 Mobility sont normalement reconnues !
Pas d'autres solutions que de réinstaller encore une fois Ubuntu alors ?

Si quelqu'un peut m'indiquer comment repasser aux drivers libres (les mêmes que ceux d'une fresh install) une fois qu'on a essayé d'installer sans succès les Catalyst et les drivers ATi du Synaptic ou Add/Remove, ça serait sympa ... neutral

Hors ligne

#17 Le 17/12/2008, à 23:37

Beo

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Bon j'ai réinstallé Ubuntu-desktop via le synaptic et ça a partiellement résolu mon problème.
L'accélérération est activée mais lorsque je consulte mon fichier xorg.conf, voici ce que je vois :


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
    Identifier    "Configured Video Device"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
EndSection


Je ne comprends pas comment l'accélération 3D peut être activée avec un tel setting ...

Hors ligne

#18 Le 18/12/2008, à 00:02

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#19 Le 18/12/2008, à 20:07

Beo

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Pour l'accélération graphique, ça me donne :
glxinfo | grep "direct rendering"
=> direct rendering: Yes

Hors ligne

#20 Le 18/12/2008, à 20:37

Beo

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Et pour les fps ça me donne ça :

glxgears -info

GL_RENDERER   = Mesa DRI R300 20060815 AGP 4x x86/MMX/SSE2 TCL
GL_VERSION    = 1.3 Mesa 7.2
GL_VENDOR     = DRI R300 Project
GL_EXTENSIONS = GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow_ambient GL_SUN_multi_draw_arrays
9530 frames in 5.0 seconds = 1905.854 FPS
9810 frames in 5.0 seconds = 1961.918 FPS
9981 frames in 5.0 seconds = 1996.123 FPS
9808 frames in 5.0 seconds = 1961.592 FPS
9752 frames in 5.0 seconds = 1950.385 FPS
9831 frames in 5.0 seconds = 1966.130 FPS
9801 frames in 5.0 seconds = 1960.033 FPS
9978 frames in 5.0 seconds = 1995.571 FPS
9851 frames in 5.0 seconds = 1970.105 FPS
9836 frames in 5.0 seconds = 1967.106 FPS
9785 frames in 5.0 seconds = 1956.903 FPS
9783 frames in 5.0 seconds = 1956.569 FPS
9986 frames in 5.0 seconds = 1997.129 FPS


Mais comme je l'ai lu ici, ça ne veut rien dire si le CPU n'est pas fort utilisé, c'est peut-être lui qui calcule et non le GPU ...

Hors ligne

#21 Le 19/12/2008, à 00:20

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Comme indiqué par le "yes", tu as une accélération graphique fonctionnelle.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#22 Le 28/12/2008, à 23:09

Daïne

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Je rajoute mon grain de sel car j'ai le même modèle de carte (ATI Mobility Radeon 9600), et comme indiqué dans les posts au dessus, le driver ATI est censé supporter cette carte.

Ce que je constate est la même chose que tout ce qui a été indiqué au dessus à savoir :

Direct Rendering : yes
Paquets installés : xserver-xorg-video-radeon et xserver-xorg-video-ati, mais aucun des fglrx*
xorg.conf vide (ou presque comme vu au dessus)

Et pourtant, l'essai de Google Earth sur ma machine a fait planter le système au bout de quelques secondes d'utilisation, avec en plus avant quelques bugs d'affichage... Et en dehors de Google Earth, les différents effets et défilements ne sont réellement pas fluides.

Je reste donc avec une grande question : si ça n'est pas géré dans le xorg.conf, ou ça se passe ? Sachant que les deux paquets clés pour rétablir la situation sont indiqués ci-dessus.

Autre remarque, si votre installation des drivers propriétaires ATI a échoué, vous pouvez exéctuer le script nommé "fglrx-uninstall" qui se trouve dans /usr/share/ati/

Hors ligne

#23 Le 29/12/2008, à 00:46

inbox

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Les pilotes  fournis par ATI ne gèrent pas ce modèle de carte.

Pour utiliser Google Earth avec cette carte, il faut désactiver les effets graphiques (compiz).


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#24 Le 11/01/2009, à 15:09

nicolas.dh

Re : Probleme Intrepid & Mobility radeon 9600 sur ecran VGA

Bonjour, raphaelharboun

Selon ton message #11,
ton problème est résolu,
mais sans savoir comment !!!

Selon ton message #8,
tu avais résolu les problèmes
de driver (en utilisant pilote radeon),
mais ne parvenais
pas à changer le mode graphique
pour l'écran externe asus 20"


Je crois que la commande "xrandr"
pourrait t'aider à contrôler la résolution
de ton écran externe !!!


Regarder (man, google) la commande:

   xrandr

et l'outil:

   gtf

exemple:
-------------------------------------------------------------
gtf 1680 1050 60
  ************
  # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
  Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
  ************
     (pour voir les parametres a utiliser pour la commande suivante)
  ************
xrandr --newmode "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
xrandr --addmode VGA-0 "1680x1050_60.00"
xrandr --output VGA-0 --mode  "1680x1050_60.00"
-------------------------------------------------------------

ref gtf et xrandr:http://wiki.oisux.org/xrandr?DokuWiki=e … 4156489405
ref asus 20":http://www.asus.com/products.aspx?model … 3=560&l4=0

Hors ligne

Haut de page ↑