Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 29/01/2009, à 13:48

choupette549

Pas d'entrée dans grub avec dualboot vista et Ubuntu

Bonjour

Je viens d'installer Ubuntu 8.10 sur mon portable Sony
VGN-SR21MS en suivant la procédure décrite à la page suivante
càd en gardant le bootloader de vista.

http://doc.ubuntu-fr.org/tutoriel/comment_amorcer_ubuntu_avec_bootmgr

Je n'ai pas tenu compte de la remarque concernant la gestion
des i-nodes de 256 octects par Grub car après quelques recheches
j'ai trouvé ici :

http://forum.ubuntu-fr.org/viewtopic.php?id=234044

qu'à partir de la version hardy, grub était patché pour supporter
des i-nodes de 256 octets. Suis-je dans le bon ?


Ensuite, tout s'est bien passé : une entrée vista et une entrée Ubuntu son
présente dans la bootloader de vista et vista boot normalement.

Cependant, quand je choisis Ubuntu, je me retrouve en ligne de
commande de Grub (pas de message d'erreur).

Je me suis alors basé sur cette page si

http://doc.ubuntu-fr.org/dell_xps_m1530

pour tenter de booter manuellement Ubuntu afin de pouvoir ensuite
éditer manuellement le fichier menu.lst. Hélas je suis bloqué :


root(hd0,2)  ==> m'indique que le filesystem est de type ext2fs

kernel /vmlinuz root=/dev/sda3

pour cette dernière commande il m'indique error2 : bad file or directory type


Pourriez-vous m'aider ?


Merci d'avance

Hors ligne

#2 Le 29/01/2009, à 14:32

legz

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Tu peux recopier l'entrée de ton grub qui pose problème ?


Me suivre sur Twitter ? C'est par ici : http://twitter.com/legz !

Hors ligne

#3 Le 29/01/2009, à 19:53

choupette549

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

En voulant répondre à ta question et en continuant mes recherches j'ai trouvé la solution.

Il y a en fait une erreur dans le tutoriel suivant (enfin je crois), ce qui m'a induit en erreur :
http://doc.ubuntu-fr.org/tutoriel/comment_amorcer_ubuntu_avec_bootmgr


J'ai tout d'abord redémarrer sur le live cd pour aller vérifier le contenu de menu.lst créé par l'installation. Tout semblait ok et de plus Grub semblait correctement installé.

Je suis ensuite retourné sous vista pour y vérifier les paramètres de easybcd.
J'ai également relu attentivement le tutoriel.

Je me suis alors rendu compte que easybcd avait activé néogrub or la 6e note
du tutoriel indique qu'il n'est pas compatible avec ubuntu.

J'ai d'abord cru a une erreur de ma part. J'ai donc répété l'étape :
"Ajout d’une entrée de menu pour Ubuntu dans l’amorceur de Windows Vista"
du tutoriel mais à chaque fois il m'activait neogrub.


J'ai ensuite compris qu'à l'étape 5 du tutoriel il est dit de :

"Cochez la case GRUB isn’t installed to the bootsector, car GRUB n’est effectivement pas installé dans le MBR de votre disque dur ;"

or c'est faux. Il faut que la case soit décochée ! Du coup tout est rentré dans l'ordre.


En fait je pense que la case à cocher concerne le bootsector et non le MBR comme expliqué dans le tutoriel. Quand elle est cochée il installe le bootsector sur la partition de vista et au lieu de démarrer le grub installé sur la partition de ubuntu, il m'en démarrait un autre. C'est aussi pourquoi il ne trouvait pas les dossiers dans ce que j'ai fais plus haut.

Alors que quand la case est décochée on peut choisir la partition qui contient ubuntu et grub.


J'espère avoir été clair et pas trop long.

Si quelqu'un pouvait me confirmer ce que j'affirme et me dire à qui
je dois signaler l'erreur dans le tuto afin que celle-ci soit corrigée.


Sur ce, bonne soirée à tous et merci pour se formidable forum bien utile !

Hors ligne

#4 Le 29/01/2009, à 20:00

choupette549

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Il serait peut être également bon de préciser dans la note du tutoriel sur les i-nodes qu'à partir de Ubuntu Hardy, grub est patché pour supporter les i-node 256 et qu'il n'est donc plus nécessaire de faire un formatage spécifique.

Enfin pour ma part j'ai pas du le faire et tout s'est correctement déroulé

Hors ligne

#5 Le 31/01/2009, à 17:25

xabilon

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Salut choupette549

Je ne peux te dire si il y a erreur ou pas. En attendant que les auteurs de la page se manifestent, j'ai rajouté un avertissement avec un lien vers ton message.

A+


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#6 Le 01/02/2009, à 06:13

yoos

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

bonjour,
j'ai un acer aspire 6930G avec vista (tres probablement tatoué?). pour installer ubuntu 8.04, j'ai fais exactement comme expliqué dans le tuto, donc j'ai mis Grub sur  la partition  réservée pour le systeme ( /dev/sda6 dans mon cas ) que j'ai formaté en inode 128 (avec la commande: sudo mkfs.ext3 -I 128 /dev/sda6) et j'ai coché la case "GRUB isn’t installed to the bootsector" et résultat: TOUT MARCHE PARFAITEMENT il n'y a eu aucun problème.
merci pour le tuto wink

#7 Le 04/02/2009, à 00:15

yoos

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

salut c'est encore moi.
en fait comme je disais, l'installation de ubuntu 8.04 c'est bien deroulé, et le systeme marche bien, par contre j'ai pas reussi a me conncter, car ubuntu 8.04 ne detectait ni ma carte reseaux ni ma carte wifi, j'ai fait quelque recherche mais en vain.
finalement j'ai decidé d'abondonner le 8.04 et d'installer le 8.10, et cette fois  jai fais exprès de ne pas formater en 128, apres le redemarage, quand je choisis Ubuntu, je me retrouve en ligne de commande de Grub (pas de message d'erreur).

ensuite j'ai redemaré sur vista, et j'ai decroché la case "GRUB isn’t installed to the bootsector comme disait choupette549".
et la je redemare et C'EST  NIKEL tout marche bien.
en plus ubuntu 8.10 detecte ma carte wifi automatiquement et j'ai la connexion sans aucune configuration de ma part.

donc je crois qu'il faut ajouté une petite precision dans le tuto concernant le formatage en inode 128 et/ou le cochage de la case en  question tout ca par rapport a 8.04 et 8.10.
merci a vous.
et merci a ubuntu.

#8 Le 04/02/2009, à 04:52

sidarape

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

yoos a écrit :

salut c'est encore moi.
en fait comme je disais, l'installation de ubuntu 8.04 c'est bien deroulé, et le systeme marche bien, par contre j'ai pas reussi a me conncter, car ubuntu 8.04 ne detectait ni ma carte reseaux ni ma carte wifi, j'ai fait quelque recherche mais en vain.
finalement j'ai decidé d'abondonner le 8.04 et d'installer le 8.10, et cette fois  jai fais exprès de ne pas formater en 128, apres le redemarage, quand je choisis Ubuntu, je me retrouve en ligne de commande de Grub (pas de message d'erreur).

ensuite j'ai redemaré sur vista, et j'ai decroché la case "GRUB isn’t installed to the bootsector comme disait choupette549".
et la je redemare et C'EST  NIKEL tout marche bien.
en plus ubuntu 8.10 detecte ma carte wifi automatiquement et j'ai la connexion sans aucune configuration de ma part.

donc je crois qu'il faut ajouté une petite precision dans le tuto concernant le formatage en inode 128 et/ou le cochage de la case en  question tout ca par rapport a 8.04 et 8.10.
merci a vous.
et merci a ubuntu.

En effet, moi aussi, j'ai installé Ubuntu 8.10 en dualboot avec Vista et ça a fait la même chose. J'ai donc décoché aussi la case "GRUB isn’t installed to the bootsector" et ça a marché. Je crois donc que ce serait à rajouter dans le tuto.

Hors ligne

#9 Le 08/02/2009, à 23:30

Florian Bidabé

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Coucou, je coche bel et bien cette case, et cela marche très bien O_o
Je comprends pas pourquoi pour vous, non mais ce qui signifie qu'il n'y a pas d'erreurs dans le tuto.
Je rajoute aussi les fichier stage (enfin les fichiers contenue dans /usr/lib/grub/i386) dans le dossier C:\NST et j'édite mon menu.lst...

cf mon post :
http://forum.ubuntu-fr.org/viewtopic.php?id=291960

Dernière modification par Florian Bidabé (Le 08/02/2009, à 23:31)

Hors ligne

#10 Le 08/02/2009, à 23:44

sidarape

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

bah, c'est que nous on laisse le formatage par défaut donc en inode 256

Sinon, c'Est bien plus simple de ne pas formater en inode 128 et de ne pas cocher cette case que de le faire.

Dernière modification par sidarape (Le 08/02/2009, à 23:46)

Hors ligne

#11 Le 09/02/2009, à 08:34

J5012

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

@choupette549
j'ai ecris un article similaire a celui que tu as suivi http://lolita.pf/spip/spip.php?article116&lang=fr mais je n'ai pas utiliser neogrub du tout
easybcd-add-10e82.jpg

easybcd trouve tout seul la partition qui renferme grub !

Hors ligne

#12 Le 09/02/2009, à 18:55

Florian Bidabé

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

jour...
excepté en RAID, EasyBCD ne trouvera pas ou est installé GRUB puisque Grub n'est pas installé... donc il n'est pas plus facile de la décocher tongue


Et si on l'installe toujours sous la live session, le fichier /target/etc/fstab n'étant pas reconnu, le update-grub foirera au niveau de la reconnaissance de la bonne partition et donnera hd0,0 a toute les lignes

Hors ligne

#13 Le 09/02/2009, à 20:50

fredolerouge

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

salut à tous,

en cherchant dans la doc de EasyBCD, j'ai trouvé ça :

1.  Put the Linux CD in the drive, and start the installation normally.
   2. When prompted to set up the bootloader, make sure you specify to install LILO, GRUB, or whatever to the bootsector of the partition that Linux is being installed to and not the MBR of your hard drive.
   3. Finish the Linux installation, take the CD out of the drive, and reboot.

En gros, si j'ai bien suivi, cela signifie que easyBCD considère que GRUB, s'il est installé sur "/" est sur le "bootsector".
Or, d'après le tuto http://doc.ubuntu-fr.org/tutoriel/comment_amorcer_ubuntu_avec_bootmgr la partition "/" n'est pas amorçable.
Donc je fais quoi puisqu'on me dit tout et son contraire ?

En plus, il y a un tuto ici : http://neosmart.net/wiki/display/EBCD/Ubuntu  où la case est décochée.

Bref, il y a de quoi devenir chèvre...

Dernière modification par fredolerouge (Le 09/02/2009, à 20:54)

Hors ligne

#14 Le 11/02/2009, à 10:57

bartaban

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Bonjour,

J'ai du décocher la case pour ce que ça marche moi aussi. Sinon quand je démarrais, je rester dans grub avec le prompt. (et là j'étais perdu car j'y connais rien smile )

Hors ligne

#15 Le 11/02/2009, à 23:56

sidarape

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

bartaban a écrit :

Bonjour,

J'ai du décocher la case pour ce que ça marche moi aussi. Sinon quand je démarrais, je rester dans grub avec le prompt. (et là j'étais perdu car j'y connais rien smile )

T'as formaté en inode 128?

Hors ligne

#16 Le 12/02/2009, à 01:24

Florian Bidabé

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Apparemment les inodes, ce serait de l'histoire ancienne...
Ton problème était lié au fait que le menu.lst de NeoGrub (ou EasyBCD) est quasi vierge (deux lignes de commandes) : Il recherche où le grub est installé et lance l'OS.
S'il ne trouve pas le grub alors, oui, vous vous retrouvez dans un prompt.

La solution est simple :
Créer le grub sous Ubuntu depuis une live session, en ayant monté la partition ext3 /boot, ensuite vous faite un chroot, et vous "généré un grub" :
Sauvegarder ce grub, et remplacer le fichier menu.lst dans C:\NST par le fichier menu.lst généré sous Ubuntu. (ne pas oublier de fournir les fichiers stage qui permettent de lire le système de fichiers (type de formatage du DD))

Hors ligne

#17 Le 12/02/2009, à 14:35

Deevad

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Bonjour,
J'ai eu le même soucis de compréhension du tuto que Choupette549 ;

* si vous cochez la case "GRUB isn’t installed to the bootsector"
|_ Ordinateur démarre
|_ Windows lance sont Bootmanager et propose
      |__ Windows  ( boot sur C:\ , avec le loader Windows )
      |__ Linux Ubuntu  ( boot sur un Grub de EasyBCD C:\NST\menu.lst )
                                                          |__ menu d'un Grub crée par Easy BCD qui liste vos partitions.
Résultat : ok ça fonctionne , on peux booter sur notre Ubuntu. Windows à les  fichier de configuration de Grub, why not...


* si vous décochez la case "GRUB isn’t installed to the bootsector" et que vous choisissez la partition Linux
|_ Ordinateur démarre
|_ Windows lance sont Bootmanager et propose
      |__ Windows  ( boot sur C:\ , avec le loader Windows )
      |__ Linux Ubuntu  ( boot sur un lien de EasyBCD à partir de C:\ vers la partition Linux directement )
                                                          |__  Grub installé sur votre partition Linux
Résultat : Je préfère, car c'est un peu bête mais mon Grub est décoré sur ma distribution LinuxMint , et celui de EasyBCD est assez laid.

Hors ligne

#18 Le 27/07/2009, à 22:59

duaner59

Re : Pas d'entrée dans grub avec dualboot vista et Ubuntu

Honnetement, vous n'imaginez pas à quel point je suis content de lire ce forum !!
Mdr j'étais en stress en me disant que j'étais un boulet mais au final... ^^

Il serait sage de faire qqch sur ce tuto parce que honnetement quand on est novice comme moi on fait pas gaffe a ce petit lien du tuto qui nous renvoit ici, et on se plante.

Par contre tres bon tuto a actualiser pour le coup du formatage en 128
2 petites gafouilles (je sais pas trop comment dire) qui font que l'installation devient vite un cauchemar et une prise de tete alors que franchement c'est extremement simple !

Sur ce ... @+

Haut de page ↑