Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/03/2009, à 14:41

Calimo

Forcer l'exécution d'un programme en 32 bits ?

Bonjour,

Je suis le possesseur d'un CD d'installation du logiciel "Oxford Advanced Learner's Dictionary", fourni avec le dictionnaire homonyme.

Celui-ci fonctionne à merveille nativement en 32bits (si l'on excepte les polices non lissées dues à l'utilisation d'un vieux gtk 1.x). Un répertoire linux/ sur le CD permet de lancer ./installation.sh. Notez bien que le programme s'exécute en mode natif sans passer par wine (c'est assez surprenant, mais les concepteurs ont pensé à Linux en basant leur application sur un vieux mozilla 1.6).

Mais lorsque j'essaye de l'installer sur Intrepid en 64 bits...

xavier@ubuntu:/media/cdrom/linux$ ./installation.sh 
Verifying archive integrity... All good.
Uncompressing OALD7..........................
This installation doesn't support glibc-2.0 on Linux / x86_64

Please contact Loki Technical Support at support@lokigames.com
The program returned an error code (1)

Bien entendu le support chez lokigames n'existe pas (courriels en retour-erreur).

J'ai installé les librairies de compatibilité ia32-libs, mais je ne sais pas comment les utiliser. Savez-vous comment faire ?

Merci d'avance
Xavier

Hors ligne

#2 Le 16/03/2009, à 16:07

genma

Re : Forcer l'exécution d'un programme en 32 bits ?

Tout est ici :

http://doc.ubuntu-fr.org/installation/chroot32bits

La problématique
Dans un environnement 64 bits tels que les versions amd64 de Ubuntu, certaines applications compilées ou adaptées uniquement pour des architecture 32 bits ne fonctionnent pas. Ceci est particulièrement vrai pour les applications propriétaires telles que Flash ou encore les applications exclusivement 32 bits comme Wine ainsi que les transfuges des deux tels w32codecs.
La solution

La solution consiste à mettre en place un second environnement en 32 bits et d'y exécuter les applications problématiques. C'est l'objet de cette page.


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      http://genma.free.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#3 Le 21/03/2009, à 20:18

Calimo

Re : Forcer l'exécution d'un programme en 32 bits ?

Merci pour cette réponse.

Cependant cette page indique "Cette méthode est devenue totalement inutile avec Gutsy, car il intègre directement quasiment toutes les librairies pour faire simplement un chroot", je pensais donc que je pourrais m'en passer... ce n'est pas vraiment le cas ? Donc ce n'est pas "totalement inutile" mais "presque totalement inutile" ?

Xavier

Hors ligne

#4 Le 22/03/2009, à 11:40

brakbabord

Re : Forcer l'exécution d'un programme en 32 bits ?

Installe les ia32-libs dans Synaptic

Et réessaie.

Hors ligne

#5 Le 22/03/2009, à 12:35

Calimo

Re : Forcer l'exécution d'un programme en 32 bits ?

Comme indiqué dans le premier message, le paquet ia32-libs est installé (avec toutes ses dépendances). Le problème c'est qu'il ne semble pas être détecté... roll

Dernière modification par Calimo (Le 22/03/2009, à 12:35)

Hors ligne

#6 Le 23/03/2009, à 23:56

Link31

Re : Forcer l'exécution d'un programme en 32 bits ?

linux32 ./installation.sh

Hors ligne

#7 Le 28/03/2009, à 17:51

Calimo

Re : Forcer l'exécution d'un programme en 32 bits ?

Bien vu ! big_smile

Voici la sortie :

xavier@ubuntu:/media/cdrom/linux$ linux32 ./installation.sh 
Verifying archive integrity... All good.
Uncompressing OALD7..........................
This installation doesn't support glibc-2.0 on Linux / x86

Please contact Loki Technical Support at support@lokigames.com
The program returned an error code (1)

Donc effectivement le code est cette fois bien exécuté en 32 bits.

Cela voudrait dire que l'erreur à la base vient de glibc-2.0 et pas du 64bits... je sens que je ne vais pas échapper au chroot neutral

Merci à tous pour votre précieuse aide wink

Hors ligne

#8 Le 05/04/2009, à 11:15

Calimo

Re : Forcer l'exécution d'un programme en 32 bits ?

Bon, j'ai appliqué la procédure http://doc.ubuntu-fr.org/installation/chroot32bits pas à pas pour faire un chroot.

J'insère le CD. Il ne se monte pas car visiblement il y a 2 déclarations dans le fstab. Pas grave, j'entre dans le chroot

dchroot -d

et je monte le CDROM

(32bits)xavier@ubuntu:~$ sudo mount /dev/cdrom /media/cdrom0
mount: block device /dev/scd0 is write-protected, mounting read-only

Je lance l'installation du programme :

(32bits)xavier@ubuntu:~$ cd /media/cdrom0/linux
(32bits)xavier@ubuntu:/media/cdrom0/linux$ ./installation.sh 
Verifying archive integrity... All good.
Uncompressing OALD7..........................
This installation doesn't support glibc-2.1 on Linux / x86_64

Please contact Loki Technical Support at support@lokigames.com
The program returned an error code (1)

Manifestement il y a un souci. Pourquoi je suis encore en 64 bits dans mon chroot ? yikes

(32bits)xavier@ubuntu:/media/cdrom0/linux$ uname -a
Linux ubuntu 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

J'ai pourtant bien lancé l'installation en i386 avec la commande indiquée :

sudo debootstrap --arch i386 `lsb_release -c -s` /chroot/ubuntu32bits http://archive.ubuntu.com/ubuntu

Est-ce que quelqu'un sait de quoi ça peut venir ?

Hors ligne

Haut de page ↑