Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#26 Le 05/04/2006, à 11:10

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Un peu plus de détail sur le problème :

dpkg : erreur de traitement de /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb (--unpack) :
tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xorg-core
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#27 Le 05/04/2006, à 11:14

P.HARD.FR

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Tytou a écrit :

Moi j'ai un problème de mise à jour de xgl-server avec le dépot cité au début du sujet :

E: /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb: tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xorg-core

Pareil ici avec la dernière mise à jour.:(


Linux ID: 369240
PC ID: 264362

Hors ligne

#28 Le 05/04/2006, à 11:14

apmlolster76

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Tytou a écrit :

Moi j'ai un problème de mise à jour de xgl-server avec le dépot cité au début du sujet :

E: /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb: tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xorg-core

Comment fait on pour résoudre le problème ?

la soluce st là :http://forum.ubuntu-fr.org/viewtopic.php?pid=255114#p255114



   
sudo dpkg -i --force-overwrite /var/cache/apt/archives/xserver-xorg-core_1%3a1.0.2-0ubuntu4_i386.deb

Le fichier embêtant est juste une entrée man, aucun problème.

Dernière modification par coxx (Aujourd'hui 02:36:05)
(o_                 ----- Eric -----
//\                 
V_/_               Mooseblog, mon blog kubuntu, description d'astuces et de programmes

Dernière modification par apmlolster76 (Le 05/04/2006, à 11:16)

Hors ligne

#29 Le 05/04/2006, à 11:29

Balkoth

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Plutôt que faire un --force-overwrite, il est plus propre de faire

sudo dpkg-divert --package xserver-xorg-core --divert /usr/share/man/man1/Xserver.1x.gz.xgl --rename /usr/share/man/man1/Xserver.1x.gz

puis sudo apt-get upgrade.

(source : forum ubuntu anglais)

Hors ligne

#30 Le 05/04/2006, à 11:30

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

apmlolster76 a écrit :
Tytou a écrit :

Moi j'ai un problème de mise à jour de xgl-server avec le dépot cité au début du sujet :

E: /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb: tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xorg-core

Comment fait on pour résoudre le problème ?

la soluce st là :http://forum.ubuntu-fr.org/viewtopic.php?pid=255114#p255114



   
sudo dpkg -i --force-overwrite /var/cache/apt/archives/xserver-xorg-core_1%3a1.0.2-0ubuntu4_i386.deb

Le fichier embêtant est juste une entrée man, aucun problème.

Dernière modification par coxx (Aujourd'hui 02:36:05)
(o_                 ----- Eric -----
//\                 
V_/_               Mooseblog, mon blog kubuntu, description d'astuces et de programmes

Merci beaucoup pour cette petite ligne mais y a encore un ptit truc qui m'échappe :
J'ai bien tapé cette ligne mais je comprends pas elle figure toujours dans mes mises à jour et ça n'a rien changé au niveau de ma version de XGL ?

Hors ligne

#31 Le 05/04/2006, à 11:30

benjou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

3/ miniwin me bouffe 90% du cpu dès qu'une fenêtre est minimisée...

et c'est bien dommage car c'est un plugin megapratique


écrasons l'infâme

Hors ligne

#32 Le 05/04/2006, à 14:17

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Un ptit up !!!

Je crois que j'ai pas tout pigé pour installer cette dernière version !!!

Dernière modification par Tytou (Le 05/04/2006, à 14:21)

Hors ligne

#33 Le 05/04/2006, à 14:28

benjou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

J'ai bien tapé cette ligne mais je comprends pas elle figure toujours dans mes mises à jour et ça n'a rien changé au niveau de ma version de XGL ?

C'est pas un nouveau paquet XGL mais xserver-core que tu as installe

Pour l'histoire que ca fait tjs partie de tes updates, as-tu essaye sudo apt-get update?


écrasons l'infâme

Hors ligne

#34 Le 05/04/2006, à 14:54

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

benjou a écrit :

J'ai bien tapé cette ligne mais je comprends pas elle figure toujours dans mes mises à jour et ça n'a rien changé au niveau de ma version de XGL ?

C'est pas un nouveau paquet XGL mais xserver-core que tu as installe

Pour l'histoire que ca fait tjs partie de tes updates, as-tu essaye sudo apt-get update?

J'ai tapé la ligne donnée par apmlolster76 et après j'ai refait un apt-get update.
Ensuite j'ai refait un apt-get dist-upgrade et j'ai toujours xserver-xgl version 7 qui n'arrive pas à s'installer et donc je suppose comme il est toujours là qu'il n'est pas installé.

Hors ligne

#35 Le 05/04/2006, à 15:04

benjou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Ok en l'occurence, les moi je n'arrivais pas a installer xorg derrière Xgl et toi c'est Xgl que tu n'arrive pas a installer derriere xorg

donc la commande serait plutot

sudo dpkg -i --force-overwrite /var/cache/apt/archives/xserver-xgl<la version que tu dois installer>.deb

ou (mais la, je suis moins sur)

sudo dpkg-divert --package xserver-xgl --divert /usr/share/man/man1/Xserver.1x.gz.xgl --rename /usr/share/man/man1/Xserver.1x.gz

écrasons l'infâme

Hors ligne

#36 Le 05/04/2006, à 15:10

apmlolster76

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

chez moi bien fonctionné

par contre mon message d'erreur etait :

xserver-xorg-core Version 1:1.0.2-0ubuntu4 le message d'erreur est :
E: /var/cache/apt/archives/xserver-xorg-core_1%3a1.0.2-0ubuntu4_i386.deb: tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xgl


et non  :
E: /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb: tentative de remplacement de « /usr/share/man/man1/Xserver.1x.gz », qui appartient aussi au paquet xserver-xorg-core


sad

ps : pourquoi ne pas supprimer  ou sauvegarder le man1 et refaire la mise à jour ?

Dernière modification par apmlolster76 (Le 05/04/2006, à 15:12)

Hors ligne

#37 Le 05/04/2006, à 15:15

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

benjou a écrit :

Ok en l'occurence, les moi je n'arrivais pas a installer xorg derrière Xgl et toi c'est Xgl que tu n'arrive pas a installer derriere xorg

donc la commande serait plutot

sudo dpkg -i --force-overwrite /var/cache/apt/archives/xserver-xgl<la version que tu dois installer>.deb

ou (mais la, je suis moins sur)

sudo dpkg-divert --package xserver-xgl --divert /usr/share/man/man1/Xserver.1x.gz.xgl --rename /usr/share/man/man1/Xserver.1x.gz

C'est bon c'est passé avec la commande que tu m'as donné : sudo dpkg -i --force-overwrite /var/cache/apt/archives/xserver-xgl_7.0.0-0ubuntu7_i386.deb

Maintenant tout va beaucoup plus vite avec cette version et mon ATI 9700. Avec l'ancienne version ça avançait tout doucement...

C'est cool. Je te remercie beaucoup !!! Je vais pouvoir passer à la suite...

Hors ligne

#38 Le 05/04/2006, à 15:23

Infinity

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

http://ubuntuforums.org/showthread.php?t=131267  <--- installer XGL/compiz (tuto en anglais) si ça n'est pas encore fait.

une fois le tuto suivi,
rajoute cette ligne dans les dépôts:
deb http://www.beerorkid.com/compiz/ dapper main

et fait un 'sudo apt-get update' suivi d'un 'sudo apt-get upgrade'
Ca va t'installer la dernière version

pour profiter de miniwin et trailfocus rajouter 'miniwin trailfocus' à la liste des plugins, dans le script thefuture qu'on te dis de créer dans le tuto pour istaller xgl/compiz

Hors ligne

#39 Le 05/04/2006, à 15:24

garfunk

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Euh moi j'ai pris le Xgl du dépot de beerorkid, et ça me l'a flingué ! Alors allez-y mollo, perso je ne prends QUE compiz et compiz-gnome là-bas...


Plus ça va, moins je comprends

Hors ligne

#40 Le 05/04/2006, à 15:27

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

snif

Je vais tenter la clareté :

1/En fait je m'explique XGL et compiz marchait super bien sur mon ordi mais un peu lentement depuis 15 jours avec les dépôts normaux de dapper.

2/Alors ce matin j'ai voulu rajouter le dépot deb http://www.beerorkid.com/compiz/ dapper main

3/Impossible d'installer xserver-xgl_7.0.0-0ubuntu7_i386. En forçant la chose grâce à benjou, le paquet s'est installé.

4/Manque de bol en redémarrant le pc, j'ai plus de server X. Snifff

5/ help !!!

Hors ligne

#41 Le 05/04/2006, à 15:31

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Pour être plus concret voici mon xorg.conf si ça peut aider

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        RgbPath         "/etc/X11/rgb"
EndSection

Section "Module"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. RV350 NP [Mobility Radeon 9600/9700 M10/M11]"
        Driver          "fglrx"
               Option      "UseInternalAGPGART" "no"
               Option      "KernelModuleParm" "agplock=0"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "àcran générique"
        Option          "DPMS"
        HorizSync       28-70
        VertRefresh     43-60
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. RV350 NP [Mobility Radeon 9600/9700 M10/M11]"
        Monitor         "àcran générique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1400x1050"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1400x1050"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1400x1050"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1400x1050"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1400x1050"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1400x1050"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

Serait il possible qu'en installant ce paquet

xserver-xgl_7.0.0-0ubuntu7_i386.deb"

, des paramètres de configuration ont été écrasés ?

Dernière modification par Tytou (Le 05/04/2006, à 15:34)

Hors ligne

#42 Le 05/04/2006, à 15:54

garfunk

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Euh moi j'ai pris le Xgl du dépot de beerorkid, et ça me l'a flingué ! Alors allez-y mollo, perso je ne prends QUE compiz et compiz-gnome là-bas...

Quand je le disais...:rolleyes:
Il est possible de le downgrader :

sudo apt-get remove --purge xserver-xgl
sudo nano /etc/apt/sources.list

Enlever le dépot de beerorkid, et rajouter celui de gilir :

deb http://gilir.free.fr/ubuntu ./

Puis mise a à jour de xserver-xgl :

sudo apt-get update && sudo apt-get upgrade

Normalement ça devrait fonctionner wink


Plus ça va, moins je comprends

Hors ligne

#43 Le 05/04/2006, à 16:06

Tytou

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

garfunk a écrit :

Euh moi j'ai pris le Xgl du dépot de beerorkid, et ça me l'a flingué ! Alors allez-y mollo, perso je ne prends QUE compiz et compiz-gnome là-bas...

Quand je le disais...:rolleyes:
Il est possible de le downgrader :

sudo apt-get remove --purge xserver-xgl
sudo nano /etc/apt/sources.list

Enlever le dépot de beerorkid, et rajouter celui de gilir :

deb http://gilir.free.fr/ubuntu ./

Puis mise a à jour de xserver-xgl :

sudo apt-get update && sudo apt-get upgrade

Normalement ça devrait fonctionner wink

ça marche nickel. J'ai désinstallé/installé/rebooté et tout fonctionne avec une grande fluidité comparé à la version que j'avais avant tongue

Merci beaucoup Garfunk !!! big_smile et promis j'arrête de faire joujou avec des dépôts pas sur !

Hors ligne

#44 Le 05/04/2006, à 16:16

garfunk

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Sur le site de beerorkid tu peux leur piquer compiz et compiz-gnome, chez moi ça ne pose pas de problème, et tu auras les derniers plugins wink


Plus ça va, moins je comprends

Hors ligne

#45 Le 05/04/2006, à 19:19

P.HARD.FR

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

garfunk a écrit :

Sur le site de beerorkid tu peux leur piquer compiz et compiz-gnome, chez moi ça ne pose pas de problème, et tu auras les derniers plugins wink

Euh, j'ai précisé dans ce thread que cela fonctionne sur Nvidia (ce que je possède et qui ne m'a pas posé de problème lors des mises à jour). Je ne peux pas m'engager pour les cartes ATI. Est-ce que les soucis rencontrés ici surviennent avec cartes ati ?


Linux ID: 369240
PC ID: 264362

Hors ligne

#46 Le 05/04/2006, à 19:35

garfunk

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Exactement cool


Plus ça va, moins je comprends

Hors ligne

#47 Le 06/04/2006, à 08:35

P.HARD.FR

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

Ah, lala!!
ATI et leurs pilotes codés avec les pieds !:lol:


Linux ID: 369240
PC ID: 264362

Hors ligne

#48 Le 08/04/2006, à 17:58

antoine123

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

meme probleme sur nvidia...
peut etre ca vien de moi...

Hors ligne

#49 Le 11/04/2006, à 16:37

aurel64

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

juste pour info

deb http://www.beerorkid.com/compiz/ dapper main

es que ce dépot donne la derniere version de compiz (la 0.0.8 il me semble) stable ??

merci

Hors ligne

#50 Le 11/04/2006, à 17:16

Infinity

Re : Infos pour les utilisateurs Xgl (testé sur Nvidia)

c'est la version 0.0.9-0ubuntu1, et chez moi elle est stable (même le plugin water big_smile)
par contre, la mise à jour de nvidia-glx ou xserver-xgl (je sais pas) m'a foutu ma config en l'air, heuresement, j'ai réussi à la récupérer.

Hors ligne

Haut de page ↑