Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 25/04/2009, à 14:06

sipi

Ubuntu 9.04 et ati xpress 1100

Bonjour à tous,

Voila je vient d'installer ubuntu 9.04,
je test donc mes performances graphiques avec glxgears -> 250

grrrrr, mais bon je me dit pas grave on va installer les pilotes catalyst proprietaire,
Au surprise catalyst 9.4 et incompatible avec ma carte graphique et catalyste 9.3 et incompatible avec ubuntu 9.04.

Au mon dieu que faire??? retourné sur ubuntu 8.10 ou inferieur???

quelqu'un a t'il une solution peut etre un pilote libre radeon? (enfin si c'est pas celui utilisé par défault )

Si quelqu'un à le meme souci et a trouvé une solution...

Merci d'avance.


6pi

Hors ligne

#2 Le 25/04/2009, à 17:42

Cisa

Re : Ubuntu 9.04 et ati xpress 1100

salut
meme probleme avec xpres 1200 mad

Hors ligne

#3 Le 25/04/2009, à 18:58

Bernard JEANNE

Re : Ubuntu 9.04 et ati xpress 1100

Bonjour, j'ai le même souci sur deux poste équipés respectivement d'une X1300 en PCIe et d'une Radeon 9550 en AGP8x

J'ai résolu le problème de cette façon :

d'après : Downgrade Xorg Ubuntu 8.10 intrepid vers Ubuntu 8.04 hardy
http://www.benjaminbaudouin.com/downgra … 804-hardy/
Fichier original Rédigé par Benjamin Beaudouin () le 6 février 2009,
modifié par Bernard JEANNE le 25 avril 2009

Contexte

La dernière version de Ubuntu 9.04 livre une version packagée de xorg qui ne gère pas les "anciennes" cartes 3D Ati (celles qu'ATI a décidé de ne plus soutenir) voir sur le site http://support.amd.com/us/gpudownload/Pages/index.aspx si vous êtes concerné en essayant de télécharger votre drivers. Si vous êtes dirigés sur la version 9.3 au lieu de la 9.4 (qui est la dernière en date et la seule compatible Ubuntu) vous l'êtes.


Procédure

La seule solution pour le moment est d’installer la version de xorg contenue dans la distribution précédente Ubuntu 8.10 intrepid.


1- Télécharger au préalable la dernière version compatible des drivers ATI (la 9.3 en ce qui me concerne):
http://support.amd.com/us/gpudownload/Pages/index.aspx
Penser à lui attribuer des droits d'éxécution :
clic droit -> propriétés -> onglet Permisions -> autoriser l'exécution.. (case à cocher)

2- La copier dans un répertoire d'accés facile (chez moi c'est /pub ) Cette manoeuvre est utile avant de tout mettre en l'air ;-) car lors des manoeuvres qui suivent tous les serveurs sont supprimés. Il faut donc faire l'installation aussitôt le "downgrade" effectué.

3- Ouvrir une console texte : Menu Applications -> Accesoires -> Terminal
vous obtenez une invite du genre :
charlie@bohemond:~$

4- Ouvrir le fichier des sources de dépots:
soit en pasant par la console que vous venez d'ouvrir,

charlie@bohemond:~$ sudo gedit /etc/apt/sources.list

    ajouter en fin de fichier :

    ##dépots intrepid pour xorg 7.4
    deb http://us.archive.ubuntu.com/ubuntu intrepid main
    deb http://us.archive.ubuntu.com/ubuntu intrepid-updates main
    deb http://us.archive.ubuntu.com/ubuntu intrepid-security main
    ##fin de modif intrepid

    sauvegarder puis  mettre à jour la base des dépots :

charlie@bohemond:~$ sudo apt-get update

soit en utilisant l'interface graphique : menu Système -> Administration -> Sources de mise à jour

Si vous êtes "ceinture et bretelles", mettre à jour la base des dépots : (ça se fait normalement de façon automatique lorsque vous fermez)

charlie@bohemond:~$ sudo apt-get update

Fin du travail en mode graphique.

ATTENTION pour faciliter le travail je vous conseille de copier les commandes à partir de 6-, en supprimant au maximum les interlignes, dans un fichier texte nommé (par exemple) down-xorg (j'aurais pu faire un script sh mais j'avais la flemme). Vous mettrez ce fichier dans votre répertoire /pub, répertoire à partir duquel vous effectuerez toutes les manoeuvres.

5- Basculez sur une console

(Ctrl Alt F2 par exemple...)

renseignez votre login et mot de passe puis passez en mode administrateur :

charlie@bohemond:~$ sudo -i

allez dans /pub :

charlie@bohemond:~# cd /pub
charlie@bohemond:/pub# cat down-xorg

Miracle !les commandes que vous avez à entrer sont sur votre écran, deux cas de figure : vous avez la souris active ce qui vous permet de faire du copier coller, elle ne l'est pas, vous recopiez ce que vous voyez à l'écran (je sais c'est fastidieux).

SUITE DE LA MANOEUVRE

6- fermer ou tuer X:

charlie@bohemond:~# /etc/init.d/gdm stop

7- Purger les paquets:

charlie@bohemond:~# cd /var/lib/dpkg/info/
charlie@bohemond:~# dpkg --purge `ls *xorg*.list | sed s/.list//` (attention au "`" d'encadrement de l'argument de commande.

NB: il va y avoir des erreurs de purges suite à des dépendances. On peut néanmoins poursuivre.

8- Réinstallation de xorg à partir du dépot intrepid:

charlie@bohemond:~# apt-get --reinstall install x11-common/intrepid xorg/intrepid xserver-xorg/intrepid xserver-xorg-core/intrepid xserver-xorg-input-kbd/intrepid xserver-xorg-input-mouse/intrepid xserver-xorg-input-evdev/intrepid

Si vous obtenez des erreurs, elles peuvent être dues à un serveur encombré ou à des espaces incongrus ou des lettres manquantes vérifiez bien la concordance avec le texte ci dessus je l'ai testé plusieurs fois. Si ce sont des erreurs de permissions, vous n'êtes pas en mode administrateur.

9- Lorsque tout est fini, refaite un apt-get update, éventuellement un apt-get autoremove et passez à l'installation des drivers ati :

charlie@bohemond:~# ./ati-driver-installer-X-X-x86.x86_64.run 
                      (X.X correspond à la version de votre drivers : 9.3 au maximum)

charlie@bohemond:~# aticonfig --initial -f

10- Vérifiez que fglrx apparaît bien comme driver dans xorg.conf

relancez la bouzine et croisez les doigts...
ça a parfaitement fonctionné chez moi...

#4 Le 25/04/2009, à 20:20

Bernard JEANNE

Re : Ubuntu 9.04 et ati xpress 1100

Rebonsoir

Stop yikes

A l'usage, on n'y gagne rien... trop de paramêtres à surveiller dans les mises à jour, désactivation du direct rendering bref trop de travail de suite et d'installation fichier par fichier.

Conclusion : ne tenez pas compte de mon post précédent à moins de vouloir passer une nuit à tout configurer point par point... sad:(:(

si j'ai le temps de m'y remettre, je vous donnerai la suite mais ne touchez à rien d'ici là

merci

Dernière modification par Bernard JEANNE (Le 17/05/2009, à 21:20)


Titou m'a dit : "assieds-toi et réfléchis... !"
Je me suis assis, le fauteuil était bien confortable...
Je me suis endormi.

Hors ligne

#5 Le 25/04/2009, à 22:51

sipi

Re : Ubuntu 9.04 et ati xpress 1100

ok merci,
j'avais commencer, mais j'ai rencontrer un problème une fois le serveur X tuer je n'ai plus la connexion à internet du coup impossible de réinstaller le xorg d'interpid ( enfin il me semble que je n'ai plus la connexion internet car sudo apt-get install vim ne marche pas, après avoir tuer le serveur X alors qu'il marche en mode graphique )

enfin bon voilà de tout façon je crois qu'on peut abandonner les dernières versions d'ubuntu...

merci quand même.


6pi

Hors ligne

#6 Le 26/04/2009, à 21:35

Cisa

Re : Ubuntu 9.04 et ati xpress 1100

Tank you bernard jeanne

Je ne me risquerer pas ce soir ;mais probable que je tente ma chance sauf si bien entendu je trouve meilleur proposition wink

Hors ligne

#7 Le 27/04/2009, à 06:32

stplease

Re : Ubuntu 9.04 et ati xpress 1100

salut je n'ai pas tuer le prosessus et fais seulement une install de xorg et tout fonctionne... a plus

Hors ligne

#8 Le 27/04/2009, à 08:32

gague

Re : Ubuntu 9.04 et ati xpress 1100

et comment tu t'y est pris?

Hors ligne

#9 Le 28/04/2009, à 06:24

stplease

Re : Ubuntu 9.04 et ati xpress 1100

en fait j'ai tenter de faire ce qui est decri au dessus mais j'ai du mal avec la console donc je n'ai pas reussi. J'ai changer la liste des sources comme indiquer au dessus  puis je suis retourner en console et l'ordi a comme ecraser. Puis j'ai installer catalyst 9.3 manuelement en le deplacant sur la console. puisun update!!! et voila ca fonctionne.

au fait ma radeon est une xpress200 integré.

a plus

Hors ligne

#10 Le 28/04/2009, à 10:11

atichu

Re : Ubuntu 9.04 et ati xpress 1100

tu t'es arréte a l'étape 4alors? non?


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#11 Le 28/04/2009, à 14:28

Rydgel

Re : Ubuntu 9.04 et ati xpress 1100

Downgrader Xorg.. Passer donc au pilote libre ! ATI vous l'a mise bien profond alors boycottez le ! J'ai une ATI Xpress 200M, je suis passé au pilote libre et j'ai de la 3D !


Linux - Web 2.0 --> http://phollow.fr

Hors ligne

#12 Le 28/04/2009, à 15:12

atichu

Re : Ubuntu 9.04 et ati xpress 1100

Rydgel j'ai un ati Xpress 1100 et j'ai pas de 3d avec le libre..


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#13 Le 28/04/2009, à 17:08

stplease

Re : Ubuntu 9.04 et ati xpress 1100

rydgel avec ta 200 tu as la 3 d? tu peux me donner le pilote libre?
merci

Hors ligne

#14 Le 28/04/2009, à 17:13

atichu

Re : Ubuntu 9.04 et ati xpress 1100

il y en a 2 readon ou radeonHD..^^^lequel est le bon..

Dernière modification par atichu (Le 28/04/2009, à 17:13)


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#15 Le 28/04/2009, à 17:31

stplease

Re : Ubuntu 9.04 et ati xpress 1100

moi c'est pas hd!!!!

Hors ligne

#16 Le 28/04/2009, à 19:56

Rydgel

Re : Ubuntu 9.04 et ati xpress 1100

le radeon xf86-ati-video


Linux - Web 2.0 --> http://phollow.fr

Hors ligne

#17 Le 28/04/2009, à 21:55

sipi

Re : Ubuntu 9.04 et ati xpress 1100

salut,
ce n'est pas celui installer par default?

parce que celui par default... enfin c'est vraiment pas terrible...
Combien obtient tu avec glxgears???

merci

Dernière modification par sipi (Le 28/04/2009, à 21:56)


6pi

Hors ligne

#18 Le 29/04/2009, à 11:35

steph88

Re : Ubuntu 9.04 et ati xpress 1100

slt sipi,
J'utilise aussi les pilotes libre (pas le choix une ati x1900) installé par default, voilà mes resultats de glxgears :

buntux@buntux-desktop:~$ glxgears
20417 frames in 5.0 seconds = 4083.379 FPS
23520 frames in 5.0 seconds = 4703.875 FPS
23578 frames in 5.0 seconds = 4715.593 FPS
23619 frames in 5.0 seconds = 4723.697 FPS

"Un résultat sur "direct rendering: Yes" indique que l'accélération est bien prise en compte dans le cas contraire c'est à refaire." lu sur http://doc.ubuntu-fr.org/ati

buntux@buntux-desktop:~$ glxinfo | grep "direct rendering"
direct rendering: Yes

Voilà l'accélération de mon pilote libre est bien prise en compte, peut etre que tu as un probleme a ce niveau essaye la commande glxinfo | grep "direct rendering"

Hors ligne

#19 Le 29/04/2009, à 13:31

sipi

Re : Ubuntu 9.04 et ati xpress 1100

Salut,

Avec les pilotes installés de base sur ubuntu 9.04 je ne monte pas à plus de 400 avec glxgears, et pas d'acceleration graphique, de plus l'affichage de glxgears saute lamentablement enfin c'est vraiment moche.

Là je suis retourné sur une 8.04 ou j'ai un score d'environ 1000 à glxgears mais toujours pas d'accelertation graphique (avec catalyst 9.3).

j'aimerai savoir si le pilote que cite Rydgel (radeon xf86-ati-video) est celui de base sur ubuntu 9.04 ou un autre, dans ce cas je me tenterai peut être a réinstaller ubuntu 9.04.


Pour info j'ai un dual-core 1.86Ghz, 1Go de Ram et comme le titre du post l'indique une ati xpress 1100 détecter comme une ati xpress 200 par ubuntu.

voila merci à tous pour vos réponse
et d'avance pour vos réponse future.

Dernière modification par sipi (Le 29/04/2009, à 13:33)


6pi

Hors ligne

#20 Le 29/04/2009, à 16:03

stplease

Re : Ubuntu 9.04 et ati xpress 1100

en fait mon pb etais que lorsque je voulais utiliser gimp ou photoshop, mon ecran devenais noir et plus aucune commande ne fonctionnais . il se mettais en mode veille (l'ecran)...

Hors ligne

#21 Le 29/04/2009, à 16:41

atichu

Re : Ubuntu 9.04 et ati xpress 1100

Sipi j'ai aussi un ati 1100 xpress

j'ai une accélération est 1000frames.

mais avec une autre installe d e8.10 ( je bricole beaucoup et doit reformater j'ai réusit a aller a 2000frame.

c'était avec envy-ng uqui mavait installer le pilote propriétaire. mais je sais plus quel version ^^


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

Haut de page ↑