Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/06/2009, à 07:24

lylian44

[RESOLU] Impossible de résoudre les dépendances

Bonjour,
je suis sous Kubuntu 9.04, et depuis quelques jours, je ne peux plus faire de mise à jours.
J'ai ce message d'erreur:

Impossible de résoudre les dépendances (configuration système)
Impossible de trouver une dépendance pour le paquetage.
D'autres informations sont disponibles dans le rapport détaillé.
There are broken dependecies on your system. Please use an advanced package manage e.g. Synaptic or aptitude to resolve this situation.

Et lors des recherches de paquets, j'ai ça :

Une erreur du système interne est survenue.
Un problème inattendu s'est produit.
Veuillez signaler ce bogue ainsi que la description de l'erreur.
Message did not receive a reply (timeout by message bus)

Que faire ?:/

Dernière modification par lylian44 (Le 10/06/2009, à 19:54)

Hors ligne

#2 Le 10/06/2009, à 08:43

bruno

Re : [RESOLU] Impossible de résoudre les dépendances

On ne sait pas ce qui bloque. Donne nous le résultat de ces actions en ligne de commande :

sudo aptitude update

puis


sudo aptitude full-upgrade

En ligne

#3 Le 10/06/2009, à 09:15

lylian44

Re : [RESOLU] Impossible de résoudre les dépendances

Et voilà big_smile

sudo aptitude update

Écriture de l'information d'état étendu... Fait
Ign http://asher256-repository.tuxfamily.org ubuntu Release.gpg                                                 
Ign http://asher256-repository.tuxfamily.org ubuntu/main Translation-fr                                         
Atteint http://fr.packages.medibuntu.org jaunty Release.gpg                                                     
Ign http://fr.packages.medibuntu.org jaunty/free Translation-fr                                                 
Atteint http://archive.canonical.com jaunty Release.gpg 
Ign http://archive.canonical.com jaunty/partner Translation-fr                                                  
Atteint http://archive.ubuntu.com jaunty Release.gpg    
Atteint http://archive.ubuntu.com jaunty/main Translation-fr                                                    
Ign http://asher256-repository.tuxfamily.org ubuntu/dupdate Translation-fr                                      
Ign http://asher256-repository.tuxfamily.org ubuntu/french Translation-fr                                       
Ign http://asher256-repository.tuxfamily.org ubuntu Release                                                     
Ign http://fr.packages.medibuntu.org jaunty/non-free Translation-fr                                             
Atteint http://fr.packages.medibuntu.org jaunty Release 
Atteint http://archive.canonical.com jaunty Release     
Atteint http://archive.ubuntu.com jaunty/restricted Translation-fr                                              
Atteint http://archive.ubuntu.com jaunty/universe Translation-fr                                                
Atteint http://archive.ubuntu.com jaunty/multiverse Translation-fr                                              
Atteint http://archive.ubuntu.com jaunty-updates Release.gpg                                                    
Ign http://archive.ubuntu.com jaunty-updates/main Translation-fr                                                
Ign http://archive.ubuntu.com jaunty-updates/restricted Translation-fr                                          
Ign http://archive.ubuntu.com jaunty-updates/universe Translation-fr                                            
Ign http://archive.ubuntu.com jaunty-updates/multiverse Translation-fr                                          
Atteint http://archive.ubuntu.com jaunty-security Release.gpg                                                   
Ign http://asher256-repository.tuxfamily.org ubuntu/main Packages                                               
Ign http://archive.ubuntu.com jaunty-security/main Translation-fr                                               
Ign http://archive.ubuntu.com jaunty-security/restricted Translation-fr                                         
Atteint http://fr.packages.medibuntu.org jaunty/free Packages                                                   
Ign http://archive.canonical.com jaunty/partner Packages
Ign http://asher256-repository.tuxfamily.org ubuntu/dupdate Packages                                            
Ign http://asher256-repository.tuxfamily.org ubuntu/french Packages                                             
Ign http://archive.ubuntu.com jaunty-security/universe Translation-fr                                           
Ign http://archive.ubuntu.com jaunty-security/multiverse Translation-fr                                         
Atteint http://archive.ubuntu.com jaunty Release        
Atteint http://archive.ubuntu.com jaunty-updates Release
Atteint http://fr.packages.medibuntu.org jaunty/non-free Packages                                               
Ign http://archive.canonical.com jaunty/partner Sources 
Atteint http://asher256-repository.tuxfamily.org ubuntu/main Packages                                           
Atteint http://archive.ubuntu.com jaunty-security Release                                                       
Atteint http://archive.canonical.com jaunty/partner Packages                                                    
Atteint http://asher256-repository.tuxfamily.org ubuntu/dupdate Packages                                        
Atteint http://archive.ubuntu.com jaunty/main Packages  
Atteint http://archive.ubuntu.com jaunty/restricted Packages                                                    
Atteint http://archive.ubuntu.com jaunty/main Sources   
Atteint http://archive.ubuntu.com jaunty/restricted Sources                                                     
Atteint http://archive.ubuntu.com jaunty/universe Packages                                                      
Atteint http://archive.ubuntu.com jaunty/universe Sources                                                       
Atteint http://archive.canonical.com jaunty/partner Sources                                                     
Atteint http://asher256-repository.tuxfamily.org ubuntu/french Packages                                         
Atteint http://archive.ubuntu.com jaunty/multiverse Packages                                                    
Atteint http://archive.ubuntu.com jaunty/multiverse Sources                                                     
Atteint http://archive.ubuntu.com jaunty-updates/main Packages                                                  
Atteint http://archive.ubuntu.com jaunty-updates/restricted Packages                                            
Atteint http://archive.ubuntu.com jaunty-updates/main Sources                                                   
Atteint http://archive.ubuntu.com jaunty-updates/restricted Sources
Atteint http://archive.ubuntu.com jaunty-updates/universe Packages
Atteint http://archive.ubuntu.com jaunty-updates/universe Sources
Atteint http://archive.ubuntu.com jaunty-updates/multiverse Packages
Atteint http://archive.ubuntu.com jaunty-updates/multiverse Sources
Atteint http://archive.ubuntu.com jaunty-security/main Packages
Atteint http://archive.ubuntu.com jaunty-security/restricted Packages
Atteint http://archive.ubuntu.com jaunty-security/main Sources
Atteint http://archive.ubuntu.com jaunty-security/restricted Sources
Atteint http://archive.ubuntu.com jaunty-security/universe Packages
Atteint http://archive.ubuntu.com jaunty-security/universe Sources
Atteint http://archive.ubuntu.com jaunty-security/multiverse Packages
Atteint http://archive.ubuntu.com jaunty-security/multiverse Sources
Lecture des listes de paquets... Fait

sudo aptitude full-upgrade

Lecture des listes de paquets... Fait                
Construction de l'arbre des dépendances              
Lecture des informations d'état... Fait              
Lecture de l'information d'état étendu               
Initialisation de l'état des paquets... Fait         
Les paquets suivants sont CASSÉS :                   
  sun-java6-demo sun-java6-fonts sun-java6-javadb    
  sun-java6-plugin                                   
Les paquets suivants seront ENLEVÉS :                
  gnome-desktop-data{u} gnome-icon-theme{u}          
  gnome-pilot{u} gnome-pilot-conduits{u}             
  language-support-writing-fr{u} libcamel1.2-14{u}   
  libebackend1.2-0{u} libebook1.2-9{u}               
  libecal1.2-7{u} libedata-book1.2-2{u}              
  libedata-cal1.2-6{u} libedataserver1.2-11{u}       
  libegroupwise1.2-13{u}                             
  libexchange-storage1.2-3{u}                        
  libgdata-google1.2-1{u} libgdata1.2-1{u}           
  libglib1.2ldbl{u} libgnome-pilot2{u} libgtk1.2{u}  
  libgtk1.2-common{u} libgtkhtml-editor-common{u}    
  libgtkhtml-editor0{u} libgtkhtml3.14-19{u}         
  libgweather-common{u} libgweather1{u}              
  liblpint-bonobo0{u} libmikmod2{u}                  
  libpanel-applet2-0{u} libpisock9{u} libpisync1{u}  
  librsvg2-common{u} libsdl-mixer1.2{u}              
  libsmpeg0{u} wfrench{u}                            
Les paquets suivants seront mis à jour :             
  libmagickcore1 libmagickwand1                      
Les paquets partiellement installés suivants seront configurés :                                                
  gsfonts-x11 java-common odbcinst1debian1              
  sun-java6-doc unixodbc
2 paquets mis à jour, 0 nouvellement installés, 34 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1988ko d'archives. Après dépaquetage, 64,5Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
  sun-java6-plugin: Dépend: sun-java6-bin (= 6-13-1) mais il n'est pas installable
  sun-java6-demo: Dépend: sun-java6-jre (= 6-13-1) maisil n'est pas installable
                  Dépend: sun-java6-jdk (= 6-13-1) maisil n'est pas installable
  sun-java6-fonts: Dépend: sun-java6-jre (>= 6-13-1) mais il n'est pas installable
  sun-java6-javadb: Dépend: sun-java6-jdk (= 6-13-1) mais il n'est pas installable
Les actions suivantes permettront de résoudre ces
dépendances :

Supprimer les paquets suivants :
sun-java6-demo
sun-java6-fonts
sun-java6-javadb
sun-java6-plugin

Le score est de 326

Accepter cette solution ? [Y/n/q/?]
Les paquets suivants seront ENLEVÉS :
  gnome-desktop-data{u} gnome-icon-theme{u} 
  gnome-pilot{u} gnome-pilot-conduits{u}    
  language-support-writing-fr{u} libcamel1.2-14{u} 
  libebackend1.2-0{u} libebook1.2-9{u}
  libecal1.2-7{u} libedata-book1.2-2{u}
  libedata-cal1.2-6{u} libedataserver1.2-11{u}
  libegroupwise1.2-13{u}
  libexchange-storage1.2-3{u}
  libgdata-google1.2-1{u} libgdata1.2-1{u}
  libglib1.2ldbl{u} libgnome-pilot2{u} libgtk1.2{u}
  libgtk1.2-common{u} libgtkhtml-editor-common{u}
  libgtkhtml-editor0{u} libgtkhtml3.14-19{u}
  libgweather-common{u} libgweather1{u}
  liblpint-bonobo0{u} libmikmod2{u}
  libpanel-applet2-0{u} libpisock9{u} libpisync1{u}
  librsvg2-common{u} libsdl-mixer1.2{u}
  libsmpeg0{u} sun-java6-demo{a} sun-java6-fonts{a}
  sun-java6-javadb{a} sun-java6-plugin{a}
  wfrench{u}
Les paquets suivants seront mis à jour :
  libmagickcore1 libmagickwand1
Les paquets partiellement installés suivants seront configurés :
  gsfonts-x11 java-common odbcinst1debian1
  sun-java6-doc unixodbc
2 paquets mis à jour, 0 nouvellement installés, 38 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1988ko d'archives. Après dépaquetage, 123Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]

Est-ce que je continue à mettre : OUI ?

ps: c'est ce p*%§$ de Java qui fout ça m.....ça zone ?

Hors ligne

#4 Le 10/06/2009, à 11:06

bruno

Re : [RESOLU] Impossible de résoudre les dépendances

Tu peux répondre OUI (Y) et essayer ensuite de réinstaller le paquet sun-java6-plugin. Mais tu devrais vérifier avant ce qui se passe en désactivant tes dépôts non officiels (asher256).

En ligne

#5 Le 10/06/2009, à 19:56

lylian44

Re : [RESOLU] Impossible de résoudre les dépendances

Super, ça marche !!

Bon ce n'était à priori pas le dépôt qui était en cause, mais bien les paquets Java.

Merci pour ton aide Bruno.

A+

Hors ligne