Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 31/07/2009, à 13:07

p6s

Flash plugin 64 bits nouvelle version :)

je viens de voir qu'adobe a balancé une nouvelle version de son plugin flash 64 bits hier smile
on passe de la 10.0.22 (qui marchait deja pas si mal) à la 10.0.32.

s'il y a des testeurs fous qui veulent comparer  cool :
http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz

a premiere vue, ca a l'air un poil plus reactif, genre quand on switche entre mode normal et hq sous youtube...

Dernière modification par p6s (Le 31/07/2009, à 13:10)

Hors ligne

#2 Le 31/07/2009, à 13:15

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

Yop,

En effet, ça semble un peu mieux, et pour l'instant ça ne crashe pas à tout va comme l'ancienne release. Reste toujours quelques bugs récurrents (notamment la sortie du plein écran lorsque l'on modifie le volume)

Hors ligne

#3 Le 31/07/2009, à 14:14

Kerlam

Re : Flash plugin 64 bits nouvelle version :)

Bien, la première question qui me vient est comment fait-on la mise à jour? big_smile Faut-il désinstaller l'ancienne version avant?


-Tour: CPU: Intel Q9550, RAM: 4Go, CG: ATI HD5850, OS: Windows 7 / Xubuntu 13.10
-NetBook: Eee PC 1000H, RAM: 2Go, SSD: Intel X25-V 40Go, OS: Xubuntu 13.10
-Portable: HP Pavilion zv6000, RAM: 640Mo, OS: Debian Wheezy XFCE

Hors ligne

#4 Le 31/07/2009, à 14:38

p6s

Re : Flash plugin 64 bits nouvelle version :)

Kerlam a écrit :

Bien, la première question qui me vient est comment fait-on la mise à jour? big_smile Faut-il désinstaller l'ancienne version avant?

c'est juste un fichier à copier. donc suivant où t'avais foutu le precedent libflashplayer.so (par exemple dans /usr/lib/mozilla/plugins), tu le remplaces au meme endroit.
tu peux essayer un locate aussi si t'as d'autres instances du meme fichier qui trainent ailleurs, des fois que le plugin flash te serve aussi sous d'autres programmes/browsers que ceux qui utilisent les plugins mozilla

Dernière modification par p6s (Le 31/07/2009, à 14:43)

Hors ligne

#5 Le 31/07/2009, à 18:09

Kerlam

Re : Flash plugin 64 bits nouvelle version :)

Merci, j'ai quelque peu modifié un script trouvé ici: [url]http://doc.ubuntu-fr.org/ubuntu_64bits?s[]=flash64#installation_de_flash_player_10_flash_version_64_bits[/url]

#!/bin/bash
# # Script fait par  
# # Romeo-Adrian Cioaba romeo.cioaba@spotonearth.co
# # avec modification pour version 64 bits par Tomtoom
# # Mis à jour à la version 10.0.22.87 par Theozzfancometh
# # Sous GPL  
  
echo "Fermeture de Firefox"  

sudo killall -9 firefox  
  
echo "Suppression des plugins Flash déjà installé:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper  
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f /usr/lib64/mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox*/plugins/*flash*
sudo rm -f /usr/lib64/firefox*/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper
    
echo "Installation de Flash Player Version Alpha 64 bits"  
cd ~ 
wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-*.linux-x86_64.so.tar.gz
tar zxvf libflashplayer-*.linux-x86_64.so.tar.gz
sudo cp libflashplayer.so /usr/lib64/mozilla/plugins
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
sudo cp libflashplayer.so /usr/lib64/mozilla/plugins/
sudo cp libflashplayer.so /usr/lib/firefox*/plugins/
sudo cp libflashplayer.so /usr/lib64/firefox*/plugins/
rm -rf libflashplayer-*.linux-x86_64.so.tar.gz
rm -rf libflashplayer.so

echo "-----------------------------------------------------------------------"
echo "C'est Fait, Flash 64 bit (Alpha) est installé :-)"
echo "Cette version est une Alpha donc risque d'instabilité"
echo "-----------------------------------------------------------------------"

J'aimerais savoir si le remplacement du numéro de version par une astérisque dans les commandes incluant le nom du fichier, comme je l'ai fait là, est possible pour rendre ce script applicable pour toutes les nouvelles versions?


-Tour: CPU: Intel Q9550, RAM: 4Go, CG: ATI HD5850, OS: Windows 7 / Xubuntu 13.10
-NetBook: Eee PC 1000H, RAM: 2Go, SSD: Intel X25-V 40Go, OS: Xubuntu 13.10
-Portable: HP Pavilion zv6000, RAM: 640Mo, OS: Debian Wheezy XFCE

Hors ligne

#6 Le 31/07/2009, à 20:46

ppmt

Re : Flash plugin 64 bits nouvelle version :)

C'est a verifier mais il me semble que wget ne marche pas avec les wildcard comme *


le dock dont vous avez toujours rêvé  Cairo-Dock
irc://irc.freenode.net/#Cairo-Dock-fr

Hors ligne

#7 Le 01/08/2009, à 14:53

brakbabord

Re : Flash plugin 64 bits nouvelle version :)

Merci pour l'info.

Perso j'ai copié le fichier dans ~/.mozilla/plugins (répertoire à créér si il n'existe pas).
Par rapport à la version précédente, moins de lag dans les vidéos HQ j'ai l'impression.

Player plus rapide à charger aussi (j'ai flashblock qui bloque tout, donc quand je clique je le vois charger sous mes yeux).

Que du bon donc.

Hors ligne

#8 Le 17/09/2009, à 11:22

Lifesaver

Re : Flash plugin 64 bits nouvelle version :)

Et la version 64 bits est-elle prévue dans les dépots de KK ? Ou restera-t-on avec une version 32 bits pour les architectures amd64 ?


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#9 Le 17/09/2009, à 13:52

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

La version flash 64 bits étant en alpha et pour l'instant assez incomplète, la version des dépôts reste la 32 bits + nsplugin

Hors ligne

#10 Le 17/09/2009, à 14:15

brakbabord

Re : Flash plugin 64 bits nouvelle version :)

C'est d'ailleurs bien dommage car la 64bit marche beaucoup mieux que la 32+ns.

Hors ligne

#11 Le 17/09/2009, à 19:19

Lifesaver

Re : Flash plugin 64 bits nouvelle version :)

oui, mais bon de toutes façons avec ma connexion internet merdique de campagne, la HD je peut tirer un trai dessus pour longtemps ;-)
Jusqu'à présent, je n'ai jamais eu de soucis avec la version flashplayer des dépôts.
Donc le bits attendra chez moi, tant pis !


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#12 Le 17/09/2009, à 19:47

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

brakbabord a écrit :

C'est d'ailleurs bien dommage car la 64bit marche beaucoup mieux que la 32+ns.

Je viens d'essayer pour voir... Catastrophe ça crashe en boucle big_smile (sous Karmic certes)

Hors ligne

#13 Le 02/11/2009, à 07:49

angelofrancois

Re : Flash plugin 64 bits nouvelle version :)

n aurait pu penser que pour la sortie de la nouvelle version d’Ubuntu, les développeurs  nous mettraient enfin la version 64 bits du FlashPlayer Adobe dans les dépots de Karmic 64 bits. Eh bien, non ! Le paquet flashplugin-installer disponible dans les dépots officiels pour la version 64 bits fait la même chose que pour les versions précédentes : il récupère le plugin 32 bits depuis le site d’Adobe et l’enrobe avec nspluginwrapper pour qu’il tourne dans les navigateurs 64 bits, ce qui cause encore et toujours quelques bugs dont on peut se passer avec le Flash Player natif 64 bits d’Adobe Labs. 

Différentes solutions existent pour installer ce dernier , et voici plus simple que j’ai trouvée et que j’utilise : récupérer et installer le paquet d’installation du plugin pour Debian Sid 64 bits.
Contrairement aux méthodes présentées sur la doc Ubuntu-fr, le plugin installé ici est désinstallable très simplement via Synaptic ou apt-get remove.

Remarque : Cela s’applique également à Ubuntu 9.04 Jaunty Jackalope pour ceux qui ne voudraient pas migrer vers le Koala.

Voici donc la procédure à suivre, en deux lignes de code à copier-coller dans un terminal :

1 – Supprimer toute version déjà installée de FlashPlayer ou d’un autre lecteur Flash

sudo apt-get remove -y --purge flashplugin-nonfree flashplugin-installer mozilla-plugin-gnash   swfdec-mozilla nspluginwrapper

2 – Télécharger et installer la dernière version du paquet Debian Sid

wget http://ftp.fr.debian.org/debian/pool/contrib/f/flashplugin-nonfree/flashplugin-nonfree_2.8_amd64.deb && sudo dpkg -i flashplugin-nonfree_2.8_amd64.deb

3 – Enjoy ! j ai ttouver ca pour flash player 64 ca marche impec

Hors ligne

#14 Le 02/11/2009, à 14:48

Lifesaver

Re : Flash plugin 64 bits nouvelle version :)

Effectivement, je trouve bien dommage que nous ne disposons pas dans les dépots de KK de la version 64 bits du flashplugin, même si ce n'est pas une version "finale"...


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#15 Le 02/11/2009, à 14:57

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

C'est une version alpha, dont la stabilité est loin de m'avoir convaincu...

Hors ligne

#16 Le 02/11/2009, à 16:33

brakbabord

Re : Flash plugin 64 bits nouvelle version :)

Tu es bien le seul, et tu as certainement un autre problème derrière.

Sur tous les ordinateurs 64bit où je l'ai installé, il n'a jamais planté. Par contre le plugin 32+nspluginwrapper était vraiment pourri, t'es sûr que c'est pas celui là que t'as mis??

Hors ligne

#17 Le 02/11/2009, à 16:39

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

brakbabord a écrit :

Tu es bien le seul, et tu as certainement un autre problème derrière.

Nope, chui pas le seul selon Launchpad et aux plate-formes de rapport de bug wink Rien que le flash utilisé pour jouer les sons du tchat sur Gmail fait crasher le tout...

brakbabord a écrit :

Sur tous les ordinateurs 64bit où je l'ai installé, il n'a jamais planté. Par contre le plugin 32+nspluginwrapper était vraiment pourri, t'es sûr que c'est pas celui là que t'as mis??

Quand même roll

Hors ligne

#18 Le 02/11/2009, à 18:34

josian

Re : Flash plugin 64 bits nouvelle version :)

La nouvelle version de  ce flash 64b permet-elle de ne plus avoir la tâche npviewer.bin qui me prend 30% de charge UC ?


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#19 Le 03/11/2009, à 16:03

josian

Re : Flash plugin 64 bits nouvelle version :)

Après avoir supprimé les différenst flash, j'ai installé la version 1.2.8 ( #13) du flashplugin nonfree ==> rien ne marche


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#20 Le 03/11/2009, à 16:08

josian

Re : Flash plugin 64 bits nouvelle version :)

Rectificatif : je n'avais pas relancé firefox , dans un premeir test OK


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#21 Le 03/11/2009, à 16:34

josian

Re : Flash plugin 64 bits nouvelle version :)

Rectificatif 2 : une vidéo OK, plantage firefox à la seconde vidéo : le première ne semble pas se fermer correctement ; je suis donc revenu à flashhplugin installer et npviewer.bin sad.


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#22 Le 03/11/2009, à 16:52

brakbabord

Re : Flash plugin 64 bits nouvelle version :)

Tu t'es planté, le flashplugin-nonfree est un paquet qui installe la version 32bit, donc elle tourne encore dans npviewer!

CF le wiki pour installer la version 64bit native.

Hors ligne

#23 Le 03/11/2009, à 16:53

brakbabord

Re : Flash plugin 64 bits nouvelle version :)

slasher-fun a écrit :
brakbabord a écrit :

Tu es bien le seul, et tu as certainement un autre problème derrière.

Nope, chui pas le seul selon Launchpad et aux plate-formes de rapport de bug wink Rien que le flash utilisé pour jouer les sons du tchat sur Gmail fait crasher le tout...

brakbabord a écrit :

Sur tous les ordinateurs 64bit où je l'ai installé, il n'a jamais planté. Par contre le plugin 32+nspluginwrapper était vraiment pourri, t'es sûr que c'est pas celui là que t'as mis??

Quand même roll

Mouais bon c'est une version alpha.
Y'a pas un launchpad chez Adobe big_smile ?

Hors ligne

#24 Le 03/11/2009, à 18:06

slasher-fun

Re : Flash plugin 64 bits nouvelle version :)

brakbabord a écrit :

Mouais bon c'est une version alpha.

Ah j'ai jamais dit contraire, et je modifierai bien la doc à ce sujet d'ailleurs (oui parce que pour l'instant ça parle de stabilité reconnue...)

brakbabord a écrit :

Y'a pas un launchpad chez Adobe big_smile ?

Y'a un machin qui ressemble si, mais je sais plus où.

Hors ligne

#25 Le 04/11/2009, à 23:41

josian

Re : Flash plugin 64 bits nouvelle version :)

J'ai essayé le script signalé par Kerlam ( #5): plantageS régulierS , Firefox est devenu très instable et inutilisable.
N'étant pas un spécialiste Ubuntu, Ma question est donc comment revenir à la situation précédente avec npluginwrapper ? faut-il supprimer quelques librairies, ou simplement libflashplayer.so ?
Merci


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

Haut de page ↑