Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/06/2009, à 19:31

rifi58

[résolu] Xsane : choix du périphérique par défaut

Bonjour,

Xsane : quand je le lance, il me détecte ma webcam (coché par défaut) et mon imprimante/scanner ;

Comment faire pour qu'il ne me détecte que l'imprimante/scanner ?

Merci

Dernière modification par rifi58 (Le 18/08/2009, à 15:37)


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#2 Le 26/06/2009, à 19:32

Grunt

Re : [résolu] Xsane : choix du périphérique par défaut

Il faut le lancer en lui indiquant le bon péripérique, parmi "/dev/video0" et "/dev/video1".

Pour plus d'infos:

man xsane

#3 Le 26/06/2009, à 19:40

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

merci mais c'est pour quelqu'un qui débute et on envoie xsane en graphique, pas en console...


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#4 Le 26/06/2009, à 19:55

Grunt

Re : [résolu] Xsane : choix du périphérique par défaut

Il faut modifier le raccourci de xsane pour ajouter le nom du bon périphérique au lancement.
En bref:

xsane -d /dev/video1

au lieu de

xsane

comme commande pour le raccourci.

#5 Le 26/06/2009, à 20:51

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

oui mais la personne a déjà bien du mal et il n'est pas question pour elle (pour l'instant) d'utiliser la console pour lancer une appli...


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#6 Le 26/06/2009, à 20:57

Grunt

Re : [résolu] Xsane : choix du périphérique par défaut

Je ne parle pas de lui faire utiliser la console, mais de modifier son raccourci graphique.

Chez moi (KDE) ça se résume à faire un clic-droit, choisir "Editer le menu", chercher "xsane", et modifier la commande "xsane" du raccourci.

Ensuite la personne n'a plus qu'à cliquer sur ce raccourci ou à utiliser une copie de ce raccourci.

#7 Le 26/06/2009, à 21:17

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

OK
j'ai essayé de mettre xsane -d /dev/video1 à la place de xsane mais ça ne change rien...


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#8 Le 26/06/2009, à 21:21

Grunt

Re : [résolu] Xsane : choix du périphérique par défaut

C'est peut-être "/dev/video0" alors?

#9 Le 26/06/2009, à 21:23

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

dans /dev j'ai effectivement un fichier video0 mais ça ne change rien


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#10 Le 26/06/2009, à 21:26

Grunt

Re : [résolu] Xsane : choix du périphérique par défaut

Y'a un "/dev/video0" et un "/dev/video1"?
Soit c'est l'un, soit c'est l'autre..

Ce qui peut poser soucis est que, si la webcam n'est pas là, le scanner devient "video0" et passe à "video1" si la webcam est connectée en "video0" hmm

#11 Le 26/06/2009, à 21:29

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

Disons que j'avais mis (bêtement) video1 mais après avoir été dans /dev j'ai vu qu'il y avait video0

Donc même avec ton astuce, j'ai toujours ma webcam (cochée par défaut) et mon imprimante/scanner ; il faut donc à chaque lancement de Xsane cocher l'imprimante/scanner...

Mais question car à priori video0 correspond à la webcam ?
De mettre -d /dev/video0 indique de ne pas rechercher la webcam, c'est ça ?? (j'ai fait man xsane mais en anglais, je ne pige pas tout...

Dernière modification par rifi58 (Le 27/06/2009, à 11:03)


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#12 Le 12/08/2009, à 20:55

stdjulz

Re : [résolu] Xsane : choix du périphérique par défaut

Salut,
Même souci que toi, je n'ai pas envie de scanné via la webcam!
Dans mon cas il ne m'a pas fallu choisir entre "/dev/video0" et un "/dev/video1"...
Tape dans un terminal:

scanimage -L

qui devrait te renvoyer quelque chose comme

device `hpaio:/usb/Deskjet_F2200_series?serial=CN8BO1S2VF05GG' is a Hewlett-Packard Deskjet_F2200_series all-in-one
device `v4l:/dev/video0' is a Noname Z-star Vimicro zc0301p virtual device

Il te suffit alors de récupérer l'identifiant de ton scanner (hpaio:/usb/Deskjet_F2200_series?serial=CN8BO1S2VF05GG dans mon cas) et de le mettre à la suite de ta commande xsane (ou de modifier ton raccourci comme proposé par Grunt)

xsane hpaio:/usb/Deskjet_F2200_series?serial=CN8BO1S2VF05GG

et hop, tu démarre direct xsane avec ton scanner
Testé & approuvé en 8.04 avec une Hp F2280
A+

Hors ligne

#13 Le 18/08/2009, à 15:37

rifi58

Re : [résolu] Xsane : choix du périphérique par défaut

OK c'est bon !
merci !


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Hors ligne

#14 Le 10/11/2009, à 16:57

epictete

Re : [résolu] Xsane : choix du périphérique par défaut

Ça faisait longtemps que, moi aussi, ça m'énervait de devoir sélectionner le périphérique à chaque lancement du logiciel de scan :

merci beaucoup Stdjulz !

NB. Pour un Canon Scan Lide 30 la commande est chez moi (grâce à scanimage -L) :

xsane plustek:libusb:006:002


Promouvoir et défendre le logiciel libre : http://www.april.org
Foundation for a Free Information Infrastructure : http://www.ffii.org/Home
               « La liberté, la liberté, les gens n'ont que ce mot-là à la bouche ! » Françoise de Panafieu (UMP).
               « Rien ne justifie qu'on cherche à préserver la liberté de l'Internaute » Chantal Brunel (UMP).

Hors ligne

#15 Le 17/11/2009, à 21:07

tinf

Re : [résolu] Xsane : choix du périphérique par défaut

Pour moi aussi, c'est un succès

xsane epson:libusb:001:009 pour un Epson 1240U photo

merci

UBUNTU 9.04

Hors ligne

#16 Le 17/11/2009, à 22:46

fabux

Re : [résolu] Xsane : choix du périphérique par défaut

Salut,

je viens de tomber sur ce thread. J'ai trouvé une autre méthode qui marche chez moi.

Dans le fichier /etc/sane.d/dll.conf j'ai commenté (mis un #) la ligne v4l.

Hors ligne

Haut de page ↑