Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/09/2009, à 07:57

Cémoidon

[Résolu]Totem se ferme au lieu de lire mes videos

Bonjour ,

Depuis quelques jours ne ne parviens plus à lire les vidéos sur ma machine .
Cela a commencé un jour où j'ai voulu relire les vidéos ' youtube ' présentes dans le cache de mozilla .
Totem a annoncé ne pas disposer des codecs nécessaires et s'est chargé de télécharger quelques paquets que je n'ai pas mémorisés .
Le même jour j'ai installé le programme paprass qui apporte lui aussi son lot de paquets dont des paquets concernant python . Je précise cela du fait du message d'erreur affiché dans la console lors du chargement de totem .
J'ai au moyen de synaptic réinstallé tout ce qui concernait python 2.6 mais cela n'a rien changé au message d'erreur .

Voici ce que donne la console quand je lance totem :

thierry@Shuttle:~$ totem
/var/lib/python-support/python2.6/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 54 error_code 11 request_code 133 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
thierry@Shuttle:~$ totem --sync
/var/lib/python-support/python2.6/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 54 error_code 11 request_code 133 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
thierry@Shuttle:~$

Mplayer est lui aussi devenu incapable de lire les vidéos , comme totem il se ferme :

thierry@Shuttle:~$ gmplayer
MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) XP 2400+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/Données/Documents de Thierry/Gags/Bud1.wmv.
ASF file format detected.
[asfheader] Audio stream found, -aid 1
[asfheader] Video stream found, -vid 2
VIDEO:  [WMV2]  320x240  24bpp  1000.000 fps  200.0 kbps (24.4 kbyte/s)
Clip info:
 name: 
 author: 
 copyright: 
 comments: 
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
==========================================================================
Opening video decoder: [dshow] DirectShow video codecs
Win32 LoadLibrary failed to load: wmv8ds32.ax, /usr/lib/win32/wmv8ds32.ax, /usr/local/lib/win32/wmv8ds32.ax
Warning: DS_Filter() could not open DirectShow DLL.  (DLL=wmv8ds32.ax, r=0xa9490d8)
Failed to create DirectShow filter
ERROR: Could not open required DirectShow codec wmv8ds32.ax.
You need to upgrade/install the binary codecs package.
Go to http://www.mplayerhq.hu/dload.html
VDecoder init failed :(
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:230400  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32 
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 320 x 240 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12 
Selected video codec: [wmvdmo] vfm: dmo (Windows Media Video DMO)
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 1 ch, s16le, 20.0 kbit/3.91% (ratio: 2500->64000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [pulse] 32000Hz 1ch s16le (2 bytes per sample)
Starting playback...
[ws] Error in display.
[ws]  Error code: 11 ( BadAlloc (insufficient resources for operation) )
[ws]  Request code: 133
[ws]  Minor code: 19
[ws]  Modules: flip_page

Comme tout fonctionnait normalement auparavant je suppose que les codecs chargés par totem mais je suis incapable d'aller plus loin tout seul pour me dépanner , pouvez vous m'aider ?.
Je précise que je suis allé sur le site http://www.mplayerhq.hu/dload.html comme indiqué , que j'ai téléchargé les codecs et que je les ai placés en /usr/local/lib/win32/ . Le fichier wmv8ds32.ax est effectivement absent . J'ai pu ouvrir par gmplayer un fichier avi qui s'ouvre en vignette , le tout se ferme quand j'élargis la fenêtre . Quand à Totem , la tentative d'ouverture du fichier avi provoque immédiatement sa fermeture

Merci d'avance

Dernière modification par TChatenet (Le 06/09/2009, à 09:12)

Hors ligne

#2 Le 06/09/2009, à 09:10

Cémoidon

Re : [Résolu]Totem se ferme au lieu de lire mes videos

Je me réponds à moi même .
Bien que n'ayant pas de circuit Intel ( ma carte graphique est une NVidia ) la solution est venue de cette page http://doc.ubuntu-fr.org/compiz_fusion_problemes_connus .
Totem a été stabilisé par l'application du conseil suivant :

Pour certaines cartes Intel (exemples : GM950, GM965, utilisant le paquet 915resolution) il arrive que Totem crashe lors de la lecture d'une vidéo au format avi (alors qu'il fonctionne correctement sans Compiz). Cela provient en fait d'un mauvais réglage de gstreamer, qu'utilise Totem. Pour le corriger :

$ gstreamer-properties

et dans l'onglet Vidéo, sélectionner "X Window System (sans Xv)" à la place de "Autodetect" comme greffon de sortie par défaut. Plus de renseignements (en anglais) sur https://bugs.launchpad.net/ubuntu/+sour … ug/111257.

J'ai ensuite appliqué le même traitement à gmplayer . Dans l'onglet préférences j'ai choisi la sortie vidéo X11/XImage/Shm et maintenant les deux lecteurs fonctionnent à nouveau normalement sauf le codec qui manque toujours à Mplayer .
Je ne m'explique pas pourquoi cette panne est apparue sur mon système qui lisait les vidéos convenablement auparavant . Fruit d'une maj ???

Dernière modification par TChatenet (Le 06/09/2009, à 09:11)

Hors ligne

#3 Le 20/12/2009, à 12:47

Cémoidon

Re : [Résolu]Totem se ferme au lieu de lire mes videos

Je corrige la solution apportée .
En sélectionnant "X Window System (sans Xv)" il semble que l'on délègue tout le travail de la carte graphique au processeur et cela finit par coincer .
J'ai secondairement sélectionné "X Window System (X11/Xshm/Xv)" . Cela fonctionne toujours , et depuis skype ne freeze plus lors de l'usage de la vidéo
Pour GMPLayer , suivant la même logique j'ai choisi Xv ( X11/Xv ) et cela fonctionne toujours , par contre je n'ai pas remarqué une utilisation moindre du CPU. ?

Hors ligne

Haut de page ↑