Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/10/2009, à 14:58

tidjean

kde4 scim [Resolu]

bonjour je suis ne chine et je cherche desperement a faire fonctionner scim pour l'ecriture en chinois. je suis sous kubuntu 9.10. Aprés milles recherche je fini par poster. merci d'avance

Dernière modification par tidjean (Le 16/10/2009, à 03:52)


de:moi(tidjean)

Hors ligne

#2 Le 11/10/2009, à 22:22

Keiser

Re : kde4 scim [Resolu]

Bonjour,

Personnellement, j'ai essayé des tonnes de bidouilles pour faire marcher scim sur kde, sans succès.
Puis, par curiosité, pour essayer d'autres environnements, j'ai installé Gnome en plus de KDE.
Gnome intègre par défaut, scim...Et du coup scim fonctionne aussi bien sur Gnome que sur KDE!
C'est un encouragement à essayer tous les environnement possibles...
J'ai ainsi continué avec Enlightenment, LXDE, Openbox.
Tout ça pour dire:

 sudo apt-get install gnome

Hors ligne

#3 Le 12/10/2009, à 12:19

tidjean

Re : kde4 scim [Resolu]

donc si j'install gnome, je pourrais utilisé scim sur mon kde4?


de:moi(tidjean)

Hors ligne

#4 Le 12/10/2009, à 13:18

Seren

Re : kde4 scim [Resolu]

tidjean a écrit :

donc si j'install gnome, je pourrais utilisé scim sur mon kde4?

J'avais réussi à installer skim/scim avec kde4 pour le chinois justement.

J'avais du modifier un fichier de conf.

Le problème c'est que si le chinois fonctionnait il y avait un bug pour le caractère "^" pour le français.

En gros systèmatiquement il affiche ^ directement, impossible de l'utiliser comme accent.

Par exemple : être --> ^etre


Il me semble que le tuto suivant en modifiant le fichier "scim" fonctionnait avec le problème déjà évoqué...:
(en anglais)

https://help.ubuntu.com/community/SCIM/Kubuntu

Je suis quasiment sûr que j'avais aussi modifier une variable d'environnement LANG ou LANGUAGE, mais j'arrive plus à retrouve le site...

Peut être ici :
http://ubuntuforums.org/archive/index.php/t-452018.html

Sachant que lang en_US soit être remplaçé par un truc du style fr_FR.

Dernière modification par Seren (Le 12/10/2009, à 15:51)


"I am not young enough to know everything". Oscar Wilde

Hors ligne

#5 Le 12/10/2009, à 18:50

Keiser

Re : kde4 scim [Resolu]

En effet tidjean, si tu installes gnome tu pourras utiliser scim sur Gnome ET Kde.
Maintenant, il y a sûrement d'autres solutions, comme ce que te propose Seren.
"C'est vous qui voyez!"

Hors ligne

#6 Le 13/10/2009, à 20:22

Seren

Re : kde4 scim [Resolu]

J'ai trouvé une alternative ( je suis sous karmic mais le paquet existe sous jaunty donc ça marche peut être)

Il y a un nouveau système qui remplace scim qui s'appelle ibus.

pour l'installer :

sudo apt-get install ibus ibus-pinyin

Modifier le .bashrc en rajoutant à la fin :

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

relancer la session.

Puis aller dans Menu > settings > ibus preferences
et ici sélectionner la méthode d'input "pinyin".

A priori ça doit aussi marcher pour le japonais, etc.. Par défaut on active désactive par ctrl+espace

再见

Dernière modification par Seren (Le 13/10/2009, à 20:28)


"I am not young enough to know everything". Oscar Wilde

Hors ligne

#7 Le 14/10/2009, à 09:22

tidjean

Re : kde4 scim [Resolu]

谢谢!!!! super sa marche nikel simple rapide et efficace. merci beaucoup a tous, pour vos réponses et surtout a seren pour la réponse miracle!!!

a plus
在天


de:moi(tidjean)

Hors ligne

#8 Le 14/10/2009, à 12:54

tidjean

Re : kde4 scim [Resolu]

j'ai parler un peu trop tot, cela fonctionne bien sur les appli gtk, mais les appli qt4 pas moyen, j'ai bien le paquet ibus-qt4 d'installer...

que faire que faire.
谢谢


de:moi(tidjean)

Hors ligne

#9 Le 14/10/2009, à 13:04

Seren

Re : kde4 scim [Resolu]

tidjean a écrit :

j'ai parler un peu trop tot, cela fonctionne bien sur les appli gtk, mais les appli qt4 pas moyen, j'ai bien le paquet ibus-qt4 d'installer...

que faire que faire.
谢谢

Normalement je dirais que cette ligne là
export QT_IM_MODULE=ibus

doit indiquer au système que pour les applis QT il peut utiliser ibus comme entrée.

J'avoue que j'ai testé que rapidement sur Firefox hier soir, je verrais ce soir si je trouve d'autres infos...

Dernière modification par Seren (Le 14/10/2009, à 13:05)


"I am not young enough to know everything". Oscar Wilde

Hors ligne

#10 Le 15/10/2009, à 07:31

tidjean

Re : kde4 scim [Resolu]

j'ai bien essayer la variable QT4_IM_MODULE=ibus mais sa ne fonctionne pas...


de:moi(tidjean)

Hors ligne

#11 Le 15/10/2009, à 20:35

Seren

Re : kde4 scim [Resolu]

Ok j'ai trouvé comment faire sur un autre forum...

Il faut aller dans

Menu > Settings > QT 4 settings

Là dans le tab "interface" tout en bas, il y a "defaut input" method.

Par défaut c'est "xim", il faut choisir ibus et ensuite ça fonctionne aussi dans les applis KDE.

Franchement c'était pas gagné comme installation à mon avis ça vaudrait le coup de le mettre dans la doc..

Par contre à chaque redemarrage, il faut faire un "ibus-daemon &" pour que le daemon ibus se lance.

C'est bizarre que ça soit pas automatique, mais si on veut vraiment que ça y soit, on peut le rajouter dans le /etc/rc.local (et rendre le fichier executable)

Il te reste plus qu'à mettre un [RESOLU] dans le titre de ton premier message. smile

Dernière modification par Seren (Le 15/10/2009, à 20:39)


"I am not young enough to know everything". Oscar Wilde

Hors ligne

#12 Le 16/10/2009, à 03:51

tidjean

Re : kde4 scim [Resolu]

super sa fonctionne merci seren!!! moi j'ai mis ibus-deamon au demarrage auto avec le system config de kde4...

voila donc 谢谢 在天!!!


de:moi(tidjean)

Hors ligne

#13 Le 08/11/2009, à 18:32

mondai

Re : kde4 scim [Resolu]

salut,

j'utilise aussi ibus, mais je n'arrivai toujours pas à mettre les accents circonflexes normalement.

Finalement, avec la touche compose j'ai réussi mais c'est un peu relou de pas pouvoir les mettre en faisant simplement ^ puis o (par ex).

j'ai bien mis ibus à la place de xim dans la partie "interface", à "default input method" dans Qt4 setting, mais ça n'a pas marché.

dans xinput.d, mon fichier ibus :

/etc/X11/xinit/xinput.d$ more ibus
XIM=ibus
XIM_PROGRAM=/usr/bin/ibus-daemon
XIM_ARGS="--xim"
if [ -e /usr/lib/gtk-2.0/*/immodules/im-ibus.so ]; then
    GTK_IM_MODULE=ibus
else
GTK_IM_MODULE=scim
   #GTK_IM_MODULE=xim
fi

if [ -e /usr/lib/qt4/plugins/inputmethods/libqtim-ibus.so ]; then
        QT_IM_MODULE=ibus
else
QT_IM_MODULE=scim
        #QT_IM_MODULE=xim
fi
DEPENDS="ibus, ibus-gtk, ibus-qt4"
# vim:ft=sh:

j'ai ibus qui se lance automatiquement à chaque session par contre, mais dans le doute j'ai quand même essayé au cas où ça changerait qqchose, mais non. J'ai "current session already has an ibus-daemon." qui est retourné.

donc voilà, si qqn aurait une idée...

Hors ligne

#14 Le 08/11/2009, à 18:36

mondai

Re : kde4 scim [Resolu]

une précision supplémentaire peut-être, pour la configuration de mon clavier :
setxkbmap -model pc104 -layout fr -variant oss

Hors ligne

#15 Le 09/11/2009, à 03:46

tidjean

Re : kde4 scim [Resolu]

salut

tout d'abord je ne sais pas si poster une question sur un post en résolu va t'aider. enfin pour ton probleme d'accent, normalement sa ne vient pas de ibus. pouvais tu les faire avant de lancer ton ibus-deamon?


de:moi(tidjean)

Hors ligne

#16 Le 09/11/2009, à 14:07

mondai

Re : kde4 scim [Resolu]

ah tiens, effectivement c'était pas à cause de ibus.
en cherchant sur le forum, qqn écrivait "j'ai trouvé un moyen pour que ça marche sous KDE4, tout en ayant les touches mortes (vous savez, l'accent circonflexe et autres) qui fonctionnent dans les programmes QT", dans le premier message, là : http://forum.ubuntu-fr.org/viewtopic.php?id=282754. Du coup j'avais pensé qu'il y avait un lien entre ce qui permet d'écrire et les accents circonflexes.

J'avais trouvé ça aussi : https://bugzilla.redhat.com/show_bug.cgi?id=468590#c19. Du coup, si ce n'est pas ibus ça serait le problème de permission....et du coup je suis hors sujet...hahaha...

bon, merci quand même en tout cas, et désolé pour mon erreur.

EDIT : je viens de retrouver l'autre sujet qui m'avait ammené à penser que ibus et le problèmes des accents circonflexes étaient liés : http://forum.ubuntu-fr.org/viewtopic.php?id=301268. Mais vu que j'ai pas ~/.xinput.d/, il était difficile d'aller jusqu'au bout de son "howto".

Dernière modification par mondai (Le 09/11/2009, à 14:16)

Hors ligne

Haut de page ↑