Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 18/10/2009, à 11:11

boogiewoogie

Problemes sur netbook Toshiba NB200-10Z

Bonjour,

Après quelques recherches il semble que nous sommes pas nombreux à installer Linux sur ce portable.

Les problèmes de compatibilité sont :

1 - Pas de son mais j'ai vu que dans le kernel 2.6.31.4 il y avait une correction donc j'attend ....

ALSA: hda - Added quirk to enable sound on Toshiba NB200

2 - Le disque dur se met régulièrement en pause ..... je suis obligé de bouger la souris régulièrement.
Est ce un problème d'ACPI ?
Si je ne bouge pas la souris au démarrage je peut avoir des plantages car le système veut écrire sur le disque et ne peut pas.

3 - Les touchse FN + F8 pour activer.déactiver le wifi ne fonctionnent pas.

C'est surtout le problème du disque dur qui est bloquant.

@+

Dernière modification par boogiewoogie (Le 31/10/2009, à 11:37)

Hors ligne

#2 Le 30/10/2009, à 18:38

bokit51

Re : Problemes sur netbook Toshiba NB200-10Z

Salut,

je te fais de fausse joie en te répondant, mais c'est pour te soutenir moralement.

J'ai le même problème.

Sur le forum de mandriva j'ai pu constater qu'ils avaient les mêmes soucis, à l'exception prêt:
Lorsque sous XP tu actives le wifi et que tu reboot sous notre OS favoris oh miracle ça marche...

Si on peut nous aider ça serait super sympa.

Dernière modification par bokit51 (Le 30/10/2009, à 18:58)

Hors ligne

#3 Le 30/10/2009, à 20:44

boogiewoogie

Re : Problemes sur netbook Toshiba NB200-10Z

Salut,

Je me sens moi seul maintenant !!!!

As tu essayé de désactiver l'ACPI ?

@+

Hors ligne

#4 Le 30/10/2009, à 23:49

lynn

Re : Problemes sur netbook Toshiba NB200-10Z

Bonsoir,

J'ai également ce pc mais je n'ai pas encore fait la bascule sur la 9.10. Je vous tiens informés si je rencontre ces mêmes difficultés et surtout si j'arrive à les éliminer wink


Linux est la solution ! Au fait, c'est quoi ton problème ?
Ubuntu 14.04 - 64 bits  -  Ubuntu 14.10 - 64 bits - Utopic Unicorn

Hors ligne

#5 Le 31/10/2009, à 00:19

bez856

Re : Problemes sur netbook Toshiba NB200-10Z

Bonsoir !!

Je viens d'acheter ce netbook ce soir et particulierement le NB200-10Z. Sans attendre je l'ai passé sous ubuntu et pour le moment aucun problème majeur à part le son qui ne marche pas mais j'ai vu quelque part une solution, si ça interesse quelqu'un je la posterais une fois retrouvée.

Sinon très content que mes touches Fn marchent du premier coup et pour moi le son n'est pas le plus important donc vraiment très heureux de mon achat !!

Hors ligne

#6 Le 31/10/2009, à 11:42

boogiewoogie

Re : Problemes sur netbook Toshiba NB200-10Z

bez856 a écrit :

Bonsoir !!

Je viens d'acheter ce netbook ce soir et particulierement le NB200-10Z. Sans attendre je l'ai passé sous ubuntu et pour le moment aucun problème majeur à part le son qui ne marche pas mais j'ai vu quelque part une solution, si ça interesse quelqu'un je la posterais une fois retrouvée.

Sinon très content que mes touches Fn marchent du premier coup et pour moi le son n'est pas le plus important donc vraiment très heureux de mon achat !!

Tu as la touche FN+F8 (wifi) qui fonctionne ???

Pour le son j'ai trouvé des infos sur la doc ubuntu mais rien n'a fonctionné.
edit /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=asus-mode4

J'ai essayé plein de model mais cela n'a rien donné.

sinon au niveau du disque dur tu n'as rien remarqué ?

Plus d'info ici
http://ubuntuforums.org/showthread.php?t=1215665

Pour ma part j'ai installé la beta de la 9.10 que j'ai mis à jour. Peut-être qu'il faudrait maintenant  que j'installe la version stable qui vient de sortir.
Je précise aussi que j'ai mis le bios à jour (version 1.6)

@+

Dernière modification par boogiewoogie (Le 31/10/2009, à 12:36)

Hors ligne

#7 Le 01/11/2009, à 20:48

bez856

Re : Problemes sur netbook Toshiba NB200-10Z

Salut booglewoogle !!

Alors non je n'ai pas Fn+F8 qui fonctionne ni le son avec les memes infos que j'avais vu que toi et même en mettant model=toshiba . . .

Le disque dur, pour ne pas avoir le moindre problème, il suffit que tu ailles dans les réglages du BIOS et tu mets "SATA mode" en Compatibilité au lieu de AHCI ou un truc comme ça . . .

Mais vraiment ce netbook marche extrèmement bien sous Ubuntu par rapport au XP Home que j'avais de base avec et personnellement je ne desactive pas le wifi, ou par Ubuntu et le son c'est juste ça qui m'embête un petit peu mais ça va bien réussir à se résoudre . . .

Bon courage

Bez856

Hors ligne

#8 Le 04/11/2009, à 11:01

bez856

Re : Problemes sur netbook Toshiba NB200-10Z

Je vois que ce topic n'est pas très actif mais je reviens quand même vers vous avec le son qui marche sur mon netbook NB200-10Z sous Karmic Koala.

Après avoir testé plusieurs solutions voici mes résultats :

1ère solution :
Ajouter dans "/etc/modprobe.d/alsa-base.conf" à la fin la ligne :

options snd-hda-intel model=asus-mode4

Cette technique marche pour avoir simplement le son dans les écouteurs mais pas dans les enceintes du PC.


2ème solution :
C'est une solution trouvée à cette page :
https://help.ubuntu.com/community/OpenSound

Elle consiste à enlever Pulseaudio et Alsa au profit de OSS4 qui reconnait notre carte son. Le défaut de cette technique c'est que, personnellement, je perds mon icône de son, je ne peux plus régler le son dans Système->Préférences->Son qui ne trouve plus ma carte . . .
J'ai donc bien le son dans mes enceintes intégrées mais pas pour toutes les applications et en plus je ne peux pas le régler . . . Admettons que c'est quand même un début et on se dit que nos enceintes ne sont pas encore mortes . . . big_smile



3ème solution :
Je pense qu'avec cette solution je vais faire pas mal d'heureux . . . He oui car maintenant mes enceintes marchent impeccable sur tous les sons et applications et en plus je peux continuer à régler mon volume avec mes touches Fn ou dans les préférences du son. Je n'ai pas encore testé si le son sortait aussi au casque ni que les enceintes se désactivent quand je branche un casque. Je testerai ça ce soir car pour le moment je suis au boulot.
Ah, je parle, je parle mais je vous ai pas encore dévoilé cette solution ? Elle arrive . . .

Cette solution est tirée de la page :
https://bugs.launchpad.net/ubuntu/+sour … bug/389040
et plus précisément de ce commentaire :
https://bugs.launchpad.net/ubuntu/+sour … mments/117
qui dit :

Hi Chris and Antonio,

Thanks again for the all the testing and quick feedback. I have one more Karmic image for you guys. Please test and let me know if the 4 test cases are OK or not. Thanks.

http://people.canonical.com/~ogasawara/lp389040/karmic/linux-image-2.6.31-10-generic_2.6.31-10.30~lp389040oga1_i386.deb

Alors le principe est "simple", du moins du côté utilisateur, car il suffit de télécharger le paquet cité plus haut :
http://people.canonical.com/~ogasawara/ … 1_i386.deb
De l'installer, de redémarrer, de choisir le bon kernel et le son IS BACK !!!!

Ce paquet est donc le noyau 2.6.31-10 avec des modifications apportées autour de ALSA.
Au moment où je vous écris, je ne me suis pas encore renseigné sur "Comment changer l'entrée par défaut dans GRUB" car je veins de le découvrir au passage que avec Karmic, Grub2 n'utilises plus de fichier "/boot/grub/menu.lst". J'éditerai dés que j'ai plus d'infos.

Donc pour en revenir au fonctionnement, une fois installé, redémarrez votre PC, au menu Grub, choisissez "Ubuntu, Linux 2.6.31-10-generic".

En espérant en avoir aidé certains.

Bez856

Dernière modification par bez856 (Le 04/11/2009, à 11:03)

Hors ligne

#9 Le 07/11/2009, à 13:33

Choobidou

Re : Problemes sur netbook Toshiba NB200-10Z

Hey !

"Je vois que ce topic n'est pas très actif"

Rien de très etonant... Autant rester sous windows que se prendre la tete pendant des heures sur linux, pour au final avoir un OS avec une logiteque bien pauvre, de nombreux bugs, une autonomie reduit, et un temps de boot horriblement long...

Enfin hormis ces "problemes minimes" impossible de suivre tes methodes, si tu pouvais m'aidez.

Pour la première, je n'ai pas l'autorisation yikes YOuhOu ! Je n'ai meme pas accés à mon PC, mais ce doit etre une des mes "habitudes windowsiennes" encore, et non une des inombrable incohérence de linux

Quand à la troisième, l'écran avec Grub ne ce lance pas sur Karmic... je fais comment pour selectionner mon noyau au boot ? je pris les dieux qu'ubuntu soit un jour un veritable OS fonctionnel ?

Sinon, si tu as une solution pour installer le nouveaux noyaux sur mandriva 2010 i586, je suis preneur, parce que la, une heure sur ubuntu pour essayé ta methode a suffit pour me degouté encore plus de linux que je ne le suis deja.

Enfin merci de ton aide et du travail que tu as posté, c'est deja énorme

Biz

Hors ligne

#10 Le 07/11/2009, à 14:11

michel_04

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour,

Choobidou a écrit :

Autant rester sous windows que se prendre la tete pendant des heures sur linux, pour au final avoir un OS avec une logiteque bien pauvre, de nombreux bugs, une autonomie reduit, et un temps de boot horriblement long...
~ ~~
et non une des inombrable incohérence de linux
~ ~~
je pris les dieux qu'ubuntu soit un jour un veritable OS fonctionnel ?
~ ~ ~
une heure sur ubuntu pour essayé ta methode a suffit pour me degouté encore plus de linux que je ne le suis deja.

Je viens de regarder tes posts ...
À lire ... :

http://doc.ubuntu-fr.org/#documentation_hors_ligne
http://www.delafond.org/survielinux/

A+

Hors ligne

#11 Le 16/11/2009, à 23:05

adamforever1979

Re : Problemes sur netbook Toshiba NB200-10Z

bonjour bez856
y a t il de nouvelle

merci pour nous informer

Hors ligne

#12 Le 27/11/2009, à 17:23

Tetsuo6995

Re : Problemes sur netbook Toshiba NB200-10Z

Bon je ressuscite ce post étant donné que mon problème en est très proche.

Jusqu'à aujourd'hui j'utilisais le "noyau 2.6.31-10 avec des modifications apportées autour de ALSA" dont bez856 parlait.
J'étais très satisfait de ce noyau sauf pour un petit détail.
Le wifi était très instable et avait de grosse difficulté a se connecter sur certaine AP.
On m'a donc conseillé d'activer les backports. Une fois cela fait un nouveau noyau 2.6.31-15-generic a été installer. Du coup le wifi semble maintenant très stable et la réception aussi bonne que sur windows ce qui est une grosse avancé.

Ma question est donc :

Est-il possible de modifier mes drivers ALSA pour être compatible avec les enceintes de mon Netbook tout en restant sur le noyau 2.6.31-15-generic ?

Merci d'avance smile
J'espère que ce topic restera vivant afin de permettre aux quelques utilisateurs de NB200 sous Ubuntu leurs dernières découvertes/solutions/astuces !

Hors ligne

#13 Le 08/12/2009, à 00:10

sylvere

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour

Je viens de mettre mon Beau-père sous 9.10 Remix (version stable téléchargée) il a acheté un Toshiba NB200

Je constate 2 problèmes :

1°) Le son

j'ai bidouillé avec ce que vous avez ecris plus haut, et il a maintenant le son dans le casque mais pas dans les enceintes... j'hesite à faire la modif n°3 car le kernel est plus recent...

Question est-ce la manipe marche avec le dernier kernel? Est-ce qu'elle perdure quand on upgrade le kernel? (non a priori?)

2°) C'est super lent au démarrage 10 minutes!!!  (mon EEEPC démarre en 16s (Message log))

je vous mets un extrait de son message log
....
...
Nov 27 22:00:01 kernel: [   21.887034] usbcore: registered new interface driver usbhid
Nov 27 22:00:01 kernel: [   21.887046] usbhid: v2.6:USB HID core driver
Nov 27 22:01:07 kernel: [   88.333874] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Nov 27 22:01:21 kernel: [  101.760120] usb 1-8: new high speed USB device using ehci_hcd and address 4
....
...
Nov 27 22:01:26 kernel: [  107.015346] sd 6:0:0:0: [sdb] Attached SCSI removable disk
Nov 27 22:02:49 kernel: [  189.949068] usb 1-8: USB disconnect, address 4
Nov 27 22:02:57 kernel: [  198.171624] sd 7:0:0:0: [sdb] Attached SCSI removable disk
Nov 27 22:03:17 kernel: [  218.426942] usb 1-8: USB disconnect, address 5
Nov 27 22:10:57 kernel: [  678.156123] usb 1-8: new high speed USB device using ehci_hcd and address 6

Est-ce que quelqu'un pourrait m'aider à comprendre ce qui ce passe ?

merci de votre aide

Sylvere

Hors ligne

#14 Le 08/12/2009, à 12:35

Tetsuo6995

Re : Problemes sur netbook Toshiba NB200-10Z

Je suis surpris que le "noyau 2.6.31-10 avec des modifications apportées autour de ALSA" ne résout pas ton probème de son... Ca a très bien marché sur mon NB200 hmm
Es-tu sûr de bien avoir sélectionner le bon noyau au démarrage ?
As-tu bien installer le noyau -10 à l'aide du .deb donné sur un lien plus haut?

Pour ton problème de boot hyper long:
Tu peux peut-être débrancher tout périphérique USB connecté dessus. Si cela ne change rien alors ca doit être un problème de reconnaissance d'un périphérique interne je suppose...
Je suis peut être a des années lumières de la solution mais tu peux aussi essayer de passer ton BIOS en mode compatibilité pour le SATA ? Je sais que mon PC est réglé comme ça et le boot est normal chez moi.

Voilà quelques pistes smile
C'est mieux que rien j'espère !!

PS: Ca a probablement rien à voir mais il faut activer le wifi dans Windows avant de démarrer Ubuntu. Qui sait peut-être que ton poste éprouve des difficultés a détecter la carte Wifi ??

Dernière modification par Tetsuo6995 (Le 08/12/2009, à 12:50)

Hors ligne

#15 Le 10/12/2009, à 02:04

sylvere

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour


En fait j'ai pas installé le noyau 31.10... Je vais tenté l'expérience dès qu'il rentre de vacances.
Et je vais suivre ton conseil sur le mode sata.

y a pas de raison, si ca marche toi, ca doit marcher sur le sien.

Je mettrai le résultat sur le forum

Merci pour ta réponse,

Sylvère

Dernière modification par sylvere (Le 10/12/2009, à 02:06)

Hors ligne

#16 Le 10/12/2009, à 18:35

Tetsuo6995

Re : Problemes sur netbook Toshiba NB200-10Z

Garde bien évidemment les autres noyaux sous la main.
Parce que j'ai eu pas mal de problème de wifi avec le -10.
Bref je doute que ce soit un exemple de stabilité !
Mais bon il faut attendre que le bug soit résolu proprement : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/438318

Hors ligne

#17 Le 03/01/2010, à 13:55

sylvere

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour

merci Tetsuo6995

J'ai mis mode sata compatibilité dans le bios, et là plus de pb de démarrage lent (46s) ce qui est tres bien.

Pour le son, le kernel 31.10 n'est pas installé sur ce PC, le plus ancien est le 31.14, donc la manipe sur le kernel 31.10 ne peux pas marché. De plus l'instabilité du wifi sur le kernel 31.10 ne m'incite pas a utiliser ce kernel. Il semble que le hernel 32.2 résout le pb. Donc comme ce pb de son reste mineure par rapport aux autres améliorations (notamment du wifi) . Je vais attendre que la solution soit integrée dans le prochain kernel.

Merci à tous pour vos contributions

Sylvere

Hors ligne

#18 Le 26/01/2010, à 11:27

sylvere

Re : Problemes sur netbook Toshiba NB200-10Z

bonjour

Je viens de faire la mise à jour 31.17 du kernel .... le son ne marche toujours pas sauf dans les ecouteurs avec
la modif "asus-mod" dans l'alsa.conf

J'ai remis la ligne initial a la place de alsa.conf rien ni fait

Dois-je mettre autre chose que asus-mod ? est-ce que ca marche chez vous? avec le 31.17?

merci

Hors ligne

#19 Le 28/01/2010, à 22:20

Bristow

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour, pour info, ce nouveau noyau fait fonctionner le son : http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32.2/

En revanche, je n'ai pas poussé plus loin les tests wink


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org
Ubuntu 14.04 LTS x86_64 avec Unity

Hors ligne

#20 Le 06/03/2010, à 10:20

boogiewoogie

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour,

Sur le NB200-10Z pour les problèmes de lenteur ou d'arrêt du disque dur j'ai modifié le bios.
Dans Avancés - Mode de contrôleur SATA j'ai mis [Compatibility] au lieu de [AHCI].
Depuis cette modif et la 9.10 à jour j'ai plus de problème.

Pour le son des HP je cherche plus la solution mais je pense qu'avec la prochaine version le problème sera résolu (dans le noyau 2.6.32 j'ai vu pas mal de modif au niveau du son). Reste pas longtemps à attendre ....

Au final le NB200-10Z est un très bon portable et Ubuntu tourne très très bien dessus.

Dernière modification par boogiewoogie (Le 06/03/2010, à 10:21)

Hors ligne

#21 Le 25/04/2010, à 15:46

Bristow

Re : Problemes sur netbook Toshiba NB200-10Z

Je viens d'installer (ou plutôt de migrer) Lucid (Ubuntu 10.04) en version RC et Netbook Remix. -> c'est super beau smile

Pour le son, c'est toujours pareil, il faut ajouter la ligne :

options snd-hda-intel index=0 model=auto

dans le fichier /etc/modprobe.d/alsa-base.conf

Le son sera actif dans les écouteurs et les enceintes au redémarrage.

Par contre, je ne sais toujours pas pour couper le wifi...


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org
Ubuntu 14.04 LTS x86_64 avec Unity

Hors ligne

#22 Le 02/05/2010, à 21:10

boogiewoogie

Re : Problemes sur netbook Toshiba NB200-10Z

Bonjour,

Idem pour moi le son fonctionne maintenant sur le HP en rajoutant le code que tu cites.

@+

Dernière modification par boogiewoogie (Le 02/05/2010, à 21:10)

Hors ligne

#23 Le 03/05/2010, à 16:38

Tetsuo6995

Re : Problemes sur netbook Toshiba NB200-10Z

Bristow a écrit :

Je viens d'installer (ou plutôt de migrer) Lucid (Ubuntu 10.04) en version RC et Netbook Remix. -> c'est super beau smile

Pour le son, c'est toujours pareil, il faut ajouter la ligne :

options snd-hda-intel index=0 model=auto

dans le fichier /etc/modprobe.d/alsa-base.conf

Le son sera actif dans les écouteurs et les enceintes au redémarrage.

Par contre, je ne sais toujours pas pour couper le wifi...

Attention on n'a plus le droit d'appeller ça un remix smile
Maintenant c'est Ubuntu Netbook Edition (UNE) wink

Concernant ce petit patch maison. Pourquoi alors qu'il suffit simplement d'ajouté une ligne à une fichier de configuration, cela n'a pas été inclue dans Lucid Lynx ? Ça fait une éternité qu'on connaît l'astuce et pourtant... 

Pour le wifi : Bouton droit sur l'applet wifi et décocher "Activer le réseau sans fil" ?
Ok ca n'éteint pas la carte wifi, mais au moins ca ne l'utilise plus.
C'est mieux que rien !

Hors ligne

#24 Le 07/05/2010, à 04:28

Frezi

Re : Problemes sur netbook Toshiba NB200-10Z

J'ai aussi un NB200 mais pas le 10Z mais un 10G sur qui j'aimerai mettre ubuntu netbook surtout la 10.04 qui me permettra d'être à laisse un moment. Je suppose que les petit soucis doivent être identique ? Pour le son comme j'utilise de haut parleur externe par la prise casque, si ta solution fonctionne, ça me va mais dans la liste des portables Toshiba, j'ai vu pour un NB200 :

Le système de partitionnement d'Ubuntu peut corrompre le MBR et la partition Windows, il est préférable de faire ses partitions avec un autre utilitaire et de ne pas installer GRUB sur le MBR.

As-tu aussi rencontré le même soucis en installent la 10.04 sur ton 10Z ?


Mageia - Ubuntu 11.10 (Laptop)
Meego (Netbook)

Hors ligne

#25 Le 07/05/2010, à 09:58

Tetsuo6995

Re : Problemes sur netbook Toshiba NB200-10Z

Frezi a écrit :

J'ai aussi un NB200 mais pas le 10Z mais un 10G sur qui j'aimerai mettre ubuntu netbook surtout la 10.04 qui me permettra d'être à laisse un moment. Je suppose que les petit soucis doivent être identique ? Pour le son comme j'utilise de haut parleur externe par la prise casque, si ta solution fonctionne, ça me va mais dans la liste des portables Toshiba, j'ai vu pour un NB200 :

Le système de partitionnement d'Ubuntu peut corrompre le MBR et la partition Windows, il est préférable de faire ses partitions avec un autre utilitaire et de ne pas installer GRUB sur le MBR.

As-tu aussi rencontré le même soucis en installent la 10.04 sur ton 10Z ?

Pour moi ce que tu cites n'a aucun sens mais bon après je peux me tromper.
J'ai GRUB sur mon 10Z depuis que je l'ai acheté et ma partition windows se sent toujours très bien (même si je ne m'en sers jamais). D'ailleurs je viens de re-installer toute ma partition "/" pour passer sur lucid lynx et GRUB a correctement ajouté la partition windows sans le moindre soucis.
Et franchement j'ai plus confiance en Gparted qu'en tout autre outil de partitionnement.

A ta place je ferais une petite install de la 10.04 via Wubi pendant quelques jours. Si tout semble correcte tu fais une install en dur et je suis sûr que tout ira bien. Le tout c'est de bien activer le wifi sous windows avant toute install d'Ubuntu.

Hors ligne

Haut de page ↑