Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 02/11/2009, à 19:12

Inceptor

Problème webcam Skype avec ubuntu 9.10 [RESOLU]

Bonjour à tous,

J'essaie de faire fonctionner ma webcam sur Skype avec ubuntu 9.10, le problème est que mon image est verte avec des lignes mais je me vois quand même un peu! Ce n'est pas la même erreur que celle qui est décrite ici:

http://forum.ubuntu-fr.org/viewtopic.php?id=264606

La solution de marcdima fonctionne un peu mais pas suffisamment, je m'explique: Au début j'avais rien du tout comme image, j'ai suivi la solution et maintenant je me vois un peu mais a double et tout reste très vert (inutiliable)

En cherchant un peu, j ai remarquer que la solution faisait intervenir v4l comme librairie pour la caméra mais si je vais dans gstreamer-properties ma caméra ne fonctionne pas avec v4l (l'image est verte) tandis qu'elle fonctionne avec v4l2.

J'ai essayer plusieurs solution pour charger cette librairie a la place mais rien ne marche, j'ai comme librairie dans mes dossiers:
usr/lib/libv4l/v4l1compat.so
usr/lib/libv4l/v4l2convert.so
usr/lib/libv4l1.so.0
usr/lib/libv4l2.so.0
usr/lib/libv4lconvert.so.0

Je suppose que les "convert" doivent être la solution à mes problèmes, je pense en effet que je charge la mauvaise librairies en lançant skype... (En passant, c'est quoi les libs avec des .0 à la fin?)

J'ai essayé plusieurs solution dont par exemple : (ci-dessous le texte du script lancé automatiquement, voir solution marcdima)

#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so:/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

Encore une chose, ma webcam est : ID 093a:2621 Pixart Imaging, Inc.

Voila, donc je demande votre aide...

Merci d'avance!

Inceptor

Dernière modification par Inceptor (Le 05/11/2009, à 22:30)

Hors ligne

#2 Le 03/11/2009, à 13:24

Inceptor

Re : Problème webcam Skype avec ubuntu 9.10 [RESOLU]

Est-ce que quelqu'un à une idée ?

Merci d'avance

Hors ligne

#3 Le 03/11/2009, à 18:20

georosen

Re : Problème webcam Skype avec ubuntu 9.10 [RESOLU]

Salut, Inceptor

Peut être une piste en utilisant le dépôt medinbuntu
Regardes par là: --->  http://forum.ubuntu-fr.org/viewtopic.php?id=349223

Peut être ... !!

A+  wink

Gt


Ubuntu 10.4
Bonjour, au revoir, merci, ne sont pas des mots interdits.
On peut aussi bâtir quelque chose de beau avec les pierres qui entravent le chemin.

Hors ligne

#4 Le 05/11/2009, à 10:11

Inceptor

Re : Problème webcam Skype avec ubuntu 9.10 [RESOLU]

Hello,

J'ai essayer d'installer skype depuis les dépôt medibuntu mais le problème reste le même... Je pense que je vais pas trouver de solution simple à mon problème, ce qui me laisse deux options:

La première serait de lancer un programme qui "grab" des images et les enregistres dans un dossier suivit d'un programme qui simule une webcam depuis là! Peut-être que ça marcherai, mais je sais pas du tout quel programme utilisé pour simuler une caméra!

L'autre solution c'est de me faire un machine virtuelle avec windows intégrée... C'est moin fun mais au moins j'aurai une solution en cas d'autre problème!

Moi qui ai installer linux il y a qq jour pour ne plus avoir de problème avec mon OS! Ail ail ail...

Voila, je te remercie de ta réponse!

Inceptor

Dernière modification par Inceptor (Le 05/11/2009, à 21:36)

Hors ligne

#5 Le 05/11/2009, à 22:29

Inceptor

Re : Problème webcam Skype avec ubuntu 9.10 [RESOLU]

Salut a tous,

J'ai trouver la solution à mon problème :-D

Mon problème était que ma caméra avait une résolution de 640x480 et que ce n'est pas réglé comme ça de base dans skype! D'ou très logiquement mon problème de "superposition"

Il vous faut aller dans le fichier /home/<user name>/.Skype/<Skype user name>/config.xml

et ajouter les lignes:

<Video>
    <CaptureHeight>480</CaptureHeight>
    <CaptureWidth>640</CaptureWidth>
    <RecvPolicy>callpolicy</RecvPolicy>
</Video>

Et magie... Ca marche!!!

Bonne fin de journée à tous :-D

Hors ligne

Haut de page ↑