Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 09/11/2009, à 15:26

Nadjibs

[résolu]Clique gauche Impossible !!!!!!

bonjour a tous ;

voila j'ai ubuntu 9.10 ....et depuis hier je ne peut plus faire de clique gauche avec ma souris ni avec mon touchpad ....c'est la galére ...
en faite hier soir j'étais entrain de tripoté sur compizconfig que j'ai eu ce probléme .....mais quand j'ai desinstaller compiz tjrs le méme blém !!!


si quelqu'un a une solution ....!!

Dernière modification par Nadjibs (Le 10/11/2009, à 16:02)

Hors ligne

#2 Le 09/11/2009, à 15:56

jmlaguiness

Re : [résolu]Clique gauche Impossible !!!!!!

Hello.

A tout hasard, "Système">"Préférences">"Souris" ?

Hors ligne

#3 Le 09/11/2009, à 16:43

Nadjibs

Re : [résolu]Clique gauche Impossible !!!!!!

non, j'ai essayé mais toujours le méme blém !!

Hors ligne

#4 Le 09/11/2009, à 18:42

indiana tux

Re : [résolu]Clique gauche Impossible !!!!!!

Salut, je sais qu'il y a un problème de touchpad avec certaines marques : acer, dell, nec et j'en oublie.
Cela peut provoquer des comportements "étranges".

Si c'est le cas, tu peux tenter d'ajouter une ou deux options à ton kernel, si tu as Karmic Koala, il te faut éditer le fichier /etc/default/grub

sudo nano /etc/default/grub

Puis modifier la ligne :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

en ajoutant i8042.nomux, voir i8024.reset=1 (uniquement si avec nomux cela ne fonctionne pas)

comme ceci :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux i8042.reset=1"

ensuite tu lance un :

sudo update-grub2

et tu redémarre

Dernière modification par indiana tux (Le 09/11/2009, à 18:44)


Si tu es prêt à sacrifier un peu de liberté pour te sentir en sécurité, tu ne mérites ni l’une ni l’autre. (Jefferson)

Défendez le libre, adhérez à l'april http://www.april.org
Aidez la quadrature du net : http://www.laquadrature.net/Soutien2010

Hors ligne

#5 Le 10/11/2009, à 10:21

Nadjibs

Re : [résolu]Clique gauche Impossible !!!!!!

non , non ..sa na rien avoir le touchpad ...ca n a rien de hard ...puisque avant de rentré dans ma séssion ...la sourie et le touchpad marche parfaitement ..une fois que je tape mon mot de passe ...le clique gauche ne marche plus !!

Hors ligne

#6 Le 10/11/2009, à 15:48

Nadjibs

Re : [résolu]Clique gauche Impossible !!!!!!

up

Hors ligne

#7 Le 10/11/2009, à 15:58

Nadjibs

Re : [résolu]Clique gauche Impossible !!!!!!

c'est bon j'ai pu réglé mon probléme !!

Bouton droit de la souris»»effets visuels»»choisir aucun effets .....pour moi le probléme a étais reglé !! mais pour ceux qui n'arrive toujours pas reglé le blém voila la solution que j'ai trouvé :

I've just experienced the same problem, but i found a way to get it functioning again without any other problems. Im gonna tell the steps how i did it successfully. BTW im running jaunty (9.04)

    1. Right click on desktop --> Change desktop background(you can press enter to open it) --> Visual effects tab(use the arrows to move betwen tabs)
    2. select none (to activate it), to select none while having your left click not functioning, press the right clock on the "NONE: ..." then hit the space key (keyboard)

Now try using the left click, It should work now (that what happened with me), If it doesnt work make sure that "None" is selected, if still doesnt work then sorry but i think you have a different problem. If it worked continue...

Now What I realized is that this problem arises from using "Compiz Fusion Desktop Effects". so now if you want to use the "normal" option from "visual effects tab" hopefully it'll work out of the box, the "extra option" might work, not sure. anyhow if you want to use the "Compiz Fusion Desktop Effects" continue.


    3. after selecting the "none" option goto "system"-->"preferences"-->"compiz desktop effects"

What actually happening (left click not functioning)is that -from what i read in this thread- the left click is held down automatically, and by that i can say that one of the options in "Compiz desktop effects" is making the problem.

    4. Now make sure that none of the effects that you use has [Button1] as its shortcut key. I had the problem within the "Effects" section, in "paint fire on screen" so i entered it by clicking on it(not by checking/unchecking the box) and removed the [button1] by clicking on the brush icon.

any by that it was solved

    5. open your visual effects tab (Right click on desktop --> Change desktop background --> Visual effects tab) and select "custom or extra" and apply your "compiz desktop effects" if it didn't apply automatically

I hope this helps you getting over your problem.

Hors ligne

#8 Le 19/11/2009, à 20:55

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

indiana tux a écrit :

Salut, je sais qu'il y a un problème de touchpad avec certaines marques : acer, dell, nec et j'en oublie.
Cela peut provoquer des comportements "étranges".

Si c'est le cas, tu peux tenter d'ajouter une ou deux options à ton kernel, si tu as Karmic Koala, il te faut éditer le fichier /etc/default/grub

sudo nano /etc/default/grub

Puis modifier la ligne :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

en ajoutant i8042.nomux, voir i8024.reset=1 (uniquement si avec nomux cela ne fonctionne pas)

comme ceci :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux i8042.reset=1"

ensuite tu lance un :

sudo update-grub2

et tu redémarre

Salut indiana tux
merci pour cette info. Je voudrais savoir si c'est une méthode suffisamment fiable pour la mettre dans la Doc (http://doc.ubuntu-fr.org/touchpad#probleme_du_touchpad_fou). As-tu testé? D'où tires-tu l'info stp?

Au fait il y a un truc qui me parait bizarre: dans "quiet splash i8042.nomux i8042.reset=1" c'est normal que tu aies a la fois nomux et reset ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#9 Le 23/11/2009, à 15:12

indiana tux

Re : [résolu]Clique gauche Impossible !!!!!!

Yannubutnu a écrit :

Salut indiana tux
merci pour cette info. Je voudrais savoir si c'est une méthode suffisamment fiable pour la mettre dans la Doc (http://doc.ubuntu-fr.org/touchpad#probl … uchpad_fou). As-tu testé? D'où tires-tu l'info stp?

Au fait il y a un truc qui me parait bizarre: dans "quiet splash i8042.nomux i8042.reset=1" c'est normal que tu aies a la fois nomux et reset ?

Salut,
Cela peut paraitre bizarre, mais pour mon "touchpad fou" (j' ai un acer aspire 5310), c'est la seule combinaison qui ait eu un résultat, et je peut te dire que j'ai cherché et tenté toutes sortes de possibilitées. Si je ne met que nomux, ou que le reset, cela ne marche pas, il faut obligatoirement d'abord nomux puis le reset... Je pense qu'il s'agit d'un bug.

Pour la source : je m'étais aidé de ça : http://lkml.indiana.edu/hypermail/linux/kernel/0401.0/0436.html qui donne les options du driver i8042

et en recherchant de l'info sur le reset, cette page à été ma solution : http://forum.vectorlinux.com/index.php?topic=8964.0 sauf qu'il a fallut que je supprime le "=1" de i8042.nomux=1 pour que cela marche.

Dernière modification par indiana tux (Le 23/11/2009, à 15:30)


Si tu es prêt à sacrifier un peu de liberté pour te sentir en sécurité, tu ne mérites ni l’une ni l’autre. (Jefferson)

Défendez le libre, adhérez à l'april http://www.april.org
Aidez la quadrature du net : http://www.laquadrature.net/Soutien2010

Hors ligne

#10 Le 04/12/2009, à 16:30

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

salut
question pour info: tu indiques "update-grub2", mais dans la doc (http://doc.ubuntu-fr.org/grub-pc) il est indiqué de faire "update-grub". Quelle est la différence ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#11 Le 04/12/2009, à 21:35

indiana tux

Re : [résolu]Clique gauche Impossible !!!!!!

YannUbuntu a écrit :

salut
question pour info: tu indiques "update-grub2", mais dans la doc (http://doc.ubuntu-fr.org/grub-pc) il est indiqué de faire "update-grub". Quelle est la différence ?

En fait, les 2 marchent... le update-grub2 est plus spécifique à grub2, c'est tout, en vrai il n'y a pas de différences (pour le moment)

EDIT : j'ai retrouvé la source de mon update-grub2 ici , dans la doc de grub :

Utilisez les commandes update-grub2 ou grub-mkconfig pour regénérez le menu de GRUB 2 après chaque modification des fichiers de configuration.

Dernière modification par indiana tux (Le 05/12/2009, à 01:42)


Si tu es prêt à sacrifier un peu de liberté pour te sentir en sécurité, tu ne mérites ni l’une ni l’autre. (Jefferson)

Défendez le libre, adhérez à l'april http://www.april.org
Aidez la quadrature du net : http://www.laquadrature.net/Soutien2010

Hors ligne

#12 Le 07/12/2009, à 18:47

Valezan

Re : [résolu]Clique gauche Impossible !!!!!!

Bonjour,
Je rencontre parfois ce problème de "touchpad fou" sur un Toshiba Sattelite P300, je voulais donc suivre les recommandations d'indiana tux mais voilà...

Si c'est le cas, tu peux tenter d'ajouter une ou deux options à ton kernel, si tu as Karmic Koala, il te faut éditer le fichier /etc/default/grub

le fichier /etc/default/grub n'existe pas (et j'utilise bien Karmic tongue)
Dois-je le créer ?
Cordialement

Hors ligne

#13 Le 08/12/2009, à 04:30

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

@indianatux : ok, merci pour l'info ! Je viens d'ajouter i8042.nomux a mon /etc/default/grub , et je n'ai pas revu le bug jusqu'à maintenant...

@Valezan: on dirait que tu n'as pas d'autre choix que d'essayer. Fais des sauves, et suis les instructions de la Doc http://doc.ubuntu-fr.org/grub-pc#restaurer_grub-pc


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#14 Le 08/12/2009, à 08:46

Valezan

Re : [résolu]Clique gauche Impossible !!!!!!

Merci YannUbuntu.

Hors ligne

#15 Le 29/03/2010, à 19:53

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

tiens au fait, il semble que "i8042.nomux=1" ait le meme effet que "i8042.nomux" ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#16 Le 10/01/2011, à 21:35

Mehdinefrance

Re : [résolu]Clique gauche Impossible !!!!!!

Bonjour à tous,

Petite question à ce sujet :
La manip' fonctionne-t-elle également sous Ubuntu 10.10 ? car j'ai le même bug avec un portable MSI VR 630...

Hors ligne

#17 Le 11/01/2011, à 09:50

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

chez moi oui. (Ubuntu 10.10) j'utilise i8042.nomux=1


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#18 Le 11/01/2011, à 21:09

Mehdinefrance

Re : [résolu]Clique gauche Impossible !!!!!!

oups, je lance l'éditeur de fichier nano et voilà ce que j'obtiens :

GNU nano 2.2.4      Fichier : /etc/default/grub
_


Aide  Ecrire  Lire fich.  Page préc.  Couper  Pos. cur.
Quitter Justifier Chercher Page suiv. Coller  Orthograp.

Le tiret clignote mais le fichier ne semble contenir aucune ligne.

Cela veut-il dire que je suis dans le même cas que Valezan et que je dois réinstaller GRUB ?

Autre paramètre depuis hier : les clics gauche de ma souris ET de mon trackpad refusent désormais totalement de fonctionner, même après plusieurs redémarrages...

J'espère que je suis au bon endroit pour trouver la solution à ce problème !

hmm

Hors ligne

#19 Le 12/01/2011, à 03:39

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

Salut
concernant GRUB, as-tu migré sucessivement depuis Ubuntu 9.04 -> 9.10 -> 10.04 -> 10.10 ?  si oui tu as encore GRUB1 (Legacy), et donc il est normal que ton /etc/default/grub soit vide.
Sinon, il y a un soucis, et tu peux réinstaller GRUB via http://doc.ubuntu-fr.org/tutoriel/comme … aurer_grub

Ensuite, voir http://doc.ubuntu-fr.org/touchpad#pointeur_fou


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#20 Le 13/01/2011, à 23:51

indiana tux

Re : [résolu]Clique gauche Impossible !!!!!!

Oui, ou tout simplement éditer le grub 1

sudo nano /boot/grub/menu.lst

Si je me souviens bien et rajouter le i8042.... à la fin de la ligne de boot.

Dernière modification par indiana tux (Le 13/01/2011, à 23:52)


Si tu es prêt à sacrifier un peu de liberté pour te sentir en sécurité, tu ne mérites ni l’une ni l’autre. (Jefferson)

Défendez le libre, adhérez à l'april http://www.april.org
Aidez la quadrature du net : http://www.laquadrature.net/Soutien2010

Hors ligne

#21 Le 21/01/2011, à 20:37

Mehdinefrance

Re : [résolu]Clique gauche Impossible !!!!!!

Merci YannUbuntu & indiana tux pour vos précisions, elles m'ont permis d'éditer le fichier et rajouter "i8042.nomux" (essai infructueux) puis "i8042.nomux i8024.reset=1" à la fin de la ligne de boot...

Mise à jour du Grub et redémarrage, tout marche, je commence à y croire, je vais sur Firefox, Thunderbird... peaufine mes paramètres utilisateurs... bref je commence à me sentir à l'aise, et puis, fatal error kernel panic : je lance Skype et voilatipa que mon clic gauche cesse instantanément de fonctionner !!!

Je redémarre pour oublier tout ça, le clic gauche fonctionne parfaitement, je lance Skype : tout semble marcher, mais cette fois c'est lorsque je lance Firefox que mon clic gauche arrête de répondre...

Je ne comprends plus... avez-vous d'autres pistes ?

Merci encore de votre aide

Hors ligne

#22 Le 23/01/2011, à 19:36

Mehdinefrance

Re : [résolu]Clique gauche Impossible !!!!!!

bonjour, je m'aperçois que mon dernier message n'est pas très précis... je reprends :
ne sachant pas comment éditer le fichier

sudo nano /etc/default/grub

car ce dernier est vide, j'ai suivi la recommandation du dernier post d'indiana tux d'éditer le fichier grub en tapant la commande

sudo nano /boot/grub/menu.lst

le menu m'apparait alors avec les différents boots de mon ordi :
[*]Ubuntu 10.10, kernel 2.6.35-24-generic
Ubuntu 10.10, kernel 2.6.35-24-generic (recovery mode)
Ubuntu 10.10, kernel 2.6.32-27-generic
Ubuntu 10.10, kernel 2.6.32-27-generic (recovery mode)
Ubuntu 10.10, kernel 2.6.31-22-generic
Ubuntu 10.10, kernel 2.6.31-22-generic (recovery mode)
Ubuntu 10.10, kernel 2.6.27-9-generic
Ubuntu 10.10, kernel 2.6.27-9-generic (recovery mode)
Ubuntu 10.10, memtest86+[/*]
Other operating systems :
[*]Windows Vista/Longhorn (loader)[/*]

J'ai modifié la ligne kernel du premier titre ainsi :
/boot/vmlinuz-2.6.35-24-generic root=UUID=off41d4b-d069-4351-be4e-575f7d5da4a6 ro quiet splash i8042.nomux i8042.reset=1

Est-ce bien la manip' proposée ? ou le fait que je sois novice en Linux m'aura fait me tromper ?

Autre précision, lorsque je mets à jour le fichier grub, l'image splash n'est pas trouvée :

Searching for splash image ... none found, skipping ...

Merci d'avance pour votre aide :-)

Hors ligne

#23 Le 24/01/2011, à 09:07

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

Mehdinefrance a écrit :

Merci YannUbuntu & indiana tux pour vos précisions, elles m'ont permis d'éditer le fichier et rajouter "i8042.nomux" (essai infructueux) puis "i8042.nomux i8024.reset=1" à la fin de la ligne de boot...

Mise à jour du Grub et redémarrage, tout marche, je commence à y croire, je vais sur Firefox, Thunderbird... peaufine mes paramètres utilisateurs... bref je commence à me sentir à l'aise, et puis, fatal error kernel panic : je lance Skype et voilatipa que mon clic gauche cesse instantanément de fonctionner !!!

Je redémarre pour oublier tout ça, le clic gauche fonctionne parfaitement, je lance Skype : tout semble marcher, mais cette fois c'est lorsque je lance Firefox que mon clic gauche arrête de répondre...

A mon avis si le problème de souris se reproduit malgré "i8042.nomux" , et malgré "i8042.nomux i8024.reset=1" , c'est que ce ne sont pas les solutions adéquates.
Au cas ou, essaye :

i8042.nomux=1 i8042.reset=1

comme indiqué ici

Dernière modification par YannUbuntu (Le 24/01/2011, à 09:08)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 24/01/2011, à 17:29

Mehdinefrance

Re : [résolu]Clique gauche Impossible !!!!!!

Merci Yannubuntu, je viens d'essayer avec

i8042.nomux=1 i8042.reset=1

sans plus de succès.

Je renonce. Ca ne marche pas avec mon ordi. sad

Je vais sauvegarder mon /home et réinstaller Ubuntu 9.10 car tout marchait avant la mise à niveau...

En tout cas, merci de votre patience.

Mehdinefrance

Hors ligne

#25 Le 25/01/2011, à 03:58

YannUbuntu

Re : [résolu]Clique gauche Impossible !!!!!!

Attention : Ubuntu 9.10 ne sera plus supportée dans 3 mois, donc de préférence réinstalle Ubuntu 10.04 LTS, qui sera supportée jusqu'en avril 2013 smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

Haut de page ↑