Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/10/2009, à 22:38

spacepirate

Gestion son sous Karmic

Bonjour à tous,

J'ai un petit soucis au niveau de ma gestion du son.

En effet, lorsque que je branche mon casque dans la prise casque j'ai encore du son dans les enceintes.

Sous Jaunty j'avais une case headphones à cocher mais sous karmic la gestion est differente.

Avez vous une idée pour palier au probleme ?

Merci

Hors ligne

#2 Le 30/10/2009, à 22:43

winux12

Re : Gestion son sous Karmic

la petite icone en haut à droit > clic droit >préférences du son
elle est pas là pour rien, tu choisi ta sortie et hop ....


La LIBERTE n'a pas de prix ...Ubuntu 12.04 - Gnome-Shell - Asus K52F-SSD 240Go-8Go Ram
TuxLibre - ARU2L
Adhérent à l'APRIL
1 Photo - 1 Jour

Hors ligne

#3 Le 30/10/2009, à 22:53

spacepirate

Re : Gestion son sous Karmic

Ben justement dans cette icone j'ai 2 sorties dans l'onglet sortie :

analog headphones : qui ne donne rien
analog output : avec laquelle j'ai du son dans le casque et les hp simultanément.

Hors ligne

#4 Le 30/10/2009, à 22:56

Kanor

Re : Gestion son sous Karmic

Salut
tu a peut étre la même  carte que moi

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

J'ai du me rabbatre sur alsamixer qui se lance dans le terminal pour déscendre passer d'un channel des écouteur au channel des enceinte
je pense qui doit avoir une solution plus élégante

Hors ligne

#5 Le 30/10/2009, à 23:08

spacepirate

Re : Gestion son sous Karmic

il me semble que ma carte est une Realtek ALC888.

le fait de passer par alsamixer ne résoud toujours pas mon problème.
il n'y à pas de séparation entre headphones et les hp

Hors ligne

#6 Le 01/11/2009, à 20:30

ben.schmark

Re : Gestion son sous Karmic

J'ai le même problème lorsque le branche mon portable sur mon ampli.

Je suis obligé de lancer Alsamixer en console et de réduire le volume des speaker pour que la musique ne sorte que sur l'ampli. C'est pas vraiment pratique.

Si quelqu'un a une solution...

Hors ligne

#7 Le 01/11/2009, à 21:20

Kanor

Re : Gestion son sous Karmic

J'ai résoulue ce prb en installant le paquet
linux-backports-modules-alsa-karmic-generic

Hors ligne

#8 Le 01/11/2009, à 23:01

ben.schmark

Re : Gestion son sous Karmic

Effectivement, ça marche aussi chez moi.

Merci !!! wink

Hors ligne

#9 Le 02/11/2009, à 19:02

Totobibi

Re : Gestion son sous Karmic

Bonjour à tous,

J'ai exactement le même problème que vous :
son qui sort des enceintes et au casque avec analog Output : tout est parfait.:
Le passage à headphone Output ne fait pas fonctionner le casque et coupe les enceintes (normal).
L'installation de linux-backports-modules-alsa-karmic-generic ne résout pas le problème.
AlsaMixer lancé dans le terminal non plus...en faisant varier les colonnes.

Ma carte son :

00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)

Merci de votre aide, j'avoue avoir épuisé les limites des forums !
@+

Dernière modification par Totobibi (Le 03/11/2009, à 12:57)

Hors ligne

#10 Le 03/11/2009, à 12:58

Totobibi

Re : Gestion son sous Karmic

Petit up car après de nouvelles réinstallations de linux-backports-modules-alsa-karmic-generic ne donne rien...:(
Merci !:)

Hors ligne

#11 Le 03/11/2009, à 14:42

ben.schmark

Re : Gestion son sous Karmic

Bonjour,

Je suis désolé, pour ma part je n'ai pas les compétences pour résoudre ton problème...Essaie de faire un tour sur le chan irc d'ubuntu-fr on sait jamais.

Bon courage, tu finiras bien par trouver une solution.;)

Hors ligne

#12 Le 04/11/2009, à 00:03

Totobibi

Re : Gestion son sous Karmic

Merci ben.schmark : Du nouveau !
Ça marche !...mais c'est laborieux.

Je m'explique :
- j'ai le paquet linux-backports-modules-alsa-karmic-generic installé ;
- je me mets sur headphone output : pas de son ;
- je lance alsamixer dans une console : Front est muet ;
- je monte le son sur Front et enlève le muet (qui se met automatiquement) ;
- et le casque marche sans les enceintes !

Quelqu'un pense à une procédure plus courte ?
Forcer alsamixer à "rendre actif" (=non muet) Front lorsque headphone output est activé ?

Reste aussi à voir si le micro marche aussi...
@+

Dernière modification par Totobibi (Le 05/11/2009, à 15:20)

Hors ligne

#13 Le 04/11/2009, à 19:58

ben.schmark

Re : Gestion son sous Karmic

Tu tiens le bon bout Totobibi,

A force de persévérance ça va bien finir par marcher !

Tiens nous au courant ! wink

Hors ligne

#14 Le 14/11/2009, à 14:25

jy_moustache

Re : Gestion son sous Karmic

salut à tous

j'étais confronté au meme pb mais je viens de trouver une solution. Je sais que ce genre de pb est lié au driver audio.
pour info j'ai une carte son RealTeck ACL888

Voici plusieurs solutions glanées sur le web. toutes concernent la ligne

options snd-hda-intel model=XXXX

(XXXX est le modele de votre PC/carte)
dans le fichier /etc/modprobe.d/alsa-base.conf

Soit
1 - la remplacer par  :

options snd-hda-intel model=targa-dig

et redemarrer

2 - la remplacer par :

options snd-hda-intel model=targa-2ch-dig

et redemarrer

Voila

j'espere que ca marchera pour vous

a plus
jy

Dernière modification par jy_moustache (Le 14/11/2009, à 15:13)

Hors ligne

#15 Le 14/11/2009, à 18:31

Totobibi

Re : Gestion son sous Karmic

Le micro et le casque fonctionnent !

Pour le casque :
toujours la même procédure : après avoir démarré ma session, alsamixer dans une console, front est muet, je l'active et monte le son, je mute speaker : seul le casque marche.

Pour le micro :
J'ai installé le paquet pavumeter
Alt-F2 (ou un lanceur, au choix!) : pavucontrol.
J'ouvre le canal audio interne Analog Stereo.
Ca marche !

Cependant...
1/ La procédure est longue et lourde à chaque ouverture de session ;
2/ tout est réinitialisé au démarrage (je précise que chez moi, l'hibernation ne marche plus non plus avec la 9.10...autre problème à régler!).

Bref, je ne suis pas pro en scripts mais je sens que l'un deux pourrait bien m'aider.

(Et je vais tenter la procédure de jy_moustache : merci).

@+

Dernière modification par Totobibi (Le 15/11/2009, à 12:42)

Hors ligne

#16 Le 14/11/2009, à 22:22

Autiwa

Re : Gestion son sous Karmic

J'ai moi aussi ce soucis, mais je m'en suis accomodé en fait, parce qu'au final, je trouve ça super pratique. J'ai mon casque tout le temps branché, et quand je veux la musique dans le casque, j'éteint les enceintes et je met le casque. Moi qui suis feignant, c'est plus facile d'appuyer sur un bouton que de me baisser et chercher le trou pour insérer la fiche du casque à taton.

Je croyais que c'était mon ordi qui déconnait (vu que j'ai vu sur le net que ça pouvait être un truc qui a grillé) mais apparemment non vu le nombre de gens dans mon cas.

En fait, tout ça me fait penser qu'une option "le branchement du casque coupe le son des HP" dans le gestionnaire de son serait super pratique. (une fois que les développeurs auront résolus ce soucis, ça devrait être possible d'en faire une option)


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#17 Le 19/11/2009, à 09:00

hicouri

Re : Gestion son sous Karmic

Salut !

personnellement, je me suis fait un petit script (qui marchait à merveille sous Jaunty) qui en un clic me permet de passer du casque au enceinte et inversement, et qui se base sur la commande amixer.

Le problème c'est que mon script foire depuis Karmic...

Sous Jaunty chaque entrée/sortie (Mic, Front, etc.) correspondait à 2 contrôles : le volume (valeur de 0 à 31) et la sourdine (on/off). Donc c'était nickel, je contrôlais chaque sortie indépendamment et je switchais dès que j'en avais besoin.

Sauf que voilà, le passage à Karmic a eu (chez moi) les effets suivants qui empêche mon script de fonctionner bien :

- les switch ne fonctionnent plus indépendamment : si j'utilise la commande pour mettre en sourdine la sortie du casque, par exemple, ça met aussi en sourdine le volume général (super !) résultat impossible de désactiver le casque sans désactiver tout le son...

- inversement, le contrôle du volume général via l'icône de la barre des tâches modifie le volume individuel des sorties aussi : si j'utilise la commande pour mettre le volume du casque à 0 (pour le désactiver) et qu'après je veux régler le volume des enceintes par le contrôle du tableau de bord ça réactive le casque...

Du coup je t'aurais bien passé mon script mais je sais pas si ça va t'être utile... Mais bon sur demande je peux le poster et on peux éventuellement essayer de voir ensemble comment le faire fonctionner à nouveau ++


ASUS X72J
CPU : i3 - 350M
Carte graphique : ATI Mobility Radeon HD5145

Hors ligne

#18 Le 12/01/2010, à 19:07

alexia8

Re : Gestion son sous Karmic

En lisant le topic et puisque j'avais le même problème, c'est à dire du son dans les enceintes quand je branchais mon casque, j'ai trouvé un début de réponse sur Ubuntu.forums :

ubuntuforums.org/showthread.php?t=1308748

"HP Pavilion and Karmic: Headphone and speaker at the same time
This problems started in Karmic. Whem I plug my headphone, the sound keep coming from the speaker and from the phone at the same time! How can I solve that?

EDIT: Problem solved. Add the following line at the end of the file /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=hp

And reboot. This will solve the problem."
__________________

Cela fonctionne très bien sur mon PC, peut-être à tester avec d'autres marques...

Dernière précision, il faut passer 'root' pour l'ajout de cette ligne de commande wink

Hors ligne

#19 Le 14/01/2010, à 22:08

Autiwa

Re : Gestion son sous Karmic

J'ai fait la manip, et le lendemain, au démarrage, rien n'avait changé pour moi.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#20 Le 15/01/2010, à 17:41

alexia8

Re : Gestion son sous Karmic

Mes connaissances sont très limitées sur Karmic, en plus cette manip' a déjà été donnée par jy-moustache, mais déjà tu peux essayer la seconde qu'il propose (model =targa-dig), c'est à dire essaye de voir si ton soucis n'est pas lié à un problème de reconnaissance de tes écouteurs.
@+

Hors ligne

#21 Le 15/01/2010, à 17:48

Autiwa

Re : Gestion son sous Karmic

j'utilise les mêmes écouteurs qu'au début où ça marchait. Seul truc, c'est qu'il est possible qu'il y ait un problème matériel et que cette non désactivation soit due à un truc qui ne fonctionne plus. Et ça par contre, je sais pas comment le vérifier.


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

Haut de page ↑