Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/01/2010, à 01:34

Reenjii

Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour

Je souhaite écrire en Japonais, j'ai donc suivi la documentation, tout c'est bien passé. Je suis sous KDE.

Seulement, je lance ibus, je peux aller dans las paramètres, j'ai bien choisi la méthode de saisie.

Donc a priori il faut faire Ctrl + espace pour activer/désactiver ??

Je ne comprends pas, chez moi ça ne fait rien. Je ne comprends pas comment la saisie se fait.

Genre je suis dans Kate, je fais Ctrl + espace et c'est sensé faire quoi ?? Je ne comprends pas. J'ai le petit carré blanc de ibus en bas a droite, mais je ne peux rien faire avec, et les raccourcis clavier n'ont aucune réaction.

Quelqu'un a-t-il déjà eu ce problème ?

Merci !!

Hors ligne

#2 Le 15/01/2010, à 11:15

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

おはようございます!
ca fait plaisir de voir un japonisant sur ubuntu-fr smile
(Tu habites au Japon?)
En fait je n'ai pas encore bien pris le temps de mettre a jour la page http://doc.ubuntu-fr.org/japonais depuis Ubuntu 9.10, je regarderai ca ce weekend smile
Par contre je n'utilise que Gnome et Xfce, tu as essaye/ avec Gnome?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#3 Le 20/01/2010, à 13:22

Reenjii

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Je n'habite pas au japon non ^^
Je suis en région parisienne, c'est juste que j'apprends le japonais en cours depuis cette année, donc ça l'intéresse beaucoup !!

Sinon, je n'ai pas essayé sous Gnome ni Xfce. Merci si tu mets à jour la documentation, je réessayerais un de ces jours !!

Hors ligne

#4 Le 21/01/2010, à 11:16

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Salut
Dans le petit carré blanc de ibus en bas à droite, est-ce bien Anthy qui est sélectionné ?

Et dans les préférence d'Ibus, il y a bien Control+space comme raccourci pour activer/désactiver ?

Dernière modification par YannUbuntu (Le 21/01/2010, à 11:18)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#5 Le 21/01/2010, à 20:08

Reenjii

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Salut !

Bah en fait je ne comprends pas très bien car il y a certes un petit carré blanc en bas à droite, mais je ne comprends pas à quoi il sert...
Je ne peux rien faire dedan, je peux le déplacer si je clique au bon endroit mais c'est tout.

Sinon, dans les préférences, le raccourci Control+space est bien désigné, et la méthode d'entrée Anthy ajoutée...

Il est sensé se passer quoi quand on fait ctrl+espace ?

Voilà un screen avec le carré blanc, comme je le vois.

http://benjitheone.free.fr/screen_ibus.png

Dernière modification par Reenjii (Le 21/01/2010, à 20:09)

Hors ligne

#6 Le 22/01/2010, à 07:14

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

ouh la! effectivement il y a un soucis. Voici ce que j'ai:
1264137221.png


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#7 Le 22/01/2010, à 08:04

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

par contre j'ai un soucis avec Ibus: impossible de sélectionner katakana/kanji avec la touche hiragana/katakana. Bref, pas pratique pour l'instant, il faut que je me renseigne a ce sujet, et que je fasse un rapport de bug si besoin.

En attendant j'utilise SCIM, qui a fait ses preuves depuis plusieurs années. smile (regarde ici dans la Doc pour savoir comment l'installer, je l'ai mis a jour de memoire donc si tu as un probleme previens-moi stp)

Dernière modification par YannUbuntu (Le 22/01/2010, à 09:39)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#8 Le 07/02/2010, à 16:29

jeje2a

Re : Japonais Ibus - Ctrl + espace ne fait rien !

effectivement ,comme il est indiqué dans la doc, Ibus pose quelques problèmes il vaut mieux garder Scim-Anthy
et pour ceux qui ont un problème avec les accents circonflexe il faut utiliser le clavier Français/Europeen de Anthy sur certaines applications comme par exemple Anki , car j'ai cru comprendre que du fait que c'est écrit en Qt il y a ce bug

Dernière modification par jeje2a (Le 07/02/2010, à 16:34)


config. actuelle: MSI Z97 Gaming 5 - Intel Core i5 4690K 3.50GHZ - SAPPHIRE Radeon HD 7870 2Gb -        
Corsaire Vengeance 2x4 Go

Hors ligne

#9 Le 07/02/2010, à 16:44

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

salut jeje2a,
je n'ai pas bien compris ton problème d'accents, peux-tu le décrire plus précisément stp? as-tu fait un rapport de bug sur Launchpad?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#10 Le 07/02/2010, à 18:38

jeje2a

Re : Japonais Ibus - Ctrl + espace ne fait rien !

oui ça n'est pas très clair je te l'accorde^^
Le contrôle de Anthy avec Ibus via le raccourci Ctrl+Space ne fonctionne pas chez moi, pas de petit carré blanc
donc j'ai installé le prérequis Scim-Anthy d'après la doc( http://doc.ubuntu-fr.org/japonais )
et ça fonctionne parfaitement.
pour la suite je pense que c'est lié au logiciel et je vais d'ailleurs de ce pas rapporter ce bug, on ne sait jamais il y a peut-être une parade
mais je vais expliquer tout de même
J'ai installé Anki afin de réviser les mots/ expressions/phrases-type appris dans ma méthode d'apprentissage.
Lorsque j'ajoute un nouveau mot/ expression/ phrase-type dans la partie "Meaning" (traduction) je désactive Anthy (Ctrl+Space) ce qui paraît logique.
Les accents circonflexes s'affichent alors comme ceci: ^a ^o ^e ^i ^u
donc pour placer cet accent il me faut donc réactiver Anthy, et passer par la fonction de clavier Français/Européen ( Shift+Ctrl)
Ce petit bug n'est pas trop gênant à partir du moment que je sais comment procéder et je suis certain que ça va éviter à nombre de'utilisateurs de trifouiller son système^^
je précise que OOo ,Gedit ,et le terminal ne pose pas ce problème

edit: je ne suis pas vraiment bon en anglais pour expliquer ce bug et les outils de traduction ne sont pas très fiable

Dernière modification par jeje2a (Le 07/02/2010, à 19:31)


config. actuelle: MSI Z97 Gaming 5 - Intel Core i5 4690K 3.50GHZ - SAPPHIRE Radeon HD 7870 2Gb -        
Corsaire Vengeance 2x4 Go

Hors ligne

#11 Le 08/02/2010, à 04:19

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

ok, je pense avoir compris. Avec quelle version d'Anki as-tu ce bug? Tu as un clavier français?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#12 Le 08/02/2010, à 14:24

jeje2a

Re : Japonais Ibus - Ctrl + espace ne fait rien !

je possède un clavier français Microsoft Natural Ergonomic 4000 et ma version de Anki est la 0.9.9.7.8 mais je n'ai pas pensé un seul instant à regarder sur le site pour voir que la derniere est la 0.9.9.8.5
je vais de ce pas mettre Anki à jour à l'aide du .deb, il se peut que ça corrige le bug
edit: ah ben non, c'est toujours pas ça l'accent circonflexe^^
par contre maintenant il est bel et bien complètement françisé big_smile
perso ça ne me dérange pas plus que ça, et des mots avec des accents circonflexe ça court pas les rues
par contre les polices japonaise sont super-moches, donc je propose aux utilisateurs d'installer les polices suivantes:
Kochi Gothic _ Kochi Mincho _ Sazanami Gothic _ Sazanami Mincho
qui sont beaucoup plus jolies, mieux travaillées, plus fines et disponibles dans le gestionnaire de paquet plutôt que de s'embêter à installer les classiques MsGothic et MsMincho wink

Dernière modification par jeje2a (Le 08/02/2010, à 14:33)


config. actuelle: MSI Z97 Gaming 5 - Intel Core i5 4690K 3.50GHZ - SAPPHIRE Radeon HD 7870 2Gb -        
Corsaire Vengeance 2x4 Go

Hors ligne

#13 Le 09/02/2010, à 02:46

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

tu as raison, on devrait conseiller l'installation de ces polices dans la Doc japonais.  EDIT: ajouté a la Doc.

Par contre je ne peux pas t'aider plus car j'ai un clavier jap, donc pas de touche accentuée, j'insère mes accents avec l'applet Palette de caractères.

Dernière modification par YannUbuntu (Le 09/02/2010, à 03:09)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#14 Le 26/02/2010, à 07:12

Gascon7

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Yann

J'aimerais, si vous trouvez le temps, bénéficier de vos conseils.

Je songe depuis un moment à migrer de Windows à Linux-Ubuntu.
Je décide aujourd'hi du divorce car j'ai payé avec ma machine une option d'upgrade de Xp à Win7. Mais il semble que je ne puisse plus en jouir aujourd'hui car j'ai attendu trop longtemps ( que les faiblesses les plus graves soient patchées).

Je m'adresse à vous en particulier car l'usage simple et conjoint du français, de l'anglais et du japonais est une condition nécessaire de mon activité (chercheur shs).

J'ai lu les documents correspondant mais ces textes se réfèrent à des notions "linux" que je ne comprends pas.

J'envisage d'installer en dual boot et éventuellement, si cela offre des avantages, de virtualiser en plus XP dans ubuntu .

Je réside à Kyoto et je dispose comme vous d'un clavier japonais.

Est-il possible de basculer d'un clavier azerty fr classique-complet à un clavier qwerty-jp classique-complet instantanément?
(achat de voix vote buying 投票買収)

Est-il possible de saisir en romaji
k+a+b+u+k+i pour obtenir かぶき puis 歌舞伎 ?

Est-ce qu'un document multilingue saisi avec word sera lisible sous open office sans mojibake et vice versa?
Tous mes correspondants sont sous Windows et les machines du labo de même.

Je ne tape pas vite et je ne souhaite pas mémoriser plus de 2 agencements de clavier.

J'utilise des logiciels d' analyse de données et j'ai souvent besoin de l'agencement des touches tel que je le vois sur mon clavier physique.

Voilà.

Mes exigences peuvent-elles satisfaites ou bien est-il plus sage que je demeure docilement soumis à l'arbitraire de Windows puisque Atok fait ce qu'il faut?


Bien à vous,

Hors ligne

#15 Le 26/02/2010, à 08:07

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour Gascon7

quels logiciels d'analyse de donnees utilisez-vous ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#16 Le 27/02/2010, à 03:21

Gascon7

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour

J'utilise Stata, Ucinet, Ucinet, Pajek, P*net et je commence à regarder du côté de R et WinBugs.

Ces logiciels exste sous Linux pour la plupart mais je possède des versions windozs pour les non-libres.

Hors ligne

#17 Le 27/02/2010, à 14:16

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Juste pour info, qu'est-ce qu'un "chercheur shs" ? et "voix vote buying 投票買収" ?

Pour répondre à vos questions:
J'utilise quotidiennement Ubuntu au boulot et à la maison, j'écris/lit en anglais/jap/français, sans problème dans tous mes logiciels (emails, doc, xls, pdf, musique, films, internet etc..) avec ma session (menus, logiciels..) en français, et je peux facilement aussi choisir d'avoir la session en anglais ou japonais (pratique pour mes amis japonais par exemple). Premier bon point par rapport à Windows.

Oui un document multilingue saisi avec word sera lisible sous open office et vice versa (il y a parfois quelques différences de mise en page ou avec les macros complexes, ca ne m'a jamais gêné). Mes correspondants/collègues/clients sont tous sous Windows.

Mon clavier est japonais, et comme dit plus haut j'ai un applet dans ma barre en haut de l'écran pour tous les caractères accentués (je clique sur le caractère voulu, puis Ctrl-V pour l'insérer). Donc j'utilise mon clavier " à la vue" (rien besoin d'apprendre par coeur). Il doit être possible de simuler un clavier azerty (menu Système->Préférences->Clavier->Agencements), mais je n'ai jamais essayé car je n'en ai pas l'utilité. Bref pour cela je trouve Ubuntu beaucoup plus pratique que Windows.

Lorsqu'on veut écrire en japonais, il suffit d'appuyer sur le raccourci choisi dans SCIM, par exemple Ctrl-Espace ou la touche 半角/全角 pour moi, et la saisie se fait en japonais, c'est-a-dire: on saisit en romaji k+a+b+u+k+i pour obtenir かぶき (ou カブキ ou カブキ , selon la méthode sélectionnée dans la barre SCIM), puis en saisissant la touche Espace on a les kanjis 歌舞伎, puis si besoin on appuie une 2e fois sur Espace pour avoir la liste des kanjis. Comme sous Windows il me semble.

Bref, je vous conseille de commencer par un dual-boot Windows-Ubuntu (n'oubliez pas de sauver vos données auparavant), de façon à pouvoir continuer à travailler avec XP, et en parallèle prendre en main Ubuntu (notamment trouver des équivalents Ubuntu aux logiciels d'analyse de données, car c'est le seul point qui risque de poser problème à mon avis). De mon coté j'ai mis ~1 mois à passer complètement à Ubuntu, et je garde windows en dual-boot au cas-où (les rétroprojecteurs de mes clients ne sont pas tous compatibles avec ubuntu).

Je vous conseille aussi de commencer par installer Ubuntu (dual-boot) sur votre ordinateur personnel si vous en avez un.

Au plaisir de vous rencontrer un jour à Kyoto ou Tokyo.  N'hésitez pas à poser d'autres questions ici ou en message privé si besoin. smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#18 Le 02/03/2010, à 02:19

Gascon7

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Cher Yann,

Merci de votre rapide et précise.

Je vais procéder comme vous l'indiquer.

Chercheur shs signifie chercheur en sciences humaines et sociales.
L'achat de voix 表の買収 est simplement l'un des sujets sur lesquels je travaille actuellement et ces mots me passaient par l'esprit. Pratique générale dans le Japon d'avant-guerre.

2 questions encore:

Quelle version d'Ubuntu est-il préférable d'installer?

Comment vous adresser un message sur votre e-mail privé?

Hors ligne

#19 Le 02/03/2010, à 03:08

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour Gascon7,
pour envoyer un message privé à quelqu'un, il suffit de cliquer sur son pseudo (par exemple sur "YannUbuntu" en haut a gauche de ce message), vous arrivez sur le profil dans lequel il y a un lien "Envoyer un e-mail".

Concernant la version d'Ubuntu, je vous conseille d'essayer d'abord avec la version la plus utilisée actuellement : Ubuntu 9.10. Téléchargez l'ISO correspondante (ici), gravez-la sur un CD pour l'essayer sans installation ("session-live"), et vérifiez bien que votre matériel (écran, clavier, connexion internet) est reconnu. En cas de soucis (par exemple avec la connexion internet), essayez avec Ubuntu 9.04.

Puis une fois testé en "session-live", vous pourrez installer en dual-boot.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#20 Le 16/03/2010, à 14:59

jeje2a

Re : Japonais Ibus - Ctrl + espace ne fait rien !

salut j'ai résolu le problème d'accent circonflexe^^
j'ai eu le même problème avec amsn, donc j'ai suivi la manipulation:
https://help.ubuntu.com/community/SCIM# … and%20aMSN
du coup ça résout en même temps le souci Amsn et Anki
donc ça ne venait pas du logiciel, c'est déjà ça smile


config. actuelle: MSI Z97 Gaming 5 - Intel Core i5 4690K 3.50GHZ - SAPPHIRE Radeon HD 7870 2Gb -        
Corsaire Vengeance 2x4 Go

Hors ligne

#21 Le 16/03/2010, à 16:59

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

(pour ceux qui ne comprennent pas l'anglais, le même tuto en français: http://doc.ubuntu-fr.org/scim#utilisation_de_scim_avec_amsn_et_skype )


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#22 Le 14/07/2010, à 15:11

gulp

Re : Japonais Ibus - Ctrl + espace ne fait rien !

avec lucid tout semble marché quelqu'un confirme?

Hors ligne

#23 Le 14/07/2010, à 19:45

YannUbuntu

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour
que veux-tu dire par "tout" ?

Si tu parles d'iBus, oui depuis Lucid il fonctionne bien. (j'ai mis a jour http://doc.ubuntu-fr.org/japonais#activer_l_ecriture_japonaise).


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 15/07/2010, à 01:22

gulp

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Euh en fait j'ai continué dans l'autre sujet

http://forum.ubuntu-fr.org/viewtopic.php?id=233697

Dernière modification par gulp (Le 15/07/2010, à 15:06)

Hors ligne

#25 Le 20/11/2010, à 12:24

CEDRIK

Re : Japonais Ibus - Ctrl + espace ne fait rien !

Bonjour,
Je suis sous Lucid et je n'arrive pas a faire fonctionner Ibus pour le Japonais.
J'ai bien suivie la procédure , mais le Ctl - space ne fait rien apparaitre si Ibus et sélectionné dans les préférences linguistiques. Mais si je le lance moi , j'ai un petit carré vide qui appairé !

Du coup je fonctionne avec Scim pour l'instant ...
Je n'arrive pas à écrire en Japonais dans openoffice non plus ...

Tout se que je trouve sur le net ne fonctionne pas ...

Si quelqu'un a des idées ..
merci

Hors ligne

Haut de page ↑