Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 30/01/2010, à 17:17

JohnTR

empêcher le terminal de se fermer après exécution d'une commande

Bonjour,
je cherche à ajouter une entrée dans le menu fluxbox (par ex.) qui permette d'ouvrir un terminal dans un dossier précis. J'ai donc mis comme commande dans le menu :

urxvt -e 'cd ~/dossier'

Le problème est que la fenêtre se referme immédiatement.
J'ai essayé différentes choses :

-e 'cd ~/dossier;bash -'
-e bash -c cd ~/dossier

... etc
Mais rien à faire. Le problème est le même avec xterm, rxvt...
La seule méthode que j'ai trouvé est de créer un script, d'y mettre la commande et de l'exécuter avec -e, mais c'est pas très pratique.
Quelqu'un aurait-il une meilleure solution ?
Merci

Hors ligne

#2 Le 30/01/2010, à 17:22

credenhill

Re : empêcher le terminal de se fermer après exécution d'une commande

hello

urxvt -e "cd ~/dossier ; $SHELL"

Hors ligne

#3 Le 30/01/2010, à 19:17

JohnTR

Re : empêcher le terminal de se fermer après exécution d'une commande

$SHELL est équivallant à bash dans mon cas donc ça ne change rien...

Hors ligne

#4 Le 30/01/2010, à 19:48

Elzen

Re : empêcher le terminal de se fermer après exécution d'une commande

Plus précisément,

urxvt -e sh -c "cd ~/dossier ; sh"

devrait te donner les résultats attendus (en remplaçant sh par le shell de ton choix, bash, zsh, ksh ou autres)

L'option -e lance une commande et ferme le terminal une fois la commande terminée (ne pas indiquer l'option -e est en fait équivalent à passer -e le_shell_par_défaut). Ici, la commande demandée sera un shell, qui lui-même appliquera la commande demandée et se terminera. La commande en question est de changer de répertoire et de lancer un nouveau shell, qui se trouvera dans le répertoire demandé et dans lequel tu pourras travailler.

Il y a probablement une solution plus simple (et plus propre), mais au moins, celle-ci a l'air de marcher.


Elzen : polisson, polémiste, polymathe ! (ex-ArkSeth)
Un script pour améliorer quelques trucs du forum.
La joie de t'avoir connu surpasse la peine de t'avoir perdu…
J'ai pour qualité de ne jamais attaquer les gens. J'ai pour défaut de souvent avoir l'air de le faire.

Hors ligne

#5 Le 30/01/2010, à 22:40

JohnTR

Re : empêcher le terminal de se fermer après exécution d'une commande

C'est parfait, merci bien !

Hors ligne

Haut de page ↑