Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 28/05/2006, à 23:41

souxin

[WInfast tv2000xp expert] sous dapper, son ok !

Si comme moi, vous testez la dernière dapper, vous avez certainement decouvert un problème  de son, pour les cartes Winfast tv2000xp expert, surtout quand le chip est un cx88.

Je vous donne la config qui pour moi a fonctionné.

à partir d'une fenêtre terminal :

lspci

0000:00:08.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

dmesg | grep cx88

[4294687.343000] CORE cx88[0]: subsystem: 107d:6611, board: Leadtek Winfast 2000XP Expert [card=5,autodetected]
[4294687.455000] i2c-algo-bit.o: cx88[0] passed test.
[4294687.549000] cx88[0]: Leadtek Winfast 2000XP Expert config: tuner=38, eeprom[0]=0x01
[4294687.549000] input: cx88 IR (Leadtek Winfast 2000XP as /class/input/input3
[4294687.549000] cx88[0]/0: found at 0000:00:08.0, rev: 5, irq: 193, latency: 32, mmio: 0xe2000000
[4294687.720000] tuner 1-0060: chip found @ 0xc0 (cx88[0])
[4294687.720000] tuner 1-0060: cx88[0] tuner I2C addr 0xc0 with type 38 used for 0x0e
[4294687.770000] tda9887 1-0043: chip found @ 0x86 (cx88[0])
[4294687.776000] cx88[0]/0: registered device video0 [v4l2]
[4294687.776000] cx88[0]/0: registered device vbi0
[4294687.776000] cx88[0]/0: registered device radio0

Ensuite, j'installe "TVTIME" à l'aide de synaptics (gestionnaire de paquets)

Puis, je cré un fichier "tv" dans /etc/modprobe.d/ en faisant ceci : gksudo "gedit /etc/modprobe.d/tv" et j'y ajoute les lignes suivantes

# i2c
alias char-major-89 i2c-dev
options i2c-algo-bit bit_test=1

# cx88
alias char-major-81 videodev
alias char-major-81-0 cx8800
options tuner  secam=l tuner_debug=1
options tda9887  qss=1 port1=0 port2=0 secam=1

j'enregistre et je ferme

En fin, je rajoute "TV" dans /etc/modules/ , en faisant ceci : gksudo "gedit /etc/modules" (je rajoute en fin de fichier "tv" puis engistrer et fermer)

je redemarre le pc, me log de nouveau, lancement de tvtime et hop le son est OK !

voilà, j'espère que ça marchera pour vous.

Hors ligne

#2 Le 01/06/2006, à 22:48

francky_51

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Souxin t'es un boss !!!!!!!!!!!!!

Je suis sous Dapper aussi et ca marche nickel je te remercie.

Hors ligne

#3 Le 04/06/2006, à 14:31

hokkos

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Salut,
moi ca ne marche pas hmm

lspci

0000:00:00.0 Host bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Processor to I/O Controller (rev 04)
0000:00:01.0 PCI bridge: Intel Corporation 915G/P/GV/GL/PL/910GL PCI Express Root Port (rev 04)
0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
0000:00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
0000:00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
0000:00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro FX 330/GeForce PCX 5300] (rev a2)
0000:02:01.0 Communication controller: Agere Systems V.92 56K WinModem (rev 02)
0000:02:02.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
0000:02:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
0000:02:04.0 IDE interface: VIA Technologies, Inc. VT6410 ATA133 RAID controller (rev 06)
0000:02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

et dmesg | grep cx88

[4294689.405000] CORE cx88[0]: subsystem: 107d:6611, board: Leadtek Winfast 2000XP Expert [card=5,autodetected]
[4294689.517000] i2c-algo-bit.o: cx88[0] passed test.
[4294689.607000] cx88[0]: Leadtek Winfast 2000XP Expert config: tuner=38, eeprom[0]=0x01
[4294689.607000] input: cx88 IR (Leadtek Winfast 2000XP as /class/input/input3
[4294689.607000] cx88[0]/0: found at 0000:02:02.0, rev: 5, irq: 201, latency: 32, mmio: 0xd3000000
[4294689.640000] tuner 0-0060: chip found @ 0xc0 (cx88[0])
[4294689.640000] tuner 0-0060: cx88[0] tuner I2C addr 0xc0 with type 38 used for 0x0e
[4294689.684000] tda9887 0-0043: chip found @ 0x86 (cx88[0])
[4294689.689000] cx88[0]/0: registered device video0 [v4l2]
[4294689.689000] cx88[0]/0: registered device vbi0
[4294689.689000] cx88[0]/0: registered device radio0

Donc la même chose aux emplacements des périphériques près.

Mais pas de son.

Je me demande, comment avez vous branché votre carte pour le son ?

J'ai branché la sortie son de la carte TV sur ma carte mere, à un endroit ou ca rentrais, nommé JCD1.

Sous windows, le son ne marche pas direct, je suis obligé d'aller dans l'interface qui gere la carte son et de cliquer sur un bouton qui met en marche l'entrée son CD. Et sous windows le bouton pour augmenter et baisser le son de la télécommande ne fonctionne pas.

Donc avez vous fait pareil ?
Sinon dans l'iterface son de dapper il faut fair qql chose ?

Merci

Hors ligne

#4 Le 06/06/2006, à 18:26

manu (newbie)

Re : [WInfast tv2000xp expert] sous dapper, son ok !

@Hokkos

j'ai une leadteck winfast XP (pas la "expert", l'autre avec un tuner bttv878), mais je te conseil de faire les manipulations proposées pae Souxin.

mon entrée son est branchée sur la carte mère à la place où normalement on branche la sortie audio du lecteur de CDROM, donc comme toi!!

Du coup, dans la config de TVtime, j'ai du spécifié que le son arrive par le port audio-cdrom de la carte mère:

gedit ~/.tvtime/tvtime.xml

....
  <option name="V4LDevice" value="/dev/video1"/>
  <option name="VBIDevice" value="/dev/vbi1"/>
  <option name="Norm" value="SECAM"/>
  <option name="Frequencies" value="France"/>
  <option name="MixerDevice" value="/dev/mixer:cd"/>

sinon, il y a plein d'astuces dans les pages manuels de TVtime et tvtime.xml ,qui devraient t'aider à trouver la bonne configuration:

man tvtime
man tvtime.xml
       <option name="MixerDevice" value="/dev/mixer:line"/>
              This  sets  the  mixer device and channel to use.  The format is
              device name:channel name.  Valid channels are:

              vol, bass, treble, synth, pcm,  speaker,  line,  mic,  cd,  mix,
              pcm2,  rec, igain, ogain, line1, line2, line3, dig1, dig2, dig3,
              phin, phout, video, radio, monitor

derniere chose, ouvre ton mixer audio et regarde si le son du CDROM est
1-activé
2-au max

après ça, normalement, no-soucis.


Manu

Dernière modification par manu (newbie) (Le 06/06/2006, à 18:32)

Hors ligne

#5 Le 07/06/2006, à 15:21

hokkos

Re : [WInfast tv2000xp expert] sous dapper, son ok !

manu (newbie) a écrit :

@Hokkos
derniere chose, ouvre ton mixer audio et regarde si le son du CDROM est
1-activé
2-au max

après ça, normalement, no-soucis.
Manu

Arf, j'ai essayé ce que tu m'a dis, avec toutes les options possibles, ca donne toujours :

hokkos@ubuntu:~/Desktop/Projet3D/marche$ tvtime --mixer=cd
Running tvtime 1.0.1.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/hokkos/.tvtime/tvtime.xml
mixer: Can't open device cd, mixer volume and mute unavailable.
Thank you for using tvtime.

Pourtant dans le controleur de volume de gnome, j'ai mis tout à fond et j'ai activé les inputs sources linee et cd, et j'mais un son, et toujours le : mixer: Can't open device cd, mixer volume and mute unavailable.

J'ai de nouveau regardé ma carte tv,
j'ai le fil gris avec les 3 petits fils connecté dans la carte avec le petit fil rouge sur le coin de la carte, puis le noir (en allant vers le centre de la carte), puis rien, puis le blanc. Sur la prise qui correspond sur ma carte mere, c'est connecté de la meme manière (avec les détrompeurs dans le meme sens, qui ne détrompe rien en fait, c'est pour ca que je précise).
Sur ma carte mère cela s'appelle JCD1, tout les autres ont un format différent, il y a bien à coté JAUD1, mais il y a 8 pins sur 2 niveaux.

Il y a une commde linux à faire pour activer JCD1 ? Le pilote de ma carte son est ok ?

Merci

Hors ligne

#6 Le 13/10/2006, à 20:08

hokkos

Re : [WInfast tv2000xp expert] sous dapper, son ok !

En fait aprés avoir bricolé la sortie audio de ma carte télé, j'ai pu vérifier qu'elle sortait bien le son, donc le probleme ce situe au niveau de la carte mere, l'entrée JCD1 ne veut pas sortir de son sous linux. hmmmad

Hors ligne

#7 Le 02/12/2006, à 16:18

r17777

Re : [WInfast tv2000xp expert] sous dapper, son ok !

juste un petit massage pour un gros

MERKKKKKKKKKIIIIIIII !!!!! big_smile

j'ai suivi ton tuto à la lettre ... exepté les   guillements dans tes commandes ...
petit rigolo và!!  wink ... et c'est "que du bonheur"  comme disent les gros naze ... lol

allé .! Continuez comme ça mésieurs les Kings! smile

Dernière modification par r17777 (Le 02/12/2006, à 16:19)


Energie: pAnser les fuites pour pEnser la suite! :-°
Faites un geste pour l'environnement, fermez vos fenètres/windows et adoptez un pingouin! ;-)
Portable Fujitsu Siemens XI2528  (Ubuntu 12.04 /64bits) + admin tant bien que mal de divers ordis Ubuntu et ordinausores avec OS libres léger (chez des proches) + 1 serveur Nas QNAP TS-109 PRO (toujours pas sorti du carton)

Hors ligne

#8 Le 02/12/2006, à 16:28

hokkos

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Juste pour dire comment je m'en suis sortit avec le son :

j'avais remarqué que quand j'avais la télé lancé, en enregistrant le son depuis le programme d'enregistrement de gnome, j'entendais la télé.

J'ai donc fait un script : qui s'appel : .TV
ce script contient :

arecord -f | aplay &
tvtime

en fait il lance un enregistrement dont la sortie est joué sur les haut parleurs.
C'est rudimentaire, et au bout de 2h de télé il y a un immonde bruit aigu, mais ca marche, je compte le refaire en C, pour que ca capte le signal de plantage et relance le truc... mais ca marche.

Hors ligne

#9 Le 07/12/2006, à 21:01

Gnondpom

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Salut
Je suis sous Ubuntu 6.10 Edgy Eft et j'ai aussi un probleme de son
jen'arrive donc pas à le faire fonctionner
j'ai pourtant suvis toutes les indications mais aucuns succés
D'ailleur c'est mon seul probleme sous Ubuntu

gnondpom@ubuntu:~$ lspci
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev a2)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev a2)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev a2)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev a2)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev a2)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev a2)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:06.1 Modem: nVidia Corporation Unknown device 0069 (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev a2)
01:06.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
01:06.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
01:07.0 Network controller: RaLink Wireless PCI Adapter RT2400 / RT2460
03:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX - nForce GPU] (rev a3)

gnondpom@ubuntu:~$  dmesg | grep bttv
[17180590.136000] bttv0: unloading
[17180595.424000] bttv: driver version 0.9.16 loaded
[17180595.424000] bttv: using 8 buffers with 2080k (520 pages) each for capture
[17180595.448000] bttv: Bt8xx card found (0).
[17180595.448000] bttv0: Bt878 (rev 17) at 0000:01:06.0, irq: 201, latency: 32, mmio: 0xdc000000
[17180595.448000] bttv0: detected: Leadtek WinFast TV 2000 [card=34], PCI subsystem ID is 107d:6606
[17180595.448000] bttv0: using: Leadtek WinFast 2000/ WinFast 2000 XP [card=34,insmod option]
[17180595.448000] bttv0: gpio: en=00000000, out=00000000 in=003ff500 [init]
[17180595.592000] bttv0: using tuner=24
[17180595.596000] bttv0: i2c: checking for MSP34xx @ 0x80... not found
[17180595.596000] bttv0: i2c: checking for TDA9875 @ 0xb0... not found
[17180595.600000] bttv0: i2c: checking for TDA7432 @ 0x8a... not found
[17180595.604000] bttv0: i2c: checking for TDA9887 @ 0x86... found
[17180595.692000] bttv0: registered device video0
[17180595.692000] bttv0: registered device vbi0
[17180595.696000] bttv0: registered device radio0
[17180595.696000] bttv0: PLL: 28636363 => 35468950 . ok
[17180595.724000] input: bttv IR (card=34) as /class/input/input5
[17180595.732000] bttv-input: bttv IR (card=34) detected at pci-0000:01:06.0/ir0

Merci d'avance


.::[Ubuntu addict]::.

Hors ligne

#10 Le 07/12/2006, à 22:57

hokkos

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Gnondpom a écrit :

Salut
Je suis sous Ubuntu 6.10 Edgy Eft et j'ai aussi un probleme de son
jen'arrive donc pas à le faire fonctionner
j'ai pourtant suvis toutes les indications mais aucuns succés
D'ailleur c'est mon seul probleme sous Ubuntu

Merci d'avance

A mon avis tu n'as pas le même type de carte que nous. Tu a l'air d'avoir un chipset BT878  nous c'est plutot du CX..., donc  cherche un tutoriel pour a carte hmm

Hors ligne

#11 Le 25/11/2007, à 17:55

bjalon

Re : [WInfast tv2000xp expert] sous dapper, son ok !

Bonjour,

Je viens d'acheter une leadtek tv2000... Global...
Ah la boulette, ... j'ai bien trouvé des tuto pour tv2000 Deluxe et tv2000 Expert mais pas pour Global...

Je me suis dit que cela ne devait pas être bien grave donc j'ai esssayé les deux tutoriaux et celui qui correspond le mieux est le votre car en faisant lspci j'ai bien :

0000:00:08.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

Par contre quand je lance tvtime, il ne me propose pas quand je click droit sur l'écran le premier élément du menu, c'est à  dire la configuration des chaine...

Donc je reviens sur votre tutorial et la en regardant mieux, en fait je remarque que le module cx88 ne trouve pas ma carte, il me met :

CORE cx88[0]: subsystem: subsystem: 107d:6618, board: UNKNOWN/GENERIC [card=0,autodetected]

Argghhhh, donc je me dit qu'il suffit de mettre 5 sans autodetetion dans le module, sauf que....
Je ne sais pas comment faire et o๠le faire...

Merci par avance si vous savez...

Benjamin

Hors ligne

Haut de page ↑