Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/02/2010, à 09:54

alci

[Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Bonjour,

plus qu'un problème, voici un petit témoignage qui pourra servir à d'autres je l'espère...

Suite à l'acquisition d'un portable sony vaio VPCCW2S1E, muni d'une carte graphique NVidia GeForce GT 330M, j'ai bien sûr installé Ubuntu (Karmic 64bits). Premier démarrage impeccable, mais en vesa (problème de caractères qui se chevauchent en particulier). J'installe le driver propriétaire NVidia (celui des dépôts), je redémarre et là : écran noir !

Le problème vient du fait que l'écran du laptop n'est pas reconnu : le serveur X ne parvient pas à lire son EDID (les informations de configuration fournies par l'écran), et donc c'est comme si il n'avait pas d'écran.

Il existe de multiples messages sur le réseau qui expliquent le problème et sa solution.
La solution (de contournement, en attendant que la source du problème soit résolue) est la suivante :

1) récupérer le fichier EDID brut de cette écran (cherchez sur internet un fichier avec le nom SNY05FA.bin pour ce portable, sinon il doit être possible de trouver des utilitaires Windows qui permettent de sauvegarder ce fichier).
2) sudo mv SNY05FA.bin /etc/X11/
3) modifiez votre /etc/X11/xorg.conf avec les lignes :

Section "Device"
   Identifier          "Device0"
   Driver              "nvidia"
   VendorName         "NVIDIA Corporation"
   Option             "ConnectedMonitor"   "DFP-0"
   Option             "CustomEDID"          "DFP-0:/etc/X11/SNY05FA.bin"
EndSection

Et voilà.

Deuxième petit problème, impossible de jouer une vidéo. Totem s'ouvre, semble lire la vidéo mais affiche un rectangle noir... Le problème vient cette fois de Totem, qui règle le contraste XVideo à -1000. La correction est simple : allez dans Totem/Edition/Préférences onglet Affichage, rétablir les valeurs par défaut.

A part ça, cette machine marche impeccablement, le matériel est entièrement reconnu, y compris la webcam avec un paquet  ricoh-r5u87x_1.0-1karmic1_amd64.deb (pas officiel pour des raison de licences sur le firmware je crois)

Et voilà...

Dernière modification par pierguiard (Le 04/02/2010, à 15:42)

Hors ligne

#2 Le 04/02/2010, à 13:06

PPdM

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Salut
tu indique Résolu tu a fais quoi?

Edit , j'avais mal lu( trop vite) je me suis permis de mettre en avant ta solution en la séparant du reste.

Dernière modification par pierguiard (Le 04/02/2010, à 15:44)


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#3 Le 04/02/2010, à 14:23

malbo

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Il témoigne de son expérience de Ubuntu 9.10 64 bits dans son portable sony vaio VPCCW2S1E. Moi, ça me parait plutôt clair et intéressant comme post.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#4 Le 03/03/2010, à 17:27

svast

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Merci !!
J'ai eu exactement ce problème avec mon VAIO VPC F11 tout neuf (VPCF11C5E pour être précis). Ma recette:

1) Un court passage par Win 7 afin de récupérer le fichier EDID (via un utilitaire Phoenix EDID editor je crois bien), puis mise sur clé USB du fichier nommé sonyedid.raw,
2) reboot en mode "recovery" pour avoir un mode texte,
3) en ligne de commande, récup du fichier, puis Adaptation du xorg.conf selon les conseils lumineux précisés dans ce post:

mount /dev/sdb1 /mnt
cp /mnt/sonyedid.raw /etc/X11/
vi /etc/X11/xorg.conf

Et voilà! C'est beau la communauté smile

Dernière modification par svast (Le 03/03/2010, à 17:29)

Hors ligne

#5 Le 18/04/2010, à 11:56

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Salut, Est-ce que c'est possible de regler le "Brightness"? J'ai 10.04 et apres ta resolution j'arrive a avoir tout ok sauf le brightness. (J'ai auccune idee de commend dire brightness en francais)

Hors ligne

#6 Le 18/04/2010, à 12:33

PPdM

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

luminosité ou brillance selon le contexte


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#7 Le 18/04/2010, à 21:58

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Hmm. Mais c'est possible de la regler ou pas? J'arrive pas a changer la luminosité (batterrie)

Hors ligne

#8 Le 23/04/2010, à 13:17

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Salut de nouveau. Est-ce que le HDMI marche? Moi j'ai même pas l'option dans nvidia-settings

Hors ligne

#9 Le 24/04/2010, à 01:39

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Pas besoin d'extraire le EDID dans W7.
Option  "CustomEDID"    "DFP-0:/proc/acpi/video/NGFX/LCD/EDID"
marche.

However:
antibody@Neptunus:~$ cat /proc/acpi/video/NGFX/LCD/brightness
<not supported>

Hors ligne

#10 Le 05/05/2010, à 10:26

suskoat

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Moi je suis le ptit tuto de svast. Mais la console me dit que le fichier xorg.conf n'existe pas. Je suis sous 10.04 lts.

Hors ligne

#11 Le 05/05/2010, à 17:23

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Pas besoin the fichier BIN essaye  avec ça

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Fri Mar 12 02:13:46 PST 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
#    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
#    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Sony Nvidia Default Flat Panel"
    HorizSync       29.0 - 47.0
    VertRefresh     0.0 - 61.0
    Option         "DPMS"
#    Option         "CustomEDID"    "DFP-0:/proc/acpi/video/NGFX/LCD/EDID"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 330M"
    BusID          "PCI:1:0:0"
#    Screen          0
    Option         "ConnectedMonitor"    "DFP-0"
    Option         "CustomEDID"    "DFP-0:/proc/acpi/video/NGFX/LCD/EDID"

EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Hors ligne

#12 Le 10/05/2010, à 13:46

Maître Kaïo

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

bonjour

merci pour la combine forevertheuni, je viens d'acquerir un vaio F et je rencontrais un pb quand j'installais le driver propriétaire nvidia de ma 330M. ta soluce corrige ce bug. cependant j'ai encore un soucis, a chaque reboot je repars en 800*600 et je dois moi meme aller mofifer les parametres nvidia pour mettre en "auto" la definition de l'ecran, afin qu'il passe en full HD.

y a t'il un moyen de rendre ca automatique?

Hors ligne

#13 Le 10/05/2010, à 16:30

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

attend.
essaye ça

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Fri Mar 12 02:12:40 PST 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option             "ConnectedMonitor"   "DFP-0, DFP-1,CRT"
    Option             "CustomEDID"         "DFP-0:/proc/acpi/video/NGFX/LCD/EDID"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Tu peux connecter le hdmi et VGA en TwinView. J'ai pas encore reussi avec "Different X server".

For the brightness.

sudo add-apt-repository ppa:mactel-support
sudo apt-get update
sudo apt-get install nvidia-bl-dkms

reboot. Should Work.
(Je sais pas si avec Fn marche- J'ai pas encore fait reboot, mais echo 7 > /sys/class/backlight/nvidia_backlight/brightness comme root devras te dire si ça marche ou pas.

Hors ligne

#14 Le 10/05/2010, à 18:20

Maître Kaïo

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

merci pour le travail!

sinon j'ai toujours le meme souci, le gdm est en bonne resolution, mais une fois connecté j'suis en 800 par 600 :-(

Hors ligne

#15 Le 11/05/2010, à 12:28

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Mais, C'est TV/Moniteur ou le LCD du portable?
Peut être que c'est une configuration de la session que n'est pas bonne. Je sais que il y a une option dans le xorg.conf pour le "auto"

Hors ligne

#16 Le 11/05/2010, à 13:41

Maître Kaïo

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

pour moi c'est le lcd du portable, à chaque connection je repars en 800 par 600, au lieu d'etre en "auto", je dois passer à la main par nvidia settings manager pour changer la resolution (ou je choisis 'auto' et ca marche directe).

mais à la connection suivante, bling, 800 par 600. j'ai essaye d'enregistré ma conf xorg via le menu nividia justement, si je sauvegarde avec l'option merge, ca change rien, si je la sauvegarde sans la fontion merge, ca replante completement l'affichage comme avant tes modifications.

en fait je me doute que c'est juste une option à passer en auto, mais c'est qu'au milieu de tous ces parametres je suis un peu perdu.

en tout cas merci bcp pour ton aide depuis le début.

sinon j'ai trouvé ca:

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   SubSection     "Display"
       Depth       24      #Color Depth
       Modes      "1280x1024" "1024x768" "800x600"  #Resolution
   EndSubSection
EndSection

c'est cette ligne 'Modes' dans 'Screen'??

Dernière modification par Maître Kaïo (Le 11/05/2010, à 13:51)

Hors ligne

#17 Le 11/05/2010, à 14:02

forevertheuni

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Essaye ça. Le bizarre c'est le gdm qui est ok. Essaye de creer un nouveaux utilizateur pour voir si c'est le meme prob. Ma resolution dans mon vpccw2s1e c'est 1366x768

Hors ligne

#18 Le 13/05/2010, à 21:46

Maître Kaïo

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

toujours le meme souci! je m'y accomode pour l'instant... en tout cas merci pour ton aide ;-)

j'ai meme testé d'autres modifs du xorg.conf trouvées sur la doc en ligne mais ca change rien... y sans d'autre autre chose qui force en 800*600 apres le gdm. mais pffffffft

Hors ligne

#19 Le 17/05/2010, à 06:04

totof1169

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

salut
une petite question apres mainte recherche ,j ai le meme probleme sur un vaio ,mais avec une carte video intel ,j ai essaye avec le custom edid mais rien n y fait
j ai cree le xorg.conf et je l ai "bidouille" , est ce que je peut maintenant l effacer purement et simplement (il n existait pas a l origine)
il y a apparement un patch qui sort et qui devrait resoudre mon probleme

merci

Hors ligne

#20 Le 23/05/2010, à 17:00

totof1169

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

salut
un petit up

Hors ligne

#21 Le 24/01/2011, à 22:46

champomy62

Re : [Résolu] écran noir avec Sony VPCCW2S1E et NVidia

Salut à tous. Equipé du même portable que vous j'ai cherché à tout prix a pouvoir utiliser Ubuntu (merde quoi). J'ai finis par réussir, j'ai SUIVI LE POST 20 de ce TUTO. Moi celà à marcher du premier coup effectivement c'est genial. Il ne reste plus que les touches fn...

Hors ligne

Haut de page ↑