Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 01/05/2010, à 19:16

compte supprimé

[ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bonsoir!

Voila, tout est dans le titre: je cherche à virer pulseaudio.
Pourquoi? Parce qu'avec, le son est 50 fois trop fort (mais vraiment: limite je pourrais sonoriser un 600m² au plus bas niveau de volume). Le bug est connu, mais le statut sur launchpad n'est pas très encourageant: "wont fix".
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/410948

Virer pulseaudio via synaptic équivaut a virer tout le système, ce qui rend évidemment cette méthode inacceptable.

Voila, si quelqu'un sait comment je pourrais revenir à alsa sans foutre en l'air mon système, ce serait génial.

Merci à tous d'avance! big_smile*



Edit: la solution.
- Virer pulseaudio dans synaptic. Ça fera aussi dégager indicator-sound et ubuntu-desktop, donc il faudra ensuite être prudent sur les mises à jour/apt-get autoremove (risque de virer tout le système).
- Ajouter les dépôts audiohacks:

deb http://ppa.launchpad.net/dtl131/ppa/ubuntu lucid main 
deb-src http://ppa.launchpad.net/dtl131/ppa/ubuntu lucid main

- installer gnome-media, gnome-applets
- rebooter
Ajouter l'applet 'contrôle de volume" sur le tableau de bord.
Et voila!

Dernière modification par monsieurweller (Le 02/05/2010, à 16:17)

#2 Le 01/05/2010, à 20:54

sioc

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

bonjour,

Pour un problème de carte son en conflit avec Pulse (je n'avais pas de son du tout) j'ai viré Pulse avec la commande suivante :

sudo apt-get remove --purge pulseaudio

Après redémarrage j'ai eu du son sans problème, gérer par alsa.

Seul problème, plus de controleur de son. J'ai installé alsa gnome mixer (par synaptic), bidouillé un peu dedans pour trouver les curseurs qui controle mon son et ça marche.

Je ne sais pas si ça va résoudre ton problème de puissance sonore... En tous cas virer pulse ne détruit pas le son puisqu'il reste alsa qui se débrouille très bien seul (oui je sais... À quoi sert pulseaudio ? Nous sommes très nombreux à nous poser la question). Et tu peux toujours réinstaller pulse si la manip n'a aucun effet...

François

Hors ligne

#3 Le 01/05/2010, à 21:01

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Merci pour ta réponse smile.

sioc a écrit :

bonjour,

Pour un problème de carte son en conflit avec Pulse (je n'avais pas de son du tout) j'ai viré Pulse avec la commande suivante :

sudo apt-get remove --purge pulseaudio

Après redémarrage j'ai eu du son sans problème, gérer par alsa.

Si je fais ça, j'ai la tonne de trucs qui dégage (dont les applet, openshot et ubuntu-desktop, ce dernier fait qu'au prochain apt-get autoremove j'ai tout le système qui dégage: je préfère éviter hmm).

Seul problème, plus de controleur de son. J'ai installé alsa gnome mixer (par synaptic), bidouillé un peu dedans pour trouver les curseurs qui controle mon son et ça marche.

C'est assez embêtant, parce que l'applet est assez pratique. sad

Je ne sais pas si ça va résoudre ton problème de puissance sonore... En tous cas virer pulse ne détruit pas le son puisqu'il reste alsa qui se débrouille très bien seul (oui je sais... À quoi sert pulseaudio ? Nous sommes très nombreux à nous poser la question). Et tu peux toujours réinstaller pulse si la manip n'a aucun effet...

Le truc c'est que pulseaudio apporte pleins de feature sympa, dont pouvoir régler individuellement le niveau sonore de chaque application lancée.
Le truc c'est que ce goret semble rehausser, par rapport à alsa (qui lui marchait bien sur la 9.04 après avoir viré proprement pulseaudio, ce qui n'est plus possible visiblement)), le niveau sonore de quelques dizaines de dB. C'est gênant.

#4 Le 01/05/2010, à 23:50

sioc

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Pourquoi ne pas réinstaller, après avoir virer pulse, ubuntu-desktop, pour ne parler que de lui?

Hors ligne

#5 Le 02/05/2010, à 00:00

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

sioc a écrit :

Pourquoi ne pas réinstaller, après avoir virer pulse, ubuntu-desktop, pour ne parler que de lui?

Parce qu'il remettrait surement pulseaudio, et pleins de truc chiants que j'ai déja viré (genre les jeux par défaut, pitivi...).

Je vais tester ça, en espérant que ça marche aussi sur ubuntu:

Disabling pulseaudio completely (ALSA fall-back)

Under openSUSE 11.2, pulseaudio is the audio subsystem of choice for all GNOME based applications. This may cause various coexistence problems, especially in relation to phonon, KDE's sound subsystem that uses ALSA. A very common symptom is that ALSA audio is unable to acquire real-time (or more precisely near-real-time) scheduling, in effect causing delayed and/or clipped sound. Many have found that disabling pulseaudio completely, and thus forcing all GNOME based applications to use ALSA, works much better for them. To accomplish this do the following:

    * Disable pulseaudio:

setup-pulseaudio --disable

    * Remove all pulseaudio packages except libpulse-mainloop-glib0 and libpulse0, as these are required by all GNOME based applications (since they are compiled with pulseaudio by default).
    * Hide the libraries provided by the libpulse-mainloop-glib0 and libpulse0 packages, in order to force GNOME applications to ALSA fall-back. To do this, move them out of the way by issuing the following commands as root (openSUSE 11.2 x86_x64 assumed):

cd /usr/lib64
md HIDDEN
mv *pulse* HIDDEN
ldconfig

Note that if under $HOME/.pulse you have properly setup configuration files (e.g. from when pulseaudio was enabled), the last step above for hiding the pulseaudio libraries may not be required. However, if you accidentally (or intentionally) delete $HOME/.pulse, GNOME based applications will loose audio once again. Regardless of the contents of /etc/asound.conf, moving the libraries out of the way is the only guaranteed method to force fall-back to ALSA.

    * Use an ALSA compatible mixer (e.g. kmix under KDE or alsamixer in a terminal) and make sure all channels of interest are not muted.

Note that this is a work-around, not a definite solution: if either the libpulse-mainloop-glib0 and/or the libpulse0 package is updated, you will need to reissue the above commands to move the pulseaudio libraries out of the way once again.

Edit: marche pas. La commande setup-pulseaudio n'existe pas et pulseaudio --disable renvoie un gros message d'erreur. Je continuerais demain.

Dernière modification par monsieurweller (Le 02/05/2010, à 00:06)

#6 Le 02/05/2010, à 00:14

sioc

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Tiens nous au courant ! Ça m'intéresse de virer pulse-audio sans dommages co-latéraux.

Hors ligne

#7 Le 02/05/2010, à 00:21

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Copier le fichier /etc/pulse/client.conf dans son répertoire $HOME/.pulse/ et remplacer la ligne

; autospawn = yes

par

autospawn = no

puis tuer pulseaudio par

$ pulseaudio -k

L'affaire est classée. Et pour que pulseaudio ne redémarre pas à la session suivante, il suffit créer un fichier .pulse_a11y_nostart à la racine de son répertoire $HOME

$ touch ~/.pulse_a11y_nostart

Si on change d'avis, il suffit de relancer pulseaudio

$ pulseaudio --start

et de remettre autospawn en commentaire (";") ou à yes. Pour un redémarrage normal à la session suivante, il suffira juste de virer le fichier "~/.pulse_a11y_nostart"...

Hors ligne

#8 Le 02/05/2010, à 10:27

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

alej a écrit :

Copier le fichier /etc/pulse/client.conf dans son répertoire $HOME/.pulse/ et remplacer la ligne

; autospawn = yes

par

autospawn = no

puis tuer pulseaudio par

$ pulseaudio -k

L'affaire est classée. Et pour que pulseaudio ne redémarre pas à la session suivante, il suffit créer un fichier .pulse_a11y_nostart à la racine de son répertoire $HOME

$ touch ~/.pulse_a11y_nostart

Si on change d'avis, il suffit de relancer pulseaudio

$ pulseaudio --start

et de remettre autospawn en commentaire (";") ou à yes. Pour un redémarrage normal à la session suivante, il suffira juste de virer le fichier "~/.pulse_a11y_nostart"...

Merci pour l'astuce! big_smile
Malheureusement ça ne marche pas chez moi: pulseaudio continue à spawner (j'ai bien décommenté le truc, je ne suis pas totalement branque quand même tongue).



Edit:
Bon et sinon, j'ai viré le paquet pulseaudio. Ça m'a fait dégager indicator-sound et ubuntu-desktop. Faudra que je me passe d'apt-get autoremove.
J'ai remis alsa dans gstreamer-proprieties, et alsa marche. Mais j'ai plus d'applet. Je me débrouille avec alsamixer, mais j'aimerais bien la récupérer, l'applet.

La j'ai plus d'applet de contrôle du son. J'ai pu lire sur ubuntuforums qu'on peut compiler indicator-applet sans le support pulseaudio. Je vais aller voir ça. Et j'essayerais le cas échéant de remettre la bonne vieille gnome-mixer-applet (qui n'est plus dans les dépôts).

Dernière modification par monsieurweller (Le 02/05/2010, à 10:43)

#9 Le 02/05/2010, à 10:46

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

monsieurweller a écrit :

j'ai bien décommenté le truc

C'est pas tant qu'il faille décommenter la ligne que mettre la variable à "no" (elle est à "yes" par défaut si la ligne est commentée). Et ~/.pulse/client.conf a priorité sur /etc/pulse/client.conf (extrait du man)

       ~/.pulse/client.conf,  /etc/pulse/client.conf:  configuration  settings
       for  PulseAudio  client applications. If the version in the user's home
       directory does not exist the global configuration file is  loaded.  See
       pulse-client.conf(5) for more information.

En tout cas, chez moi© big_smile, ça fonctionne sous karmic et sous lucid...

Hors ligne

#10 Le 02/05/2010, à 10:56

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

alej a écrit :
monsieurweller a écrit :

j'ai bien décommenté le truc

C'est pas tant qu'il faille décommenter la ligne que mettre la variable à "no" (elle est à "yes" par défaut si la ligne est commentée). Et ~/.pulse/client.conf a priorité sur /etc/pulse/client.conf (extrait du man)

       ~/.pulse/client.conf,  /etc/pulse/client.conf:  configuration  settings
       for  PulseAudio  client applications. If the version in the user's home
       directory does not exist the global configuration file is  loaded.  See
       pulse-client.conf(5) for more information.

En tout cas, chez moi© big_smile, ça fonctionne sous karmic et sous lucid...

J'ai bien évidemment mis "no". wink

#11 Le 02/05/2010, à 11:02

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

monsieurweller a écrit :

J'ai bien évidemment mis "no"

J'm'en doutais un peu mais vu qu'on ne sait jamais vraiment à qui on a affaire ici, j'aimais autant préciser big_smile

Hors ligne

#12 Le 02/05/2010, à 11:15

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

P.S. J'ai pas testé mais ça pourrait t'intéresser...

Hors ligne

#13 Le 02/05/2010, à 11:24

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

alej a écrit :

P.S. J'ai pas testé mais ça pourrait t'intéresser...

Mais c'est parfait!!!!
Merci beaucoup, je vais tester ça! big_smile:D:D

#14 Le 02/05/2010, à 11:51

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Yes, ça marche!!!!!!
Merci beaucoup!

#15 Le 02/05/2010, à 15:10

Bionet

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bonjour,

j'ai regardé rapidement https://launchpad.net/~dtl131/+archive/ppa mais je dois bien avouer ne pas avoir compris ce qu'il fallait réellement installer (ou désinstaller) pour obtenir le résultat tant attendu et obtenu par monsieurweller.  Pour ma part, j'ai du son qui crache avec PulseAudio et du son nickel mais toujours à fond en retirant le paquet (et plus d'indicator sound non plus...).

je pense que cette alternative pourrait être profitable pour mon système.

bien cordialement,
Bionet

Hors ligne

#16 Le 02/05/2010, à 15:30

Bionet

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bonjour (re),

Pour ma part, j'ai mis en place la liste des dépôts PPA en question (noter que la signature n'est pas valide soit dit en passant). La mise à jour des dépôt s'est traduite par une installation de quasiment tous les packages (sauf le libcanbera0 qui demande une mise à jour partielle ! alors que je suis en 10.04, évidemment il n'y a aucune mise à jour qui fonctionne).

Une fois tous ces packages installés, j'ai le choix du son dans GnomAlsaMixer (ou dans le contrôleur de volume) mais des applications comme Skype n'offrent toujours que PulseAudio (et le son est toujours aussi pourri).

monsieurweller a du faire d'autres modifications pour que le système fonctionne.

bien cordialement,

Bionet

Hors ligne

#17 Le 02/05/2010, à 15:41

Pacifick_FR42

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

monsieurweller a écrit :
alej a écrit :

P.S. J'ai pas testé mais ça pourrait t'intéresser...

Mais c'est parfait!!!!
Merci beaucoup, je vais tester ça! big_smile:D:D

Salut @tous ! smile
Bon... je suis pas super anglophone...

Je me suis pas encore penché sur le problème, mais :
pulseaudio -k
tue le server, mais... il redémarre aussitôt !
Je pense qu'il faudrait tous simplement empécher le deamon de redémarrer mais... comment ?
Car impossible de désinstaller Pulse...


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#18 Le 02/05/2010, à 15:42

Bionet

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bonjour,

et la démarche donnée par alej fonctionne à un bémol prêt c'est que je ne peux plus du tout régler le volume sonore (aucun des contrôleurs ne fonctionne, même pas gnome alsa mixer).

monsieurweller, peux-tu repasser ce thread en non-résolu car nous sommes plusieurs à avoir le même soucis avec pulse-audio et il faut qu'on arrive à trouver une solution reproductible.

Bien cordialement,

Bionet

Hors ligne

#19 Le 02/05/2010, à 15:54

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Pacifick_FR42 a écrit :

pulseaudio -k
tue le server, mais... il redémarre aussitôt !

D'où l'"autospawn" à ... no !!!

Hors ligne

#20 Le 02/05/2010, à 16:00

Bionet

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bonjour,

il faudrait peut-être voir si le paramétrage de pulseaudio ne serait pas suffisant : http://www.clapico.com/2010/05/01/pulse-audio-mixer/

bien cordialement,

Patrice

Hors ligne

#21 Le 02/05/2010, à 16:15

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bionet a écrit :

Bonjour,

j'ai regardé rapidement https://launchpad.net/~dtl131/+archive/ppa mais je dois bien avouer ne pas avoir compris ce qu'il fallait réellement installer (ou désinstaller) pour obtenir le résultat tant attendu et obtenu par monsieurweller.  Pour ma part, j'ai du son qui crache avec PulseAudio et du son nickel mais toujours à fond en retirant le paquet (et plus d'indicator sound non plus...).

En fait, ce dépôt permet de réinstaller l'ancien contrôleur sonore (gestion d'alsa), et son applet. Il va pour cela mettre a jour gnome-media, et il faudra installer le paquet d'applet (et redémarrer pour voir les applets dans le menu de sélection des applets).
-> Applet= petit truc sur le tableau de bord qui te permet de régler le son.

Sans ce contrôleur, pour régler les niveau il faut obligatoirement passer par alsamixer (ligne de commande), ce qui est gênant.

Donc dans mon cas j'ai viré pulseaudio, remis l'applet de gnome, et basta, je suis de retour avec alsa.

Donc: il faut désinstaller pulseaudio.
Pour ton problème avec skype et autres:
Lance dans un terminal:

gstreamer-properties

Et met tout sur "ALSA" dans l'onglet audio. Tu fais ainsi en sorte que gstreamer utilise alsa pour lire les fichiers.

Pour skype: regarde dans les options de skype et paramètre sur ALSA si possible.

Bionet a écrit :

Bonjour,

et la démarche donnée par alej fonctionne à un bémol prêt c'est que je ne peux plus du tout régler le volume sonore (aucun des contrôleurs ne fonctionne, même pas gnome alsa mixer).

monsieurweller, peux-tu repasser ce thread en non-résolu car nous sommes plusieurs à avoir le même soucis avec pulse-audio et il faut qu'on arrive à trouver une solution reproductible.

Bien cordialement,

Bionet

Normal: l'indicator-applet ne gère que pulseaudio, et tant que pulseaudio est présent, alsamixer foire (règle un niveau et tu dérègle les autres).

Bionet a écrit :

Bonjour,

il faudrait peut-être voir si le paramétrage de pulseaudio ne serait pas suffisant : http://www.clapico.com/2010/05/01/pulse-audio-mixer/

bien cordialement,

Patrice

Malheureusement non: cet idiot de pulseaudio coupe le son si je descend le niveau sonore en dessous de 25%, ne me permet pas de régler le LFE (subwoofer) de mon portable, et toucher une jeauge d'alsamixer en la présence de pulseaudio, modifie toute les autres.
Et enfin, au strict minimum (donc 25%), pulseaudio fait en sorte que mon PC portable puisse sonoriser un concert.

Dernière modification par monsieurweller (Le 02/05/2010, à 16:20)

#22 Le 02/05/2010, à 16:18

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

Bionet a écrit :

la démarche donnée par alej fonctionne à un bémol prêt c'est que je ne peux plus du tout régler le volume sonore (aucun des contrôleurs ne fonctionne, même pas gnome alsa mixer)

Je viens de tester - pour la dernière fois - sous karmic - vu que je suis en train de "migrer" - et avec pulseaudio à l'arrêt, alsamixer, p.e., fonctionne parfaitement...

Hors ligne

#23 Le 02/05/2010, à 17:38

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

monsieurweller a écrit :

Malheureusement non: cet idiot de pulseaudio coupe le son si je descend le niveau sonore en dessous de 25%, ne me permet pas de régler le LFE (subwoofer) de mon portable, et toucher une jeauge d'alsamixer en la présence de pulseaudio, modifie toute les autres

Si tu ne veux pas que pulseaudio touche à un/des contrôles d'alsamixer, il suffit de lui demander gentiment... big_smile

Hors ligne

#24 Le 02/05/2010, à 18:22

compte supprimé

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

alej a écrit :
monsieurweller a écrit :

Malheureusement non: cet idiot de pulseaudio coupe le son si je descend le niveau sonore en dessous de 25%, ne me permet pas de régler le LFE (subwoofer) de mon portable, et toucher une jeauge d'alsamixer en la présence de pulseaudio, modifie toute les autres

Si tu ne veux pas que pulseaudio touche à un/des contrôles d'alsamixer, il suffit de lui demander gentiment... big_smile

J'avais mis ce lien dans mon premier post, et précisé le statut du bug: "won't fix" (=ne veut pas se corriger). tongue
Ce bug traine depuis karmic, et touche énormément de gens. Et ne veut donc pas se corriger.
Tout ça n'est pas de très bonne augure. hmm

#25 Le 02/05/2010, à 18:44

alej

Re : [ubuntu 10.04] Virer pulseaudio (ou le désactiver)

monsieurweller a écrit :

J'avais mis ce lien dans mon premier post

Justement ! J'ai peut-être pas tout compris mais si tu ne veux pas que pulseaudio touche au contrôle LFE, p.e., c'est 10 fois + facile de faire ce qui est indiqué dans ce topic que de faire ce que tu as fait, non ?

Hors ligne

Haut de page ↑