Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 23/05/2005, à 14:39

Orphée

[hoary]Xine et esd

Bonjour à tous, voila j'ai un petit soucis avec Xine, il tourne tres bien sauf que, je suis obligé de le lancer en console avec "xine -A esd"
j'ai tenté de faire un raccourci de cette commande, mais rien y fait il ne prend pas en compte "-A esd" ailleurs que qd je le tappe dans la console, j'aimerai pouvoir automatiser ca roll
si vous pouvez m'aider smile merci d'avance

Hors ligne

#2 Le 23/05/2005, à 20:08

manal

Re : [hoary]Xine et esd

Regarde dans le fichier ~/.xine/config
Tu dois avoir une ligne "audio.driver". Chez moi elle est en commentaire et fixée à "auto". Essaie de voir de ce coté.


Libère ton esprit, et ton cul suivra

Hors ligne

#3 Le 24/05/2005, à 11:26

O.

Re : [hoary]Xine et esd

Dans les options de Xine tu peux déterminer le driver utilisé. Il faut te mettre en "master of the known universe" sur la première page des options, et ensuite c'est sur l'onglet "audio".

En parlant de ça, j'ai renoncé à utiliser ESD avec Xine, ça me décale systématiquement le son et l'image. C'est n'importe quoi, et pas moyen de trouver comment forcer la synchro. Moralité, quand je veux voir un film, je flingue le process "esd" et je lance xine avec ALSA. Quitte à relancer esd quand j'ai fini, parce que cette faigneasse de Rhythmbox refuse de fonctionner avec quoi que ce soit d'autre que ESD.

Quelqu'un peut m'expliquer :

- pourquoi il y a de la latence dans ESD ?
- combien ?
- comment contourner la difficulté ?

Je précise : j'ai lu l'article pour utiliser "dmix" avec ALSA. Quand je fais ça, ça me dit que le fichier de conf (qui vient de l'article en copier-coller) est vérolé, obsolete, pas bon, moche, etc.). Et naturellement ça ne marche pas.


Erreur : pas de clavier détecté. Appuyer sur F1 pour continuer

Hors ligne

#4 Le 24/05/2005, à 12:38

dawar

Re : [hoary]Xine et esd

Il y'a une latence avec ESD car c'est un serveur son, donc un programme qui tourne avec tes droits, et qui est (a mon avis) super mal foutu...

Pour dmix, ça ne marche pas forcément avec toutes les cartes son, essai de chercher ton modèle/chipset/module sur http://alsa.opensrc.org/index.php?page=AlsaOpensrcOrg


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#5 Le 24/05/2005, à 12:42

O.

Re : [hoary]Xine et esd

Excellent site ! Je sais maintenant à quoi occuper mon après-midi... je teste ce soir et je te dis si j'ai trouvé mon bonheur !


Erreur : pas de clavier détecté. Appuyer sur F1 pour continuer

Hors ligne

#6 Le 24/05/2005, à 14:12

Orphée

Re : [hoary]Xine et esd

Alors, j'ai mis en master of machin, du coup j'ai les options dans audio, mais j'ai ni alsa ni esd, je n'ai que OSS.. ca marche avec OSS, mais toujours est il que des que j'en fais un raccourci, pas de son! maintenant je ne suis plus obligé de lancer xine -A esd en console juste xine mais toujours en console ...
une idée ? :s

Hors ligne

Haut de page ↑