Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 06/06/2010, à 11:05

Syrtacryptus

écrire le chinois aur ubuntu 10.04

Bonjour, je n'arrive pas à configurer correctement SCIM, enfin c'est ce que j'en conclus puisque cela ne marche pas du tout. Normalement il suffit de faire ctrl+space pour ouvrir la méthode de saisie,  mais là rien ne se passe ??
Si vous avez une idée, elle sera très bien venue big_smile

Hors ligne

#2 Le 06/06/2010, à 16:35

mondai

Re : écrire le chinois aur ubuntu 10.04

essaie avec ibus mdrrr

EDIT : maintenant on utilise ibus-anthy pour le japonais, et pour le chinois c'est aussi ibus maintenant il me semble.

Dernière modification par mondai (Le 06/06/2010, à 16:36)

Hors ligne

#3 Le 07/06/2010, à 19:37

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

sad rien à faire ! cela ne marche pas non plus ? est-ce qu'il faut faire un réglage particulier en utilisant un terminal ? SCIM ne marche pas non plus, pourtant j'ai téléchargé tous les paquets indiqués...

Hors ligne

#4 Le 07/06/2010, à 21:15

mondai

Re : écrire le chinois aur ubuntu 10.04

ok, bon.

T'utilise ubuntu avec gnome ?

Est-ce que tu arrive à écrire en chinois quand tu fais :

GTK_IM_MODULE=ibus gedit

?
Ou si t'utilise kde essaie :

QT_IM_MODULE=ibus kwrite

Si ça marche, alors mets entre ceci dans un terminal :

nano ~/.xinitrc

Puis fais copier coller de ceci :

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon --xim -d &

Ensuite entre ctrl+o puis ctrl+x pour quitter, redémarre, et vois si ça marche

Dernière modification par mondai (Le 07/06/2010, à 21:16)

Hors ligne

#5 Le 07/06/2010, à 22:19

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

lol j'utilise gnome. le problème c'est que le chinois n'est pas dans les langues optionnelles de gedit !  Pourtant j'ai bien le chinois simplifié pris en charge enfin c'est ce qui est indiqué ... ?
ce code : GTK_IM_MODULE=ibus gedit ouvre bien gedit  mais pas de chinois en ligne lol

Hors ligne

#6 Le 07/06/2010, à 22:48

mondai

Re : écrire le chinois aur ubuntu 10.04

mdrrrr ok

J'ai écris un peu vite en fait et si ibus est bien installé c'est qu'il faudrait que t'essaie de faire :

ibus-daemon

puis

ibus-setup

Une fois la fenêtrev de ibus-setup apparue, tu rajoute le chinois, ensuite tu fais :

GTK_IM_MODULE=ibus gedit

Et ça devrait marcher quand tu fais ctrl+space.

Si ça marche après tu fais comme je t'ais dit. J'ai jamais bcp utilisé gnome, et là j'utilise openbox du coup j'ai plus en tête comment ça se présente, mais normalement au lieu de rajouter le ibus-daemon dans ton xinitrc tu peux le mettre avec l'interface graphique de gnome (installée par défaut) dans la partie système (mais j'ai oublié où et comment ça s'appelle)

Dernière modification par mondai (Le 07/06/2010, à 22:49)

Hors ligne

#7 Le 08/06/2010, à 12:09

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

big_smile ça marche, merci bien... mais ... je dois toujours passer par le terminal pour afficher le clavier pinyin, donc mon problème semble être un pb de raccourci clavier.
On avance lol

Hors ligne

#8 Le 08/06/2010, à 23:08

mondai

Re : écrire le chinois aur ubuntu 10.04

mdrrr

mais t'as fait comme je t'ai dit après ? On peut remplacer nano par gedit lol

gedit ~/.xinitrc

puis fais copier-coller de ce ça :

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon --xim -d &

sinon par rapport à ton analyse des observations :

donc mon problème semble être un pb de raccourci clavier.

À priori je ne vois pas pourquoi il y aurait un problème de raccourci clavier. Le problème est : faire marcher ibus. Nous observons que ibus marche avec le daemon et la commande que t'as rentré. Nous pouvons en déduire qu'il faut que le daemon se lance au démarrage et qu'il faut qu'il y ait export GTK_IM_MODULE=ibus pour les applications gtk par exemple.

Hors ligne

#9 Le 08/06/2010, à 23:27

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

big_smile ben y veut pas exporter ! lol
Je dois faire une mauvaise manip quelque part mais je ne vois pas où puisque dans le terminale je colle tes infos. Tant que le terminal est ouvert ça marche très bien mais si je le ferme je n'ai plus accès au "clavier" chinois et ctrl+space quand gedit est ouvert ne donne rien.
merci beaucoup de prendre mon petit problème à cœur.

Hors ligne

#10 Le 09/06/2010, à 01:17

mondai

Re : écrire le chinois aur ubuntu 10.04

Ok ça doit être un oubli ou une omission de ta part.

Là j'ai retiré ubuntu y a pas longtemps pour mettre archlinux, et je suis sous openbox mais normalement les packages sont similaires pour ce qui concerne ibus.
moi quand je fais yaourt -Ss ibus j'ai ceci :

$ yaourt -Ss ibus
core/libusb 0.1.12-4 [installé] (base)
  Library to enable user space application programs to communicate with USB devices
extra/libusb1 1.0.8-1 [installé]
  Library to enable user space application programs to communicate with USB devices.
extra/scribus 1.3.6-2
  A desktop publishing program
community/ibus 1.3.4-1 [installé]
  Next Generation Input Bus for Linux
community/ibus-anthy 1.2.0.20100313-2 [installé]
  Japanese input method Anthy IMEngine for IBus Framework
community/ibus-pinyin 1.3.8-1 [installé]
  The PinYin Engine for IBus Input Framework
community/ibus-sogoupycc 0.2.5-1 [installé]
  A Sogou cloud client and Chinese input method on ibus platform.
community/ibus-sunpinyin 2.0-2 [installé]
  The SunPinYin Engine for IBus Input Framework. SunPinYin is a Statistical Language Model based pinyin IME by Sun.
community/ibus-table 1.2.0.20100111-2 [installé]
  The IM Engine framework for table-based input methods, such as ZhengMa, WuBi, ErBi, CangJie and so on.
community/ibus-table-extraphrase 1.2.0.20100305-1 [installé]
  The extra phrases of tables engines for IBus.
community/ibus-table-wubi 1.2.0.20091227-1 [installé]
  The Wubi Input Method of tables engines for IBus.

[.... le reste on s'en fout lol]

Là où tu vois  [installé], alors installe...bref, installe tout quoi comme ça tu sera sûr de rien oublier. D'autant plus que moi c'est japonais et pour le chinois je suis pas sûr de ce qu'il faut installer exactement.

Sur ubuntu, pour voir les paquets que t'as soit tu vas dans synaptic et tu cherche "ibus-" ; soit tu ouvre un terminal et tu entre ce qui suit :

sudo apt-get install ibus-*

Normalement, ça devrait tt installer ce qui est avec ibus.

Après, si ça marche pas alors montre moi ce que tu obtiens quand tu fais ceci :

cat ~/.xinitrc

Moi ça marche très bien. Je te montre des captures d'écran en relation avec ce que je t'ai dit précédemment, ça te parlera peut-être plus.
Une capture avec les paquets que j'ai installé et ce que je peux sélectionner avec ibus-setup :
1276038736.png
Et une autre capture d'écran avec .xinitrc :
1276038953.png
Toi dans ton .xinitrc si t'utilise pas openbox tt'as pas besoin de tout ce que j'ai mis, mais juste ça très exactement :

#!/bin/sh
# This shell script is run before Openbox launches.
# Environment variables set here are passed to the #Openbox session.

/usr/bin/ibus-daemon --xim -d &
export  IBUS_SESSION_ID=`mktemp -u XXXXXXXX`
export  GTK_IM_MODULE=ibus
export  QT_IM_MODULE=ibus
export  XMODIFIERS=@im=ibus

Edit : au cas où ce que je t'ai dit ne marcherait pas, fait moi une capture d'écran de ce que t'as installé dans synaptic qui a un rapport avec ibus, et fait copier-coller de ce que t'obtiens quand tu fais "sudo locale-gen" dans un terminal, et ce que t'as quand tu fais "cat ~/.xinitrc"

Dernière modification par mondai (Le 09/06/2010, à 01:38)

Hors ligne

#11 Le 09/06/2010, à 21:29

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

big_smile merci beaucoup, je vais faire ta manip, en fait il me demande d'ouvrir le fichier $Home.bashrc, mais je ne trouve pas ce dossier... j'en ai fait un au cas où pour y copier comme indiquer :export GTK_IM_MODULE=ibus
  export XMODIFIERS=@im=ibus
  export QT_IM_MODULE=ibus
mais ce la n'a rien donné
Merci encore

Hors ligne

#12 Le 09/06/2010, à 22:00

alej

Re : écrire le chinois aur ubuntu 10.04

Comme Syrtacryptus n'a pas daigné me répondre dans l'autre topic qu'il a ouvert sur le sujet, j'vais mettre ici, pour les ceusses que ça peut/pourra intéresser, une méthode pour ubuntu lucid telle qu'installée par défaut...

On vire ibus-m17n, sauf à en avoir vraiment l'usage mais qui ne sert à rien dans le cas d'espèce, à part à donner une tripotée de méthodes d'entrée pour le chinois, ce qui ne peut qu'ajouter à la confusion...

sudo apt-get --purge autoremove ibus-m17n

Il reste donc (et encore, on doit encore pouvoir gicler ibus-table si on n'en a pas l'usage, p.e., mais bon)...

ibus ibus-gtk ibus-table libibus1 python-ibus

On installe ibus-pinyin (et ses 2 dépendances)...

sudo apt-get install ibus-pinyin

Et sur la base de sa localisation, on met un coup de im-switch. Par exemple, pour une localisation en fr_FR...

im-switch -z fr_FR -s ibus

Puis on quite sa session, on se reconnecte et dans les préférences d'ibus (Système --> Préférences --> Préférences d'IBus - onglet Méthode d'entrée --> Sélectionner une méthode d'entrée ---> Ajouter) on choisit "Chinois - Pinyin".

Le coup d'"im-switch" a créé un lien symbolique "~/.xinput.d/fr_FR" qui pointe sur "/etc/X11/xinit/xinput.d/ibus", ce qui a pour effet de faire démarrer le démon automatiquement au démarrage de la session et de positionner les variables d'environnement.

Un coup de "Ctrl + Espace" et l'affaire est classée...

capturealexnada1.th.png

Dernière modification par alej (Le 09/06/2010, à 22:12)

Hors ligne

#13 Le 10/06/2010, à 12:41

Syrtacryptus

Re : écrire le chinois aur ubuntu 10.04

wink pardon pardon pardon .... Finalement j'ai viré ubuntu et je l'ai réinstallé, il devait y avoir un bug quelque part, maintenant tout marche très bien tongue

Hors ligne

#14 Le 10/06/2010, à 13:00

mondai

Re : écrire le chinois aur ubuntu 10.04

mdrrrrr lol

Hors ligne

#15 Le 10/06/2010, à 18:28

alej

Re : écrire le chinois aur ubuntu 10.04

Syrtacryptus a écrit :

il devait y avoir un bug quelque part

... entre la chaise et le clavier wink

P.S. J'allais oublier ....... mdrrrr lol

Hors ligne

Haut de page ↑