Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 25/06/2006, à 20:15

Geoffrey

Conflits de dépendances

Depuis quelques jours, j'ai des conflits de dépendance.
Pourtant je n'ai que des dépots Ubuntu.


geoffrey@606-LTS:~$ sudo apt-get clean
geoffrey@606-LTS:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
geoffrey@606-LTS:~$ install kdebase-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  kdebase-dev: Dépend: kate (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: kdesktop (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: kicker (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: konqueror-nsplugins (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: konqueror (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: ksysguard (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: kwin (= 4:3.5.2-0ubuntu27) mais 4:3.5.3-0ubuntu0.1 devra être installé
               Dépend: kdelibs4-dev (>= 4:3.5-rc1) mais ne sera pas installé
E: Paquets défectueux
geoffrey@606-LTS:~$ install kdelibs-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Note, sélection de kdelibs4-dev au lieu de kdelibs-dev
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  kdelibs4-dev: Dépend: kdelibs4c2a (= 4:3.5.2-0ubuntu18) mais 4:3.5.3-0ubuntu0.1 devra être installé
                Dépend: kdelibs-bin (= 4:3.5.2-0ubuntu18) mais 4:3.5.3-0ubuntu0.1 devra être installé
                Dépend: libarts1-dev (>= 1.5-rc1) mais ne sera pas installé
E: Paquets défectueux
geoffrey@606-LTS:~$

ca me le fait avec beaucoup d'autres paquets aussi, j'approche la paralysie

Hors ligne

#2 Le 25/06/2006, à 21:25

Smarter

Re : Conflits de dépendances

On dirait que tu as KDE 3.5.3 (pas dans les dépots officiels) mais que kdebase-dev n'est pas en 3.5.3! C'est bizarre hmm
Tu peut toujours essayer de passer complétement à la 3.5.3 en ajoutant cette ligne à ton /etc/apt/sources.list (sans trop de risque)

## KDE 3.5.3
deb http://www.kubuntu.org/packages/kde-353 dapper main

Hors ligne