Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 06/07/2010, à 12:20

toto_away

script au démarrage pour mode powersave

Bonjour,
Voilà je vous expose la situation:
j'ai un vieux portable avec un P4 3,06 Ghz qui chauffe pas mal. Dans le moniteur de changement de fréquences je peux choisir entre différents modes et les fréquence 1.60 Ghz et 3,06 GHz.
J'ai cherché le moyen de fixer la fréquence 1.60  (mode powersave) au démarrage car cette fréquence me convient pour les taches quotidiennes et baisser le bruit du ventilo.

J'ai donc édité le fichier /etc/rc.local comme ci dessous:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
bash /home/notebook/.script/power
exit 0

et j'ai créer un autre script /home/notebook/.script/power

#!/bin/sh -e
#power
echo powersave > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
#FIN DE power
exit 0

Le script ne marchait pas vraiment avant que je désactive le service de gestion d'énergie. cela ne me pose pas de problème de désactiver la gestion d'énergie car mon portable est toujours sur secteur.
Mais au démarrage je suis en mode powersave quelques secondes, puis quand le pc a tout chargé il se remet en mode performance.

Quelqu'un pour éclairer ma lanterne ?car là je sèche.
Merci d'avance.

Hors ligne

#2 Le 14/07/2010, à 21:21

toto_away

Re : script au démarrage pour mode powersave

yeahhhh! j'ai réussi! big_smile

En fait il fallait, empêcher daemon Jolicloud (j'ai la distribution jolicloud) de démarrer. Je crois que ça cherche les mises à jour, mais ce n'est pas grave, je les ferai manuellement.

Penser à désactiver la gestion d'énergie et si VLC est installé désactiver l'option qui justement désactive la gestion d'énergie (car apparemment vlc démarre la gestion d'énergie pour ensuite la désactiver...)

Voilouuuuu

Hors ligne

Haut de page ↑