Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 15/07/2010, à 18:42

dolger

[grub] line 20, commande introuvable [RÉSOLU]

bonjour j ai récemment voulu changer l odre de boot et a la fin ,d apres se que j ai compris faut fair "sudo update-grub" pour que la modification soit prise en compte. mais sa m ecrit

Searching for GRUB installation directory ... found: /boot/grub
/etc/default/grub: line 20: want : commande introuvable

merci de votre réponse et je suis que débutant smile

Dernière modification par dolger (Le 15/07/2010, à 19:52)

Hors ligne

#2 Le 15/07/2010, à 18:50

gl38

Re : [grub] line 20, commande introuvable [RÉSOLU]

Il faudrait que tu nous montres ton fichier /etc/default/grub

C'est un peu dangereux de toucher à grub quand on débute, il faut au moins sauvegarder les fichiers avant de les modifier pour pouvoir revenir en arrière en cas d'erreur qui empêche la machine de démarrer.

Cordialement,
Guy

Hors ligne

#3 Le 15/07/2010, à 18:59

dolger

Re : [grub] line 20, commande introuvable [RÉSOLU]

voici mon fichier grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="Windows NT/2000/XP (on /dev/sda1)"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=-1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Hors ligne

#4 Le 15/07/2010, à 18:59

sinbad83

Re : [grub] line 20, commande introuvable [RÉSOLU]

Bonjour,
pour éditer des fichiers, je te conseille gedit (que l'on lance avec gksu devant, équivalent de sudo pour les applications graphiques). Trois avantages, tu peux lui changer des préfèrences pour:
- faire apparaître les numéros de ligne
- faire par défaut une copie de sauvegarde
- mettre une coloration syntaxique
Doc sur http://coursinforev.ovh.org/dokuwiki/doku.php/edition_linux


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#5 Le 15/07/2010, à 19:06

dolger

Re : [grub] line 20, commande introuvable [RÉSOLU]

c es avec gedit que j ai modifier le fichier

Hors ligne

#6 Le 15/07/2010, à 19:12

sinbad83

Re : [grub] line 20, commande introuvable [RÉSOLU]

Là, n'est pas le problème, je te faisais part de réglages utiles pour Gedit.
Quelle est la fameuse ligne 20 du grub.cfg ?


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#7 Le 15/07/2010, à 19:17

gl38

Re : [grub] line 20, commande introuvable [RÉSOLU]

Il faudrait lire la doc de grub.

Tu as perdu une apostrophe dans la ligne
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian
ce qui met la zone dans la suite.

Je ne suis pas sûr que ta ligne
GRUB_DEFAULT="Windows NT/2000/XP (on /dev/sda1)"
soit correcte, puisqu'il y a un 0 (zéro) dans le fichier original.

Cordialement,
Guy

Hors ligne

#8 Le 15/07/2010, à 19:18

dolger

Re : [grub] line 20, commande introuvable [RÉSOLU]

a du grub cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd1,5)'
search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd1,5)'
search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
set locale_dir=($root)/boot/grub/locale
set lang=
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.32-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	linux	/boot/vmlinuz-2.6.32-22-generic root=UUID=6a2aa571-571c-43aa-8a55-caa322ded1ab ro   quiet splash
	initrd	/boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-22-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	echo	'Loading Linux 2.6.32-22-generic ...'
	linux	/boot/vmlinuz-2.6.32-22-generic root=UUID=6a2aa571-571c-43aa-8a55-caa322ded1ab ro single 
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	linux	/boot/vmlinuz-2.6.32-21-generic root=UUID=6a2aa571-571c-43aa-8a55-caa322ded1ab ro   quiet splash
	initrd	/boot/initrd.img-2.6.32-21-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-21-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	echo	'Loading Linux 2.6.32-21-generic ...'
	linux	/boot/vmlinuz-2.6.32-21-generic root=UUID=6a2aa571-571c-43aa-8a55-caa322ded1ab ro single 
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	linux16	/boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	insmod ext2
	set root='(hd1,5)'
	search --no-floppy --fs-uuid --set 6a2aa571-571c-43aa-8a55-caa322ded1ab
	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows NT/2000/XP (on /dev/sda1)" {
	insmod ntfs
	set root='(hd0,1)'
	search --no-floppy --fs-uuid --set 0cc46be3c46bcd90
	drivemap -s (hd0) ${root}
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

Hors ligne

#9 Le 15/07/2010, à 19:27

dolger

Re : [grub] line 20, commande introuvable [RÉSOLU]

c es bon c étai ` qui manquai
je vous remercie de votre aide:)

Hors ligne

#10 Le 15/07/2010, à 19:43

sinbad83

Re : [grub] line 20, commande introuvable [RÉSOLU]

N'oublie pas de rajouter Résolu dans ton titre. Merci.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

Haut de page ↑