Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/12/2006, à 13:01

john5168

Installer SALOME

Je cherche un logiciel de 3D méca type Workflow.
Avec plusieurs essais je ne suis jamais parvenu à installer graphiteone, donc maintenant je test Salome.

Sur la doc ubuntu ça et rien, je voie pas comment télécharger et installer salome.
la doc Ubuntu : http://doc.ubuntu-fr.org/applications/installation_de_salome
la page web de salome : http://www.salome-platform.org/download/dl322/
(ou est le lien de téléchargement ?)

Si vous avez déjà utilisé ce logiciel, comment avez vous fait et qu'en pensez vous ?
Merci.


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#2 Le 20/12/2006, à 13:25

Tom_L

Re : Installer SALOME

J'ai jamais utilisé ce logiciel mais ca peut m'interesser... Il faut être inscrit sur le site pour pouvoir télécharger, c'est écrit sur la page de téléchargement:

You have to be logged in to start downloading!

Des retours d'expérience avec ce logiciel sont les bienvenus...


~~~~~~
Thomas.

Hors ligne

#3 Le 20/12/2006, à 13:39

john5168

Re : Installer SALOME

ok merci pour l'info de l'enregistrement je n'avais pas vu,
quel idiot ces écris en rouge en plus,
Je le télécharge de suite je vous tien au courent.

A+


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#4 Le 20/12/2006, à 20:49

john5168

Re : Installer SALOME

J'ai télécharger la version pour debian sarge 3.1
Impossible de compiler car il me demande gcc version 3.3.5 alors que j'ai gcc 4.1.1

Avec la version only SALOME sources version 3.2.2, je me retrouve avec une tonne de dossier, je ne sais pas les quel compiler il en a trop pour tous les faire.

Y a t'il un paquet .deb sur le net pour salome.


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#5 Le 23/12/2006, à 10:49

john5168

Re : Installer SALOME

Personne utilise SALOME ?


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#6 Le 23/12/2006, à 13:03

Tom_L

Re : Installer SALOME

Salut,

J'ai pas trouvé de paquet deb....
Par contre j'ai trouvé ça:
http://www.caelinux.com

C'est en fait un liveDVD avec plein d'outils génie méca/civil dont SALOME+code ASTER préinstallé. J'ai pas pu tester mais ca m'a l'air pas mal, y'a des screenshots là:
http://www.caelinux.com/CMS/index.php?option=com_content&task=view&id=17&Itemid=2

Ca peut peut être t'aider à savoir si c'est ça qu'il te faut... Je testerai ça en rentrant de vacances...
A+


~~~~~~
Thomas.

Hors ligne

#7 Le 23/12/2006, à 20:43

scorpio810

Re : Installer SALOME

john5168 a écrit :

J'ai télécharger la version pour debian sarge 3.1
Impossible de compiler car il me demande gcc version 3.3.5 alors que j'ai gcc 4.1.1

Avec la version only SALOME sources version 3.2.2, je me retrouve avec une tonne de dossier, je ne sais pas les quel compiler il en a trop pour tous les faire.

Y a t'il un paquet .deb sur le net pour salome.

doc:http://doc.ubuntu-fr.org/materiel/modem_adsl_fast_800?s=gcc

Comment résoudre le problème de version du compilateur gcc ?

Rédigé par jmp

Attention pour compiler sur Breezy, la version du compilateur gcc n'est pas la bonne ! Le noyau a été compilé avec la 3.4 alors que c'est la 4.0 qu'il est livrée sur le CD... Il faut donc télécharger les paquets gcc-3.4, gcc-3.4-base et cpp-3.4 (je sais, il faut avoir une connexion qui marche pour faire ça !). Le plus simple est d'utiliser le moteur de recherche de paquets Ubuntu de Firefox (suivre le lien pour l'installer dans la barre de recherche). On les installe avec dpkg :

sudo dpkg -i gcc-3.4_3.4.4-6ubuntu8_amd64.deb gcc-3.4-base_3.4.4-6ubuntu8_amd64.deb cpp-3.4_3.4.4-6ubuntu8_amd64.deb

Bien sûr si vous n'êtes pas sur un AMD64, le nom des paquets est quelque peu différent ! Il faut ensuite momentanément faire pointer gcc sur gcc-3.4 :

export  CC=gcc-3.4 make

Il n'y a alors plus qu'à lancer sudo make install, sudo eagleconfig et sudo startadsl pour compiler le driver et lancer la connexion. On n'oubliera pas bien sûr de restaurer le bon gcc une fois le driver compilé !


"Le jour où tu découvres le Libre, tu sais que tu ne pourras jamais plus revenir en arrière..."

Hors ligne

#8 Le 18/01/2007, à 10:17

laruen

Re : Installer SALOME

bonjour john

Essaye donc un concurrent de SALOME
Il s'agit de COLLABCAD (logiciel venant de l'inde)
Ecrit en anglais mais partiellement modifiable je crois il faut voir la doc
Il fonctionne sous Linux et son "concurrent"
Il est fourni avec une doc multi langue(un peu petit negre car traduction automatique).

Avez vous resolu vos problemes avec G1
Moi j'en ai de plus en plus
Dur dur .........

Avec la bonne annee en prime  a+
laruen

Hors ligne

#9 Le 31/01/2007, à 12:43

james-blonde

Re : Installer SALOME

après beaucoup d'essais infructueux, j'ai trouvé un thread adapté sur le forum de salome http://www.salome-platform.org/forum/?groupid=10&forumid=9&thread=942
cela semble fonctionner impeccable,
plus qu'à apprendre...:cool:


HAEFFLER   
2006-11-17 15:38:34     quote
Thanks Vadim for your answer

I have all ready linked dash to sh : sudo ln -fs /bin/bash /bin/sh

I have install Salome on /opt/salome_3.2.2/
:  cd InstallWizard_3.2.2_DS/
./runInstall

I have edit env_build.sh
change "out_var=`echo $1 $2 | awk -v dir=$3 '{                   \"
to "out_var=`echo $1 $2 | awk -W sprintf=5060 -v dir=$3 '{   \"


I have edit KERNEL_3.2.2/salome.sh/salome.sh
- and change "out_var=`echo $1 $2 | awk -v dir=$3 '{                   \"
to "out_var=`echo $1 $2 | awk -W sprintf=5060 -v dir=$3 '{   \"

I have edit  KERNEL_3.2.2/bin/salome/runSalome
- add "source /opt/salome_3.2.2/env_build.sh"

Yet i can launch Salome with  KERNEL_3.2.2/bin/salome/runSalome

#10 Le 03/02/2007, à 13:03

john5168

Re : Installer SALOME

salut laruen,

Dit moi comment tu télécharge Callabcad sur http://www.collabcad.com.
Moi il me demande un loging et mot de passe.

Merci


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#11 Le 03/02/2007, à 14:22

scorpio810

Re : Installer SALOME

john5168 a écrit :

salut laruen,

Dit moi comment tu télécharge Callabcad sur http://www.collabcad.com.
Moi il me demande un loging et mot de passe.

Merci

tu t'enregistre c'est tout


"Le jour où tu découvres le Libre, tu sais que tu ne pourras jamais plus revenir en arrière..."

Hors ligne

#12 Le 03/02/2007, à 22:02

john5168

Re : Installer SALOME

merci j'ai installer collabcad avec un alien du .rpm

Résultat j'ai un dossier /usr/collabcad : mais aucun exécutable viable.
Que faire ?


Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#13 Le 04/02/2007, à 16:47

john5168

Re : Installer SALOME

j'ai fait un pas en avans.

sudo apt-get install csh ; Maintenant /usr/collabcad/collabcad ce lance.

Problème je choisi mode local et poste seul au démarrage puis le programme plante juste après.

en java j'ais :

Il y a 3 alternatives fournissant « java ».

  Sélection    Alternative
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
          2    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
*+        3    /usr/lib/jvm/java-6-sun/jre/bin/java

Message dans la console :

~@Bureau-desktop:/usr/collabcad$ ./collabcad

Setting CollabCAD VARIABLES

.

Home Directory of COLLABCAD is .

LD_LIBRARY_PATH ./linux/lib:./linux/lib/other_libs:/usr/X11R6/lib
Properties from collabcad_client.properties loaded successfully!
*sys-package-mgr*: can't create package cache dir, 'cachedir/packages'
Loading native object libraries ...

--collabcad_server.properties : The Database Primary Key File "<installation directory>/scripts/ccadsysdb_pk.txt" does not exist.
--collabcad_server.properties : The Database Connection not establishable. Check "jdbc:postgresql://localhost:5432/ccadsysdb, <user name>, "
Properties from collabcad_server.properties loaded successfully! (((partially)))

Aborted

Les associations du logiciel libre :
http://www.april.org/ ; http://www.aful.org/
Boutique informatique à encourager
Je suis client satisfais de Novatux

Hors ligne

#14 Le 07/02/2007, à 13:51

YMulleneers

Re : Installer SALOME

Le sujet de l'aide sur Salome n'est pas encore créé.  Je n'ai pas les privilèges pour le créer.
Il faudrait aussi un sujet sur "CAD" pour faire les liens et créer une certaine cohésion de l'ensemble et pârtir en arborescence de l'acceuil.

Le sujet de la page n'est-il Salome?  D'aprés mes renseignements, 
Salome = bibliothèque <> programme

PS : moins Chère -> moins cher (histoire de d'avoir l'air de gens trés éduqués)


Linux Mint 16

J'aime à utiliser Linux.

Hors ligne

#15 Le 14/02/2007, à 22:34

YMulleneers

Re : Installer SALOME

Tiens, quel est la licence de collacad?


Linux Mint 16

J'aime à utiliser Linux.

Hors ligne

#16 Le 01/03/2007, à 10:02

laruen

Re : Installer SALOME

Bonjour john5168

Desole mais je ne viens pas souvent dans les forums.
Je vois que vous avez recupere "Collabcad" bravo.
Mais moi pour me faire une idee et les "dents" j'ai charge la
version du "concurrent" sur une autre machine et la 3mn
et "basta" avec les fichiers d'aide et le tutorial en html c'est tout bon.
Quand j'en saurai plus sur linux on changera de version.
Et j'espere utiliser un jour "GraphiteOne" mais bon sang qu'elle galere
ce truc !!!!

Tu as aussi un soft 3D assez puissant sur linux c'est "equinox3D"
et il est autonome je crois et tourne sur toutes les distrib que j'ai essayees

A plus et belles images
laruen

Hors ligne

#17 Le 04/06/2007, à 21:23

fanatux

Re : Installer SALOME

john5168 a écrit :

Personne utilise SALOME ?

Si moi!! enfin j'essaye pk c pas simple de devoir definir un point et un vecteur a chaque fois qu'on veut tracer un cercle... c'est bizard comme logiciel qd meme mais sa a l'air puissant! (puis c'est utilisé par les mines de paris, EADS, EDF... rien que ça!)


HM lar's Ubuntu
-------------------------------------------------------------
Jamendo: Portail de musique libre // hooseek Pour un internet solidaire

Hors ligne

#18 Le 05/06/2007, à 02:03

paulnux

Re : Installer SALOME

Bonjour fanatux,
Si j'ais bien compris le tuto ya pas besoins d'install Open Cascade ?


« Il y a beaucoup de causes pour lesquelles je suis prêt à  mourir mais aucune cause pour laquelle je suis prêt à  tuer. » Gandhi

Hors ligne

#19 Le 06/06/2007, à 10:07

Lami

Re : Installer SALOME

Bonjour,

Pour votre information, la page Wiki sur Salome vient d'être mise à jour avec une procédure complète et fonctionnelle de Salome 3.2.6. Voir : salome#installation_sous_kubuntu_7.04.

À vos marques, prêt, dessinez !


L'ami René

Tous pour un et un pour tous !

Hors ligne

#20 Le 26/11/2007, à 01:10

Lami

Re : Installer SALOME

Bonjour,

La page Wiki sur Salome vient d'être mise à  jour avec une procédure complète et fonctionnelle de Salome 3.2.6. sous Kubuntu 7.10 Voir : salome#installation_sous_kubuntu_7.10.

à€ vos marques, prêt, dessinez !


L'ami René

Tous pour un et un pour tous !

Hors ligne

#21 Le 10/04/2009, à 14:33

lebled

Re : Installer SALOME

Bonjour,
Je souhaite installer salome sous ubuntu. J'ai bien suivi la procédure décrite sur le site
salome#installation_sous_kubuntu_7.10.
jusqu'à la commande :  sudo salome_appli_3.2.6/./runAppli
voici les erreurs qu'il m'affiche :

stagiaire@lasaFTP:~$ sudo salome_appli_3.2.6/./runAppli
python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

il me semble d'après la nature des erreurs citées que je n'ai pas bien installer quelques bibliothèques.

Quelqu'un pourrait m'eclaircir un peu plus le problème? Que dois-je faire? Il y a t il un moyen simple pour télécharger les donées manquantes.

Bien cordialement
lebled

Hors ligne

#22 Le 10/04/2009, à 15:58

YMulleneers

Re : Installer SALOME

Installer ce paquet : http://packages.debian.org/stable/base/libstdc++5

c'est à dire

apt-get install libstdc++5

Voir aussi -> http://forum.ubuntu-fr.org/viewtopic.php?id=160149


Linux Mint 16

J'aime à utiliser Linux.

Hors ligne

#23 Le 29/04/2009, à 10:15

holmes0

Re : Installer SALOME

Juste pour éviter que des gens se fassent de fausses idées sur ce logiciel, je vais donner quelques précisions.
Salome n'est pas un logiciel de CAD (Comptuter Aided Design) ou CAO (Conception assistée par ordinateur) avec l'objectif d'avoir une représentation géométrique de bureau d'études (les plans avant fabrication). C'est en réalité un logiciel pour préparer des modèles géométriques pour la simulation numérique (il y en a de toutes sortes : calcul de la tenue mécanique, de la thermique, des écoulements fluides). D'ailleurs SALOME ne fait que préparer le modèle discret (éléments finis). La simulation est à effectuer avec d'autres logiciels (CODE_ASTER, OPEN_FOAM, ... pour parler des solutions gratuites).
En clair, il ne s'agit pas du tout de dessin. N'imaginez surtout pas pouvoir dessiner une maison ou une voiture avec ça !
Enfin, il faut savoir que la diffusion de ce logiciel est relativement restreinte au sein des entreprises.
La plupart d'entre-elles utilisent des solutions commerciales (SAMCEF, ABAQUS, ...) qui, bien que très chères, offrent des fonctions et surtout un support bien plus élaborés que SALOME.

Hors ligne

#24 Le 16/06/2010, à 03:59

YannUbuntu

Re : Installer SALOME

Bonjour
je viens de mettre a jour la page wiki : http://doc.ubuntu-fr.org/salome

Pourriez-vous svp vérifier la procédure d'installation ? (et m'indiquer sur quelle version d'Ubuntu ca marche afin que je puisse mettre les tags de version adéquats)

Il y avait aussi un tuto "Installation sous Kubuntu 7.10", est-ce qu'il est obsolète ou toujours valide pour les versions actuelles d'Ubuntu ?

Merci d'avance pour votre aide.

(pour info il y a du nouveau dans http://doc.ubuntu-fr.org/calcul_numerique et http://doc.ubuntu-fr.org/mecanique , n'hésitez pas a compléter smile )


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#25 Le 22/07/2010, à 00:43

CrokNoks

Re : Installer SALOME

Salut,
Juste une remarque
La méthode pour installé sur 7.10 fonctionne apparement sur 10.04 à un détail près, le script d'installation n'est pas bon.
A la ligne suivante : sudo apt-get install tcl8.4 tcl8.4-dev tk8.4 tk8.4-dev qt3-dev-tools sip4 python-sip4-dev libboost-dev swig g++ libg2c0
Le paquet libg2c0 est à prendre sur le launchpad ainsi que le paquet gcc-3.4-base3.4.6-8ubuntu2 (c'est une dépendance du premier). Ils sont tout deux uniquement disponible pour karmic (je les ai installé au cas, à vérifier s'il sont toujours nécessaires ou s'ils ont été remplacé par d'autre paquets.

Dernière modification par CrokNoks (Le 22/07/2010, à 00:44)

Hors ligne