Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 25/08/2010, à 23:56

Kisscool15

Lancement de Code Blocks 10.05

Bonjour,
Je viens d'installer CB 10.05 ( a partir de LPG via Synaptics )
Le problème est : je clique sur l'icone et rien ne se passe  T_T


Merci d'avance pour vos réponses

Hors ligne

#2 Le 26/08/2010, à 01:06

Cirius1987

Re : Lancement de Code Blocks 10.05

Bonjour Kisscool15,

j'ai une solution, à ton problème.
Va dans Système > Administration > Gestionnaire de paquets Synaptic, et recherche "libwxbase2.8-0".
Une fois que libwxbase2.8-0 s'affiche, sélectionne-le, puis clique sur l'onglet "Paquet" et sélectionne "Forcer la version..." ou bien fait Ctrl+E (raccourci pour "Forcer la version...").

De là, choisi la version "2.8.10.1-0ubuntu1 (lucid)".
La version à jour "2.8.10.1-0ubuntu1.2 (lucid-updates)" génère l'erreur suivante lorsqu'on lance C::B 10.05 dans un terminal:

"codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference"  hmm.
Ce qui, du fait de cette erreur, ne lance pas codeblocks.

Voilà.

Il est à noter que tu devras refaire la manip à chaque fois que tu remettras libwxbase à jour, et ce, tant qu'une version appropriée n'apparaîtra pas mad.

Dernière modification par Cirius1987 (Le 31/08/2010, à 14:45)


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#3 Le 26/08/2010, à 18:35

Kisscool15

Re : Lancement de Code Blocks 10.05

Merci de ta réponse ! Je teste ça de suite


En milieu de journée je me disais que je n'aurai aucune réponse parce que j'ai donné aucune info du style version utilisée &  co.

Ce qui m'étonnait  c'était que la fenêtre splash s'affichait mais sans plus.
Treve de blabla, passons à l'action




EDIT : IL VIIT IL VIIIT



EDIT² : Bon Code Blocks marche mais des que je fais un Run+build sur un petit bout de code du pur style hello world
il me sort un :

sh: [chemin]\[nomdufichier] permission denied

J'ai pas trouvé mon bonheur sur Google donc si je pourrais avoir un coup de pouce pour éviter cette erreur

Dernière modification par Kisscool15 (Le 26/08/2010, à 18:43)

Hors ligne

#4 Le 26/08/2010, à 20:32

Cirius1987

Re : Lancement de Code Blocks 10.05

Le "sh: [chemin]\[nomdufichier] permission denied" n'est pas une erreur en soi.
Ca ne vient pas de C::B (c'est du moins ce que j'aime à croire) mais d'un problème de droit d'accès.
Selon moi le dossier dans lequel tu enregistres ton projet nécessite le droit d'accès administrateur.
Crée un dossier dans un endroit qui n'en nécessite pas (genre Raccourcis > Dossier personnel > "Nom_de_ton_dossier").
Et dès que tu es sous C::B tu crées ton projet dans ce dossier.

Dernière modification par Cirius1987 (Le 31/08/2010, à 14:46)


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#5 Le 26/08/2010, à 22:35

lifala

Re : Lancement de Code Blocks 10.05

salut,
ça fonctionne chez moi.
merci


conky 1 --- conky 2 --- conkyForecast 2.09 --- Tuto Finch
Lucid minimal + openbox

Hors ligne

#6 Le 27/08/2010, à 00:33

Cirius1987

Re : Lancement de Code Blocks 10.05

Super, j'espère que Kisscool15 pourra y arriver aussi.
Si malgré tout C::B ne fonctionne pas correctement il est toujours possible de revenir à la version du dépôt officiel.

Pour ce faire, allez dans Système > Administration > Sources de logiciels.
De là, clique sur l'onglet "Autres logiciels" et sélectionne "http://lgp203.free.fr/ubuntu/ lucid universe" puis clique sur le bouton "Enlever".
Ensuite, clique sur l'onglet "Authentification" et sélectionne la signature "pasgui (lgp203.free.fr)<lgp203@free.fr>" puis clique sur le bouton "Enlever".
Après cela ferme la fenêtre "Sources de logiciels" en prenant soin de laisser la mise à jour de la base de données de logiciels dispo se faire.

Suite à cela, une petite manip en console s'impose un peu smile.
Va dans Applications > Accessoires > Terminal (ou Ctrl+Alt+t (raccourci terminal)), et entre la commande suivante: sudo apt-get autoremove --purge codeblocks
puis appuie sur entrée.
Il te demandera un mot de passe par la suite, ce sera celui que tu utilises pour ouvrir ta session linux quand tu allumes ton pc.
Après ça il te demandera si tu es sûr de ce que tu fait, tu appuies sur la touche "o" de ton clavier puis sur entrée.

Cette manip a pour but de désinstaller la version actuelle de C::B ainsi que tout ce qui l'accompagne (afin d'éviter d'éventuels problèmes, peu probables, lors de l'installation de la version antérieure de C::B).

Toujours dans le terminal, et une fois que l'opération précitée est arrivée à son terme,
entre la commande suivante: sudo apt-get autoclean
et appuie sur entrée.
Cela a pour but de supprimer les copies des paquets désinstallés.
La raison de cette action est que lorsque tu réinstalleras C::B 8.02 à partir de Application > Logithèque ubuntu, si le paquet d'installation de la version 10.05 est toujours présent dans ton pc, il y a de fortes chances que linux choisisse d'installer ce paquet plutôt que de télécharger celui d'une version antérieure (ici 8.02) du dépôt officiel lol.

Voilà, tu n'as plus qu'à fermer le terminal et à réinstaller C::B à partir de la logithèque (ou du terminal: sudo apt-get install codeblocks)

Appuie sur la touche Tab pour utiliser l'autocomplétion (ex: tu entres "sudo apt-get install codeb" et tu appuies sur Tab, ça te fera apparaître "sudo apt-get install codeblocks", et si ce n'est pas le cas, double-appuie sur la touche Tab, ça fera apparaître les possibilités).

Astuce: pour coller (dans une optique de copier-coller des commandes) dans un terminal, utilise Ctrl+shift+V

Dernière modification par Cirius1987 (Le 11/09/2010, à 11:21)


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#7 Le 03/09/2010, à 22:17

Cirius1987

Re : Lancement de Code Blocks 10.05

La compatibilité avec la dernière version de libwxbase est désomais établie avec la dernière mise à jour de code block 10.05 des dépôts LGP.


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#8 Le 08/09/2010, à 19:50

lifala

Re : Lancement de Code Blocks 10.05

salut.

oui plus de soucis, je confirme.


conky 1 --- conky 2 --- conkyForecast 2.09 --- Tuto Finch
Lucid minimal + openbox

Hors ligne

#9 Le 21/12/2010, à 18:44

Quent42340

Re : Lancement de Code Blocks 10.05

Bonjour,

J'ai actuellement le même problème, mais sous Maverick (10.10).
Après avoir fait des recherches, j'ai trouvé quelques solutions : celle du dépôt :

Je viens juste d'avoir le même problème, voici comment je l'ai réglé:

fait:

sudo gedit /etc/apt/sources.list

Ajoute cette ligne:

deb http://apt.wxwidgets.org/ jaunty-wx main (donc là pour moi je remplace jaunty par maverick)

et maintenant fais les mises à jour avec le Gestionnaire de mise à jour

Système -> administration -> Gestionnaire de mise à jour

J'espère que ceci va t'aider!

ou celle mentionnée ici.
Le problème est que le dépôt pour maverick n'existe pas apparemment, et que, pour la seconde solution, l'option forcer la version est grisée, en même temps c'est normal, car sous maverick il n'y a qu'une seule version, à l'inverse de lucid...

Si quelqu'un pouvait se pencher là dessus... Ce serait utile.

D'avance merci.

Hors ligne

#10 Le 22/12/2010, à 01:18

Cirius1987

Re : Lancement de Code Blocks 10.05

Je suis actuellement sous la version 10.10 et Code Block 10.05, des dépôts par défaut, fonctionne sans aucune manipulation... .
Refait ton installation en passant par la logithèque Ubuntu.

Dernière modification par Cirius1987 (Le 22/12/2010, à 01:18)


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#11 Le 22/12/2010, à 10:40

Quent42340

Re : Lancement de Code Blocks 10.05

J'ai tout désinstallé (codeblocks & la libwxbase2.8-0), et recommencé en passant par la logithèque, mais rien ne change, toujours la même erreur...

Hors ligne

#12 Le 22/12/2010, à 18:17

Cirius1987

Re : Lancement de Code Blocks 10.05

De quelle mannière a tu désinstallé?
Essaye dans le terminal avec ceci:

sudo apt-get autoremove --purge codeblocks

-> supprime le(s) paquet(s) indiqué(s), les dépendances logicielles et leurs fichiers de configuration

sudo apt-get clean

-> supprime les copies de paquets installés

sudo apt-get autoclean

-> supprime les copies des paquets désinstallés

Les deux dernières manips permettent de vider les archives d'installation, ce qui auras pour effet de retélécharger le logiciel lorsque tu en demandera la réinstallation via la logithèque ou vià le terminal:

sudo apt-get install codeblocks

Dernière modification par Cirius1987 (Le 22/12/2010, à 18:18)


∠ Besoin d'une assistance informatique ?
››››› http://www.repap-ordi.fr.nf → Prise en main à distance (via internet) de vos ordinateurs, tablettes & smartphones.

Faire clignoter la LED Scroll Lock du clavier à réception d'un (nouveau) message → Blink !

Hors ligne

#13 Le 22/10/2011, à 19:16

ainouss

Re : Lancement de Code Blocks 10.05

Bonjours !
Mon Pc a été brusquement éteint , Je n'arrive pas à lancer codeblocks !
Voici ce que j'obtiens en laçant la commende codeblocks dans un terminal :


Exception: An exception has been raised!

The application encountered an error at configmanager.cpp, on line 211.
The error message is:

TinyXML error: Error document empty.
In file: /home/abel/.codeblocks/default.conf
At row 0, column: 0.

Code::Blocks Version revision 0 (gcc 4.4.1, build: Sep 13 2009 19:31:56)

Hors ligne

#14 Le 31/05/2012, à 12:47

bob_1973

Re : Lancement de Code Blocks 10.05

Bonjour,

J'ai également un problème de démarrage de CodeBlocks:

Au lancement, j'ai bien le splash screen, puis la fenêtre de sélection du compilateur. Dès que je clique sur OK, CodeBlocks se ferme inopinément.

J'ai lancé CB en console, voici ce que j'obtiens:

Initialize EditColourSet .....
Initialize EditColourSet: done.
Loading toolbar...
ToDoList: loaded
CodeCompletion: loaded
Debugger: loaded
ProjectsImporter: loaded
ScriptedWizard: loaded
Compiler: loaded
FilesExtensionHandler: loaded
ClassWizard: loaded
Autosave: loaded
AStylePlugin: loaded
OpenFilesList: loaded
Todo List plugin activated
Code completion plugin activated
Debugger plugin activated
Foreign projects importer plugin activated
Project wizard added for 'Empty project'
Project wizard added for 'Console application'
Project wizard added for 'D application'
Project wizard added for 'FLTK project'
Project wizard added for 'GLFW project'
Project wizard added for 'GLUT project'
Project wizard added for 'GTK+ project'
Project wizard added for 'Irrlicht project'
Project wizard added for 'Lightfeather project'
Project wizard added for 'OpenGL project'
Project wizard added for 'Ogre project'
Project wizard added for 'Code::Blocks plugin'
Project wizard added for 'QT4 project'
Project wizard added for 'SDL project'
Project wizard added for 'SFML project'
Project wizard added for 'Static library'
Project wizard added for 'Shared library'
Project wizard added for 'wxWidgets project'
Build-target wizard added for 'Console'
Build-target wizard added for 'Static library'
Build-target wizard added for 'wxWidgets'
Project wizard added for 'ARM Project'
Project wizard added for 'AVR Project'
Project wizard added for 'TriCore Project'
Project wizard added for 'PowerPC Project'
File(s) wizard added for 'Empty file'
File(s) wizard added for 'C/C++ source'
File(s) wizard added for 'C/C++ header'
Scripted wizard plugin activated
Added compiler "GNU GCC Compiler"
Added compiler "Intel C/C++ Compiler"
Added compiler "SDCC Compiler"
Added compiler "Tiny C Compiler"
Added compiler "GDC D Compiler"
Added compiler "Digital Mars D Compiler"
Added compiler "GNU ARM GCC Compiler"
Added compiler "GNU AVR GCC Compiler"
Added compiler "GNU GCC Compiler for PowerPC"
Added compiler "GNU GCC Compiler for TriCore"
Compiler plugin activated
Files extension handler plugin activated
Class wizard plugin activated
Autosave plugin activated
Source code formatter (AStyle) plugin activated
Open files list plugin activated
Initializing plugins...
The program 'codeblocks' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 10626 error_code 3 request_code 152 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Quelqu'un aurait-il une idée ?

Hors ligne

Haut de page ↑