Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/09/2006, à 13:04

yanek

[Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Bonjour à tous !

Je suis un utilisateur récent (une semaine) d'Ubuntu totalement convaincu par le système et pas près de changer smile

Webmaster, j'utilise plusieurs serveurs FTP avec Nautilus. Afin d'y accéder plus rapidement, j'ai mis en signet (toujours dans nautilus), les adresses de type ftp://user:password@serveur.ext .
J'allais dans Raccourcis, Mon serveur, et ça s'ouvrait dans Nautilus, et la vie était belle cool

J'ai, par erreur, choisi de mettre Firefox par défaut.

Depuis, lorsque je clique sur mes signets, Firefox les ouvre à la place, et je ne peux plus transférer de fichiers, juste voir la liste. sad

Je n'ai pas l'intention de recourir à une extension, j'ai juste envie que ce soit Nautilus qui les ouvre.

Info: l'option "Se connecter à un serveur" de Nautilus fonctionne, mais il est réverbatif de la taper en permanence.

Je vous remercie d'avance, et en profite pour vous remercier de l'aide que j'ai pu trouver en lisant le forum et le wiki qui m'ont permis de changer d'OS sans avoir à poser la moindre question smile

Dernière modification par yanek (Le 08/09/2006, à 18:18)

Hors ligne

#2 Le 01/09/2006, à 20:18

figaro

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

utilise gFTP pour les transferts ftp


Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#3 Le 01/09/2006, à 21:13

saceirdoth

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

ça règle pas son problème, et qui plus est gFTP est notoirement instable.

Sinon Yanek, moi j'ai firefox 2 beta-1, installé par un paquet deb fait par Asher256, aucun problème de ce genre, j'espère qu'Asher va faire la beta-2.

Hors ligne

#4 Le 02/09/2006, à 10:28

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Tout d'abord, merci à vous pour les réponses, même si pour le moment cela ne m'aide pas vraiment.
En effet, j'aime beaucoup Nautilus pour utiliser le FTP (lorsque j'ai vu que le FTP se faisait via nautilus, j'ai été totalement séduis).

Si cela peut apporter un élément de réponse, je pense de plus en plus fort que tout les problèmes sont venu lorsque j'ai cliqué sur "Vérifier que Firefox est le navigateur par défaut".

A partir de ce moment, il s'est mis par défaut, mais aussi pour les signets de type ftp:// .

Ma question est la suivante: comment faire pour que Nautilus soit par défaut pour les signets de type ftp://blabla .

Merci d'avance smile

Yanek

Hors ligne

#5 Le 02/09/2006, à 10:42

saceirdoth

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Au niveau de gnome, dans système>préférence, ya "applications préférées", mais bon on peut pas définir grand chose, ça doit pas venir de là.

Doit y avoir moyen de définir ça autrement, mais je sais pas où, si je trouve une réponse je ferais signe ici.

Hors ligne

#6 Le 02/09/2006, à 12:26

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Je n'ai en effet rien trouvé de ce coté là.

Je vous remercie d'avance.

En attendant, je n'utilise pas les signets smile

Hors ligne

#7 Le 03/09/2006, à 20:40

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Désolé de faire un petit up, mais j'avoue qu'une aide me serait fort utile... smile

Hors ligne

#8 Le 03/09/2006, à 20:45

figaro

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Firefox 2 c'est une beta, alors les bugs sont là.....


Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#9 Le 03/09/2006, à 20:48

Compte anonymisé

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Gftp est bien tant que tu ne veux pas transférer des fichiers trop lourds ou en tros grand nombre.

#10 Le 04/09/2006, à 00:24

saceirdoth

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

figaro a écrit :

Firefox 2 c'est une beta, alors les bugs sont là.....

Ces signés sont dans Nautilus, pas dans Firefox, je pense pas que le statut beta de Firefox est un rapport avec le problème, il faut arriver à comprendre pourquoi Nautilus ouvre Firefox quand ça concerne du FTP.

Dernière modification par saceirdoth (Le 04/09/2006, à 00:25)

Hors ligne

#11 Le 04/09/2006, à 01:30

Bubble's Talks

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Vérifie dans Nautilus, volet répertoire - clic droit sur un repertoire - si à l'onglet "Ouvrir avec", Firefox ne s'est pas ajouté.
... ?

Hors ligne

#12 Le 04/09/2006, à 13:47

saceirdoth

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

J'ai vérifié chez moi, et sur les répertoires de montage réseau, ya pas "ouvrir avec"

Hors ligne

#13 Le 04/09/2006, à 13:54

Zangdar

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Clic droit propriétés -> Onglet ouvrir avec...

Mais je suis pas sûr et pas sur Ubuntu pour le moment...

Hors ligne

#14 Le 04/09/2006, à 14:16

saceirdoth

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Cet onglet n'est pas là quand ça concerne pas du local (j'ai vérifié avec du ssh et du ftp)

Hors ligne

#15 Le 04/09/2006, à 14:26

SkeRoy

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

J'ai les firefox et nautilus des depots, et j'ai aussi remarqué ca. Le lien de montage est cree sur le bureau quand "j'ajoute des nx serveurs". Mais en cliquant betement, c'est ff qui s'ouvre. Je dois faire clic droit "explorer" pour être dans nautilus...
C'est pas genant parce qu'en general j'utilise gftp, mais de tps en tps...

C'est assez recent (peut-être 2 mois), pour moi ca vient de nautilus...

Dernière modification par SkeRoy (Le 04/09/2006, à 14:27)


== Debian Lenny == {Linux User #422949}

Hors ligne

#16 Le 04/09/2006, à 14:59

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Bonjour à vous, et merci pour toutes ces réponses.

La solution que j'utilise actuellement, c'est aller dans Raccourcis, Serveurs Réseaux, et mon FTP. Cela reste très contraignant.

Ouvrir avec n'est pas là...

Je pense aussi que cela vient de Nautilus, mais de là à le prouver...

Hors ligne

#17 Le 07/09/2006, à 23:43

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Bon, j'avoue que le soucis commence réellement à m'agacer, et qu'avoir Nautilus pour gérer les FTP est fort pratique.

Je résume donc l'histoire:

- J'ai des signets de type ftp://user:password@host.com dans Nautilus.

Avant, en cliquant dessus, j'avais mon dossier avec le FTP qui s'ouvrait instantanément, c'était génial.

- J'ai eu le malheur de cliquer sur "Mettre Firefox par défaut" dans le navigateur en question.

- Depuis, Firefox ouvre les signets contenant mon lien FTP à la place de Nautilus.

Avec quelques tests, si je supprime Firefox, Nautilus me dit:

"Impossible d'ouvrir l'emplacement « ftp://xxxxx:xxxxx@ftp.xxx.net »

Détails : Il y a eu une erreur au lancement de la commande d'action par défaut associée à cet emplacement."

J'ai volontairement crypté le mot de passe et le nom d'utilisateur...
Désinstaller Firefox n'y fait donc rien...

J'ai fais un tour dans /home/yanek/.gnome/application-info/user.applications

Il y a écrit:

"# This file is automatically generated by gnome-vfs application registry
# Do NOT edit by hand
# Generated: Thu Sep  7 23:38:14 2006

Firefox
    requires_terminal=false
    command=/usr/lib/firefox-asher-unstable/firefox
    can_open_multiple_files=false
    mime_types=application/xhtml+xml,text/html
    supported_uri_schemes=http,https,ftp,gopher,chrome,file
    expects_uris=true
    name=Mozilla Firefox
    mime_types=text/html,application/xhtml+xml"

Maintenant, j'avoue ignorer de ce que je peux faire d'un tel fichier, et même s'il est réellement impliqué.

Le soucis est quelque part, il n'est pas loin. Ou configure-t-on les commandes par défaut ? Je n'ai pas envie de réinstaller Ubuntu... juste pour ça smile

Merci d'avance !

Dernière modification par yanek (Le 07/09/2006, à 23:44)

Hors ligne

#18 Le 08/09/2006, à 18:18

yanek

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Eeeet... ça marche !!!

Je te remercie très sincèrement, Mori, celà va me faciliter la vie.

J'espère que ce sujet pourra aider d'autres personnes que moi.

Bonne journée, et... merci encore tongue


Vivement que je puisse moi aussi bientôt commencer à aider les autres sur le forum.. je me fais de mieux en mieux à Ubuntu smile

Hors ligne

#19 Le 06/05/2009, à 23:56

Marc007

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Sauf que tu ne donnes pas la solution !!:lol::o

#20 Le 28/08/2010, à 20:21

IandCO

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

En voilà une :
Editez le fichier en question ainsi :
gedit ~/.gconf/desktop/gnome/url-handlers/ftp/%gconf.xml

et modifez la valeur
/usr/bin/firefox %s
par
/usr/bin/nautilus %s

NB : Vous pouvez aussi utiliser les menus Applications > Outils système > Editeur de configuration puis /desktop/gnome/url-handlers/ftp

Et voilà

Hors ligne

#21 Le 13/04/2011, à 20:18

Cissou

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Et si meme avec nautilus en url handler pour le ftp ca continue a s'ouvrir avec firefox?


Asus P5Q + Intel Q6600 + Asus 2400HD Pro + RAM 8Go G-Skill > Ubuntu 13.04 64bits
Asus T91 > Xubuntu 12.10
NAS > OpenMediaVault

Hors ligne

#22 Le 17/08/2011, à 18:52

Tuxmouraille

Re : [Résolu] Firefox ouvre mes FTP à la place de Nautilus!

Bonjour,
Solution donnée ici.


Le support d'Optimus pour Linux.
Ubuntu 18.04 64 bits, portable ASUS N53SN-SZ161V, Intel® Core™ i5-2410M @ 2.30GHz, 8080MB SODIM Ram, NVIDIA® GeForce™ GT 550M

Hors ligne