Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/07/2006, à 16:02

JackDesBwa

[Résolu] Dépendances et versions : libgtk2.0-dev

J'ai besoin des biblothèques de développement de gtk pour compiler un petit soft.
Mais libgtk2.0-dev refuse de s'installer !!!

Tous les dépots binaries listés par défaut sont actifs, d'ailleurs, il n'y a pas besoin de se connecter pour avoir l'erreur suivante :

libgtk2.0-dev:
 Dépend : libpango1.0-dev mais ne doit pas être installé
 Dépend : libcairo2-dev mais ne doit pas être installé
 Dépend : libxcursor-dev mais ne doit pas être installé
 Dépend : libxfixes-dev mais ne doit pas être installé

À vrai dire, je ne comprends pas.
J'ai conjecturé qu'il s'agit de problèmes de versions de dépendances.
En effet, lorsque j'essai d'installer libcairo2-dev ça donne :

libcairo2-dev:
  Dépend : libcairo2 (=1.0.4-0ubuntu1) mais 1.1.8-0ubuntu1 doit être installé

Quel est la raison, comment remédier à ce problème ? Merci.

Dernière modification par JackDesBwa (Le 07/07/2006, à 14:45)

Hors ligne

#2 Le 06/07/2006, à 17:01

Mornagest

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

Sans doute des sous-dépendances avec encore des dépendances, etc.. la cascade est parfois longue..

Essaie peut-être sudo apt-get -f install libgtk2.0-dev ?

Tu as essayé via Synaptic/Adept ?

Hors ligne

#3 Le 06/07/2006, à 18:04

JackDesBwa

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

L'erreur reportée est celle que me renvoie Synaptic. Mais c'est la même avec apt-get (même avec l'option -f comme proposé)
D'après ce que je comprend, j'ai des dépendances (ou sous-dépendances) qui ont une version plus élevée qu'attendu. C'est étrange qu'il n'accepte pas l'installation dans ce cas. Mais peut-être me trompé-je...

Hors ligne

#4 Le 06/07/2006, à 21:54

mr_pouit

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

JackDesBwa a écrit :

libcairo2-dev:
  Dépend : libcairo2 (=1.0.4-0ubuntu1) mais 1.1.8-0ubuntu1 doit être installé

C'est certainement parce que tu as ajouté des dépôts exotiques à ton sources.list, car la version de libcairo2 fournie avec ubuntu est la 1.0.4 et non la 1.1.8.
Essaie en désactivant temporairement ces dépôts wink

Dernière modification par mr_pouit (Le 06/07/2006, à 21:55)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#5 Le 06/07/2006, à 22:52

Geoffrey

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

essai un : sudo dpkg --configure -a

J'ai eu ce probleme a un moment et je crois l'avoir résolu comme ca.

Hors ligne

#6 Le 07/07/2006, à 14:12

JackDesBwa

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

mr_pouit a écrit :

C'est certainement parce que tu as ajouté des dépôts exotiques à ton sources.list
[...] Essaie en désactivant temporairement ces dépôts wink

Il est possible que j'aie installé une version qui ne vient pas du dépôt principal parce que pour éviter de tout télécharger avec mon 56K j'ai copié le cache d'un copain. Je n'y pensais plus. Je comprend donc mieux, et c'est déjà un grand pas.
J'ai beau désactiver le dépôt local, il l'a déjà installé, donc pas moyen... Il faut donc que je trouve une version plus récente de libgtk2.0-dev. Pas facile... tongue

Geoffrey a écrit :

essai un : sudo dpkg --configure -a
J'ai eu ce probleme a un moment et je crois l'avoir résolu comme ca.

Avec ça, pas plus de résultat... roll

Hors ligne

#7 Le 07/07/2006, à 14:43

JackDesBwa

Re : [Résolu] Dépendances et versions : libgtk2.0-dev

Finalement, j'ai forcé l'installation de la version antérieure (en espérant que ça ne me mette pas le bazar dans tout ça) Donc, ça a accepté l'installation.

Pour ceux qui se demandent comment forcer, il faut aller voir dans les menus de l'application, ce doit être Paquet>Forcer une version... (je n'ai cherché que sur synaptic)

Hors ligne

Haut de page ↑