Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 03/10/2010, à 18:46

UnMamouth

[Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Bonjour.

J'ai un point qui m'ennuie avec mon accès à certains de mes disques durs.
La machine : Acer Aspire 9413ZWSMi en dual-booot windows xp et Ubuntu Lucid.

Elle était initialement sous windows depuis des années et est maintenant en dual-boot. Je n'utilise plus Windows que lorsque je n'ai pas le choix.

Le disque dur est partitioné en plusieurs volumes dont 3 volumes NTFS.
Mes fichiers de données sont sur les volumes NTFS (pour pouvoir être accessibles depuis les deux SE).

En utilisant psysdm (System > Administration > Storage device manager), j'ai réglé il y a un bout de temps l'auto-montage des 3 volumes NTFS au démarrage.

Seulement voilà, tout effacement de fichiers sur ces 3 volumes est définitif : lorsque j'efface un fichier, Ubuntu m'indique qu'il ne peut pas déplacer les fichiers vers le répertoires des objets effacés (deleted items folder) et me propose d'effacer définitivement le fichier à la place.
Si je regarde les permissions des fichiers, ils appartiennent tous à root / root (ceux qui datent de quand je n'avais que windows comme les nouveaux fichiers créés avec ubuntu depuis que je l'ai installé)

Or depuis peu j'ai une autre machine pour le boulot, qui était en Windows 7, et sur laquelle j'ai installé en dual-boot Ubuntu Lucid (64 bits), puisque je n'ai pas envie d'être obligé d'utiliser Windows. De même, j'ai plusieurs volumes NTFS où sont mes fichiers de travail, afin d'être accessibles depuis les deux SE.

Et j'ai remarqué que sur cette machine, l'effacement des fichiers sur les volumes NTFS se fait normalement (vers la corbeille, sans message particulier) !
Quand je regarde les permissions des fichiers, ils appartiennent à mon utilisateur et son groupe éponyme (toto - toto).
Je ne demande jamais explicitement à cette machine de monter les volumes NTFS, me contentant d'y accéder par Nautilus. J'ai fait un test en plaçant en fond d'écran une image qui se trouvait sur l'un des volumes NTFS et elle n'apparaît que lorsque je commence à accéder au volume en question. Je suppose donc que les volumes en question ne sont pas automatiquement montés mais que Nautilus s'en charge au moment où s'est nécessaire.

Quelqu'un sait-il s'il serait possible d'auto-monter ces volumes au démarrage mais pas en root, histoire de pouvoir effacer vers la corbeille, et alors, comment ?

Et accessoirement, je ne sais plus très bien comment j'enlève l'auto-montage au démarrage sur la première bécane. On peut me rafraîchir la mémoire ?

PS : des liens utiles sur l'auto-montage des volumes NTFS au démarrage, mais qui n'ont pas résolu mon problème,
https://help.ubuntu.com/community/AutomaticallyMountPartitions
http://helpforlinux.blogspot.com/2008/09/auto-mount-hard-drives-on-ubuntu.html
http://www.ubuntugeek.com/mount-manager-user-friendly-management-of-disks-and-partitions.html
http://ubuntu.bryanludvigsen.com/?p=30

Dernière modification par UnMamouth (Le 03/10/2010, à 22:14)


Acer Aspire 9413ZWSMi Ubuntu 12.04 avec Gnome Classic et MATE.
Et un Dell Latitude E6400 avec Linux Mint Qiana.

Hors ligne

#2 Le 03/10/2010, à 20:43

chopinhauer

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

UnMamouth a écrit :

Quelqu'un sait-il s'il serait possible d'auto-monter ces volumes au démarrage mais pas en root, histoire de pouvoir effacer vers la corbeille, et alors, comment ?

Dans /etc/fstab à la ligne où apparaît votre partition NTFS, il faut ajouter uid=1000,gid=1000 (le UID et GID de votre utilisateur, qui d'habitude sont tous les deux 1000) aux options de montage dans la 4 colonne.

Regardez la page de documentation pour un exemple à quoi cela rassemble.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#3 Le 03/10/2010, à 20:56

UnMamouth

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Merci pour les informations.

Pour information, le résultat du cat fstab.

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc    proc    nodev,noexec,nosuid    0    0
#Entry for /dev/sda7 :
UUID=c2046724-df06-480e-8156-447b04ad6cf6    /    ext4    errors=remount-ro    0    1
#Entry for /dev/sda1 :
UUID=6250C51950C4F537    /media/sda1    ntfs-3g    defaults,locale=en_GB.utf8    0    0
#Entry for /dev/sda5 :
UUID=D014227C14226626    /media/sda5    ntfs-3g    defaults,locale=en_GB.utf8    0    0
#Entry for /dev/sda6 :
UUID=7D841D787E29EB3A    /media/sda6    ntfs-3g    defaults,locale=en_GB.utf8    0    0
#Entry for /dev/sda8 :
UUID=da513c56-db8d-46f2-9ee5-24ec52dd6631    none    swap    sw    0    0

Les /media/sda1 ,  /media/sda5 ,  /media/sda6 sont les volumes NTFS.

Dernière modification par UnMamouth (Le 03/10/2010, à 21:03)


Acer Aspire 9413ZWSMi Ubuntu 12.04 avec Gnome Classic et MATE.
Et un Dell Latitude E6400 avec Linux Mint Qiana.

Hors ligne

#4 Le 03/10/2010, à 21:09

chopinhauer

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Du coup je peut être plus explicite: remplacez 'defaults,locale=en_GB.utf8' par 'defaults,locale=en_GB.utf8,uid=1000,gid=1000'


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#5 Le 03/10/2010, à 22:13

UnMamouth

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Impeccable !
Cela fonctionne parfaitement !

Je me permets de mettre un lien vers ce fil de discussion dans la page sur le montage des partitions windows.


Acer Aspire 9413ZWSMi Ubuntu 12.04 avec Gnome Classic et MATE.
Et un Dell Latitude E6400 avec Linux Mint Qiana.

Hors ligne

#6 Le 03/10/2010, à 22:27

chopinhauer

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Normalement cela devrait déjà être sur la page.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#7 Le 03/11/2010, à 14:07

Dim83

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

bonjour
J'ai le même problème mais comme ça ne se présente pas tout à fait pareil, si vous pouvez me confirmer

actuellement j'ai ça

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb5 during installation
UUID=7c469da2-91a0-48ed-85b6-eb78ad38dbaf /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=49936ab9-c56c-4d5b-aebc-f07c528b375a none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/dev/sdb1       /data           ntfs     rw,user           0      0 

et impossible de mettre les fichier de /data à la corbeille, si je fais ça, c'est correct ?

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb5 during installation
UUID=7c469da2-91a0-48ed-85b6-eb78ad38dbaf /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=49936ab9-c56c-4d5b-aebc-f07c528b375a none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/dev/sdb1       /data           ntfs  defaults,locale=en_GB.utf8,uid=1000,gid=1000     rw,user           0      0 

merci wink


C'est fou ce que ça me contrarie d'être contrarié comme ça. Si je ne craignais pas de m'offrir en spectacle, je crois bien que j'irais jusqu'à manifester un soupçon de mauvaise humeur. Achille Talon

Hors ligne

#8 Le 04/11/2010, à 23:54

chopinhauer

Re : [Résolu] Auto-monter des disques NTFS au démarrage, pas en root ?

Oui, c'est correct, sauf qu'il n'y a pas d'espace entre 'gid=1000' et 'rw' mais juste une virgule.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

Haut de page ↑