Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 02/10/2010, à 18:46

kemo006

[résolu] Modprobe, erreur au démarrage

Bonjour à toutes et à tous !

voilà, aujourd'hui je souhaite venir vers vous pour trouver une solution à ce message d'erreur (apparu depuis la mise à jour du noyau) :

Modprobe FATAL: Could not load /lib/modules/2.6.35-22-generic/modules.dep: No such file or directory

D'accord, il n'empêche pas le lancement de la machine, mais il allonge le chargement de cinq à dix secondes et le pire, c'est que le fichier DEP en question existe bel et bien.

Je n'ignore pas que ce bug a été signalé à la communauté mais si j'ouvre un nouveau sujet, c'était pour connaitre s'il y a la solution. D'après mes recherches, le problème semble résolu dans la version 2.6.36-rc6 du noyau, mais n'étant pas une version stable, je préfère bidouiller un peu que d'installer cette version candidate.

Merci à vous smile

Dernière modification par kemo006 (Le 11/10/2010, à 18:09)

Hors ligne

#2 Le 03/10/2010, à 07:47

jacobus77

Re : [résolu] Modprobe, erreur au démarrage

Tu as essayé de faire

sudo depmod -a
sudo update-initramfs -c -k all

juste pour voir.

Hors ligne

#3 Le 03/10/2010, à 21:58

kemo006

Re : [résolu] Modprobe, erreur au démarrage

kemo@kemo-portable:~$ sudo update-initramfs -c -k all
[sudo] password for kemo: 
update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
update-initramfs: Generating /boot/initrd.img-2.6.35
grep: /boot/config-2.6.35: Aucun fichier ou dossier de ce type
WARNING: missing /lib/modules/2.6.35
Device driver support needs thus be built-in linux image!
WARNING: Couldn't open directory /lib/modules/2.6.35: No such file or directory
FATAL: Could not open /lib/modules/2.6.35/modules.dep.temp for writing: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.35/modules.dep: No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.32-25-generic
update-initramfs: Generating /boot/initrd.img-2.6.32-24-generic

Redémarrage, toujours le même message hmm

Hors ligne

#4 Le 04/10/2010, à 19:31

hugo464

Re : [résolu] Modprobe, erreur au démarrage

J'ai moi aussi ce problème au démarrage.

Hors ligne

#5 Le 06/10/2010, à 21:33

"-"

Re : [résolu] Modprobe, erreur au démarrage

De même mais pas sur tous mes ordis. Un rapport de bug existe à ce sujet ici :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/642421

De mon côté mon matos c'est :
- CM : M2N-SLI Deluxe (chip NForce 570 SLI)
- CPU : AMD Phenom 9850x4
- 4 Go de RAM
- Ubuntu 32 bits
- CG NVidia

Dernière modification par "-" (Le 06/10/2010, à 21:36)

Hors ligne

#6 Le 07/10/2010, à 21:43

ubox

Re : [résolu] Modprobe, erreur au démarrage

Idem, j'ai également la même erreur. J'espère que ce sera corrigé bientôt. Ce n'est pas que ce soit très gênant, mais ce n'est pas très esthétique tongue

Hors ligne

#7 Le 10/10/2010, à 17:29

dante30900

Re : [résolu] Modprobe, erreur au démarrage

depuis que j'ai fait la mise a niveau ce matin sa me fait ce message ca retarde le demarage pour j'ai installer tous ce qui concerne generic3.6.35-22 dans le gestionnaire de packet je comprend pa si quelqu'un peut me dire la solution sa serait gentie

Hors ligne

#8 Le 10/10/2010, à 18:44

bishop

Re : [résolu] Modprobe, erreur au démarrage

SOLUTION
Post Modifié le 11-10-2010 (ajout de la partie 5).

À essayer...
Une solution proposée par durlo sur le Launchpad. Voir le Post #31.

Ce problème est référencé Bug #642421.
Maverick could not load /lib/modules/2.6.35-22-generic/modules.dep


Les lignes de commande sont exécutées dans un Terminal que vous trouverez dans le Tableau de bord => Applications => Accessoires.

1) Faire une sauvegarde du fichier original. Copiez/collez dans le Terminal :

sudo cp /etc/initramfs-tools/initramfs.conf /etc/initramfs-tools/initramfs.conf.backup

Appuyez sur Entrée. Entrez votre mot de passe quand il est requis. Appuyez de nouveau sur Entrée.


2) Éditez le fichier initramfs.conf. Copiez/collez dans le Terminal :

gksudo gedit /etc/initramfs-tools/initramfs.conf

Appuyez sur Entrée.  Entrez votre mot de passe s'il est requis. Appuyez de nouveau sur Entrée.


3) Remplacez :

MODULES=most

par :

MODULES=dep


4) Enregistez et fermez.


5) Réinstallez initramfs-tools. Copiez/collez dans le Terminal :

sudo apt-get install --reinstall initramfs-tools

Appuyez sur Entrée.  Entrez votre mot de passe s'il est requis. Appuyez de nouveau sur Entrée.
Merci à chris.ft pour cette suggestion (voir aussi le post #37 du Bug #642421).


6) Fermez le Terminal. C'est terminé.


NOTE.
S'il y a un problème vous pouvez restaurer le fichier initramfs.conf original en copiant/collant dans un Terminal :

sudo mv /etc/initramfs-tools/initramfs.conf.backup /etc/initramfs-tools/initramfs.conf

Appuyez sur Entrée.  Entrez votre mot de passe s'il est requis. Appuyez de nouveau sur Entrée.

Dernière modification par bishop (Le 23/02/2013, à 09:29)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

En ligne

#9 Le 10/10/2010, à 22:09

dante30900

Re : [résolu] Modprobe, erreur au démarrage

sa ne marche pas sincerement les informaticient ubuntu ne pourra faire une mise a jour coorrectif sc pas normal que sa m affiche sa tous le temp quand je demarre ca genet et ralenti le demarage quelqu'un aurait il une vraix solution pour regler ce probleme merci davance

Hors ligne

#10 Le 10/10/2010, à 22:13

chris.ft

Re : [résolu] Modprobe, erreur au démarrage

Bonjour,

Je viens de régler le problème en appliquant la solution de bishop ci-dessus que je m'empresse de remercier. CEPENDANT, pour véritablement corriger le problème, j'ai encore dû réinstaller initramfs.conf (en passant par synpatic par exemple) après avoir suivi la démarche proposée.

Bonne découverte et bonne nuit...

Hors ligne

#11 Le 11/10/2010, à 01:07

dante30900

Re : [résolu] Modprobe, erreur au démarrage

iIL EST INTROUVABLE INITRAMFS.CONF CE KE JE COMPREN PA C QUE POURTANT JAI LA VERSION STABLE 10.10

Hors ligne

#12 Le 11/10/2010, à 08:42

bishop

Re : [résolu] Modprobe, erreur au démarrage

dante30900 écrit :
iIL EST INTROUVABLE INITRAMFS.CONF CE KE JE COMPREN PA C QUE POURTANT JAI LA VERSION STABLE 10.10

initramfs.conf est un fichier qui fait partie du paquet initramfs-tools.

Si le paquet /etc/initramfs-tools est installé tu as obligatoirement un fichier /etc/initramfs-tools/initramfs.conf.

Tu peux voir le détail de ce paquet dans la Tableau de bord => Administration => Gestionnaire de paquet Synaptic, tu fais Rechercher => initramfs-tools, clique droit sur le paquet => Propriétés => Fichiers installés.
Pour avoir le détail de ce paquet il faut, bien sûr, qu'il soit installé.

Dernière modification par bishop (Le 11/10/2010, à 13:51)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

En ligne

#13 Le 11/10/2010, à 08:58

protocol06

Re : [résolu] Modprobe, erreur au démarrage

merci bishop j'ai suivi ta procédure et tout marche impécable

Hors ligne

#14 Le 11/10/2010, à 13:54

bishop

Re : [résolu] Modprobe, erreur au démarrage

chris.ft ! protocol06!
Merci d'avoir confirmer la procédure.


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

En ligne

#15 Le 11/10/2010, à 17:22

kemo006

Re : [résolu] Modprobe, erreur au démarrage

Parfait ! Enfin un démarrage propre. Merci Bishop pour la manipulation.

Hors ligne

#16 Le 11/10/2010, à 17:33

bishop

Re : [résolu] Modprobe, erreur au démarrage

kemo006 écrit :
Parfait ! Enfin un démarrage propre. Merci Bishop pour la manipulation.

Pas de quoi !

kemo006 !
Comme tu es l'auteur de cette page peux-tu mettre un [Résolu] dans le titre de ton premier post.
Merci !


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

En ligne

#17 Le 11/10/2010, à 18:55

dante30900

Re : [résolu] Modprobe, erreur au démarrage

etc/initramfs-tools/initramfs.conf. ce paquet est deja installer dans comme tous ce qui concerne initramfs mais dans le terminal quand je veux y entrer il me dise permission non accorder, alor que l'administrateur bref c'est incomprehensible tous est installer j'ai fait juste une mise a niveau de 10.04 a 10.10 je ne suis passer sur aucune version instable et voila le resultat peut etre que parce que c'est ubuntu 64 si quelqu'un a la solution miracle je le remercie d'avance de me la decrire

Hors ligne

#18 Le 11/10/2010, à 20:10

dante30900

Re : [résolu] Modprobe, erreur au démarrage

quelqu'un peut m'aider dans le terminal sa me met permission non accordée je comprem pa pourkoi vous ca marche et moi non

Hors ligne

#19 Le 11/10/2010, à 21:18

bishop

Re : [résolu] Modprobe, erreur au démarrage

dante30900 écrit :
quelqu'un peut m'aider dans le terminal sa me met permission non accordée je comprem pa pourkoi vous ca marche et moi non

Tu dois entrer ton mot de passe quand il est requis.
Sinon fait un copié/collé de ton Terminal et poste le résultat.


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

En ligne

#20 Le 11/10/2010, à 21:34

jacobus77

Re : [résolu] Modprobe, erreur au démarrage

pour passer en administrateur tu dois faire précéder tes commandes de sudo:


par exemple: ne tapes pas ca c'est juste un exemple !!!

sudo update-initramfs -c -k all

Hors ligne

#21 Le 12/10/2010, à 01:44

dante30900

Re : [résolu] Modprobe, erreur au démarrage

C'est incroyable je vous remercie de m'avoir donner des solution mai rien a faire jai tout tout bref jabandonne jatent faire une mise a jour corectif d ubuntu

Hors ligne

#22 Le 12/10/2010, à 12:07

kemo006

Re : [résolu] Modprobe, erreur au démarrage

Dante, tu as "tout tout" quoi exactement? Tu peux nous décrire ton problème?

Hors ligne

#23 Le 15/10/2010, à 15:24

febcrash

Re : [résolu] Modprobe, erreur au démarrage

OK, c'est nikel pour moi aussi, ça a corrigé le tire !


Ubuntero depuis Edgy Eft
Membre des équipes de traduction « Launchpad French Translators » (lp-l10n-fr) et « Ubuntu French Translators » (ubuntu-l10n-fr)
--
Vous aussi, aidez-nous à traduire Ubuntu 14.10 - Utopic Unicorn (doc, applis, descriptions d'applis, pages web) en français  >> http://doc.ubuntu-fr.org/ubuntu-l10n-fr

Hors ligne

#24 Le 16/10/2010, à 13:10

compte supprimé

Re : [résolu] Modprobe, erreur au démarrage

Merci pour la soluce @bishop smile

#25 Le 16/10/2010, à 18:11

jean-louis67

Re : [résolu] Modprobe, erreur au démarrage

Solution clairement expliquée et efficace. Merci Bishop!

Hors ligne

Haut de page ↑