Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 22/05/2009, à 10:52

Fenwick

Xsane et scanner Epson multifonction DX7000F sous Ubuntu 9.04

Bonjour à tous,

Je viens de faire plusieurs fois le tour de la documentation et des forums traitant des multifonction Epson, et je n'ai rien trouvé sur ce modèle. J'ouvre donc un post à son sujet.
L'installation de la partie imprimante n'a pas posé de problème particulier. Par contre, le scanner reste introuvable par Xsane, malgré plusieurs tentatives. Seul la webcam est reconnue.
J'ai essayé d'adapter la méthode décrite dans la doc ici:  http://doc.ubuntu-fr.org/imprimante_epson_multifonctions
C'est à dire modifier mon epson.conf avec les infos constructeur et modèle renvoyés par la commande

lsusb | grep -i epson

qui répond:

Bus 001 Device 006: ID 04b8:0831 Seiko Epson Corp.

La doc demande aussi de décommenter les lignes :

# usb /dev/usbscanner0
# usb /dev/usb/scanner0

Ce qui me laisse perplexe puisque ces fichiers n'existent pas.
Bref, voici mon epson.conf modifié:

# epson.conf
#
# here are some examples for how to configure the EPSON backend
#
# SCSI scanner:
scsi EPSON
# for the GT-6500:
scsi "EPSON SC"
#
# Parallel port scanner:
#pio 0x278
#pio 0x378
#pio 0x3BC
#
# USB scanner:
# There are two different methods of configuring a USB scanner: libusb and the kernel module
# For any system with libusb support (which is pretty much any recent Linux distribution) the
# following line is sufficient. This however assumes that the connected scanner (or to be more
# accurate, it's device ID) is known to the backend. 
usb
# For libusb support for unknown scanners use the following command
# usb <product ID> <device ID>

usb 0x4b8 0x831
usb /dev/usbscanner0
usb /dev/usb/scanner0

Pour mieux comprendre où ça bloque, j'ai lancé la commande:

sudo sane-find-scanner -v

qui me répond:

This is sane-find-scanner from sane-backends 1.0.19

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

searching for SCSI scanners:
checking /dev/scanner... failed to open (Invalid argument)
checking /dev/sg0... failed to open (Invalid argument)
checking /dev/sg1... failed to open (Invalid argument)
checking /dev/sg2... failed to open (Invalid argument)
checking /dev/sg3... failed to open (Invalid argument)
checking /dev/sg4... failed to open (Invalid argument)
checking /dev/sg5... failed to open (Invalid argument)
checking /dev/sg6... failed to open (Invalid argument)
checking /dev/sg7... failed to open (Invalid argument)
checking /dev/sg8... failed to open (Invalid argument)
checking /dev/sg9... failed to open (Invalid argument)
checking /dev/sga... failed to open (Invalid argument)
checking /dev/sgb... failed to open (Invalid argument)
checking /dev/sgc... failed to open (Invalid argument)
checking /dev/sgd... failed to open (Invalid argument)
checking /dev/sge... failed to open (Invalid argument)
checking /dev/sgf... failed to open (Invalid argument)
checking /dev/sgg... failed to open (Invalid argument)
checking /dev/sgh... failed to open (Invalid argument)
checking /dev/sgi... failed to open (Invalid argument)
checking /dev/sgj... failed to open (Invalid argument)
checking /dev/sgk... failed to open (Invalid argument)
checking /dev/sgl... failed to open (Invalid argument)
checking /dev/sgm... failed to open (Invalid argument)
checking /dev/sgn... failed to open (Invalid argument)
checking /dev/sgo... failed to open (Invalid argument)
checking /dev/sgp... failed to open (Invalid argument)
checking /dev/sgq... failed to open (Invalid argument)
checking /dev/sgr... failed to open (Invalid argument)
checking /dev/sgs... failed to open (Invalid argument)
checking /dev/sgt... failed to open (Invalid argument)
checking /dev/sgu... failed to open (Invalid argument)
checking /dev/sgv... failed to open (Invalid argument)
checking /dev/sgw... failed to open (Invalid argument)
checking /dev/sgx... failed to open (Invalid argument)
checking /dev/sgy... failed to open (Invalid argument)
checking /dev/sgz... failed to open (Invalid argument)
  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

searching for USB scanners:
checking /dev/usb/scanner... failed to open (Invalid argument)
checking /dev/usb/scanner0... failed to open (Invalid argument)
checking /dev/usb/scanner1... failed to open (Invalid argument)
checking /dev/usb/scanner2... failed to open (Invalid argument)
checking /dev/usb/scanner3... failed to open (Invalid argument)
checking /dev/usb/scanner4... failed to open (Invalid argument)
checking /dev/usb/scanner5... failed to open (Invalid argument)
checking /dev/usb/scanner5... failed to open (Invalid argument)
checking /dev/usb/scanner7... failed to open (Invalid argument)
checking /dev/usb/scanner8... failed to open (Invalid argument)
checking /dev/usb/scanner9... failed to open (Invalid argument)
checking /dev/usb/scanner10... failed to open (Invalid argument)
checking /dev/usb/scanner11... failed to open (Invalid argument)
checking /dev/usb/scanner12... failed to open (Invalid argument)
checking /dev/usb/scanner13... failed to open (Invalid argument)
checking /dev/usb/scanner14... failed to open (Invalid argument)
checking /dev/usb/scanner15... failed to open (Invalid argument)
checking /dev/usbscanner... failed to open (Invalid argument)
checking /dev/usbscanner0... failed to open (Invalid argument)
checking /dev/usbscanner1... failed to open (Invalid argument)
checking /dev/usbscanner2... failed to open (Invalid argument)
checking /dev/usbscanner3... failed to open (Invalid argument)
checking /dev/usbscanner4... failed to open (Invalid argument)
checking /dev/usbscanner5... failed to open (Invalid argument)
checking /dev/usbscanner6... failed to open (Invalid argument)
checking /dev/usbscanner7... failed to open (Invalid argument)
checking /dev/usbscanner8... failed to open (Invalid argument)
checking /dev/usbscanner9... failed to open (Invalid argument)
checking /dev/usbscanner10... failed to open (Invalid argument)
checking /dev/usbscanner11... failed to open (Invalid argument)
checking /dev/usbscanner12... failed to open (Invalid argument)
checking /dev/usbscanner13... failed to open (Invalid argument)
checking /dev/usbscanner14... failed to open (Invalid argument)
checking /dev/usbscanner15... failed to open (Invalid argument)
found USB scanner (vendor=0x04b8 [Language Error], product=0x0831 [Language Error]) at libusb:001:010
found USB scanner (vendor=0x046d, product=0x08f0 [Camera]) at libusb:003:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
  # `UNKNOWN vendor and product' means that there seems to be a scanner at this
  # device file but the vendor and product ids couldn't be identified.
  # Currently identification only works with Linux versions >= 2.4.8. You may
  # need to configure your backend manually, see the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
done

Les lignes "found USB scanner" m'intéressent. Celle estampillé [Camera], c'est la webcam. Celle estampillé [Language error], c'est le fameux scanner que je veux faire fonctionner.

Voilà où j'en suis. Je reste bloqué devant ce [Language error].
Quelqu'un aurait une idée ou une autre piste à exploiter ?

#2 Le 22/05/2009, à 11:05

Fenwick

Re : Xsane et scanner Epson multifonction DX7000F sous Ubuntu 9.04

Je complète ma question afin d'avoir éventuellement de quoi trouvé la solution tout seul comme un grand. Auquel cas, je la partagerai ici, bien évidement.

Il semblerait que ce scan soit reconnu automatiquement par xsane sous la 8.04. Est ce que quelqu'un, ayant une multifonction espon (pas forcément la même) sous la 8.04, pourrait me communiquer les éléments suivant:

Les réponses au commandes:

lsusb | grep -i epson
gedit /etc/sane.d/epson.conf
sudo sane-find-scanner -v

Merci d'avance pour votre aide !

#3 Le 21/10/2009, à 11:09

jeancalvet

Re : Xsane et scanner Epson multifonction DX7000F sous Ubuntu 9.04

Bonjour, jeune linuxien, je ne me sens pas (encore   sadwink  ) la compétence pour venir à bout de mon problème scanner Epson DX7000F par le code. Comme Fenwick, j'ai fait le tour des forums sans trouver de solution à ce problème de driver, driver qui semble exister si j'ai bien compris, pour d'autre distributions.
Mais j'ai pu louper qqch. Quelqu'un sait-il s'il existe -aujourd'hui- un moyen de faire fonctionner ce scanner?
Grand merci, je détesterai l'idée de repasser par Win aux seules fins de numériser mes documents.
Jean

Hors ligne

#4 Le 17/10/2010, à 15:26

bagvian

Re : Xsane et scanner Epson multifonction DX7000F sous Ubuntu 9.04

Bonjour,
J'ai eu le même type d'expériences avec mon scanner / imprimante Epson.
Je viens de passer sous 10.10 et mon scanner n'est plus reconnu par XSane. J'obtiens le message suivant :
Failed to start scanner Invalid argument

J'avais déjà eu ce problème en passant à 10.04 et je l'avais réglé avec un peu de chance et une installation de Sane à partir du source.
Cette fois-ci cela ne s'est pas passé de la même manière :

$ lsusb
m'a permis de voir que le scanner était bien là :
...
Bus 003 Device 005: ID 04b8:0802 Seiko Epson Corp. Stylus CX3200
...

ensuite, je me suis retrouvé avec 2 fichiers epson :
$ ls /etc/sane.d/epson*

...
/etc/sane.d/epson2.conf 
/etc/sane.d/epson.conf
...

en détails : epson2.conf :

# epson2.conf
#
# here are some examples for how to configure the EPSON2 backend
# SCSI
scsi EPSON
# for the GT-6500:
#scsi "EPSON SC"
# Parallel port
#pio 0x278
#pio 0x378
#pio 0x3BC
# USB
usb
# For libusb support for unknown scanners use the following command
# usb <product ID> <device ID>
# e.g.:
# usb 0x4b8 0x110
# Network
#
# net 192.168.1.123
net autodiscovery


et puis : epson.conf :

# epson.conf
#
# here are some examples for how to configure the EPSON backend
#
# SCSI scanner:
scsi EPSON
# for the GT-6500:
scsi "EPSON SC"
#
# Parallel port scanner:
#pio 0x278
#pio 0x378
#pio 0x3BC
#
# USB scanner:
# There are two different methods of configuring a USB scanner: libusb and the kernel module
# For any system with libusb support (which is pretty much any recent Linux distribution) the
# following line is sufficient. This however assumes that the connected scanner (or to be more
# accurate, it's device ID) is known to the backend.
usb
# For libusb support for unknown scanners use the following command
# usb <product ID> <device ID>
# e.g.:
# usb 0x4b8 0x110
# And for the scanner module, use the following configuration:
#usb /dev/usbscanner0
#usb /dev/usb/scanner0

a priori c'est ce dernier fichier dont on a besoin pour la configuration, or dll.conf je lisais :

# /etc/sane.d/dll.conf - Configuration file for the SANE dynamic backend loader
#
# Backends can also be enabled by configuration snippets under
# /etc/sane.d/dll.d directory -- packages providing backends should drop
# a config file similar to dll.conf in this directory, named after the package.
#

# The next line enables the network backend; comment it out if you don't need
# to use a remote SANE scanner over the network - see sane-net(5) and saned(8)
net
abaton
agfafocus
apple
avision
artec
artec_eplus48u
as6e
bh
canon
canon630u
canon_dr
#canon_pp
cardscan
coolscan
#coolscan2
coolscan3
#dc25
#dc210
#dc240
dell1600n_net
dmc
epjitsu
#epson
epson2
fujitsu
#gphoto2
genesys
gt68xx
hp
hp3900
hpsj5s
hp3500
hp4200
hp5400
hp5590
hpljm1005
hs2p
ibm
kodak
kvs1025
leo
lexmark
ma1509
matsushita
microtek
microtek2
mustek
#mustek_pp
mustek_usb
mustek_usb2
nec
niash
#p5
pie
pixma
plustek
#plustek_pp
#pnm
qcam
ricoh
rts8891
s9036
sceptre
sharp
sm3600
sm3840
snapscan
sp15c
#st400
#stv680
tamarack
teco1
teco2
teco3
#test
u12
umax
#umax_pp
umax1220u
v4l
xerox_mfp


Si on édite ce fichier :
gksu gedit /etc/sane.d/dll.conf

et que l'on change :
#epson
epson2

par :
epson
#epson2

On redémarre le XSane et le tour est joué : Xsane se remet à fonctionner.
En espérant que cela puisse être utile...
Bagvian

Hors ligne

Haut de page ↑