Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#26 Le 14/11/2010, à 17:34

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Frayer a écrit :

En faite ce sont des lignes dans le fichier bluray.c lors du "make" qui posent problème.
Ca se passe entre les lignes 130 à 170, vers là. Toute la partie "Warning the user about AACS/BD+", "AACS" et "BD+". Les erreurs : variables non déclarées.

En les mettant en "commentaires" je vais jusqu'au bout.

Je viens de compiler aujourd'hui et je n'ai eu aucun problème.
Par contre attention ! Nouvel emplacement pour les clefs à savoir :

'~/.config/aacs/KEYDB.cfg'

Hors ligne

#27 Le 14/11/2010, à 19:51

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Quand tu compiles VLC (disons pour la première fois), tu compiles aussi x264 et FFmpeg, comme dans le tuto que j'ai "linké".
Ou tu fais juste "build-dep vlc", point barre ?

Dernière modification par Frayer (Le 14/11/2010, à 19:52)

Hors ligne

#28 Le 14/11/2010, à 20:50

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Non pas besoin, moi je fais comme ceci :

sudo apt-get build-dep vlc
sudo apt-get install git checkinstall
git clone git://git.videolan.org/vlc.git
cd vlc
./bootstrap
./configure --prefix=/usr --enable-bluray
make -j4
sudo checkinstall --fstrans=no --install=yes --pkgname=vlc --pkgversion "1.2.0-git-$(date +%Y%m%d)-$(git show --abbrev-commit | grep '^commit' | cut -f2 -d " ")" --default

Edit: On peut dorénavant ajouter l'option "--enable-bluray " bien que la détection de libbluray est automatique.

Dernière modification par HacKurx (Le 15/11/2010, à 17:40)

Hors ligne

#29 Le 17/11/2010, à 17:06

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Après un "formatage" pour repartir clean, j'en retenté de compiler VLC.

Après la compilation de libebml, libmatroska, libvpx, x264, ffmepg, j'ai encore une autre erreur pendant le "make" de VLC :

/usr/bin/ld: /usr/local/lib/libavformat.a(allformats.o): relocation R_X86_64_32 against `a64_muxer' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libavformat.a: could not read symbols: Bad value

Je crois que j'ai la poisse... mad

Hors ligne

#30 Le 17/11/2010, à 17:17

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Ta utilisé ma méthode?
Sinon utilise vlc avec le ppa "videolan/master-daily" :
https://launchpad.net/~videolan/+archive/master-daily

Hors ligne

#31 Le 17/11/2010, à 19:55

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Oui bien sur j'ai utilisé ta méthode.

Mais pour libebml et libmatroska, elles étaient visiblement trop vieilles dans les dépôts.
Libvpx, VLC me la demandait. Et visiblement il lui fallait des composants de x264 et ffmpeg pour compiler...

Je vais tenter le ppa maintenant, merci en tout cas !

Hors ligne

#32 Le 18/11/2010, à 09:18

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Frayer a écrit :

Mais pour libebml et libmatroska, elles étaient visiblement trop vieilles dans les dépôts.

Je ne savais pas que c'était le cas maintenant sous ubuntu, mais sous debian squeeze (que j'utilise) j'ai du installé les paquets expérimental, à savoir :

libebml2_1.0.0-1_amd64.deb
libmatroska2_1.0.0-1_amd64.deb
libebml-dev_1.0.0-1_amd64.deb
libmatroska-dev_1.0.0-1_amd64.deb

Hors ligne

#33 Le 18/11/2010, à 11:21

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Je viens aussi de voir que nombres des paquets "périmés" pour moi (sous Lucid) étaient plus récent sous Maverick...

Dernière modification par Frayer (Le 18/11/2010, à 11:22)

Hors ligne

#34 Le 18/11/2010, à 16:47

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

As-tu es encore sous ubuntu 10.04, c'est normal quelques paquets ne sont plus assez récents wink
Tu n'aura aucun problème à compiler vlc sous ubuntu 10.10

Hors ligne

#35 Le 18/11/2010, à 21:10

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Sauf que Maverick me fait planter en permanence mon ordi, ce qui m'énerve un peu...

Hors ligne

#36 Le 19/11/2010, à 08:55

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Frayer a écrit :

Sauf que Maverick me fait planter en permanence mon ordi, ce qui m'énerve un peu...

Passe sous debian squeeze alors big_smile

Hors ligne

#37 Le 19/11/2010, à 13:23

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

En faite mon ordi s'éteint tout seul entre 5 à 30 minutes après l'allumage avec la 10.10.
Et j'ai essayé Debian 5.0.6 (trop vieux) et squeeze fait le même problème...

Mais là on s'écarte de la libbluray tongue

Hors ligne

#38 Le 19/11/2010, à 16:19

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

tongue C'est de ta faute si tu avais un ordi qui fonctionnait normalement lol
Il y a un vote pour aider videolan dans la clarification de libbdplus :
http://brainstorm.ubuntu.com/idea/26424/

Si ça peut aider à faire avancer le projet wink

Hors ligne

#39 Le 19/11/2010, à 21:54

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Bingo !

J'ai ajouté les dépôts de Maverick le temps d'installer les dépendances pour VLC et j'ai pu compiler sans aucun soucis !

Hors ligne

#40 Le 20/11/2010, à 00:59

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Ca fonctionne wouhou ! Choix des langues, des sous-titres, des chapitres et des pistes vidéos. Parfait !

Merci HacKurx !

Hors ligne

#41 Le 20/11/2010, à 01:41

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

De rien, je te tiens au courant dès que j'ai des news du projet wink

Hors ligne

#42 Le 21/11/2010, à 12:17

Chewy

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Je suis sous Maverick et effectivement, la compilation de vlc marche niquel.

Par contre, petite question sur les menus en Java. Normalement, libbluray les supporte. Est-ce vlc qui ne permet pas encore de les afficher ?

Hors ligne

#43 Le 21/11/2010, à 13:29

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Les menus Java ne sont pas encore pris en charge par vlc.
A voir donc dans xine (avec la patch inclut dans libbluray) et mplayer mais je pense que c'est au même niveau que vlc.

Edit : pour vlc c'est encore en chantier, ça va arriver. big_smile

Dernière modification par HacKurx (Le 21/11/2010, à 21:50)

Hors ligne

#44 Le 22/11/2010, à 12:26

Chewy

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Ha bonne nouvelle smile

Merci !

Hors ligne

#45 Le 23/11/2010, à 21:08

Nico-ARTS

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

HacKurx a écrit :

Non pas besoin, moi je fais comme ceci :

sudo apt-get build-dep vlc
sudo apt-get install git checkinstall
git clone git://git.videolan.org/vlc.git
cd vlc
./bootstrap
./configure --prefix=/usr --enable-bluray
make -j4
sudo checkinstall --fstrans=no --install=yes --pkgname=vlc --pkgversion "1.2.0-git-$(date +%Y%m%d)-$(git show --abbrev-commit | grep '^commit' | cut -f2 -d " ")" --default

Edit: On peut dorénavant ajouter l'option "--enable-bluray " bien que la détection de libbluray est automatique.

J'ai suivi ce que tu as fait... J'ai tout installé...

Mais ça ouvre et les informations pour l'heure de durée et le nom du film MAIS l'écran est NOIR et impossible regarder ce film :-(

Je suis sous Ubuntu 10.10

Hors ligne

#46 Le 24/11/2010, à 09:29

HacKurx

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Salut Nico-ARTS, tu as bien installés libbluray, libaacs et surtout mis ton fichier de clef dans "~/.config/aacs/KEYDB.cfg"?

Hors ligne

#47 Le 24/11/2010, à 17:25

Nico-ARTS

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Quel clef ? O_o

Hors ligne

#48 Le 25/11/2010, à 18:39

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Les clefs qui servent à VLC pour décoder les Blu-Ray.

Tu en as une liste ici : http://forum.doom9.org/showpost.php?p=1 … tcount=176

Hors ligne

#49 Le 25/11/2010, à 20:39

Nico-ARTS

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Désolé mais j'ai une question bêtement mais je ne trouve pas le dossier ~/.config ! Meme le mode de cache...

Je le trouve comment ?

Dernière modification par Nico-ARTS (Le 25/11/2010, à 20:41)

Hors ligne

#50 Le 25/11/2010, à 20:48

Frayer

Re : Utiliser libbluray/libaacs dans VLC, Mplayer etc...

Pour être sur, tu es bien dans ton dossier perso, /home/"user"/ ?

Hors ligne

Haut de page ↑