Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 14/07/2006, à 06:57

sarbogast

Package samba cassé pendant la mise à jour

Hier, je fais mes mises à jour automatiques normalement et puis tout d'un coup j'ai plein de messages d'erreurs un peu incompréhensibles et maintenant à chaque fois que j'essaie de faire une mise à jour, il me signale que le package samba est cassé et il arrête la mise à jour.

Sur mon icône de mise à jour dans la barre en haut à droite j'ai ce message:

Une erreur est survenue, veuillez lancer le gestionnaire de paquets en cliquant droit ou en lançant apt-get dans un terminal afin de déterminer la cause de l'erreur. Le message d'erreur était: "Error: BrokenCount>0".

Dans le gestionnaire de paquets Synaptics, c'est le package samba qui apparaît comme cassé. Et voilà ce que j'ai obtenu dans un terminal:

sarbogast@sarbogast-laptop:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
  samba: Dépend: samba-common (= 3.0.22-1ubuntu3) mais 3.0.22-1ubuntu3.1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
sarbogast@sarbogast-laptop:~$ apt-get -f install
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13 Permission non accordée)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
sarbogast@sarbogast-laptop:~$ sudo apt-get install -f samba
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Paquets recommandés :
  smbldap-tools
Les paquets suivants seront mis à jour :
  samba
1 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
Il est nécessaire de prendre 0o/2845ko dans les archives.
Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
(Lecture de la base de données... 134489 fichiers et répertoires déjà installés.)
Préparation du remplacement de samba 3.0.22-1ubuntu3 (en utilisant .../samba_3.0.22-1ubuntu3.1_i386.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
dpkg : avertissement - ancien script pre-removal a retourné un code d'erreur de sortie 102
dpkg - tentative d'exécution du script du nouveau paquet à la place ...
invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
dpkg : erreur de traitement de /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 102
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Quelqu'un saurait-il m'aider à décoder tout ça?

Hors ligne

#2 Le 14/07/2006, à 08:15

manuker

Re : Package samba cassé pendant la mise à jour

Regarde
là: http://forum.ubuntu-fr.org/viewtopic.php?id=49955
et là: http://forum.ubuntu-fr.org/viewtopic.php?id=40909
(Au passage une petite recherche dans les forum avec paquet cassé samba te les aurai donné wink)

Perso, j'ai eu un pb identique (mais avec le fichier /etc/rc2.d/K09samba) et je m'en suis sortit avec

sudo rm /etc/rc2.d/K09samba
sudo apt-get install -f

Pour toi il faut peut-être essayer avec /etc/rc2.d/S91samba

bonne réparation smile


Ubuntu Precise v12.04.2 - 64bits (depuis 2013)

Hors ligne

#3 Le 15/07/2006, à 20:19

TheRod

Re : Package samba cassé pendant la mise à jour

C'est super!

La commande "rm /etc/rc2.d/S91samba" a réglé mon problème de mises-à-jour impossibles. Mais, quelqu'un pourrait-il nous expliquer comment cette commande règle ce problème et pourquoi se problème est apparue?

Je me considère un Windows "Power User", mais ce problème avec Linux m'a presque fait regretter d'avoir installer Ubuntu... C'est frustrant d'avoir un problème et ne pas comprendre comment le régler!

Mais, merci à la communauté Linux Ubuntu.

Haut de page ↑