Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/11/2010, à 03:20

orAGe

[résolu] ubuntu10.10 planté

bonjour,


alors voila ; ubuntu plante au démarrage : il m'affiche :

[   2.453548]   Kernel panic - not syncing : VFS : unable to mount root fs on unknown block(0.0)
[   2.453.599]   Pid : 1, comm: swapper Not Tainted 2.6.35-23-generic #40-Ubuntu
[   2.453644]   Call Trace :
[   2.453691]   [<ffffffff81586c9f>] panic+0x90/0x111
[   2.453738]   [<ffffffff81eaa2ba>] mount_block_root+0x1ea/0x29e
[   2.453783]   [<ffffffff81aee3c4>] mount_root+0x56/0x5a
[   2.453827]   [<ffffffff81aee538>] prepare_namespace+0x170/0x1a9
[   2.453872]   [<ffffffff81aed8c9>] kernel_init+0x1ad/0x1bd
[   2.453918]   [<ffffffff8100aee4>] kernel_thread_helper+0x4/0x10
[   2.453963]   [<ffffffff8181aed71c>] ?kernel_init+0x0/0x1bd
[   2.454007]   [<ffffffff8100aee0>] ?kernel_thread_helper+0x0/0x10

en démarrant avec GRUB ça me donne :

Ubuntu, with linux 2.6.35-23
Ubuntu, with linux 2.6.35-23(recovery mode)
Ubuntu, with linux 2.6.35-22
etc...

quand je démarre avec :

Ubuntu, with linux 2.6.35-23

→ ça me donne le même message d'erreur

Ubuntu, with linux 2.6.35-23(recovery mode)

→ ça me donne un message d'erreur encore plus long

Ubuntu, with linux 2.6.35-22

→ ça marche ,et c'est avec ça que je vous envoie ce message


est ce que quelqu'un peu m'aider ?

merci

Dernière modification par awass (Le 27/11/2010, à 20:30)

Hors ligne

#2 Le 26/11/2010, à 04:12

xabilon

Re : [résolu] ubuntu10.10 planté

Salut

Garder le noyau antérieur lors d'une mise à jour de celui-ci est une sage décision smile
Si le noyau 2.6.35-22 fonctionne, et pas le 2.6.35-23, c'est à mon avis que le noyau 2.6.35-23 a un problème.
Tente de le désinstaller puis de le réinstaller :

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall linux-image-2.6.35-23-generic

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 26/11/2010, à 04:22

J5012

Re : [résolu] ubuntu10.10 planté

Kernel panic - not syncing : VFS : unable to mount root fs on unknown block(0.0)

je crois plutot qu'il y a un probleme disque, boot en livecd et faire un check disque

Hors ligne

#4 Le 26/11/2010, à 04:27

xabilon

Re : [résolu] ubuntu10.10 planté

Deux précautions valent mieux qu'une


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 26/11/2010, à 06:11

orAGe

Re : [résolu] ubuntu10.10 planté

apt-get clean

   c'est comme administration / nettoyage du système ?

apt-get update

   c'est comme gestionnaire de mise a jour / vérifier ? ou installer les mises a jour ?

je crois plutot qu'il y a un probleme disque, boot en livecd et faire un check disque

check disque ? c'est a dire utilitaire de diques ?

et après ? véfifier le système de fichier ? données smart ?

Dernière modification par awass (Le 26/11/2010, à 06:14)

Hors ligne

#6 Le 26/11/2010, à 06:52

J5012

Re : [résolu] ubuntu10.10 planté

boot en livecd pour eviter de monter la partition racine de ton disque
puis sur le bureau live, ouvrir le terminal et demander un check : fsck le disque

si tu ignores de quel disque il s'agit fais un sudo fdisk -l

Dernière modification par J5012 (Le 26/11/2010, à 06:54)

Hors ligne

#7 Le 26/11/2010, à 10:15

orAGe

Re : [résolu] ubuntu10.10 planté

avec le terminal du live cd j'ai fait :

ubuntu@ubuntu:~$ sudo fsck /dev/sda1
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
/dev/sda1 : propre, 200693/60309504 fichiers, 33643137/241218816 blocs
ubuntu@ubuntu:~$ sudo fsck /dev/sda2
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext2: Attempt to read block from filesystem resulted in short read lors de la tentative d'ouverture de /dev/sda2
Peut-être cette partition est-elle de taille zéro ?
ubuntu@ubuntu:~$ sudo fsck /dev/sda5
fsck from util-linux-ng 2.17.2
fsck: fsck.swap: not found
fsck: Error 2 while executing fsck.swap for /dev/sda5

sda1 = partition système
sda2 = partition "extended" contenant le swap (de même taille)
sda5 = linux-swap

Dernière modification par awass (Le 26/11/2010, à 10:24)

Hors ligne

#8 Le 26/11/2010, à 10:46

orAGe

Re : [résolu] ubuntu10.10 planté

ok ,j'ai fait :

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall linux-image-2.6.35-23-generic

et ça remarche ,mais impossible d'afficher grub ,qui s'affichai avant en apuyant sur MAJ au démarrage .
donc je sais pas avec quel noyau ça marche .

pourquoi le noyau avait un probleme ? qu'est ce qui l'a détruit ?

xabilon , ou as tu trouvé cette commande ? :

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall linux-image-2.6.35-23-generic

quand j'essaye de comprendre comment fonctionne le terminal ,que ce soit avec la commande man ou avec des tutoriels ,c'est trop mal expliqué pour que je puisse assimiler quoi que ce soit .

bon ,merci tout de même ,car ça a l'air de remarcher ;  mais pour combien de temps ?

Dernière modification par awass (Le 26/11/2010, à 10:47)

Hors ligne

#9 Le 26/11/2010, à 11:05

orAGe

Re : [résolu] ubuntu10.10 planté

quelle est exactement la fonction de :

sudo apt-get clean

Hors ligne

#10 Le 26/11/2010, à 13:18

xabilon

Re : [résolu] ubuntu10.10 planté

sudo apt-get clean efface le dossier où sont archivés les paquets téléchargés (dont les noyaux). Si tu avais réinstallé le noyau sans faire le "clean", il aurait réinstallé le paquet du noyau qui se trouve dans ce dossier ... et c'est peut-être celui-ci qui cause tes soucis de démarrage (un problème lors du téléchargement, lors du stockage sur le disque ?)
Le "clean" force à retélécharger le paquet depuis les dépôts.

update met à jour tes dépôts, pour voir si il n'y a pas une nouvelle version du noyau (au cas où il y aurait eu une éventuelle correction de bug)

La dernière ligne parle d'elle même

Pour savoir sur quel noyau tu te trouves :

uname -a

Tes soucis d'affichage de Grub devraient être facilement résolus. Cherche dans la doc et le forum, et si tu ne trouves pas, ouvre une nouvelle discussion, pour ne pas mélanger les sujets

Dernière modification par xabilon (Le 26/11/2010, à 13:20)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#11 Le 26/11/2010, à 14:49

orAGe

Re : [résolu] ubuntu10.10 planté

la première fois j'ai fait juste la 3eme commande et après ça marchai ,et après j'ai fait les 3 commandes et ça marche .

mais en faisant clean ça n'a pourtant pas effacée mes logiciels téléchargés ,codecs ,etc ...    ???

ou et comment a tu appris le fonctionnement du terminal ?

j'ai fait la commande   uname -a   et c bon c le bon noyau

Hors ligne

#12 Le 26/11/2010, à 15:30

xabilon

Re : [résolu] ubuntu10.10 planté

J'ai dit que ça effaçait les archives de tes paquets installés.
Les paquets sont téléchargés dans /var/cache/apt/archives
Ensuite ils sont décompressés et installés, mais les paquets compressés restent dans le dossier, et à chaque fois qu'il a besoin de réinstaller le même paquet (nom+version) il va le chercher dans /var/cache/apt/archives, au lieu de le télécharger à nouveau ... sauf si tu vides le contenu du dossier avec apt-get clean, mais cette commande ne désinstalle rien.

Sinon, le fonctionnement du terminal, ma foi, c'est forgeant qu'on devient forgeron. Ça s'apprend un peu partout et un peu tout le temps.
Commence par la documentation :
http://doc.ubuntu-fr.org/commande_shell

Et n'oublie pas de modifier ton 1er message pour ajouter [résolu] au titre


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#13 Le 26/11/2010, à 15:46

breizhat

Re : [résolu] ubuntu10.10 planté

Bizarre j'ai eu le même problème hier soir... c'est une épidémie?:)

Je vais appliquer cette méthode ce soir et je vous tiendrai au courant.
-----------

En ce qui me concerne c est la 2.6.3.5-22 qui plante et la vesrion précédente est la 2.6.3.2-25.

Pourtant je suis toutes les mises à jour proposées par Ubuntu (10.10 à jour).

Dernière modification par breizhat (Le 26/11/2010, à 22:43)


------------------------------------------------------
N'utilisez pas sudo, utilisez sumo!

Hors ligne

#14 Le 27/11/2010, à 00:10

breizhat

Re : [résolu] ubuntu10.10 planté

awass a écrit :

ok ,j'ai fait :

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall linux-image-2.6.35-23-generic

et ça remarche ,mais impossible d'afficher grub ,qui s'affichai avant en apuyant sur MAJ au démarrage .
donc je sais pas avec quel noyau ça marche .

pourquoi le noyau avait un probleme ? qu'est ce qui l'a détruit ?

xabilon , ou as tu trouvé cette commande ? :

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall linux-image-2.6.35-23-generic

quand j'essaye de comprendre comment fonctionne le terminal ,que ce soit avec la commande man ou avec des tutoriels ,c'est trop mal expliqué pour que je puisse assimiler quoi que ce soit .

bon ,merci tout de même ,car ça a l'air de remarcher ;  mais pour combien de temps ?


En cas de Kernel panic, pas de panique, utilisez cette méthode ca marche nickel!

J'ai même pu passer au noyau supérieur, car une mise à jour était en attente.


------------------------------------------------------
N'utilisez pas sudo, utilisez sumo!

Hors ligne

#15 Le 27/11/2010, à 05:33

J5012

Re : [résolu] ubuntu10.10 planté

un swap equivalent à zero ?? bizarre, non ? m'enfin si ca remarche pour toi awass, tant mieux...

Hors ligne

#16 Le 27/11/2010, à 06:00

orAGe

Re : [résolu] ubuntu10.10 planté

non ,moi le swap fait 11,33 go
mais la je suppose que ça ne l'avait pas détecté . (??)


xabilon , j'ai l'impression que mon pc rame un peu plus qu'avant : connait tu une façon de s'assurer que TOUT les éléments du système sont dans un état et un fonctionnement optimal ??

après les mésaventures que j'ai eues ,ne seait ce pas mieux que je fasse une sauvegarde de mes dossiers perso puis formater et ensuite reinstaller ubuntu10.10    ????

Dernière modification par awass (Le 27/11/2010, à 08:55)

Hors ligne

#17 Le 27/11/2010, à 07:07

J5012

Re : [résolu] ubuntu10.10 planté

swap 11go et fsck te dit que le swap est nul ? gros probleme alors...

que te dis sudo fdisk -l en terminal ??

Hors ligne

#18 Le 27/11/2010, à 08:28

orAGe

Re : [résolu] ubuntu10.10 planté

ouais mais en fait (c ubuntu10.10 qui l'a fait automatiquement a l'installation) gparted me dit qu'il y a une partition "extended" de 11,33go qui contient linux-swap de 11,33 go .

la commande sudo fdisk -l :

Disque /dev/sda: 1000.2 Go, 1000204886016 octets
255 têtes, 63 secteurs/piste, 121601 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x000c245d

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *           1      120122   964875264   83  Linux
/dev/sda2          120122      121602    11884545    5  Etendue
/dev/sda5          120122      121602    11884544   82  Linux swap / Solaris

ps : c quoi la différence entre la commande exit (de la quelle je ne comprends pas l'explication du man) et fermer le terminal en appuyant sur la croix ?

Dernière modification par awass (Le 27/11/2010, à 08:32)

Hors ligne

#19 Le 27/11/2010, à 19:07

xabilon

Re : [résolu] ubuntu10.10 planté

Une swap de 11Go ça sert à rien, mais ça ne nuit pas pour autant. Une swap de la taille de ta RAM (ou 2 fois ta RAM si > 1Go) est suffisante.
Le message de la swap lors du fsck, c'est probablement dû au fait que le LiveCD utilise quand il peut la swap déjà présente sur le disque. Elle se retrouve donc montée, du coup le fsck ne marche pas dessus.
Utilise le moniteur système pour voir si la swap est effectivement montée par le système (si la swap disponible est de 0, c'est qu'elle n'est pas montée)

Pour ton impression que ton PC rame plus qu'avant, il faut d'abord s'assurer que ce n'est pas qu'une impression. Consulte encore une fois le moniteur système (liste des process) pour regarder si il n'y a pas un service ou logiciel qui prend trop de CPU ou de RAM.

Si tu t'es juste limité au 3 commandes que je t'ai donné pour remettre d'aplomb ton noyau, il n'y a aucune raison que ça ai changé quoi que ce soit d'autre sur ton système. Si auparavant tu as fait des manips au hasard pour essayer de résoudre le problème, c'est autre chose ...

Sinon, sur une fenêtre de terminal, taper exit ou fermer la fenêtre à la souris, ça ne change rien à mon avis.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#20 Le 27/11/2010, à 19:24

xabilon

Re : [résolu] ubuntu10.10 planté

Bonjour Gomariogo.

Je crains que ton intervention ne fasse inutilement dévier le sujet vers là où il ne doit pas, donc évitez le HS s'il vous plaît.
Si tu veux parler de ce qui s'est passé sur ton Ubuntu, ouvre un autre sujet, merci.
Il est totalement improbable qu'un virus se soit glissé chez awass. De plus, Avast pour Linux ne détecte que les virus Windows ...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

Haut de page ↑