Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/12/2010, à 23:20

Perturabo

Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Bonsoir à tous, je me suis acheté Warcraft III ainsi que son extension cet après midi. J'ai suivi la documentation, l'ai installé sans problèmes, et maintenant en jouant, je sélectionne mes paramètres, au moment de lancer une partie, la fenêtre se ferme subitement et j'ai le message suivant dans le terminal: mat@ubuntu:~$ drmRadeonCmdBuffer: -12. Kernel failed to parse or rejected command stream. See dmesg for more info.

Quelqu'un aurait-il une idée ? Merci d'avance

Dernière modification par Perturabo (Le 05/12/2010, à 17:03)

Hors ligne

#2 Le 05/12/2010, à 14:15

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Jamais vu passer ce genre d'erreur mais au vu du "Radeon" dedans, je pense que tu as une carte ATI, non ?
Dans ce cas, quel modèle ? quel pilote (libre ou proprio) utilises-tu ?

Comme suggéré par le message d'erreur, tu peux jeter un coup d'œil à dmesg (à lancer dans un terminal juste après le plantage).

En ligne

#3 Le 05/12/2010, à 14:35

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Bonjour, je suis confus je ne connais absolument aucune des références de ma carte... Peut être existe-t-il une manip' dans le terminal qui permet de le savoir ? Autrement, après avoir tapé dmesg j'ai un truc super long (Je sais même pas si tu auras la patience de lire alors je te copie-colle la fin qui m'a un peu inquiété):
[ 1234.302563] ISOFS: changing to secondary root
[ 2080.433064] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -12!

Hors ligne

#4 Le 05/12/2010, à 14:41

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Essaie lspci | grep VGA pour connaître la référence de la puce graphique. Mais c'est surtout pour savoir si c'est une carte ancienne ou relativement récente (en gros, c'est un PC qui a 1 an ? 5 ans ? 10 ans ?).

Dans Système -> Administration -> Pilotes supplémentaires, tu as un pilote activé qui correspond à la carte graphique ?

Est-ce que tu lances le jeu normalement ou dans un second serveur X ? Est-ce que tu as essayé de le lancer dans un bureau virtuel (dans la config de Wine) ? Est-ce que tu l'as installé directement avec Wine ou tu passes par PlayOnLinux (POL) ?

Dernière modification par abelthorne (Le 05/12/2010, à 14:42)

En ligne

#5 Le 05/12/2010, à 14:47

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
Voila...
Non, je n'ai pas de pilote supplémentaire d'installé correspondant à ma carte. Je passe par un bureau virtuel, et ça ne passe pas par POL (Parce que j'ai racheté la réédition du jeu, avec WIII et The Frozen Throne, l'extension.)

Hors ligne

#6 Le 05/12/2010, à 15:01

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Tu es à jour pour Wine (wine --version pour connaître la version utilisée) ?

En ligne

#7 Le 05/12/2010, à 15:03

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Wine 1.2 apparemment

Hors ligne

#8 Le 05/12/2010, à 15:06

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Essaie éventuellement de passer à Wine 1.3.x via le PPA dédié (si tu es sous Ubuntu 10.04 ou plus récent).

En ligne

#9 Le 05/12/2010, à 15:55

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Ouais ça marche ! En tout cas pour le moment, reste plus qu'à régler ce fu***** problème de son et c'est parfait merci beaucoup !

Hors ligne

#10 Le 05/12/2010, à 15:56

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Mh parlé trop vite... Ça me la recoupé en plein jeu cette fois...

Hors ligne

#11 Le 05/12/2010, à 16:23

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Si c'est lié au pilote de la CG, je ne sais pas s'il y a grand chose à faire... hmm

Essaie éventuellement de baisser les options du jeu pour voir s'il y en a une en particulier qui pose problème. Et lance le jeu en OpenGL si tu ne le fais pas actuellement (rajout de -opengl à la fin de la ligne de commande pour le lancer). Ou inversement.

En ligne

#12 Le 05/12/2010, à 16:31

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Je le lance en Open GL et sans, c'est tout bugué, le jeu est deux de tension et il finit par couper aussi (un peu plus loin dans la partie...) Est-ce que ça aurait éventuellement un rapport avec la mémoire RAM ? Parce qu'en installant l'extension je me souviens qu'il m'a affiché un message disant que la mem. Ram était insuffisante, comme il m'autorisait l'installation tout de même je n'y ai pas prêté attention.

Hors ligne

#13 Le 05/12/2010, à 16:35

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Tu as combien de RAM ? Tu peux le vérifier avec la commande top : en face de la ligne "Mem", tu auras entre autre la RAM totale (pour arrêter top, c'est ctrl + C).

En ligne

#14 Le 05/12/2010, à 17:01

Perturabo

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Ah en baissant la qualité du jeu ça  a marché yikes merci beaucoup Abelthorne smile

Hors ligne

#15 Le 07/12/2010, à 23:30

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Bonsoir à tous,
Je viens d'acheter, sur le site de Blizzard, le digital distribution copy de WARCRAFT 3 or il n'est pas connu par PlayonLinux Je n'arrive donc pas à l'installer.
est ce que quelqu'un peux me venir en aide SVP

Merci à tous.

Hors ligne

#16 Le 07/12/2010, à 23:41

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

PlayOnLinux (POL) est essentiellement une interface pour Wine, qui permet d'une part d'utiliser des scripts adaptés à certains jeux (avec les réglages correspondants pour Wine) et d'autre part de regrouper les jeux Windows dans une seule interface.

Si la version dématérialisée ne fonctionne pas avec le script, tu peux commencer par aller le signaler sur le forum de PlayOnLinux, pour demander s'il est possible de modifier le script afin de la prendre en compte. Bien sûr, il faut que quelqu'un qui a les compétences pour le faire soit en possession du jeu, donc ce ne sera pas forcément fait immédiatement.

En attendant, comme Warcraft 3 n'a à priori pas de réglages spécifiques pour Wine, tu peux utiliser une de ces deux méthodes :
- si tu veux qu'il apparaisse dans la fenêtre de POL, tu peux choisir "installer un paquet .pol ou une application non supportée" (dans le menu d'installation, sous la liste des scripts) et suivre les instructions
- si tu te fous d'utiliser POL, tu peux lancer l'installeur directement avec Wine. Il utilisera alors son préfixe par défaut (~/.wine) et le jeu sera donc installé dans ~/.wine/drive_c/Program Files/Warcraft III (si tu l'installes dans C:\Program Files\Warcraft III)

Dernière modification par abelthorne (Le 07/12/2010, à 23:43)

En ligne

#17 Le 08/12/2010, à 13:54

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Bonjour Abelthorne.

Tout d'abord, merci pour ta réponse rapide.

Ensuite, j'ai appliqué la première solution proposée:

abelthorne a écrit :

En attendant, comme Warcraft 3 n'a à priori pas de réglages spécifiques pour Wine, tu peux utiliser une de ces deux méthodes :
- si tu veux qu'il apparaisse dans la fenêtre de POL, tu peux choisir "installer un paquet .pol ou une application non supportée" (dans le menu d'installation, sous la liste des scripts) et suivre les instructions

... et ça a fonctionné. Le jeux se lance et tourne correctement sauf pour les cinématiques, qui ne fonctionnent pas. (mais je crois avoir lu quelque chose à ce sujet plus haut dans le topic, je vais donc creuser un peux)

Donc un deuxième merci, grâce à toi je vais pouvoir initier mon ignare de petit voisin aux jeux de stratégie en temps réel... et me refaire un classique!)
J'imagine que cette méthode peux fonctionner sur pas mal d'autre (vieux) jeux.

  PS: Tu l'aura deviné, je suis tout jeune sur Ubuntu (1 semaine!! )

Hors ligne

#18 Le 08/12/2010, à 14:03

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Le-Timonier-Fou a écrit :

... et ça a fonctionné. Le jeux se lance et tourne correctement sauf pour les cinématiques, qui ne fonctionnent pas. (mais je crois avoir lu quelque chose à ce sujet plus haut dans le topic, je vais donc creuser un peux)

Pour les cinématiques, c'est un peu le foutoir. Sur certains systèmes, elles passent, sur d'autres elles font planter le jeu (ça dépend peut-être de la version de Wine). Possible aussi qu'elles nécessitent d'utiliser un bureau virtuel dans la config de Wine (pour accéder à la config de Wine dans POL, il faut sélectionner le lanceur correspondant et aller dans je ne sais plus quel menu).

J'imagine que cette méthode peux fonctionner sur pas mal d'autre (vieux) jeux.

Oui, bien sûr. Pour avoir une idée de la compatibilité d'un jeu avec Wine (et donc POL), il y a des tests d'utilisateurs sur AppDB.

EDIT : puisqu'on parle de vieux jeux, précisons quand même que Wine simule un environnement Windows et ne gère donc que les jeux spécifiquement prévus pour Windows (95 et supérieur). Il ne gère pas les jeux DOS ou "mixtes" (jeux DOS avec couche de compatibilité Windows 95, comme ceux qui sont sortis pendant quelques mois lors de la transition entre les deux systèmes il y a 15 ans). Pour ceux-là, il y a DOSBox.

Dernière modification par abelthorne (Le 08/12/2010, à 15:02)

En ligne

#19 Le 08/12/2010, à 16:54

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Re bonjour,

J'ai de nouveau un problème avec l'installation mais cette fois ci c'est pour l'extension: WC the frozen throne.
je lance l'installation avec la méthode décrite plus haut par abelthorne mais à la fin de l'installation il me demande de mettre le CD de WC3 ... que je n'ai pas puisque j'ai acheté la version numérique directement sur le site de Blizzard (idem pour l'extension)

Hors ligne

#20 Le 08/12/2010, à 17:10

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Tu es passé par la même méthode que pour l'installation de Warcraft 3 ou tu as utilisé un script de POL ? Tu as bien indiqué le préfixe choisi pour Warcraft 3 (de façon à installer TFT dans le même dossier), en choisissant l'option "utiliser un préfixe existant" ?

Il te demande le CD pour finaliser l'installation ou en lançant le jeu ?

En ligne

#21 Le 08/12/2010, à 17:15

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Heuuu...

alors j'ai jesuis passé par la mm méthode que pour l'installation de Wc3 (application non supportée)
quand au préfixe... tu atteint la limite de mes connaissance ubuntiennes!
il me demande le CD de warcraft (pas l'extension) pour finaliser l'installation

Hors ligne

#22 Le 08/12/2010, à 17:37

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Quand tu choisis l'option "application non supportée", POL va te donner le choix, à un moment, entre "installer une application dans un nouveau préfixe" (choix par défaut) et "utiliser un préfixe existant". Dans le cas d'une extension ou d'un patch, il faut choisir "utiliser un préfixe existant", pour que le dossier du jeu d'origine soit utilisé.

Le préfixe, c'est le dossier que Wine utilise pour simuler Windows. Par défaut, il correspond à ~/.wine. Dedans, il va stocker des fichiers qui simulent la base de registre, créer des dossiers qui simulent la hiérarchie du système de fichiers (un dossier drive_c qui correspond à C: notamment), etc.
On règle le préfixe via une variable d'environnement.

Avoir plusieurs préfixes (plusieurs dossiers ".wine", en quelque sorte) a certains avantages :
- ça permet de séparer les logiciels installés et d'ajouter plein de trucs adaptés dans le Windows simulé (des bibliothèques Visual Basic ou .NET, par exemple) sans poser de conflits avec d'autres logiciels ; si tu installes tout dans ~/.wine et qu'un jeu a besoin de vcrun2008, un autre de vcrun2005 et qu'ils sont incompatibles, tu vois le genre de problèmes que ça peut donner ;
- ça permet de les installer à peu près où on veut (on peut choisir de créer des dossiers dans ~/Jeux ou un dossier dans le genre pour les classer) ;
- ça permet de les supprimer facilement sans dépendre des installeurs Windows qui marchent une fois sur deux : avec un préfixe par jeu, quand on veut le virer, on supprime le dossier tout simplement.

C'est la méthode qu'utilise POL : il crée un préfixe par jeu installé (avec la possibilité d'utiliser un préfixe existant) dans ~/.PlayOnLinux/wineprefix au lieu d'utiliser ~/.wine. Et des scripts de lancement dans ~/.PlayOnLinux/configurations/installed, qui spécifient à chaque fois le préfixe à utiliser (ils règlent la variable correspondante) avant de lancer le jeu ou les softs de config de Wine pour que celui-ci retrouve ses petits.

En bref, il faut comprendre qu'en utilisant plusieurs préfixes, c'est comme si on installait Windows sur plusieurs disques dur, avec un seul jeu installé sur chacun, qu'on changerait en fonction de celui auquel on veut jouer.

Donc, si tu installes TFT en gardant les options par défaut, il va créer un nouveau préfixe. C'est comme si tu avais un Windows avec Warcraft 3 et un autre avec TFT. Comme ils sont censés s'installer les deux dans le même dossier, ça pose problème.

En ligne

#23 Le 08/12/2010, à 20:08

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

j'ai réessayé mais ça ne fonctionne toujours pas, il me demande toujours le cd de warcraft3 à la fin de l'installation!

Hors ligne

#24 Le 08/12/2010, à 20:22

abelthorne

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Quand tu as installé War3, tu as dû choisir un nom de préfixe. Il te l'affiche bien comme possibilité quand tu installes TFT sur un préfixe existant ?
Si tu annules la demande de CD, il abandonne l'installation ou te laisse une installation incomplète ?

Après avoir annulé l'installation, qu'est-ce que tu as dans les dossiers ~/.PlayOnLinux/wineprefix et ~/.PlayOnLinux/configurations/installed ? (~ correspond à ton dossier perso et les fichiers/dossiers qui commencent par un point sont cachés.)

Si tu n'arrives à rien, on essaiera l'installation directement avec Wine et si ça marche, je t'expliquerai comment l'ajouter à POL manuellement.

En ligne

#25 Le 08/12/2010, à 22:45

Le-Timonier-Fou

Re : Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Bon... on progresse mais ce n'est pas brillant,
j'ai réussi à installer TFT, il se lance mais sans l'image et il plante à la fin de l'intro!

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » Problème en jeu sur Warcraft III (The Frozen Throne) [Résolu]

Haut de page ↑