Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 25/09/2010, à 14:40

Spelth

Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Bonjour,



Voici donc mon probleme:

Sous Windows 7 Lorsque je l'utilise, le son sort directement de mes enceintes qui sont relié a ma TV, et qui est celle ci es relié a mon ordi.
Le soucis c est que sous windows j ai le son, mais pas sous linux. Dans les parametres de son, j ai la configuration mise en Stereo Duplex(par defaut) mais, je n ai pas l option  HDMI digital, je suis forcement en analogique stereo duplex. J ai donc essayé les deux Digital qui sont Digital stereo duplex et un autre du meme nom avec + analogue stereo input mais rien ne marche, et les autres analogue non plus. Je pense que je devrais avoir marqué HDMI dans le choix comme c est ecrit sur la doc mais je n ai rien.

Config:
PC GT240 branché en HDMI a ma TV'sony' branché a mon kit son par jacks.


spelth@spelth-desktop:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
spelth@spelth-desktop:~$

Merci pour l aide.

Dernière modification par Spelth (Le 17/12/2010, à 06:06)

Hors ligne

#2 Le 30/09/2010, à 10:04

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Personne ?

Hors ligne

#3 Le 30/09/2010, à 11:32

gerarmentor

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Salut

Personnellement j'ai une nvidia GTX 260 et dans les options de KDE il faut que je choisisse le périphérique :  "IEC958 (S/PDIF) DIGITAL AUDIO OUTPUT" et là le son et l'image arrivent bien sur la TV uniquement avec un cordon HDMI.

Mais je ne connais pas le GT 240 et je ne sais pas comme c'est sous gnome...

Hors ligne

#4 Le 04/10/2010, à 21:30

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Ok... Merci^^ c est sympa d avoir repondu, je vais tester avec kde pour voir

Hors ligne

#5 Le 04/10/2010, à 22:45

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

44224_1623230710692_1534207816_1542143_5123145_n.jpg

Dernière modification par Spelth (Le 04/10/2010, à 22:45)

Hors ligne

#6 Le 09/10/2010, à 10:58

Zugol

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Salut,

Sous ubuntu 10.10 ta sortie son HDMI apparaitra par défaut dans le gestionnaire de son.
En revanche, je n'ai aucun son qui en sort (tous du moins qui sort de ma télé...)


Ordineux depuis 1988

Hors ligne

#7 Le 13/10/2010, à 13:39

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Oui, je vois que ca c est affiché mais je n es pas de son moi aussi. .. Rien ne sort ni de ma tv ni de mes enceintes .. . . .. .

Hors ligne

#8 Le 29/11/2010, à 14:26

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

salut à vous deux.

je vais bientôt m'acheter une carte nvidia avec sortie hdmi (NVIDIA GeForce GT 430, modèle asus surement), je fais quelques recherches actuellemnt pour voir la compatibilité linux/ubuntu
sur le site de nvidia http://www.nvidia.fr/object/product-gef … 30-fr.html
c'est marqué en tout petit et tout en bas, que le support du son via l'hdmi n'est possible qu'à partir du driver 260 et +
si c'est le cas pour ce modèle, je suppose que ça l'est également pour les votres puisque " Le support des normes x.v.Color et HDMI Deep Color et du son surround numérique 7.1 sera intégré dans les pilotes version 260"

c'est pourquoi, et bien que pour l'instant je ne peux pas tester ce drivers et vous assurez de la résolution du problème, je vous conseil de suivre la doc http://doc.ubuntu-fr.org/nvidia#methodes_alternatives
pour installer ce drivers 260

je suis intéressé par le résultat, si vous pouviez m'en informer, merci

Dernière modification par exzemat (Le 29/11/2010, à 14:28)


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#9 Le 29/11/2010, à 15:07

lynn

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Bonjour,

J'ai une GT240 et pour que le son fonctionne par le cable HDMI, j'ai été obligé de rajouter

options snd-hda-intel probe_mask=2

dans le fichier alsa-base.conf

sudo gedit /etc/modprobe.d/alsa-base.conf

Depuis, ça fonctionne smile

Hors ligne

#10 Le 12/12/2010, à 14:19

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Merci beaucoup pour l aide Lynn, en final j ai fais un pti tuto sur ce qui m a fait marcher ma carte je suis passé par le termian pour conf mon chipset son integré a la carte graphique. En reponse a exzemat la gt 430 marche mais ne vaut pas le coup, je l ai acheter et j en suis tres decu pour quelque euros de plus il y a une gts . Merci a tous pour l aide ^^

Hors ligne

#11 Le 12/12/2010, à 14:27

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Pour info pour ceux que ca peux aider, qui veulent le son hdmi, voici mon alsa base.conf
J ai une GT430 et tout est fonctionnel.

spelth@spelth-P5K-VM:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)
spelth@spelth-P5K-VM:~$ 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


Si quelqu un voit des choses a ameliorer dans mon.conf merci de ne pas hesiter car je n ai pas le son de mon micro integré a ma cam. c est une logiteque c950hd.
Merci a tous wink

Dernière modification par Spelth (Le 12/12/2010, à 18:30)

Hors ligne

#12 Le 12/12/2010, à 22:27

cab4

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

j'ai le même problème que toi, une gt430 , et sur windows 7 tout marche très bien
j'ai exacetement le même fichier de conf que toi pourtant j'ai toujours pas de son.

Quel  pilote as tu activé :

hda nvidia ou audio interne dans gnome-volume-manager

Dernière modification par cab4 (Le 12/12/2010, à 22:29)

Hors ligne

#13 Le 13/12/2010, à 06:30

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

ouvre un nouveau terminal et rentre dedans ;

sudo gedit ~/.asoundrc

puis tente d effacer ce que t avais dedans puis copie colle ceci dans le fichié texte. Je pense que ca t aideras wink :

defaults.pcm.device 3

pcm.pulse { type pulse }
ctl.pulse { type pulse }

ensuite CTRL+S pour sauvegarder et quitte tout puis redemare. Retourne dans le panneau alsa en haut de ton ecran( d origine) puis regle le son sur le bon materiel. Ensuiteci ca ne marche pas tante a nouveau mon tuto.
terminal alsamixer puis selectionne la bonne carte avec F6 et regle le son. la touche M seras pour activer la sortie ou entrée.
J espere que je suis pas trop brouillon dans mes expliquations mais j suis un peux fatigué par l heure wink /

Bon courage.

Je viens de passer a OSS4 et rebelotte je n ai plus de son HDMI. Je cherche encore la solution ... hmm

http://forum.ubuntu-fr.org/viewtopic.ph … 0#p3897810

Dernière modification par Spelth (Le 13/12/2010, à 06:37)

Hors ligne

#14 Le 14/12/2010, à 09:35

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

arf, j'ai reçu ma gt430 (avant d'avoir vu que Spelth la déconseillait, ceci étant elle m'a l'air suffisante pour ce que j'en fait : décodage film uniquement - pas de jeu .que lui reproche tu exactement? il est encore temps pour moi de la renvoyer).
par contre le son par l'hdmi c'est un problème!

lspci | grep -i audio
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
02:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)

mon alsa conf est similaire à celui de Spelth, mais j'ai beau choisir hdmi comme sortie, aucun son n'enchante mon oreille.
par contre, si je suis le post 13 de spelt( modification d'asoundrc) au redémarrage suivant, j'ai bien le son par l'hdmi...mais je n'ai plus QUE le son par l'hdmi: plus possible de changer pour mettre sur les haut parleurs du pc, plus de micro...)


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#15 Le 14/12/2010, à 10:39

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Re wink
Et bien c est deux sorties differrente l hdmi, si je ne me trompe pas tu ne peux utiliser qu un module de son a la fois, soit la carte mere soit la carte video. Carte video =HDMI donc que la TV et toutes les connectique de la tv( moi j y est brancher mon son sur la tv pat rca)
ou la carte mere.= les prises vert bleu rose noir etc a l arriere de la tour.

Autrement le reproche de la carte est le bruit, tres bruyante et aigu. J ai jamais vue ca... et puisssance graphique je la trouve pas toptop pour le prix. Et particuilerment finne et "bon marché" . En dirais plus un circuit imprimé avec un bout deventilo mis dessus. Ca me change de ma gainward GT 220. (voir dans google). Autrement je conseil une GTS

Hors ligne

#16 Le 14/12/2010, à 19:00

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Spelth a écrit :

Re wink
Et bien c est deux sorties differrente l hdmi, si je ne me trompe pas tu ne peux utiliser qu un module de son a la fois, soit la carte mere soit la carte video. Carte video =HDMI donc que la TV et toutes les connectique de la tv( moi j y est brancher mon son sur la tv pat rca)

oui, je pense bien que je ne peut pas utiliser deux sortie en même temps, mais mon problème n'est pas là : mes autres sorties disparaissent quand j'opte pour ta solution du poste 13.
en temps normal dans l'applet son, je peux choisir ma sortie "audio interne analogue" pour le son sur mon pc, ou "hda nvidia digital hdmi" pour ma tv.
(sauf que le son ne sort pas quand j'opte pour hdmi)
avec ta solution je n'ai plus que hdmi de proposé, le son passe nickel,...mais quand je ne regarde pas un film je ne peux plus avoir de son sur mon pc!


Spelth a écrit :

Autrement le reproche de la carte est le bruit, tres bruyante et aigu. J ai jamais vue ca... et puisssance graphique je la trouve pas toptop pour le prix. Et particuilerment finne et "bon marché" . En dirais plus un circuit imprimé avec un bout deventilo mis dessus. Ca me change de ma gainward GT 220. (voir dans google). Autrement je conseil une GTS

la mienne n'est pas plus bruyante que la 8400GS que j'avais avant, mais ça dépend peut être de l'assembleur : j'ai pris une asus.
truc bizarre, c'est la résolution dans plymouth (même en suivant la doc pour améliorer la chose) et au niveau du bios : je me retrouve avec des bandes noir autour de l'image.


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#17 Le 15/12/2010, à 19:14

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

-désinstallé pulseaudio
-installé vlc +alsatray +gnomealsamixer

configuré vlc avec sortie son : alsa, périphérique nvidia hdmi hw2,3 et décoché "utiliser spdif si possible" : c'est pas possible ...pour l'instant j'espère que les prochain drivers nvidia proprio le permettront


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#18 Le 16/12/2010, à 16:09

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

pfff, n'importe quoi, il n'y a pas besoin de désinstaller pulseaudio : vlc se suffit à lui même!
dans vlc uniquement, il suffit de choisir alsa et de choisir le périphérique hdmi qui va bien. voir - si la video est en ac3, DTS- activer les codec adéquats, "et voilà"

par contre, le fait que vlc fonctionne parfaitement via alsa prouve que le fait de cocher "nvidia hdmi" dans le gestionnaire de son sans plus de résultat est bien un bug de pulseaudio.
je vais voir pour rapporter ça sur launchpad.

edit : j'ai reporté le bug ici
https://bugs.launchpad.net/ubuntu/+sour … bug/691135
ce serait cool que ceux concernés complètent le bug en utilisant apport (en ligne de commande) ou au moins se signalent comme étant affecté.

Dernière modification par exzemat (Le 16/12/2010, à 16:46)


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#19 Le 17/12/2010, à 02:32

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

Bon bon bon. .. Apres plusieur jours et heures je commence a tout comprendre dans le syteme de son de ubunut alsa. C est tout tres tres simple, mais suffit de connaitres les bonne commandes.

1 Tout d abord installe les paquets libasound2-plugins "pulseaudio-*" paman padevchooser paprefs pavucontrol pavumeter et alsa-utils

sudo apt-get install libasound2-plugins "pulseaudio-*" paman padevchooser paprefs pavucontrol pavumeter

2 Il existe plein de commandes pour le son :

1-

alsamixer

: Sert à avoir une interface de gestion du systeme de son dans le terminal pour regler les cartes son trouvées.

Exemple:

┌───────────────────────────── AlsaMixer v1.0.23 ──────────────────────────────┐
│ Card: HDA Intel                                      F1:  Help               │
│ Chip: Realtek ALC883                                 F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: -46,50]                       Esc: Exit               │
│                                                                              │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │  │              │  │     │  │     │▒▒│     │▒▒│     │  │     │  │      │
│     │  │              │ ┌────── Sound Card ───────┐▒│     │  │     │  │      │
│     │  │              │ │-  (default)             │▒│     │  │     │  │      >
│     │  │              │ │0  HDA Intel             │▒│     │  │     │  │      >
│     │  │              │ │1  USB Device 0x46d:0x80a│▒│     │  │     │  │      >
│     │  │              │ │2  HDA NVidia            │▒│     │  │     │  │      >
│     │  │              │ │   enter device name...  │▒│     │  │     │  │      >
│     │  │              │ └─────────────────────────┘▒│     │  │     │  │      >
│     │  │              │  │     │  │     │▒▒│     │▒▒│     │  │     │  │      >
│     │  │              │  │     │  │     │▒▒│     │▒▒│     │  │     │  │      │
│     │  │              │  │     │  │     │▒▒│     │▒▒│     │  │     │  │      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │OO│              │OO│     │OO│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│      0                0<>0     0<>0   100<>100 100<>100   0<>0      0        │
│  < Master >Headphon   PCM     Front   Front Mi Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘

2-

aplay -l

: Sert a montrer les noms des cartes son reconnu et leurs numeros de périphériques et sous périphériques.Ainsi que le nombre de périphérique connecté en total.

Exemple:

spelth@spelth-P5K-VM:~$ aplay -l
**** Liste des PLAYBACK périphériques ****
carte  0: Intel [HDA Intel], périphérique 0 : ALC883 Analog [ALC883 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  0: Intel [HDA Intel], périphérique 1 : ALC883 Digital [ALC883 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  2: NVidia [HDA NVidia], périphérique 3 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  2: NVidia [HDA NVidia], périphérique 7 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  2: NVidia [HDA NVidia], périphérique 8 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  2: NVidia [HDA NVidia], périphérique 9 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

Donc si l on veut le son pour l hdmi c est donc la "carte 2" pour mon cas le sous "périphérique 9" et il y a 1/1 de connecté (donc mon HDMI )

3-

cat /proc/asound/cards

: Sert aussi a montrer ses cartes son mais sans les sous périphériques.

Exemple:

spelth@spelth-P5K-VM:~$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfcff8000 irq 45
 1 [U0x46d0x80a    ]: USB-Audio - USB Device 0x46d:0x80a
                      USB Device 0x46d:0x80a at usb-0000:00:1a.7-4, high speed
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe9fc000 irq 17

4-

lsmod | grep snd

: Sert a voir si son peripherique selectionné marche correctement.

Exemple :

spelth@spelth-P5K-VM:~$ lsmod | grep snd
snd_seq_midi            4588  0 
snd_seq_midi_event      6047  1 snd_seq_midi
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
snd_hda_codec_nvhdmi    13615  4 
snd_hda_codec_realtek   217971  1 
snd_hda_intel          22107  0 
snd_hda_codec          87552  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_usb_audio          86480  1 
snd_pcm                71475  3 snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_hwdep               5040  2 snd_hda_codec,snd_usb_audio
snd_usbmidi_lib        17413  1 snd_usb_audio
snd_rawmidi            17783  2 snd_seq_midi,snd_usbmidi_lib
snd_timer              19067  2 snd_seq,snd_pcm
snd_seq_device          5744  3 snd_seq_midi,snd_seq,snd_rawmidi
snd                    49006  13 snd_seq,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_timer,snd_seq_device
soundcore                880  1 snd
snd_page_alloc          7120  2 snd_hda_intel,snd_pcm

5-

sudo alsa force-reload

: Sert a forcer alsa a redémarrer pour charger les périphérique et les nouveaux réglages.

6-

gstreamer-properties

: Sert a ouvrir une interface graphique pour parametrer et tester les sortie/entrées son et video. Vous pourrez également choisir ici le greffon que vous voulez utiliser, pour le cas présent ce seras alsa architecture.

7-

 sudo dpkg-reconfigure linux-sound-base

sert a choisir le greffon a utiliser .Pour ce cas present ce seras alsa.

Exemple:

Outil de configuration des paquets

                ┌────┤ Configuration de linux-sound-base ├─────┐
                │ Système de gestion du son à utiliser :       │ 
                │                                              │ 
                │              ALSA                            │ 
                │              OSS                             │ 
                │              Système par défaut              │ 
                │                                              │ 
                │                                              │ 
                │                    <Ok>                      │ 
                │                                              │ 
                └──────────────────────────────────────────────┘ 
                                                                 

8-

lspci | grep -i audio

: Sert a detailler vos deux cartes son, leur ordre, et numero "ICH"

Exemple:

spelth@spelth-P5K-VM:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)

9-

lspci

: Sert a voir tout le materiel connecté a l ordinateur et leur chemin.

Exemple:

spelth@spelth-P5K-VM:~$ lspci 
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Device 0de1 (rev a1)
01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
03:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
05:02.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)

10-

pavucontrol

: Sert à démarrer un gestionnaire de son pulse audio pour activer les périphériques ou les désactiver par interface graphique. tres utile.


Ensuite, il y a differrents fichier a modifier, mais tout cela grace au commande cité précédemment. J espere que ca pourras en aider plus d un !

Dernière modification par Spelth (Le 17/12/2010, à 05:55)

Hors ligne

#20 Le 17/12/2010, à 06:00

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

en installant les paquets que  j ai cité, normalement tout est clean wink tenez moi au courant et j espere que pour toi exzemat ce seras bon ...

merci .

pour de l aide regarder
http://alsa.opensrc.org/index.php/MultipleCards
http://alsa.opensrc.org/index.php/TwoCardsAsOne

Dernière modification par Spelth (Le 17/12/2010, à 06:38)

Hors ligne

#21 Le 17/12/2010, à 10:05

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

merci de ton attention Spelth (même si je connais et utilise déjà ces commandes, il est toujours bon de les rappeler).
pour moi il n'y a plus d'autre problème que le bug de pulseaudio (ne permettant pas de switcher entre ma carte interne et ma sortie hdmi), puisque je peux jouer le son de mes film avec vlc en utilisant alsa.
je ne cherche pas à court-circuiter entièrement pulseaudio que je trouve plutôt bien fait en général, au contraire j'aimerai mieux que ce bug soit réparé.

c'est d'ailleurs ce que je cherche à faire en ce moment, pour cela je cherche à trouver le fichier de conf de pulse  à modifier pour établir un pipline correcte entre
- pulsesink device="alsa_output.pci-0000_02_00.1.hdmi-stereo" : la sortie hdmi de pulse qui marche pas
- alsasink device="hw:2,9" : la sortie hdmi d'alsa qui marche

...mais pas sûr que je m'y prenne bien

edit : quand je choisi "detection automatique " ou "alsa/default" dans gstreamer-properties j'ai du son via l'applet son/nvidia hdmi....aléatoirement tous 1 démarrage sur 10 !
bug,bug,bug...

Dernière modification par exzemat (Le 17/12/2010, à 12:44)


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#22 Le 17/12/2010, à 13:13

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

j'ai suivi ça
http://ubuntuforums.org/showthread.php?p=10246259 ; poste n°3
j'ai ajouté

load-module module-alsa-sink device=hw:2,9

à mon fichier /etc/pulse/default.pa
reboot du pc, et me voila avec une nouvelle sortie "nvidia stereo" dans l'applet son de maverick
1292587972.png

...et celui là marche !


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

#23 Le 17/12/2010, à 13:56

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

+1 smile J approuve.  ^^

Hors ligne

#24 Le 17/12/2010, à 14:06

Spelth

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

j ai mis a jour mon tuto et j ai cité ton rapport de bug roll

Dernière modification par Spelth (Le 17/12/2010, à 14:07)

Hors ligne

#25 Le 17/12/2010, à 14:55

exzemat

Re : Son Avec la Connexion HDMI Sur ecran TV HD [RESOLU]

content que ça marche chez toi aussi roll
du coup, si tu peux signaler sur launchpad "this bug affect me too" et poster un message avec apport (pour ton matériel/version alsa, pulse...) en signalant que cette solution marche chez toi aussi, on aura peut être une chance que le bug soit réparé bientôt et que la sortie "nvidia HDMI" pour cette carte fonctionne out of the box un jour
....peut être même pour natty?!


xubuntu sur samsung nc10 [RIP, paix  à son âme]
ubuntu sur clevo w310cz
archlinux + kde sur pc fixe

Hors ligne

Haut de page ↑